Test of Android version 2.1.x
  • 250 Comments sorted by
  • I have just installed and am testing 2.1.92 and can confirm that the hardware rendering issues I previously reported are still the same.  I can also confirm hvdwolf's problem regarding contacts.  The screen just goes blank when you select an address directly from your contacts.  You then have to force stop and restart.  As stated, if Navigator is open then it works as expected.  Hope this helps. 
  • Navigating from contacts now works for me on 2.1.93 Android 6 Moto G2 2014
  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.1.94+
    build 2.1.94
    -gles assert in drawer on highlighting icons fixed
    -show on map from routing points calculates also alternative routes not just one
    build 2.1.93
    -gles icon highlighting revision
    -geo intent - wait for result only several seconds not for ever
    -geocoding google intent fix
    -intent logging fixed
    -gles freezing on highlighting route fixed
  • Hi Roldorf, can I please clarify when you say that contacts works.  Is Navigator open when you go to contacts and select an address?   I have tested both 2.1.93 and 2.1.94 and it ends up with a black screen if you go to contacts and select to open with Navigator but Navigator is NOT open.  If I open Navigator then go to contacts, it works as expected.  This on an HTC One M8 running Android 6 Marshmallow.
  • Hello,

    Yotaphone 2
    Android 5.0
    MapFactor Version 1.2.93

    Bug found , I think.

    Start navigation from a contact, still the same error .

    I launched the navigation from a contact and I recorded it in my favorites.

    The favorite is unusable and I still have the message:
    "Unable to add a step . "
    " You 've probably had to go "
    " A step for a country "
    " That has not yet been downloaded . "

    I shared the favorite by email .

    I look at the mail, and there is an error in the link sent :


    "@ 3.0,20.0 " are too . In the data of the contact there is no such information.

  • I can confirm that under 2.1.94 address from contact still does not work. Application hangs.
  • Same for me with 2.1.94. With navigator closed and selecting an address, the application hangs on startup.
    So not solved yet.
  • Navigation to adresses from contacts app does not work either here (MF 2194+, Android 5.1.1, Xperia compact 1).

    If an adress including housenumber exists on the map, Navigator opens shortly, when it was closed before, and closes immediately without remaining any icon in the status bar.

    If Navigator was open (icon at the status bar), "navigating" from contacts just switches to the map of navigator.

    If housenumber does not exist and navigator is closed, navigation from contacts opens Navigator's menu "Choose action", with options "navigate", "set as start" etc. and I choose navigate, answer is "could not find routing point. Eventually point is in a country not downloaded." Same result for set as start. Navigator ends in a blue map. But I can add such an address to my favorites.

    Anyway reliable performance is something else.
  • @chattiewoman
    can you please give better description of 'hangs' - at what point?

  • The moment the menu opens and I can choose the next action, and I press an entry like set as destination point, it hangs. Just like the other users reported it........
  • hm, thanks, none of us can replicate this
  • my test:
    android 4.1.2
    navigator 2.1.94

    1. wifi off, GPS off, navigator off
    open adress in navigator, 
    error message: failed to execute the geo intent. maybe the internet connection is required? check OK
    message disappears, screen freezes

    2. wifi on, gps off, navigator off
    open adress in navigator,
    navigator start, selecting actions (navigate)
    allow GPS
    starts navigation

    why you need wifi? this is an offline navigation

    3. wifi off, gps on - testing 6 navigation - 2 OK
  • this is online feature, address is sent to Google and we get coordinates back
    this cannot be done using internal database
  • Why not via the internal database? 
    That is exactly how OsmAnd does it (but that one doesn't work either currently :) ) and how Here Maps does it. I don't know wether Here Maps also uses internet when it can't find the address in its internal database but it seems not.

    I guess that Google's service is the most easy and convenient one as its parser is extremely well and returns a correct addresss out of almost everything you throw at it.
    But the statement that Mapfactor can work offline is not entirely true. 
    Perhaps a setting for users to enable/disable online search would be better. This would of course require new functionality to first search in navigators internal address databases. The TomTom maps should be almost complete, the OSM maps less complete.
  • @amlumsden.

    Navigator closed not running. GPS not on.
    Open contacts.
    Select address.
    Select open with Navigator. (just once)
    Select action. (Navigate)
    Please enable GPS for navigation (open settings)
    Toggle GPS on
    GPS location Northern Germany
    (Calculates route)
    Shows Navigation screen

    Second test
    As above no wifi, restrict background data, GPS on, Navigator not running.

    Same result except no diversion to enable GPS.

    Address used
    Lockfield Drive Barnoldswick BB186HN

    Android 6.01 Moto G2 2014 XT1068 Navigator 2.1.93
  • @hvdwolf
    well, it can be done, but it would not find anything quite often - overall too much work for questionable result
  • As an addition to the above.
    Updated Navigator. Open contacts navigate to address used above.
    navigator opens all prompts as when new install.
    then as above.
    Navigator 2.1.94
  • @tomas typed: "well, it can be done, but it would not find anything quite often - overall too much work for questionable result"
    1. questionable also depends on how robust Navigators internal parser will become.
    2. It depends on the country: There are 3 countries in Europe that have 99+% addresses correct: Netherlands, Denmark (even by law 100%) and either Latvia or Lithuania (never can remember which one). So these countries could really use it. I assume lots of other countires especially in "exotic regions" have hardly any addresses registered but in this case Google Maps is not a big help either.
    3. "too much work": Well, that's of course a business decision.
  • 2. it is not just having addresses, Google can handle typing errors...
    3. yes, I think it would be a lot of work

    if you want them offline, you can add to favourites once imported

  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.1.97+
    build 2.1.97
    -rotating device while execute pending transactions call is being executed null pointer exception crash bug fix attempt
    build 2.1.96
    -not computing shortest and cheapest alternative routes
    -integer overflow when passing doubles through jni - longs used now
    -fixed minimize tcpip cmd
    build 2.1.95
    -google search everywhere using google geocoding api enabled
    -gles polygon holes fix
    -gles icon hiding fixed
    -improved cz translation
  • 2.1.97 - geocoding from contacts app: 
    By now this bug might get way too much attention and a way too high priority (as it is not at all a hard requirement or showstopper to be able to navigate correctly), but the "use a contact to start navigator and do something" is still not functional. I get one step further: It is now in the popup screen where I can set it as "Navigate to", departure, destination, show on map. I can even select one of the options (it gets focus), but then it hangs again until Androids "watchdog" offers me to "close, wait, report".
  • 2.1.97 run very good! I was testing 2.1.92 before and there was a problem with closing of software, it freezed often while closing (exit, end). This is now fixed. Very nice job.

    And for NMEA recording 1,5h it needed today only 9% Power.

    Also for NMEA Recording is it the best solution.
  • NMEA Recording - a little problem

    The Tracks contain always at the first position a point from the last session (most time yesterday for me).

    Maybe fixing this is easy.

    For me is this not very important, i can remove it with gps track editor if needed.
  • 2.1.97  - it freeze also sometimes when exit, dont know why.
    Today it needed 22% power for 1,6h NMEA recording. Sometimes is the Android like a human, it go a day good and another day bad.
  • @chattiewoman
    re - contacts
    is your nightmode settings set to night or automatic?
    if so, can you try it with day mode settings?
  • re-contacts:
    I had nightmode on automatic and then it hangs.
    When I switch off Nightmode (therefore in Day mode), it does work indeed. I can select an address from a contact and Navigator is nicely opened and give me some options that continue to work.
  • thanks, we will fix it
  • @Tomas I can confirm what hvdwolf already said.
  • thanks, I always have night mode off, that is why it worked for me :-)
  • Now i have find out why it sometimes crash while exit.
    When i stop NMEA-Recording and go outside the Menu with the Right Bottom Button on Smartphone, the map will be on display. When i wait a short while and house numbers are visible and press then the Back-Button on the Phone and Exit, it works good. When i make this to fast and the map is not yet 100% on display, it freeze.
  • thanks, we will test and fix
  • Hello there,

    a month passed by - anything new here?
  • I cannot replicate it, but I have v2.2.x, so it may have been fixed
  • @Tomas:  Your remark surprises me a little. You are testing a new version (and others within MapFactor I guess). I assume Mapfactor has change & release management in place. You should know what has been solved, or tried to solve, in your version compared with the 2.1.97 which is the current google play version.
    Or at least there should be a changelog in your development environment based on the commits in that environment.
  • nothing will get changed in already released version, you have to wait for the next release
    I am not a developer, but I know that a lot of changes have been made to hardware rendering in v2.2.x
    just be patient please
  • @tomas: That's not my point about the current and the future version. I can wait as the 2.1.97 version functions fine (for me).
    What puzzles me is that you don't know what has been improved/fixed/added in your 2.2.x test version compared to the google play store version.
    "Someone" should know what's in the changelog. I can't imagine you folks are just blindly fixing left and right and nobody knows what he/she or his/her colleague is doing, and neither that a test user doesn't even know what fixes he is supposed to test which were bugs in the google play story version.
    One of the key focus points of development is to track what you have developed especially when multiple programmers are working on the same code.
  • @hvdwolf
    I am not the one to follow all the changes and list them on this forum, I am not in charge of development and I am not programer
    I know that hardware renderer has been substantially reworked, so it is not something we can list in detail

    in any case, I do not recall anybody else reporting this issue, not even you, who usually comment quickly on any issue

    I was just trying to be helpful, sorry for any incovenience
  • @tomas I did not want to offend you and I know you are trying to help. 
    I'm not referring to @joopy's (or actually @Matthias's) issue either)

    I have been change & release manager for several OS projects (also for my own projects but that's obvious then). And maybe I did a terrible job, but for me it should be possible to answer very easily: "what has changed between the the previous versions and the version I'm supposed to test", because that's also what the end/test users want to know.
    If you don't want to answer that question because you have some great new functionality coming up, I can fully understand. But in the past we have often seen (because I was also one of the users asking for it) from MDX and Lubos and some others as well (windows build) "alpha/beta x.y.z, fixed in this release, etc..".
    And we as testers could verify that.
    That is what my "complaint" is about, and that "changelog"question hasn't been answered.
  • obviously, change log exists, but it is not public until new version is out
    I do not think that you would published change log everyday to everybody

  • Hi folks,

    please calm down. I've had just a simple question and nobody should have been blamed.

    I'm patient and can wait for the next release. Up to now the 2.1.97 is fine for me. I can live with the minor bugs that obviously are based on the hardware of my cheap mobile phone. But I trust in stability and accuracy to go to Ireland in July >:D< . BTW: Any issues depending left hand traffic ? :-\"
  • I am calm :-), do not worry
    left hand traffic is fine, no problem
  • Hi Joopy,
    I drove in Ireland about 2000 km in 2012 using MFN free and never got problems. My tip: exclude using of motorways and chose shortest route. You'll need more time but will get best impressions. But please look at sheep on roads then.
    Greetings to the shamrock shore and have a great time over there.
  • You might need to change from metric to imperial in case you cross over to North Ireland.

    It works perfectly the other way for me - when I tour Europe on a motorbike
  • @hurdygurdyman @starvich thanks for your tips

    We've been in Ireland some years ago where I used Mobile Navigator on my PDA.
    We're looking forward to a great time - especially the International Art Festival in Galway :-h
  • I remember good times and several Guinness at The Quays :!! :!! :!! :!! :!!
  • Ok, back to 2.1.*:
    Getting Information about map-updates and trying to load them direvtly out of that, I get a failure and can't download any. But starting MFN and the map management inside, updates ar shown and possible. This problem exists since more than a month or so.
  • 2.1.97 downloaded as exspected this week, just got a new map from France (one part). Device is set to direct download. This is faster here.
  • You can download for free forever here Projeto Relo

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion