Test of Android version 2.1.x
  • Hello,
    the download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.1.45+ available for testing. If you need older 2.0.33 it is available at http://download.mapfactor.com/mapfactor_navigator_stable.apk

    Version 2.1 brings some exciting changes and many stability improvements

    - New Premium Features
      - Alternative Routes
      - Head Up Display
      - Ability to remove Ads
    - User Interface
    - Better Tools dialog
    - Improved Route Info dialog
    - Many improvements to GL rendering
    - Lots of other bug fixes
  • 250 Comments sorted by
  • How can I check Premium features? Buying "fails".
  • do you hav google account?
  • @Oldie currently it is not possible, we will try to make it working before weekend
  • Hi,
    Some bug reports for the new 2.1.45 from Google Play Test.

    There is a terrible debug message (or so) in the new version when going from one street to another. In the Dutch TTS it is hardly recognizable (, same for Czech, Fench, Italian or German I suppose). Actually: it is not recognizable.
    In English TTS it is saying "turn left to "Netherlands underscore osm" to <some street>" where <some street> is of course the street name.
    So it looks like it is reading "Netherlands_osm" from the map (database).
    When trying a route in Germany it mentions "Germany underscore osm" when changing from one street to another.

    Route simulation in hardware renderer is very unstable. It crashes often and crashes always when using a simulation speed above 1.

    When zooming out on the map of the Netherlands, the IJsselmeer is suddenly disappearing. In software rendering this happens on a lower zoomlevel (larger overview) then in the software renderer.

    The map color scheme editor is still buggy. I reported that a couple of times in the forum for the 2.0.xy versions. I can import schemes, but it always asks twice to import/use as.
    When using the scheme editor itself in Navigator, even only in view mode, my personal themes disappear. I use a simple day theme where road lines are much narrower and houses have the same color as the background as I don't want to see houses. I use a much darker night theme with grey roads as it is far easier on the eyes.
  • I tried simulation in x10 speed and have had no crash

  • @Tomas: I mentioned the hardware render but forgot to mention my hardware. I have a Samsung S5 mini running the stock Samsung Android 4.4.2.
    If the team develops and tests on different hardware it is quite logical that it can fail on one phone and not on another. The OpenGL versions and implementations vary on almost every phone and Android version.

    In that case your answer that it works for you is not very useful (wrong answer helpdesk). You should have asked for my logs (which I forgot to send as well :) )

    Edit: Just did another crash and sent the logs.
  • Lubos may ask you for logs
    I think it is useful to know that it is not a common problem
  • But my question remains valid: Do you use/test on a big variety of hardware? Samsung is by far the most sold phone. Are some of you (the team) also on some Samsung?
    Let's hope some more reports on "my issue" will be mentioned:  whether it works or not.
  • I have Samsung :-) and we do test on variety of hardware
    I wonder if your crash is connected to your colour scheme - may be try to delete album.style and try it with default one
  • I immediately tried that. 
    I removed the album.style, restarted Navigator and selected the default schemes, exited Navigator, rebooted my phone to be sure, and started again. It still crashes unfortunately.
  • Hello,
    I would like ask you, when will be available new official version of Mapfactor 2.1x for downloadable on google play?
  • Hi @hvdwolf
    -TTS problem I forwarded to TTS programmer
    -I checked logs of route simulation crash ut these logs are only on medium debug, can you set high debug, repeat problem and send logs again? Thank you
    -I will try to fix scheme editor issues, give me time
    -about disappering texts in SW/HW renderer I will discuss on today meeting
  • My problems with Digger created maps is fixed in the new 2.1.45 version (http://forum.mapfactor.com/discussion/comment/10792#Comment_10792)

    see here

    and here

    But the bug with the black map still exists.
    When I start MF, the map in hardware-renderer is shown. But if I turn my device from landscape to portrait or the other way, the map is shown in a nice deep black color.
    (using Android 6 Marshmallow on Google Nexus 7 2013)

  • @crocodilefarm I just fixed problem with black screen on hardware renderer, we will publish here fixed version during next week
  • Hi folks,

    one comment from my side - I"m not sure whether it's just my phone but I can not set up the road with properly in  2.1.45

    Nexus 5 --- Android 6.0.1 

    My previous "theme" was nicely set up but I had to reset completely everything differently in this version when it comes to road width of specific roads....end even after that it's not working properly.

    - the Line for Path does not seem to change no matter what values are assigned to it and even with 0 they appear on the map
    - if the width of the road is smaller...the line that shows your directions still remains too wide
    - the arrows for the one way roads are kinda weird as well

     PLs see the screenshot below

  • Hello,
    is it necessary to uninstall previous version of Mapfactor before installation of new version 2.1.x or rewrite? 
  • no need to have previous version
  • new 2.1.47:
    - "debug messages" (Netherlands underscore osm, Germany underscore osm) solved.
    - route simulation in hardware mode no longer crashes.
    - scheme editor now works fine (some preliminary tests)

    Well done.

    - Ijsselmeer rendering bug still there.
  • @hvdwolf ... Where did you get that version from? The link to beta still shows ....45
  • same place as 45
  • @Tantum only by this link you can get 47 this weekend: https://play.google.com/apps/testing/com.mapfactor.navigator
    About scheme issues in HW renderer, I will check it next week

    @hvdwolf scheme editor still has issue with saving sometimes, I will check it next week.
    About rendering problem, I need to talk about it with others and as a textplacing programmer wasnt available on last meeting I didnt get needed informations
  • @Lubos: About the scheme editor: Yes, it just crashed Navigator on saving a scheme. But after restart it turns out it was saved correctly.

    @Tantum: If you register via google play testing as Lubos mentions, you also get automatic updates of those beta versions. Just like normal Play Store behaviour. So the .47 was automatically updated this early morning.
  • The BodenSee is not correctly rendered as well. The Northern arm is not rendered at all. Neither when zooming in.

    New topic created
  • Version  2.1.47 , hardware rendering , default color scheme. 

    On Samsung Galaxy S4 I9506 Android  5.01

    1. When I look at the map, I can’t see any road names, and it don’t help to zoom up or down, only a very few times I can see the road names for a second ore so. It has always been ok for ver. 2.0. It don’t help to change the text size. When I use software rendering it is ok.

    2. The Navigation highlight line has been much wider compared to ver. 2.0, and for me the old one was better.

  • do you use hardware or software rendering?
  • @hvdwolf - BodenSee: we have problem with separating big lakes into countries(I am not sure but polygon is probably part of Switzerland)
    -Ijsselmeer is probably problem that there is no polygon at all(just "hole" in earth_osm), so there is no posibility to attach text to any polygon(I will ask data conversion guys)
    This two lakes problems is not probably not problem with renderer but data

    @tvo - Hardware rendering was rewritten a lot because 2.0 version of it was ignoring lot of parameters from navigator map engine. Please be patient, I will take a look on those problems after weekend.
  • @lubos:  You're a busy man! Relax in the weekend! Our daily jobs stop in the evening hours and the weekends. So should your daily job. Find something nice to do :D
  • @tomas – If your question is for me, I am using hardware rendering, as I already wrote.

    @lubos  -Thank you, put it in to your schedule when you get time

  • sorry, missed that
    do you see street names in software rendering?

  • @tomas - Yes I also already wrote that.
  • it is not my day ::(
    may be screenshot would help
  • Version 2.1.47, Hardware renderer, Android 6, now no more Black Map when turning the device. -->Fixed.
    Thank you.
  • @tvo
    I  confirm that I can replicate 1.
  • V 2.1.47
    - I can't change the application language from e. g. German to English.
    - In Hardware Renderer the size of streets can't be changed (Einstellungen - Karte - Kartenmaßstab) (? Settings, Map Mapscale?) <-- sorry, can't change app-language
  • Shame you can't buy the premium upgrades other than through Google. I guess I shall just have to go without as I wont buy anything through Google.
  • @crocodilefarm
    -mapscale for roads I just fixed(will be in the next version)
    -I see that there is still problem with changing language into "system language" but if I select exact language it works, can you tell me more how to reproduce this problem? thanks

    -missing texts in map I just fixed(will be in the next version)
    -about width of route highlight-there were hardcoded scale for GLES only, if there is need to have it smaller it must be smaller in both renderers(I think this wont pass by others)

    -I tried to remove one unsafe operation in scheme editor but I am not sure if it fixes crashing... but at least I am glad that color schemes is not removing now

    -zero size is not permited by other part of navigator, so even if you save zero then it is still visible. Anyway there were extra huge frame for paths which makes paths much bigger - I just fixed it and it will be in the next version.
  • There is a problem with Premium Function. The MFN application forgets that has premium function several minuts after disconnecting Internet. So, every time, when I want to use premium function (e.g alternative routes) I have to connect to Internet before starting application.
  • I purchased all the premium functions, but I still get the question about the purchasing of TomTom maps. For a new user this is perfectly acceptable, but it's an add as well and should be removed if I once say that I don't want to see it again: I paid for that! But it is still showing up every 11th time I startup Navigator (if I counted correctly).

    Please fix this bug!
  • @lubos - would it be possible to set the width of the route highlight to equal the width of the road? In that case it should change dynamicaly when you change the map scale.

    This is a screenshot from the version that was released 7 months ago...everything looks ok here even with a very highly scaled roads

  • Nice to learn, that you have solved the missing text problem.

    It would be a very good idea, to let the width of the route highlight follow the road width as @Tantum suggests, if possible.

  • @lubos
    for changing languages I didn't changed the Map language. I tried to change the application language (Languages).

    I think, you can reproduce it when you change the Voice engine to silent and hit OK. The next step is to change that language to German or any other language. This shouldn't work.

    I think, changing application languages is just working with a selected voice engine other than silent.
  • @Tantum , @tvo - I set highlight width in hardware renderer to half(as it was in 2.0.x)

    @crocodilefarm - the hint with voice_engine=silent helped me a lot, it is fixed now

    My coleague is trying to solve issue reported by @MFNUser , after it I guess we will publish next beta version, at first it will be available on GooglePlay beta and next day we will publish link also here.
  • Issue reported by @MFNUser fixed, 2.1.49 uploaded to beta and will be available soon
  • Hi folks - 2.1.49
    The changes in "navigation highlight" color are not refrected correctly when it's renderred on the map
  • Hi,
    I tried the HUD tonight as I had to drive 160 km. As such it works nice until it starts raining. Even with my windscreen wipers on high speed the image gets immediately distorted due to rain drops on the windshield (and yes, I know the raindrops are on the outside :) but still). I assume this applies to all HUD displays but I hadn't expected it.
    (This evening I was driving a Ford Focus in case it varies per car).
  • Ver. 2.1.49
    The “map text” and “navigation highlight width” problems are solved. Good and fast work.

    For me the navigation highlight color change is running well, but there is one difference compared to ver. 2.0, in 2.0 the color change in simulating route and navigating, but in 2.1.49 the color only change in navigating not in simulating, but I think it is ok to keep it so.
  • Hi folks,

    to the ADs you show after the navigator is closed -- I'm OK with it (getting a free navigation for a few ads here and there is fine) however this could backfire at you cause 9 out of 10 ads are related to your direct competitors...just something to consider for the future...
  • Tantum said: "..however this could backfire at you cause 9 out of 10 ads are related to your direct competitors."

    Strange. I only got ads for games and I have never purchased a game and maybe downloaded 7-8 games in the past 5-6 years. Now I have the ad-free premium option so no ads anymore apart from the TomTom maps ad (which I registered as bug).

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion