Test of Android version 2.1.x
  • 250 Comments sorted by
  • Very strange rendering for 2.1.50
    - see one way streets
    - the arrow that shows the turn is now the same color as the highlight line

  • may be you changed highlight colour?
  • Yes, I did play with it...however it does not explain the strange rendering for one way streets and the arrow that shows the turn
  • @Tantum - I think I fixed this issue now, wait for next version
  • Since several versions (I currently use 2.1.49), when I define a waypoint, I always get a "route not found" error, unless the waypoint is already on the calculated route.
    No matter the way I build the route, I can no longer use waypoints.

    Edit: in fact, the culprit seems to be a bad update of OSM...
  • Hardware render versus software render:
    - also in 2.1.50 and the previous 2.1 version for me the hardware render is still not very useful. The GPS position seems lost and the GPS positioning on the map is sometimes way off. It is next to the road, in the field, on another lane (motorway), etc. Resulting in sometimes multiple recalculations per minute and incorrect spoken directions (and very annoying when you really don't know where to go). This is on Samsung S5 mini Android 4.4.2
    This never(!) happens to me in software mode. so it is not my GPS, it is the handling in hardware mode.

    - somehow the Zoom level of the hardware version is slightly more "zoomed in" compared to the software render. Hardware render shows slightly less of the map. The software render shows more at the edges. As such I don't care which zoom-level is chosen, as both are good enough for me. But the hardware render renders roads much smaller then the software render.
    Below the hardware render:
    And below the software render:
    As you can see: the roads in the hardware renderer are muchs smaller and way more "elegant"
    Also the POI icons are rendered smaller than those of the software render.

    Please align the sizes of the rendered objects. And to me that would be: Makes the sizes in the software renderer the same as in the hardware renderer..
    I really like the hardware renderer above the software renderer (apart from the 3D houses), but the hardware renderer is not usable yet on my hardware.

    Edit: And what I forgot: The oneway roads are rendered with a color instead of with a pattern and unlike the scheme definition. Is that something new or a bug?
    And they are again differently rendered compared to Tantum's "bug" report.
  • Veto: Please don't change the size of the roads in software render mode: This is, on small devices (like 5"), the only way for me to be able to identify my route at a glance, especially when driving on a motorbike. At the moment hardware render mode is no option for me because everything is too small.
  • I definitely agree with Jambafee

  • @JambaFee and @Uli: I understand your concerns, but that means that the hardware renderer definitely needs some more improvements to be able to use it on small devices (next to "my" GPS deviation issue).

    I don't care if the hardware renderer is corrected to use the same sizes as the software renderer, which means to "blow up" the roads. In that case I correct my own scheme again to use even smaller roads, but the difference between the both renders is currently causing issues for me.
    (Apart from the fact that it is a bit strange to work with different scales depending on the renderer.)

  • 2.1.52:
    - During calculation of route (or alternative routes), there is no Google "waiting circle" (or progress bar).
    (more things to be tested tomorrow)

  • 2.1.52
    - route highlight ... Too wide again
    - arrow that shows the turn has the same color as the highlight color but with no opacity
  • highlight is back where it was, it was too thin - what resolution do you run?
    highlight colour is probably changed by you, default does not clash
  • Tantum is right. It is not good at all. In my case the color of the route is also the same as the overlayed arrow: purple on purple.
    What's more: I changed the color to something else, but it doesn change in the map simulation, even though the settings display the new changed color. It remains purple on purple.

    Edit: After a reboot the popup window during a root calculation is back. The routing colors are still not correct.

  • I do apologise, colours are wrong in this version. Lubos will fix it next week
  • Another observation in 2.1.52: 
    After route calculation I sometimes like to examine the route by zooming in on it and panning along the route. The zooming works, the panning doesn't work. 
    And after having calculated the route I can of course select one of the start/destination/routing points and display on the map: After having done that panning and zooming works.
  • Version  2.1.52 , hardware rendering , default color scheme. 
    On Samsung Galaxy S4 I9506 Android  5.01

    When I load a route and then calculate the route, and then after that I start navigating, the navigating doesn’t start. If I start the navigation after a new start of the MF app, and not try to calculate the route the navigation is running. That means that I have to close down the MF app every time I have used “Calculate route”
  • For me the navigation is worse: I can't navigate at all. Neither with tvo's hints.
    I had to drive 160 km today (and back as well), and when I press navigate, I do get a route but it simply doesn't start. The map is frozen.
    Additional: During the calculation of the route (after pressing navigate) the "Calculating a route ..." popup does NOT appear.
    Also: I mentioned yesterday that I changed the route color but nothing changed in the map (simulate route). Today, after pressing navigate the newly selected color appeared, be it now green on green, but that was all. Even after reboots, before going from home and again before going home, it simply didn't navigate. I had to use another nav app (which I also have on my phone). 
  • does it work with software renderer?
  • I am rather sure that the reason for the navigation not is running after “Calculate route” is so. I start the MF app and open the GPS info in the program and, I can see that the satellites are found, then I press “Calculate route” and go back to the GPS info, and now no satellites are found, and that must be the reason  that the navigation is not running. It is so for both hardware and software rendering. The GPS symbol in the top of the phone does not disappear after calculation, and other parallel apps can find the position. 
  • I tried tu run develop versoin of Mapfactor 2.1.52 on Bluestacks emulator, always shut down, but official version from google play is normaly working, what is the problem?
  • @Tomas:  I did use (or actually tried to use) it with the software renderer. I have to use SW renderer as the hardware renderer continuously looses the GPS position: it jumps back and forth and left and right about 50 meters, "sticking" to other roads. Hardware renderer is simply not usable at all for me.
  • I confirm this issue. Navigation does not start even with sw renderer
  • @v77 - sorry I was too busy, I still didnt check route not found - I fixed another problem which can be connected with this. Give me know if it is happening in version 2.1.53(for now not public)

    -GPS issue is probably connected with rendering in 3D where is enabled "smooth animation". This extrapolate position into future and when you turn out of route, it starts making problems. You can also record NMEA(it would help us)
    -I agree that zoomlevel should be better, I have it on my list but I still didnt have time to modify it.
    -sizes of objects are multiplied by mobile DPI/160, this is totally different than in SW renderer. In HW renderer is for now incorrect calculation(it shows you objects scale for little bit different zoom)
    -problem with oneways is weird, can you send me album.style and position when it is happening?
    -panning issue can you give me exact instructions how to repeat this problem? thanks

    @Kuba - making Navigator on Bluestack is not priority for us, if you wanna run Navigator on Windows, we have PCNavigator or Navigator for Windows 8.1.

    @tvo and @IU0BMPIU0BMP - problem with not starting navigation should be fixed in next version wait until we publish it.

    @JambaFee - it looks we wont modify software renderer anymore

    -I agree with you but Tomas forced me to do it wider. I discussed this with SW renderer programmer and we found out that GLES is using incorrectly percents instead of pixels when it is resizing. So I corrected it as it should be, wait for next version.
    -about arrow color, I didnt find time for it, maybe during this week
  • @lubos
    -problem with oneways is weird, can you send me album.style and position when it is happening?
    That was in 2.1.50. The 2.1.52 version does show the correct behavior, that is: it shows the oneway roads as before.

    -panning issue can you give me exact instructions how to repeat this problem?
    Use alternative routes. Select a start point and destination. Calculate a route with 3 options. Select one of the options. Try to pan the map up/down/left/right. 
    With no alternative routes(= single route) it works.
  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.1.54+. On Google Play beta it will be available between few hours.
    -problem with not updating GPS fixed
    -routeinfo dont recalculate route so often if you modify route during navigation

    @Tantum - arrow color is fixed
    @hvdwolf - panning should be fixed now
  • "Stop Navigation" freezes application.

    Has anybody else experienced the same problem?
  • @stavrich Is it happening on BB or Android device?
  • @lubos - happens on both Blackberries, Z10, Z30 and Samsung S3.
  • @lubos: what has changed? I did have version 2.1.54 and this morning I got an automatic (Google beta tester) update but it is still 2.1.54

  • @lubos --- re Stop Navigation freezes app

    After further testing the freezing happens consistently after entering the destination, starting navigation and after route is calculated AND before start moving on clicking the Stop Navigation the app freezes ( this is a quick armchair test )

    After moving Stop Navigation freezing is intermittent - it failed 3 out of 5 times.

  • @hvdwolf - we didnt upload any version, I guess you downloaded APK and then it was replaced by same APK from Google Play official way... I have no clue but I am sure that it is same APK

    @stavrich - I cannot repeat it on my device, I sent you PM
  • Hi, this morning another update and now the 2.1.55.
    What's new?
  • -canceling route computation works even when computing alternative routes
    -routeinfo showOnMap disabled during navigation
    -gles gps arrow in 2D over texts
    -MoveRtgPointDialog disable posibility to move current gps position(it made app crashed)
    -route info show dialog of waypoints twice on navigate press fixed
    -routeinfo lazy recalculating of (un)checking waypoints during navigation
    -centering after calculate route with AR fixed
  • @lubos : can you let me have v2.1.55 please.
  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.1.56+

    @stavrich - about your problem with stop navigation, can you record a video how it happens?
  • try to enable small local roads in settings/vehicle profiles/car/road restrictions
  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.1.57+

    -DEVELOP removed from manifest
    -stop button fix for @stavrich (give me know if it helps, thanks)
    -attempt to fix incorrect names in route info after adding WP
    -disable screen rotation during recalculating
    -starting navigation for nmea currently being replayed hides the positions track from the nmea file
    -routeinfo showonmap during navigation works as back button
    -scout sounds without navigation disabled
    -routeinfo double check of waypoints on press simulation fixed
    -route highlight color after recompute stays the same
    -gles memory issues fixes
  • @lubos :stop navigation fixed, OK on BB and Samsung - well done and many thanks. =D> 

    Question 1 : when choosing own route (a specific route planned with wp) and with AR on why do alternative routes are calculated. This is a planned route to be follow exactly as designed and therefore no alternatives are required. ( I know is not a big issue - just untick AR box or figure out which of the 3 options is the route based on my vehicle preferences )
  • I ran several navigations yesterday and today with 2.1.58 on my new Huawei Y3 (Android 4.4.2).

    I don't know, whether it's normal that the map is shown in stop/motion during navigation, but overall it look quite nice.

    But not nice is
    • freezing during navigation - sometimes with a  small forward / backwards movement of the map
    • screen turns black when re-calculation the route
    • with luck it stays in landscape view but it changes to portrait view latest after the third re-calculation

    And it doesn't matter what kind of rendering is used, it's on software and hardware the same.

    (Edit: -----snip-----)

    I'm rather disappointed. Where can I get the (working) version 2.1.56+ ?
  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.1.60+
  • automatic renderer not supported destination:lanes? (in hardware renderer that works)
  • automatic just sets hardware or software renderer
    not sure what do you mean
    may be give example
  • version 2.1.60 automatic renderer OK, test - destination:lanes=Žiar nad Hronom||Hontianske Nemce  (https://www.openstreetmap.org/way/268763967)

    version 2.1.60 crashed when navigating, automatic day/night, still switches
  • Version 2.1.60 on Sony Xperia Z3 Compact.

    MFN updated to 2.1.60 overnight & now it's stuck in night mode. It's set for auto but if I switch night mode to off in settings the menu screen goes to day mode but the map stays in night mode?? I've rebooted my device but it made no difference.

    Edit - With device in landscape position MFN menu is also in landscape but when navigation starts map switches to portrait & won't switch back.
  • I get the same, please wait for fix
  • Version  2.1.60 , hardware rendering , default car settings. 
    On Samsung Galaxy S4 I9506 Android  5.01
    I have just bought the Premium features pack. When the “Alternative routes” is on “The time to destination” is wrong, and  if  I recalculate the route again, without doing any things, the time grows but the distance is still the same, and next time I recalculate, the time went even bigger. If I uncheck the “Alternative routes” in settings and close and start MP again the time is ok every time I recalculate. This problem occur for all type of  roads and  routes.
    If I change the color of the” Navigation highlight” to blue I get yellow color.

  • The alternative routes option needs (quite) some optimization from my point of view. The first route is OK and always the best: it is simply the route that is also calculated currently without the new functionality. The second route mostlly seems relatively normal as well but the third is regularly really weird. There are of course more apps, android and online, that calculate alternative routes and mostly the 1st, 2nd (and sometimes 3rd) seem very logical in those cases. I drive a lot of rental cars as well (for my work) having all kind of nav apps sometimes also calculating alternative routes: To me the navigator one seems the least optimised.
    In the case of navigator the 2nd is sometimes "not logical" and the 3rd is regularly looking like a route going from Amsterdam to Paris via Moscow.
    Fortunately the first is still the most optimal one.

    What is the approach for generating these 2nd  and 3rd route? shortest route, shortest ???? combinations ??? 

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion