Test of Android version 2.1.x
  • 250 Comments sorted by
  • 1)can you set debug to high, repeat problem and send us logs?
    2)there are possibility to choose color of all routes(you have color of selected route)
    @hvdwolf - first is calculated route normaly then links of that route changes priority to lower and then it calculates again

  • @lubos.
    I have send 2 different logs, 1 for a short route and one for a longer route. Please have a look at log ending with 172210, at the simulate route, something strange happens with the speed. 
  • V2.1.60
    1. Although I have night display switched off it switches to night mode at night (I believe others experienced the same issue)

    2. If after AR are calculated decide to go back ( cancel) it freezes. This is intermittent.
  • hvdwolf, can you please send some examples of wrong alternative routes? I am attaching a screenshot of Amsterodam to Paris routes and it doesn't seem wrong to me...image
  • Testing latest beta version on a Samsung Note 4 in Germany (and purchased premium functions). Suddenly getting bugs on this version, which I never had before:
    Flickering black screen when navigating is the major bug.
    Had to restart app to get GPS recognized once.

    Also a couple of general  suggestions/observations:
    Please make the navigation route color dotted or striped to be more visible.... or at least zero transparency.
    Alternative route function takes too long to caculate
    Scale size of POIs very diffent between normal map and 3d navigation map....too large or too small on one of them.
  • @Stepan:  Sorry for confusing you. I typed: "and the 3rd is regularly looking like a route going from Amsterdam to Paris via Moscow.".
    This was simply an example of how weird it can look like. I didn't check Amsterdam-Paris. I simply checked some routes I regularly drive varying from 120 - 250 km and for those routes the 3rd is not logical. See image.
    The primary purple one is logical and so is the secondary "yellowish-green" color (maybe some lady around might have a proper name for this color ;) ). The 3rd orange route is not logical.

    The next example might seem logical but is not logical.
    The purple primary one is logical. The "yellowish-green" is logical. But the orange is not. At some point the orange one splits off of the yellowish-green one and then crosses it and goes vertically down.
    The logical route would be to follow the yellowish-green one and then go straight down. That would be the 3rd best option.
    And finally (really low priority): Why is the route "yellowish-green" and the text below bright green? Why are those colors not the same?
  • Hardware renderer: GPS position arrow still "wandering off". This morning I drove a small route and while driving on a perfectly straight road, the GPS positioning arrow started to "wander off" in a diagonal direction about 50-60 meters of the road "sticking" to a very small road and forcing a recalculation. And then after 10 (?) seconds or so it slowly drifted back to the road I was driving on.
    This is actually not consistent with what @Lubos said (-GPS issue is probably connected with rendering in 3D where is enabled "smooth animation". This extrapolate position into future and when you turn out of route, it starts making problems.).
    I can imagine it works like that on a curvy road but this was a very straight ongoing road.
    I will try to do a NMEA recording but I will do that on a well-known route. I hate it when it goes haywire at the exact moment I really need those instructions. And added to that: It has never (!) happened to me in software render. I assume it is not the GPS position itself but some using/recalculation/rendering that position in the screen.
  • try to reboot your device, it usually helps

  • For some issues it does help indeed.
    However, I reboot my device before every trip nowadays: almost always and certainly always before a longer trip! I started doing that with the GLES alphas and continued doing that with these 2.1.x beta builds which started out as real betas and still are. As I'm already doing that for months I can tell that rebooting doesn't make any difference on this GPS hardware behavior. 
    Only after installing a new version a reboot is almost obligatory as somehow "something" remains in memory even after having closed navigator. This is some hidden issue as well (at least for me on my Samsung S5 mini android 4.4.2)

    Edit: And yes: before my trip this morning I had "rebooted" my phone as well. I always switch it off at night and had only switched it on about 15 minutes before leaving.
  • Hi, I also tested this beta version 62. I use landscape mode for navigation, but after starting to navigate the screen turns to portrait. I have to restart the app several times until it stays in landscape. This never happend in the non beta version.

    Also it changes from night to day mode during this orientation switch. If I was in night mode in landscape and I start navigation, it switches to portrait in day mode.
  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.1.62+
    -freezing on canceling route selection( @stavrich )
    -adding new ro, uk, el - translations.
    -searching on English phone in Prague returns arabic texts fix
    -automatic nightmode fixed

    @tvo The time to destination problem - we tried to repeat this issue but it worked as expected for us, only one small issue that routes are on every calculation bit different(but not much).
    Speed issue problem we attempted to fix but it didnt help. There is problem of undefined speed(another programmer said)

    @jd417, @Shrebo - problem with changing orientation is in this version still not fixed but it will be fixed in version 2.1.64+

    @hvdwolf navigator is always calculating 3routes(when AR are enabled), it can happen that last one is longer. Incorrect route color is fixed in version 2.1.63+, wait until we publish it.
    About GPS problem - on some devices happens that if device is overheated then it lost GPS signal(in GLES this is happening because it is not enough optimalized). Can you check if your GPS issue is connected with overheating? thanks
  • I realy hoped you could solve the “time to destination problem”, because for me the problem is so big that I can’t use the use MF when the “Alternative routes” is checked. I can give you one example why. 
    Default speed settings for the car.
    Departure:  Denmark – Aalborg - town center 
    Destination: Denmark – Copenhagen – town center
    With “Alternatives routes” unchecked 
    Calculate the route
    Results :
     414km – 3:29 hr.  (I am pretty sure that this is the right time)
    Then unchecked “Alternative routes” and restart the MP 
    Calculate the route
    Results (I only show the results for the first of the three routes)
    1. Calculation: 414km – 4:16 hr.
    2. Calculation: 414 km – 4:45 hr.
    3. Calculation: 414 km – 4:59 hr.
    I think you can see that is to big difference. I also have tried it for other countries and with same bad results. Please try if you can get the same results as I got for Aalborg to Copenhagen.

  • Hi,
    There seems to be no difference in hardware rendering between energy saving mode or 5 or 15 frames mode. My CPU meter always shows the same load.
    Only in 30 frames mode the battery can't be loaded during driving, because so much drain of battery from CPU usage. The phone in all modes gets really hot.
  • I forgot: will there be an immersive mode setting in future to get rid of status bar during navigation?
  • v1.2.62 - Navigation Highlight although can be changed to a different colour, in navigation mode, it reverts back to the default green colour (I want my nice purple back :)) ) .

    NB. AR unchecked

    @lubos : -freezing on canceling route selection - I can confirm that is not freezing anymore but there seems to be a kind of navigation taking place in the background. 

     In main menu the Stop Navigation is displayed. 

     In Map - although no routes are shown the navigation arrow is displayed.

    The right bottom icon shows the Navigation arrow and when clicked changes to the other two stages.

    My recording indicator is flashing recording (my default is to record automatically)
  • What android version is needed? Please change the information in google play when it run no longer with android 2.3. for example: zoiper soft phone works with android 2.3 yet with the newest version.
  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.1.64+
    -alternative routes times fix (reported by @tvo)
    -frozen dialogs on init fixed
    -show/hide extra menu buttons after failed route computation invalid thread exception fix
    -software renderer race condition in showing recalculating dialog fixed
    -screen rotating during recalculating fixed (reported by @Shrebo)
    -send logs send also information about last ANR
    -alternative route colors fixed (reported by @hvdwolf)

    -HW renderer is still not optimalized well, you should use on your device SW renderer(if you disable in scheme editor greenery and builtups then it will be as fast as HW renderer on your device)
    -we do not plan to implement immersive mode - it was in one experimental build long time ago but we wasnt able to decide how fullscreen button should work

    @stavrich - I will take on issue you reported next week
    @Matthias - We stopped supporting ARMv6 CPUs(50% Android 2.3 devices have this CPU type). If you install Navigator from Google Play on ARMv6 device you will get version 1.6.30. 2.x versions are only for newest CPUs.

  • Thanks, lubos. With SW renderer it does not make any difference with disabling any items, it is always completely unfluent. HW is nice, but uses a lot of battery. It doesn't mind me during driving, only with 30 frames the power consumed is more than the charger delivers.

    But in version 64 now the sudden rotation issue seems solved, thanks.
  • I can confirm that the problem with route times is solved, also on my phone. Thanks
  • @lubos
    Thanks - no rotation anymore on my HUAWEI
  • Going forward is nice, and hardware-support for rendering is a very great thing. Staying with the galaxy Y is maybe stupid, but no other phone is so stable and small and android 4 need to much power for wlan and have some other problems.... Forever i will not stay with this phone :). I make support for a S5 and a S4 (both got a android 5 upgrade) and can therefore always testing the newest version of navigator. Keep the good work.
  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.1.65+
    -do not allow click on map when choosing alt route
    -reverse route during navigation code moved to c++ and holds route color
    -after reversing route, only one route is computed now without alternatives
    -black screen on init fixed
    -changing english language to pure GB
  • @Lubos: You answered to Shrebo:  "(if you disable in scheme editor greenery and builtups then it will be as fast as HW renderer on your device)"

    I mentioned before that I like a clean as possible map and that I don't like the 3D-buildings in the hardware render, nor the grey areas in the SW renderer. I experimented with transparency and buildings in the same color as the background, which improved the situation.

    But your (unintentional) tip is gold for me! By disabling "Building" in the scheme editor I now have my clean map. So simple and so effective :)
  • @hvdwolf could you please explain, how to make SW rendering faster this way? I tested it with no result. Thanks.
  • @shrebo:  I did not test whether it is faster. I simply want to have the simplest map possible. I don't want all kind of distracting "things" on my map and that's especialy valid for the 3D buildings (see here). That's why I disabled the buildings.
    I simply assume that when navigator needs less rendering (no buildings), it will be faster.

    However: in contrast to what @Lubos says: On my phone software renderer is definitely faster than hardware renderer. Under all circumstances: buildup of screen, display and screen buildup of calculated route(s), rotating the map in case you drive around corners/curves, etcetera.

    Edit: And I see that @Lubos gave the exact same hint 2 posts further in that thread and I have already been using it as well. I feel quite stupid.Somehow there is a black hole in my memory.
  • @hvdwolf - in GLES there should be about 15k of triangles on screen maximum-we renderer in some zoom over 400k triangles and that make device overheated(depends on mobile chipset). Sadly when I did statistics I saw that half of these triangles are greenery and city builtups(not buildings).
  • @hvdwolf, thanks. With SW-renderer and with route simulation there is not really a fluit display possible. I did not test it with a real drive routing.

    To get rid of the buildings does also not make any difference in HW-mode at all. Perhaps this will be better in future updates on HW-rendering.

  • The SW renderer is always "jumpy" in route simulation. I have a quad-core S5 mini which is a relatively fast but it behaves exactly the same as on my older, slower less memory dual-core phone. The behaviour is exactly the same: the SW-renderer is simply not a fluent moving renderer.
    That has nothing to do with your phone.
  • @Shrebo - I was talking about map moving. In navigation real GPS position is once per second, GLES has in 3D mode some extrapolation which makes rendering "fluent". Sorry it was misunderstanding

    @Durko - can you send logs? Thanks
  • @lubos: You asked me to track to nmea on one of my routes. so I did on several, short routes.

    Navigator 2.1.65 in hardware render mode on Samsung S5 mini stock android 4.4.2

    == To start with: It matters in which order navigation and recording is switched on. I started navigation and switched on NMEA tracking. I could not backout of the recording screen. After 2-5 (?) seconds the screen went blank. After 3-4 (?) more seconds navigator crashed, but 2 more voice commands were given. It tried to restart but that didn't work. I tried this on another occasion as well and the same crash happened. 
    When starting NMEA recording first and then start navigation it works.

    == About the wandering off:
    See image below, route is from "bottom" to "top", meaning from 1. to 2..
    The light-brown track is the NMEA recorded track.
    The black dotted track is where I was driving and which was the calculated route.
    1. is where the arrow "wandered off". 
    The orange dotted line is where the arrow jumped to beginning of the purple line and started to calculate a new route "to bring me back on route"
    2. is where it snapped back to the original route.
    Note: This is my scheme with building switched off


    I did send a mail to android-log@mapfactor.com with the nmea file, the image (in original size) and a crop of the relevant area.

  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.1.66+
    -do not allow click on map when choosing alt route
    -gles shutdown crash fixed(?)
    -canceling route choosement race condition fixed - can @stavrich that it is fixed?
    -manouvrePanel during route choosement hidden
    -escaping route choosement by HW menu button fixed
    -stop simulation during route choosement fixed
    -gles dangerous subdivision removed

    I know about this issues but I am not able to repeat it on my device. Can you set debug level on high, repeat both problems and send logs?
    Btw nmea wasnt in email attachment, I prefer logs anyway, thanks
  • @lubos:
    I forgot the nmea track file. I have send it now. sorry.
    Next wednesday/thursday 17/18 Feb I'm on business trip again. I will set debug to high and track to nmea.

  • To add to this:
    This "wandering off" only happens in hardware renderer mode and only in navigation. I have numerous tracks where I simply track where I'm going. It never wanders off, nor in sw render mode and neither in hardware renderer mode. my GPS is really very precise.
    I also use 3 other nav apps, just to compare, and not one of the others wanders off: never !
    Only navigator and only when navigating in hardware render mode.

    Maybe it is only my phone as untill now I only saw one other person confirming my experience, but I can hardly believe it. Samsung is by far the most sold phone, so there must be others.
  • I also have this wandering off, also losing GPS lock which can only be restored by quitting and restarting navigation.
    This is even in software render. Motorola Moto G2 XT1068.  Android 5.0.1. Samsung Tab 2 7 Android 4.2.2. Never had this problem in ver 1.6.xx
    I have mentioned this before but never had any reply.
    I also have 3 other navigation apps non of which lose GPS fix unless it's in a tunnel and reacquire GPS lock fairly quickly when clear.
  • @lubos
    V2.1.66 - still something wrong.
    AR - checked 

    1. Chose destination > 3 routes displayed - do not choose route > cancel , go back to map = all ok as expected. 

    2. Main Menu > Route Info >Delete All > Main Menu > My Places - choose different desination -

    Calculating announcement - display goes to Map BUT no route or routes are displayed but navigation arrow is shown and recording indicator flashing. 

    Go back to Main Menu - Stop Navigation icon is shown > click on it > returns to map view, navigation arrow goes off but recording indicator keep flashing 

    Tried to stop recording, etc.. 

    Finally " Navigator isnt responding " 

    Same results on both Samsung and Blackberry
  • Hi lubos,

    In version 67 in automatic night mode it still changes to day mode when I turn the device from landscape to portrait or the other way. The map stays in night mode, but the main menu switches to day.
  • @stavrich
    I confirm that this can be replicated when recording is on
  • @lubos, today I had most of the route the arrow shown left or right to my route in HW-mode, but without rerouting. It seems that it only shows on the wrong place and got the right GPS-position.

    Yesterday I started my route in daylight, but it went totally dark during driving in the evening. Navigator still kept daylight display, also after restart (current beta version).

    And last question: Why is my route always green highlighted although I set the color to purple (default)? Thanks.
  • In new version 2.1.68 menu still switches to and stays in dayview mode when coming from nightview navigation

    I didn't notice other changes this morning
  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.1.68+
    -getactivity returns null fixed
    -screen orientation lock better
    -gles model destructor fixed
    -new en_US transaltions

    @Roldotf, @hvdwolf about "wandering off", I checked code changes between 1.6.x and 2.0.x. I found there is some dangerous modification, we will test it internally first. It is good to also mention that position extrapolation in HW renderer is quite badly written and it wont work well before someone completely rewrites it.
    @stavrich - about stop responding issue... I wasnt able to replicate it on my device, can you repeat it and then send logs by navigator settings? Thank you
    @Shrebo, @Joopy - I hope I fixed this in next version(not this one), it will be avaible on next weekend

  • @lubos
    Thanks for looking into it. I was starting to feel like it was becoming unusable. It always seemed to stop working at the worst possible time. I was beginning to think it was just me. I still have a copy of version 1.6.11, which I will install on my tablet and the latest version on my phone.
  • Twice in a row. Downloaded a map (first time Luxembourg, second time next day (or so) Netherlands). Map download was successful. Upon "Leave screen" (or whatever it is exactly called), the app crashed. The app restarts but during the second time that it restarted and did a check of my data files, it never recovered. After 15 (?) minutes or so I had to reboot the phone as I could not stop navigator. After reboot it was OK.

    Did 2 150+ km trips. Recorded everything, but no wandering off this time.

    Edit: In total slightly over 500 km the past 2 days. Not one single time the pointer "wandered off".

  • Version 2.1.70 Hardware render and software render.
    There is still a problem with the navigation highlight colour.
    Uncheck the “Alternative routes” in settings.
    Close MF
    Open MF
    Insert a destination
    Press Navigate
    The colour for the navigation highlight is not the colour from the colour setting, but a yellow-green colour , which is nearly invisible on yellow roads .
    If you calculate or simulate the route after adding departure, then  the navigation highlight colour is ok also by navigation, and will stay ok also for new routes until you close MF and start again.
    The same problem occurs when the “Alternative routes” is checked, and only one route is found, (which often happens).

  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.1.70+
    -screen orientation locking disabled for old devices
    -gles icon highlighting added
    -new sr serbian translation
    -navigation route color fixes
    -checkbox for disabling TA ad is visible&working when noAds is purchased
    -checkMCA writes into log stack of exception
    -send logs attached ANR log better
    -night mode UI problem after screen rotation fixed
    -compass calibration screen orientation locking better

    @Roldorf - if you really need 1.6.x version, here is our official link for more stable version: http://download.mapfactor.com/mapfactor_navigator_1_6_20.apk

    @hvdwolf, @tvo - we will take a look on it

    I did also test on this version during weekend and it didnt pass, so expect new version soon
  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.1.72+
    -start navigate without AR route color fix (reported by @tvo)
    -restart engines fix
    -aggresive SD card detection disabled on Android5
    -not visible advertisements on android 5 during download fix
  • Version 2.1.72
    @lubos - Yes, the route color problem is solved now, thanks.
  • @lubos Thanks for the older version.

  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.1.75+
    -alternative routes bit improved
    -tools dialog - Record/Replay/Manage GPS files renamed to GPS recording
    -set night mode after init is finished
    -show manoeuvre arrows hiding fixed
    -all fullHD devices uses GLES as automatic now
    -recomputed status fixed for simulation
    -infopanel blinking on mapmode chooseroute fixed
    -showing what's new only if there's something new
    -missing map mode button after choose AR fixed
    -players/rercorder showing during route choosing disabled
    -default route colors changed + AR route choosing more contrast

    Please do careful tests, this version is release candidate, thank you
  • Hello lubos
    i like your Navigation Software very much and tested it out.

    What i have found out, there is a Problem with the height Display. I'm living in Germany and the heigt of the Software gives me a value ca. 50 meters to much. I think it is because of the Geoid anomaly.
    Is there any plan to implement a correction table in the Software?

    Best regards

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion