Test of Android version 2.1.x
  • 250 Comments sorted by
  • Hello Larry,

    I have no idea what do you mean. Can you explain it differently or provide screenshot?
  • @lubos:  What Larry means is the so called "worldwide altitude correction". The calculated altitude by a GPS needs correction for every latitude/longitude because the GPS calculated altitude is based on the WGS84 reference ellipsoid, not based on sea level or some other standard level.

    Some Nav apps deliver a "worldwide altitude correction" data file with their apps to compensate for these inaccuracies (see OsmAnd for example). If you search the web you can find prefilled databases/CSV files and so on to convert this to a suitable format for your application/appliance.

    @Larry: Be aware that cheap GPS sensors might have an additional deviation simply because they are not accurate enough. What's more: they can be terribly innacurate for altitude.
  • Thanks hvdwolf for the explanation. Exactly that is the problem. 
    For sure have cheap GPS sensors deviations but the height is always incorrect in the same way. 
    A input for some correction value would also be nice. Better of course a correction table.
  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.1.76+
    -more secure access into eshop
    -restoring edge speeds after alternatove route computing fix
    -tools swap of gps recording and gps info

    @Larry We are sorry but we are not going to implement this right now, we have another priorities.
  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.1.78+
    -initial navigation zoom fixed
    -null pointer exception in RegionsExpandableListAdapter fix attempt
    -invalid manoeuvre arrow assert removed, error logged instead
    -unnamed disabled links named unnamed
  • Version 2.1.78 
    Hardware render 
    There is a problem with showing the calculate route.
    Go to tools and then press “Calculate route”
    3 routes are found 
    Choose one of the routes to see it on the map
    The map zooms to a very high level near to the center of all 3 routes, and you can’t see the route.
    When I go to the “Route info” and press “Show on map” only the “best” route is shown (good feature), and here I can see the entire route.

  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.1.79+
    -saving routings points should not crash any more
    -calculate route zoom issue fixed thanks @tvo
    -compass not calibrated toast not in UI thread crash fixed
    -info panels list sychchronized to avoi possible crash
  • @lubos The route calculation zoom solved.Thanks
  • Hi 
    i have an issue with the newest beta version.
    When i press "maps" on the start screen there appears only a black screen. Nothing more happens.
    Only when i touch the screen the map appears. This behavior is new in Version 2.1.79+.

    Android Version 4.3.x

    PS: Found out this only happens with software rendering or automatic mode.
    In hardware mode it works but in my case very slow.

  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.1.80+
    -french_guiana_ta, colombia_ta, yemen_ta, costa_rica_ta, guatemala_ta, honduras_ta, nicaragua_ta, panama_ta added
    -gles texts shader fix
    -nmea/gpx on replay set map centering on
    -black/purple screen in SW renderer fixed - thanks @Larry
    -possible loading profile exception caught and logged
  • Just tried 2.1.80 and hardware rendering is no longer working correctly.  Place names missing at certain zoom levels.  Others rendered white.
  • @amlumsden can you please provide screenshot?
  • it does not happen to me
  • HW rendering ran neat and smooth on my way to work this morning. No problems with several re-calculations of the route occured.
  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.1.82+
    -revert of text rendering change in hardware renderer
  • Just installed 2.1.81.  Hardware rendering issue still there - incorrect font on some place names, also rendered as white. If you zoom out too far then all place names disappear.  Tried uploading photo but failed.

  • Quick update to state that I have tried 2.1.82 and the hardware rendering issues I experienced are still present.  Missing place names at certain resolutions etc.  Software rendering works fine.  Hopefully the screenshots I sent Lubos will help identify this.
  • I have tried 2.1.82 on LG L7II (768 MB RAM) and tablet Nexo Smart (more than 1 GB RAM). MFN on tablet works perfect but on smatrfon there is a big problem. Adding second, and sametime first, point via to the route couse that MFN is frozen and must be killed by task manager.
  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.1.86+
    -gles text in 3D indices overflow fixed
    -gles unsafe operations fixed
    -gles depth test for texts disabled

    @amlumsden - try please this version and give us know
    @MFNUser - can you repeat freeze on phone and then send logs using navigator advanced settings? thank you
  • Zdravim,
    android 4.1.2, navigator 2.1.86

    pred prijazdom do ciela, som otocil mobil, navigacia zamrzla a spadla

    ak je to potrebne log a screenshot mozem zaslat na android@mapfactor.com

    edit: poslal som na android-log@mapfactor.com

  • bohuzel se mi to nepodarilo zopakovat
  • Can we please stick to english?
  • apparently Durko had black screen when turning from portrait to landscape during navigation
    I could not replicate this

  • @lubos - how can I send you logs ?
  • go to Settings and click Send logs
    please type description
  • @tomas - I have log files on my computer. I download them from my phone.
  • then email them, but I think it is easier from Navigator
  • @MFNUser - please use "send logs" in navigator - in navigator/logs are not all logs
  • hello Tomas,

    the error is not repeated, maybe error hardware(full RAM, GPS signal loss?) and not software

    navigator 2.1.88 is OK, test morning

    Thanks, Durko

  • After upgrading to Android 6 with maps stored on the SD card adopting the SD card as internal storage navigator hangs when opening with
    the message waiting for SD card, only option was to force close.
    Will uninstall and reinstall to see if that cures problem.
  • Unfortunately,
    even after upgrade to newest version, MFN on phone with poor memory is hanged during calculating route with 2 points via.
  • how much memory do you have?
  • LG L7II has 768 MB, but in fact, there is ~120 MB free.
    My tablet with 1 GB has ~400 MB free and MFN work fine.
  • Hi Lubos,  Just to confirm that 2.1.86 is still the same when rendering map with hardware.  OK with software.
  • @MFNUser
    try to Reset to default in settings/advanced - please select backup and delete
    then set your waypoints again and try it
  • I reset to default but this don't correct problem. But ..... I discovered that this problem appear only when route is calculating from form (window) "route plan". So ..... when after adding second point via (when appear window with list of point) I return to main window I select calculate route from utilities this work correctly.
  • Some feedback on 2.1.86 & 2.1.88 all in hardware rendering mode, Samsung S5 Mini stock android 4.4.2:
    - Buildup of initial map screen still (much) slower compared to software mode
    - losing GPS position and wandering off like reported before: In the last 6 150+ km trips and a few 5-15 km trips, it happened twice:
    • once on a almost straight motorway where it moved parallel  to the highway (so no hard bends in the road), but it did not really loose position and did not do recalculations. This was a long trip.
    • once in a town (short trip) with many parallel streets where I picked a one too early "take right" bend. This street went parallel (about 50 meters apart) to the calculated route. The cursor showed I was on the wrong road, but the voice direction simply continued as if I was on the correct road. On the next crossroad (after about 100 meters) I wanted to do a "go left, go right" to get back on the route while Navigator still continued "as if nothing was wrong". Once back(!) on the original route, where the cursor and the route merged again, Navigator lost complete GPS position. And then it took way too long before it had recalculated the (original) route. So it simply continued as if nothing was wrong, and once on the right track again it lost GPS position.
    From my point of view the first might be something wrong  in the "prediction" algorithm to make the map movement fluent. 
    The second is of course due to my incorrectly taking the wrong road in a dense street network, but the fact it lost position only when back on the original route, coupled with the fact that it took so extremely long to recalculate the road in a 8 km trip, was weird.

    Note: before every trip, even the short ones, my phone was rebooted (even though I hate to do that).
  • could you please record NMEA and possibly take screenshot when it happens?
  • I will send my logs. I did record NMEA logs when it happened "all the time", but  after Lubos asked me to record debug logs with setting to high, as he preferred that, I did not record those NMEA logs anymore.
    And it improved greatly in the last few builds.
  • Version 2.1.86 need more power for recording NMEA. for 1,5h recording i needed 10% and now 15-20% Akku.

    I have bought a Samsung Galaxy Xcover 3 :).

  • Where to get the version 2.1.88?
  • The latest version is 2.1.90. Those are beta builds as the current version on Google Play is 2.1.86.
    If you want to use the latest beta watch the links Lubos (mostly) mentions in this thread, or become a Google Play test user: https://play.google.com/apps/testing/com.mapfactor.navigator

  • android 4.1.2
    navigator 2.1.90

    hardware renderer: GPS position is parallel to the road (fix 8/9 satellite)
    switched software renderer / restart application
    software renderer: OK (fix 5/9 satellite)
    switched hardware renderer / restart application / start aplication "Checking data consistency"
    hardware renderer: GPS position is parallel to the road (fix 9/11 satellite)

    screenshots available, Durko

    screenshots: http://nahraj.to/g/tE1 (First photos should be the last)
  • The  "parallel to the road" observation by @Durko is the same I mentioned here, but my observations were for the 2.1.88 version, and not consistent.
  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 2.1.92+

    build 2.1.92
    -Virgania->Virginia transalation fix
    -geo intent failed message
    -gles icon highlighting revision
    -gles missing highlight fixed
    -new ro translations
    -proper favs/routes locale sorting
    build 2.1.91
    -touch route text translation fix[de]
    -continuous route highlight assert not checked when crossing sheet borders
    -choosing alternative route freeze after previous simulation fix
    build 2.1.90
    -menu buttons color after change night mode fixed
    -starting navigator without graphical menu crash fix
    -scheme editor crash on android2.3 fixed
    build 2.1.89
    -navigation from contacts fixed
    build 2.1.88
    -alternative routes choice race condition fixed
    build 2.1.87
    -route not found in navigation moved into infopanel
    -route not found dialog re-added
    -gles slerp disabled on route not found
  • 2.1.92:
    @lubos wrote:
    -geo intent failed message
    Which message?
    When I select an address from my contents Navigator still hangs.
    When I disable mobile data and wifi and select an addres from my contacts, my screen remains "dimmed" but I do not get a message.
  • @hvdwolf
    I am still not able to reproduce the problem that occurs when you select an address from your contacts. Can you please provide more info? Is Navigator already running or do you start it from contacts? Does it hang every time for any address or just some? Thanks
  • Navigator is closed.
    I open contacts and tap an address and select Navigator to open it.
    Then the screen gets black and Navigator does not react anymore.
    After a very long time Android gives the popup that Navigator doesn't react anymore and offers met to close with the options wait, report OK.
    Of course I choose OK to stop because if I don't it simply repeats itself.
    Navigator always hangs. The only time I didn't hang was after a complete uninstall and fresh install.
    And the next day it hung again.
    Cleaning the cache didn't help.

    And now that you are asking so specifically.
    If I have Navigator opened, go to the main screen and open the contacts app and select an address from the contacts app it functions, and it functions all the time.

    Then I closed navigator again.
    Tried again from the contacts app and now navigator hangs again.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion