Test of Android GLES Alpha Version
  • Here is a link available for eager alpha testers:

    The link points now to navigator_0_38_77-ANDROID_GLES_RENDERER.apk, which is based on 1.6.14.

    Note, that by default you should not notice any change. If you want to try GLES rendering you have to go to Settings/Advanced/Map renderer/Hardware
    Your selection will force Navigator to close and you have to start it again.

    There are several major implementation changes down to asynchronous map loading, display and interpolation.
    At the moment we are mainly interested in stability and if it runs on your device with your GPU.

  • 246 Comments sorted by
  • on Nexus 5 - kitkat 4.4.4 -- I can't install it...the installer starts and after a second I get a message "Application not installed"
  • Please wait, next build in 20min - obviously somebody made mistake.
  • after I uninstalled the previous version (1.5.22  if I recall correctly) then a clean install worked...but I'll wait for the new version
  • @Tantum and @mdx: The MNF application is a signed application. If the new application uses the same sign, but is apparently a different application (different manifest, different checksum, not an upgrade (or is it), same sign) you can't install it next to the current application or over the current application as it could be a "hacked" version.

    So you indeed need to do an uninstall. And then you can install the "hacked" version. (So much for security).
  • Yes, that's what we wanted to avoid that you do not have to uninstall and in some cases re-download maps. Next version should differ only by the internal version.
  • It should be fixed now (0.38.78). Please let me know if you are still forced to uninstall. Thanks
  • It runs on my Samsung S5 mini, Android 4.4.2, screen resolution 1280x720 and does route simulations. I will test this afternoon (15 minutes drive) and tomorrow on a 2 hours drive.

    Edit: I mean with hardware render enabled of course.
  • Report from a low-end device (Sony Xperia J, Android 4.1.2, 480x854), tested on simulation only, so far.:
    • Installation was without problems (I could install it over my beta version).
    • Map drawing takes too long on my slow device. Result: Opening the map takes quite long, you can see that elements are missing and are added one by one.
    • Cannot use GLES rendering together with (Google) TTS voice, because voice AND map is staccato then. (Recorded voice together with GLES still works well.)
    • I really like the new map layout. It's just too small on my display, both street widths and font size: The zoom level seems to be too low for me.
    • So far no stability issues. 

    PS, I added a test in 2D mode:

    • It loads much faster, but it's still too much for my device to run it with TTS
    • The map does not zoom at all in simulation mode, that way it's not usable:
  • First observations:
    - new map layout is an improvement to the right direction
    - rendering is smooth while driving
    - sometimes the arrow is cca 15-20 meters behind the current location however it catches up after a little while
    - POIs seem to be floating on the map and are completely unrecognizeable (while driving...in simulation it seems ok)
    - the autozoom does not seem to work
    - the map scale adjustement does not seem to work
    - the lane guidance covers the arrow in the lamdscape mode
    - arrows that show a one way street are hard to read
    - other than that no major issues...will test tomorrow on a longer drive

    Have driven cca 30 km in the city
    Device: Nexus 5; 4.4.4

    - buildings in area=industrial are not visible
    - streetnames are floating around just like POIs

    Edit 2:
    - autozoom might be working indeed :-)
    - the path (used for walking navigation) could be a little less visible/more transparent cause it's kind of intrusive in case you'd like to use the car navigation only...I might prefer to have an option to make them invisible while you are in the "car" mode
  • On a Nexus 7 2010 v 5.1 I only see fragments of a 2D-map-display and only blue screen when simulating a route in 3D-view.
    For some reason I can't include screenshots, it says "Body is 18822 characters too long"
  • I would prefer a parallel beta installation (as oruxmaps has it for beta versions).
  • Moto G 1st gen running Lollipop 5.0.2

    New map looks very good. Runs well but autozoom not good. It's fine at start of journey but then it zoomms right out then stays there.
  • The new map doesn't allow me to click on it in order to create a new way point :|
  • The new map doesn't allow me to click on itin oorder to create a new way point :|

    Edit: Works. But I have to tap as quickly as possible and then wait quite long until the menu appears.
  • 100 km behind me today and no crashes however:
    - it lags(just a little) every time I pass a node (probably relevant for osm only) on the road...then it's smooth until the next node on the road
    - the map is kinda "stretched" when I reach the destination...don't know how to explain it better
  • Here is my routing experience:
    As long as the red arrow was shown, the map moved smoothly (still with wrong zoom level, thourgh).
    The problem: Mostly, this arrow was missing (let's say, in about 70% of my tour). And whenever it was not shown, the map was not updated.
    Even when freshly updated, the position was wrong (I'd say 50 m). Thus the voice commands were much too late.

    Thus: for my slow phone, the new renderer is definitely not usable. Pity :-(
  • Had a drive of 150 km today. On my Samsung S5 mini performance is OK.
    It was stable the entire route.
    I do like the 3-D buildings. I did see that in another Czech nav app as well :) but they were too big there and "blocking" the view (my opinion). In MNF the zoom level is slightly lower and so are the buildings: they are not as "over the top" as in that other app.

    Some remarks:
    • I had 3 times big blue areas instead of green grass and forest. Something in the renderer is not yet 100% OK.
    • At the top of the screen where the sky mixes with the ground, I did see a strange discoloration in the road due to the mixing of the semi-transparent areas (I think). I can't remember having that seen in any of the "old" versions. (Edit :especially visible in portrait mode)
    • I "turbo" zoomed in and did see twice the polygons/triangles of the buildup of the screen. I think the renderer can still use some performance improvements.

    And with regard to autozooming: I think it works but it seems to work within smaller max zoom/min zoom boundaries. Of course I can't look at it for a minute while breaking or accelerating. That would be too dangerous.
  • Firstly thank you for your comments. It is important to us.

    chattiewoman - I had a look at the the specification of the Xperia J. I tried it on a tablet with a worse processor and it worked OK. I wonder if it is more to do with the limited memory (512MB).

    hvdwolf/JambaFee - I have seen the blue screen probelm myself although we thought we fixed it. We will investigate this further.

    Tantum - the smooth rendering while driving is a result of a predictive algorithm (we only get positions once a second) and I am sure this will still need fine tuning :-)

    jd417 and others - autozoom is also a feature that needs fine tuning. This is something we will have a look at.

  • Simulation works on an Asus Fonepad 7, model K004,16 GB, running on Android 4.1.2. I wonder, what makes the difference.
  • @JambaFee I tested it on Nexus 7 2012 v 5.1.1 (I think you have 2012 too because 2010 doesnt exist). Can you try it one more time and if it still not works send us logs(and write "gles alpha" into description)?
  • Looks good on Samsung S4 mini Android 4.2.2. Same problems as stated above. 
    Two minor bugs about transparency and size of custom poi icons (png 80x114 working well in normal mode):

  • @lubos: Just sent you a logfile. Of course you are right, it is a Nexus 7 model 2012 (mobile version, therefore still 5.1.0)
  • The voice commands are most of the time too slow at the beginning of the route. After some time, 30 secs to a minute, the commands get "in sync" again.
    I tried this a couple of times with and without reboots.
  • This post moved to new topic : Error in navigation.xml

  • Working fine so far on my LG L34C running Android 4.4.

    Keep up the great work!

  • This post moved to new topic : Error in navigation.xml
  • @JambaFee  I had also had a blue screen when I installed 0.38.78 on Galaxy S4 i9506 android 5.01, but when I in settings changed Projection from World – Mercator cylindrical projection to World – Miller cylindrical projection it was OK. Give it a try.

    @mdx , @lubos. When I navigate from north to south the text on the map is with upside down, but when I navigate from south to north the text is ok.

  • BUG: recorded gpx tracks are not displayed in the new GLES version. They are recorded OK as I can display them in another nav app :), but they are not displayed in the gles version.
  • Hi lubos & tvo, Miller projection works!
  • Moto G 2nd gen Android 5.0.2

    I think I must have missed something on the alpha test, been away in France for the last 3 weeks. Just dowloaded and installed alpha test version. Seems to be smooth in 3D view (which I never use) but the floating street names are very annoying and distracting (they jump around too much) would rather not see them at all. In the 2d North up which I prefer the rendering is much worse than the previous version, the position icon is very jerky jumps forward and then back ( a kind of flicker). Zoom not work, manual zoom gives huge icons which cover everything (all done in simulation mode as it's now 23.58. Will try tomorrow when driving.
    Is the smooth rendering only available in 3D mode?
  • BUG

    When I reach the destination, the Navigator shuts down. It happened to me 3 times out of 20...so it doesn't happen every time.

    Lollipop 5.0.1
    Nexus 5
  • On my last two 150+ kilometer trips (yesterday and the day before yesterday), the gles MNF version also crashed during the trip. I could restart it easily (on the highway, not in a city fortunately) and it picked up immediately, but it should not happen.

    I also had a lot of blue colored screens. More then on my trips of last week. It seems that every time I reduce speed due to whatever reason, the color comes back.
  • Also -- the rendering of the roads does not seem consistent (referring to the map scale).

    I can reproduce it when I zoom in to the maximum possible level and then zoom out slowly.


  • I am not sure if my problem was caused by the gles version or not, anyway it came up using the gles version.

    When searching for a city using the Google search from within navigator, the app halted. I had to close the app via the app manager of Android. On restart of Navigator, it had somehow lost the connection to the maps folder. The was a kind of message related to Android 4.4. Kitkat, even though the table runs on JellyBean 4.1.2. In restartet the whole tablet, but Navigator found no maps, but I could locate them with TotalCommander.

    I finally removed Navigator completly from the tablet and installed the latest Play version from scratch including all maps (sync with PC).

    At last I wonder, why Navigator does not go into the main window just because it thinks, there are no maps. There was no way to say Navigator, where it could find the maps folder.
  • I had a similar experience after a firmware upgrade (I wasn't using the gles version either). The 4.4 Kitkat message appeared, even if my phone runs 4.1.2 and Navigator couldn't find any maps. The choice was only to download the maps again or let the app shut down. Then I renamed the com.mapfactor.navigator for backup and I reinstalled the app from scratch. Then I overwrote the new com.mapfactor.navigator with the old one and everything worked fine again (no need to re-download the maps) except for a few settings that were not saved.
  • Hello,
    the link http://download.mapfactor.com/mapfactor_navigator_gles_alpha.apk now points to 0.38.84+. There are still many issues to be solved, but it is probably better idea to experiment with new version than with the old one.
    Known issues:
    - small creeks visible in high zoom

    - autozoom interpolation
    - rotated 2d texts
    - map motion should be more responsive
    - unified zoom/size (independent of history of views)

  • Autozoom works fine in 3D mode now very smooth rendering. Auto zoom doesn't work in 2D hardware rendered or 2d software rendered.
  • Autozoom works very well I must say - great job there

    - the map rendering when I start the route is strange - first I see the roads then after 2 seconds I see the buildings and then after another 2 seconds I see the landuse polygons

    - the map scaling - It doesn't scale no matter what I do and keeps the same view (which is great for portrait use but too zoomed out for the landscape use)

    - the areas marked as landuse=industrial (OSM) are above the roads and overlap them...the roads should be on top of them...a few screenshots below




    Nexus 5 -- LMY48B

  • After further testing:
    - Navigator crashes when I turn the display around few times in a short period of time (rotating between the landscape vs portrait mode)

    - the landscape mode is too zoomed out when the next turn is further away - makes it very hard to follow the route (Full HD display at least)...a screenshot below demonstrates that (imagine that you're looking at the 5 inch display and you can barely see the route)


  • I fully agree with Tantum: The landscape mode is too far zoomed out. I used MNF the last few trips in portrait mode while I prefer landscape mode.
    This is with 0.38.84
    Edit: Sorry, I meant with 0.38.84 as well as the previous.

    (Note: this gles version still has the "scout sound" bug mentioned in this post which seems to be solved in 1.6.16. Don't you cross-patch in branches?)
  • Also, as I mentioned earlier, the pathways (for foot walk) are way too much visible. If I may suggest, I'd probably choose a different color for them (maybe light brown/less contrast or so) and/or make them narrower. The current red is kinda distracting while driving cause it's more visible on the map than the white road.

    You can check it in a screenshot above from 12:53
  • you can create your own colour scheme
    BTW, if anybody wants to email better colour scheme, please do so (album.style)
  • Will do very shortly :-)

    qq - I see that you can export the color scheme..but can you also import it back? I can't find that option

    Also when I want to copy the album.style and default_album.style from my previous installation to new one...it doesn't work and the whole map becomes purple. What else needs to be copied? Cause right now I need to reset everyhing from scratch when I do a clen install...which is not ideal
  • "qq - I see that you can export the color scheme..but can you also import it back? I can't find that option"

    Your file resides "somewhere" on your phone/tablet. Double-tab on it from within any filemanager and MNF will open and request to import it.
  • you should be able to copy album.style from one device to another
    may be it is corrupted?
  • If you export a particular color scheme it is exported as <name>.mtheme. That one can also be imported.

    Do not share the album.style! That  file contains all color schemes. It is very annoying to overwrite your own album.style file which already contains your own modifications because someone else shares his/her complete album.style file.

    Again: only export your theme(s) and share that or copy it to another device.

    For example: See my GrayNightMode theme. It is a zipped file otherwise any browser would display it as the xml file it is.
    So unzip it, copy it to your phone/tablet. Double-tab it from within a file manager and import it.
    If you don't like it you can remove it again from your main album.style file with the delete option.

    I created my GrayNightMode theme as the current nightmode style is way too light and for my taste way too brown. My theme is much darker, it is "boringly" gray, but for me it is much better at night.

  • Moto G 1st gen. running Lollipop 5.0.2 & MFN 0.38.84

    When in hardware render mode the autozoom still does not work correctly. It remains at minimum zoom (ie zooms fully out) when in navigation mode. It occasionally zooms in for directional changes (when approaching a turn or roundabout etc.) but then zooms out fully again. This makes it difficult to look at the map.

    In software render mode MFN crashes when

    1) On loading navigator sometimes the menu doesn't appear, just a white screen. After a minute or so a system message appears saying navigator is not responding & offers options to wait or close. Choosing wait does nothing.

    2)If the menu does appear & I choose a destination, then navigate, when calculating or re-calculating the route navigator simply shuts down & returns to my phone start screen. It appears to work fine in simulation mode.


  • Today I installed the Gles-Alpha and switched to the hardware-renderer. That's really fast. (Nexus 7 2013, Lollipop 5.0.2).

    What I have to say, my own created mca-files (Tracks) with digger disapear, when zoom-level is coming to detail. The track-line is hiding under the streets from the official mca-files.

  • Two more graphical differences between software and hardware rendering.

    First again with digger created, a line with two colors in hardware-rendering (left) and in software-rendering (right). Same file!


    Second, I've changed in the album.style the appearance of the one-way-arrow. The hardware-rendering in gles seems to stretch the values.

    Left software-rendering and right hardware-rendering


  • I can confirm the same stretched arrows for HW/GLES redering

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion