Test of Android GLES Alpha Version
  • 246 Comments sorted by
  • I did not have this issue before.  Now I get voice instructions minutes after displayed navigation has ended. So it must be related to my ancient single core phone, if you´re right.
  • I mentioned a few topics above that I have regular crashes with the gles version. I know it is alpha, but am I the only one? (As I see no other reports)
    Yesterday over 187 km I had 3 crashes. The third at a moment I could really use the assistance. That was with the Netherlands map.

    This morning in (Kingston-Upon-)Hull 2 times in 3 km!, and I really needed the assistance.
    And then from Hull to York not once. 

    Please note that nowadays I reboot my phone (Samsung S5 Mini Android 4.4.2) before every trip.

    So again: Am I the only one experiencing one or more crashes during every trip?
  • I do not travel often, but did some 60km on Saturday and had no crash
  • Hvdwolf.. I may suggest you try the software rendering and see how it goes..
    (there's a guy complaining about 'freezes' in the thread below and he's using the 'stable' version..)
  • I will indeed try the software rendering the coming days. Such a useful and also such an obvious suggestion (Why didn't I think of that?)
  • But to answer your question: no, not a single crash with GLES (and hardware renderer).
  • Motorola Moto G running Lollipop 5.0.2 & MNF Gles aplha 2.0.0.

    Like Hvdwolf, I have experienced & reported random crashes using the GLES alpha versions in hardware render. It sometimes runs fine for many journeys then will crash two or three times during one journey. I too will switch to the software render & try that.

    In the latest version (2.0.0) the instructions at roundabouts have been changed. I now get a roundabout warning at 1 mile, 500 yards & 200 yards but don't get the direction instruction until I am at or on the roundabout. This gives no opportunity to get into the correct lane as you approach the roundabout. I think it would be better to give the direction instruction at 500 or 200 yards as well as at the roundabout.
  • 1. do you have any waypoints?
    2. this is already known, thanks
  • Another thing and now about the software renderer in the GLES version. The scale of the the text in the software version is wrong. I have to set the scale of the text to (almost) maximum to get a readible size.
  • Continous' crashes were the reason, why I went back to the playstore version on my Asus tablet K004 running jelly bean, see my post of may 29th.

    May be I try the gles version again the coming days. I think I have downloaded the file already some days ago.
  • Today I drove with GLES and hardware renderer for 90 km, and absolutely without any problem.
  • @tomas

    I've experienced crashes with or without waypoints. I did a 40km return journey today in hardware render with no crashes.
  • No crashes here either. Android 5.0.1
  • OpenGL implementations vary per mobile, per opengl version and per android version.
    I assume I have bad luck in this case. Today again a couple of holiday drives in software mode: no crash at all.

  • Hello, the link http://download.mapfactor.com/mapfactor_navigator_gles_alpha.apk now points to 2.0.6+
    - fixed first show on map (calculate route, NMEA/GPX show etc)
    - fixed azimuth direction in 3D view  (was visible for long roads)
    - fixed sorting "my routes"
    - updated tts hu

  • I don't know whether this is fault of GLES version, but:

    Today I ran navigation with hardware renderer and closed the app while the navigation was still running (because I missed the target by one meter or such).

    Now I just started the app and directly opened the map (no navigation), and the map is completely blue, not loading anything.

    I chose my favourite place to show on map, and now the map is filled again. But I cannot remember my map ever stayed blue when I opened it.
  • PS (I always forgot to tell):

    Using hardware renderer, in navigation mode the map's blue horizon is very big compared to software renderer (I'd say by factor 3). It doesn't matter whether compass is shown or not.
  • Your map position probably jumped to (0,0) ... still bug in 2.0.6
  • Yeah, next time I'd check the map coordinates to be sure.
  • my tracks made with digger still aren't fixed, see my posts http://forum.mapfactor.com/discussion/comment/10070#Comment_10070 and http://forum.mapfactor.com/discussion/comment/10070#Comment_10075

    Is there hope for me, that this will be done in the future?
  • Also in latest GLES version in software renderer (and maybe in hardware renderer as well but didn't test), the speed limits are sometimes not removed/corrected.
    Yesterday, in England I had twice coming from a "city road" (30 miles/48kmph) with the corresponding speed limit sign onto the slip-road and onto the motorway that the 30miles/48km maxspeed sign kept being displayed. The sliproad didn't have a speed limit set and neither did the motorway, but the 30miles/48kmph remained in display.
    I really had to stop and restart MNF to solve it (and get rid of the obnoxious "you're driving too fast" or "you're exceeding the speed limit", can't remember which one) while I certainly did not drive too fast).
  • I reported this a year or so ago. Even when a trunk road had a 70mph speed limit the 30mph limit from the previous road remained on the scrren though the speed warning sounds behaved correctly. To be fair though it hasn't happened for many months.
  • @jd147: I agree. The bug has returned in this latest version.
  • OK, thanks for updates/comments. There is version 2.0.10+ now available at
    - passed waypoints turn dark (instead of disappearing)
    - better handling of memory
    - initial GPS start at (0,0) should be fixed
    - translations from crowdin (Android project was removed for now, pt-BR as alternative Portuguese is not available yet in selection)
    - reporting memory info about vector data on graphical card (high debug logging only)
    - fixed texts for imported objects
    - faster click on map (but still slow)

    @crocodilefarm - I was told that import patterns should work now and also the layers should be correct. If the problem persists can you send your MCA to support and mention this forum discussion?

    p.s. Google started "Open Beta Testing" option in developers console, so if you want you can install it also directly from GP:
    ... if your Navigator crashes and you press Yes to send report then we should see stack of that crash ... thanks

  • @mdx - Hi Martin, problem still exists, I've send a mca and the source-gpx-file to support. Hope, that will help you.

  • I am simulating a route on my tablet (Asus K004, jelly bean). With software rendering it seems to work, but I see no difference to the play store version. With hardware rendering, the navigation arrow is flying somewhere in the wild but not on the street, the voice is simulating. Projection mode is not available (see my post above and answer), when in hardware rendering. Switching to software rendering and changing projection mode and then switching to hardware mode does not help. App crashes after only a couple of minutes in hardware rendering. I stop simulation (in software mode) with the gles version and will reinstall the playstore version.
  • I've used 2.0.10+ in hardware render mode 4 times & three on of those MFN crashed after setting the destination then clicking Navigate. The "calculating route" message plays but the app crashes as it starts to display the map. After starting the app again everything is OK.
  • I still have no stability issues in hardware mode. But yesterday I saw that the street name labels have an unstable size. Let's say I drive along a straight road, and two labels are displayed behind each other. When I move slowly, I expect the labels slowly to increase, the lower one bigger than the upper.
    But instead, both "danced": bigger, smaller, bigger, smaller...
  • @hvdwolf @jd417 can you provide us some additional information about speed limit problem? routing points, if map was on display all time, nmea?
  • and how was speed threshold set?
  • @crocodilefarm - thanks for MCA - I can confirm the problem now. I was told that import patterns are currently working only on areas and they are not implemented on polylines. Also the polyline level is lower then areas level ... so this problem is not fixed in GLES version yet.
  • @lubos: The first time (during one trip) was from Swansea onto the motorway (http://osrm.at/e2X).
    Actual start point was Dene Hurst hotel, Swansea (Sketty road 10; not yet in MNF maps but already added to OSM :) ) and destiny "King Edwart Court" car parking in Windsor (51.48139, -0.61208)
    I can't remember the second time when the max speed remained on 48 km/h while actually being not set on the motorway and therefore 70mph(112 km/h), but it was somewhere during that same trip. During the trip MNF was on map display all the time. No nmea or GPX recording.

    @Tomas: What do you mean? My car profile speed threshold was set to 112 km/h which is the maximum (70 mph) in England. But speed threshold is independent from the max speed display on the screen, which was incorrect in the mentioned cases. 

  • you can set speed warning threshold in setting (percentage...)
    I was asking how was your set
  • That speed warning is set at 10% above max speed. That's when I get warned when I'm speeding.
    But that's not the point here. The max speed sign on the right side of the screen as tag for a specific road (48 km/h) is not removed when I go from that road to the motorway, having either a higher speed limit or no speed limit set.

    The bug is that when going from a road with a max speed tag, to a road without such a max speed set, the max speed sign on the screen from the previous road is not removed. 
    Like in the image. The 48 km/h (30 mph) remains visible when I drive on the motorway.
  • But I understand now what you mean. I also mentioned that MNF is "telling" me that I'm driving too fast. I'm now in doubt whether that's actually being told by the tts.
  • @lubos
    See below for original post. It happened over a period of six weeks on that section of the A19 but hasn't happened since. I've not travelled on that section since upgrading to 2.0.10+ GLES but will comment when I use the road again.

  • @mdx - okay, I'll test it, if GLES supports polylines.
    But, by the way, if you look at the track in software-render-mode, you can see, that it is in dual color, like green-blue-green-blue... (or red-yellow, not sure), but in hardware-reńdering only in one color. Will this be fixed/supported in one of the next versions?
  • @Tantum
    about issue with "joined roads":
    it is very complex problem to programaticaly solve it in our navigator. What would help is making roads more tiny. I did lot of experiments and problem is if I solve problem of missing frame of road it would break many other cases. So I am leaving it unsolved for now(but hope not forever).

    @chattiewoman problem with changing text size is connected with autozoom. Autozoom makes view moving up&down but it is fluent so it is not visible. Texts are updated 2x per second in 2.0.10.

    @jd417 @hvdwolf thank you for reports, I will take a look on it
  • @jd417 I checked your route from october 2014 - I didnt see any incorrect max.speed indication.
    You wrote "I've checked the sections of road in OSM & they are correctly labellled with 70mph speed limit", I would like to note that difference between maps on www.openstreetmap.org and navigator can be 2months(?) so it is better to click on link in navigator press edit and there you can see max.speed value you have in phone.
    Another note: some osm mappers map traffic restrictions which I think could be your and @hvdwolf case.

    @hvdwolf I found link in navigator from your screenshot in actual map, clicked on edit and I saw max.speed 48km/h. So it is incorrect in data when motorway has max.speed 48km/h.
  • @lubos: Sorry for the confusion. My image was just to display WHICH 48 km/h (30mph) remained visible when going onto the motorway. This is just an image from in the town so the 48 kmh is correct here. It is simply that it stayed on 48kmh once I was on the motorway.
    I was under the impression that Tomas did not understand which max speed sign was meant.
  • @lubos
    Thanks for looking into this, I appreciate it.
    I must admit that I miss the road scale-ing option in gles version because of this. But there must be a good reason why it was removed. I always changed the road width to cca 10% of the scale cause the defaul option in the non gles version was just too wide for me.
  • @Tantum: I hope there is some good reason :D (programmer who tells it is not possible didnt say exact reason). There is still possibility to edit road widths in settings/map colors/edit color scheme
  • @lubos

    Thanks for the reply. The link in my phone has the max speed set at 70mph. As I said in my post I've had no problems since last year but when hvdwolf reported a similar problem I thought it may help.
  • @lubos
    thanks for this hint...I do not know how I missed this option.

    My questions is...why is the default value of the width of the road around 20 (depends on the road type)? I changed it to 12 for all zoom levels and it looks much better. You can now work out which road is which.


  • @Tantum Default value is lets say historic thing. It was for software renderer on WinCE with such a bad pixel density display.
  • So then it seems like an easy fix.
    I think it might be worth looking into the scheme editor and change more default values...for example the color of the roads as I discussed earlier this year with tomas (separate thread was created for it).
    This could also help to attract more users if the map interface was tweaked a little.
  • GLES link now points to 2.0.13+
    - fixed projection for x86 processors (Oldie bug)
    - added memory info into About
    - logging size of GPU vector data (level medium)
    - fixed initial position after "restart engines"
    - implemented summary for GPX imports
    also available on GP:
  • @mdx: You mention: "- implemented summary for GPX imports"

    Where do I find that? It's not in my Tools->Save/Play/Manage gpx menu?

    And secondly: Every first try after app start to "Show on map" of a GPX track it does not work. I have to go into the menu a second time to do a "show on map". Unless I open the app, go to map view, and then back to the menu to display a gpx track.Then the gpx track is displayed the first try. Somehow it seems as if the map view needs to be initialized or so and if that's not done if you have not been in map view yet..

  • That summary is on application start (I have seen only first demo when you click on GPX file, it automatically imports it and there is "Show Summary".

    Regarding the first show I expected/was told that it is already fixed ... :(. I tried it now in 2.0.13 and it works as expected (it takes while to load the map around, i.e. first I see the import and shortly after the remaining map. Can you try another GPX file?
    do you have track or waypoints in your GPX? (I am not sure if there is difference from renderer point of view)
  • "Regarding the first show I expected/was told that it is already fixed" . Yes, it is. After reboot of my phone it simply works.

    When selecting a gpx track file via a file manager I can import it into MNF and I have a (strangely postioned) "show summary" button. That works fine and gives exactly the information what I would like to see. Very nice. Maybe it could be improved from layout point of view, but that's not really important (for me). The "hide summary" button is correctly positioned.
    This "show summary" does not work for a waypoint or route gpx file, which is logical as average speed can mostly not be calculated from a route file and quite often not from a waypoint file as the  coordinates miss a timestamp. Next to that the distance in a real route or waypoint file is difficult to calculate based on the assumption that you use the Haversine formula to calculate the distance, which is "how the bird flies" and which is not what you expect in a route file. 
    Elevations are often not available either in those waypoint and route track files.
    GPX files can contain multiple sections, both as multiple tracks, or as a route section and a track section. The second type is made by some route planners for other routeplanners that can either read a route file or a track file or both. I did not test yet with such a multi-segment gpxfile but I assume that functionality has not yet been implemented.

    My feature request was, and now still is: please make this "show summary" an option in the gpx Action menu (after selecting a gpx track). I record a track with MNF, close MNF, have to tap the gpx file inside the MNF gpx folder using a file manager, and import it back into MNF to see the summary. That is not the most logical approach.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion