Test of Android GLES Alpha Version
  • 246 Comments sorted by
  • Can anyone who can repeat GPS issue record it on video and send it to us? It would help us a lot, thank you.
  • (we are not sure if you report "old issue" or something new which could be wrongly interpreted as lost of GPS signal - due to snap to the same place or something similar)
    The link http://download.mapfactor.com/mapfactor_navigator_gles_alpha.apk now points to 0.38.98:
    - fixed progress dialog for calculate route
    - fixed restart engines
    - fixed DPI scale of models (departure/destination/waypoint)
    - gray navigation sign during lost of signal
    - map scale for icons/texts
    - fixed coordinates in info panel
    - updates from 1.6.20
    - temporarily removed Mercator projection

    known issues:
    - slow first click into map (due to lookup text for info panel) .... second click is "usable"

  • I believe the issue was really the loss of GPS signal. I remember the white dot blinking in the notification bar. I then switched to GPS test app and the fix was gone and then reaquired soon, only to be lost again when navigating. I guess I won't be able to make a video, but this issue is easy to describe. I will try again with 0.38.98 when walking or driving this weekend.
  • This version force closes on me everytine I hit the navigate button - both sw and hw rendering. Tried to reinstall, clean cache and dalvik cache...no success

    Nexus 5 5.1.1
  • After downloading 0.38.98 download would not install directly. Had to install via file manager. After install about Navigator still shows 0.38.95 android gles renderer. Is 0.38.98 pulled or was the version n° change overlooked? This all on:
    asus  MeMo Pad HD (ME173X)
    os: 4.2.2
    cpu: MTK MT8125
    GPU: PowerVR SGX 544MP
    resolution: 1280x800
  • @Tantum
    ttry to Reset to default in Settings/advanced - please choose Backup and delete
    try to download again, I think you must have used the older version
  • Thanks for the advice tomas. It turns out that the custom color scheme was the issue...when I reverted back to the default color scheme and then back to the custom scheme again...everything was fine...but the reset to default settings would have worked as well I suppose
  • 0.38.98 works ok in simulation will try incar tomorrow. Moto g2 5.0.2
  • I have tried.95 with my tablet for the first time while sitting on the beach. No gps loss at all. Maybe the issue is only on my phone. Will investigate further.
  • @IU0BMP, not sure what's your OS but Lollipop has serious GPS issues across many devices...you can easily seach google for this...for example I only can use GPS on Nexus 5 in an airplane mode otherwise I get GPS drops every 5 minute or so. The issue is with the retrieval of the AGPS data as far as I understand

    Android M should address this
  • Then I'm lucky as I have Android Lollipop, but no GPS issues....
  • I also have no GPS issues on my phone. Orux maps works fine no drop of GPS signal.
  • Hi all, here is what I have found. With my tablet running Android 4.4.2 there were no GPS issues with GLES .95 (I haven't tried .98 with this device).
    With my phone (Lg L9) running Android 4.1.2 using GLES .98 there were frequent GPS losses (with the grey triangles) but the white dot was not blinking. Every time I lost the GPS, I tapped on 'tools', 'GPS info' to check the satellites and here there was no GPS loss. That is, according to GPS info, I had the fix. Going back to the map, the fix was still there but was lost again in about a couple of minutes or maybe less.
  • Since a week, I am testing each latest GLES version on a Sony Xperia Z3 compact. My tours were not longer than 20 minutes, though.

    Navigation was always stable, and there were never issues with lost signal or similar. The layout has improved much for me since the very first version.

    What I have to report are not bugs, but mere suggestions:
    1. When you turn into another direction than Navigator is directing you, the map is rotating into the direction Navigator wants you to turn. It takes more than a second until the actual GPS position "wins" and the map is rotated into correct direction again (and route recalculated).
      I think this can be an issue when you are driving through an unknown city centre, missing turns or skipping them due to road works. Suddenly rotating maps can be a dangerous distraction then.
      I understand this is a necessary result the smooth position change in map. Is it possible maybe that whenever Navigator wants you to turn somewhere (exactly then), the calculated progress is stopped for two seconds, considering only GPS?

    2. Autozoom improved a lot since first version, but imho it could zoom in even more.
      Compare the same position in old renderer vs. new renderer.

    3. This is not especially for GLES, but I find here even more important than for old renderer: Please, please make service roads (much) thinner. This would improve clearness so much ... See also here.
  • Chattie, point 1 is also related to the non-GLES version, right? I believe some delay is necessary before Navigator is "sure" that you have moved away from the right path.. IMHO, this has to do with the distance tolerance of the GPS system. Navigator might see that you are, say, 10 meters off course, but this can be normal when driving between buildings, etc. When the difference is more than that, then the app knows that you have really left the suggested path anf this can take more than a second...
  • I cannot remember point 1 was an issue in old renderer too, because it showed no calculated progress. The map did not rotate in advance (!).
  • Chattie, you are right.. the problem is worse with the new renderer, because it tends to predict your moves a bit too early. I noticed this in pedestrian navigation.
  • http://download.mapfactor.com/mapfactor_navigator_gles_alpha.apk
    now points to version 0.38.100:
    - update from DEVELOP 1.6.20+ [previous version was from 1.6.19 not 1.6.20, so some fixes were missing]
    - optimization of click in the map
    - delayed dehighlight of the current route
    - fixed filtering of entities in different zooms (e.g. small creaks vs. small rivers)

  • BUG: When tapping the map where a poi exists, normally 2 square brackets are displayed and when when tapping the i(nfo) button on the right it would also display the info for the poi. The 0.38.100 doesn't in hardware mode. It does in software mode.I don't know whether previous versions had the same bug, but that's not really relevant.
    EDIT: It doesn't do this in hardware mode with imported POIs.
  • GLES is still not usable in 2D mode, because of incorrect zoom level.

    Back to 3D: when I run simulation and stop it, all fonts on map are upside down (this is fixed when I leave map and open it again):

  • It has been mentioned before but tapping on the map works terribly bad. I have the idea that it works even worse compared to previous versions.
  • Hardware render version 0.38.100 crashed after two miles. Restarted & crashed again 6 miles after waypoint. Also suffered crash when updating maps from notification banner. Had to restart device then update maps from map manager.
  • tested GLES version 0.38.100 and at the same time had version 1.4.24 running on another device.

    GLES - OSM maps - failed again. It crashed after 4-5 miles. Restarted from the crashed point (cleared the first 3 waypoints) and completed the route.

    Again, as you can see from the logs although it completed the route a number of errors were logged as well

    I am attaching the route, the crash log, the completed log and the log from v1.4.24 which has no errors.


    Let me know if you need anything else.

    Many Thanks

    Moved from 1.6x topic as chattiewoman suggested - but I experience the same problem with the latest 1.6.20
  • I have tried the GLES versions 0.38.98 and 0.38.100 in hardware render and 3D mode, for about 800 km and it is mostly running very well, and I like it, but I have some remarks.

    1) I have also seen some problems with the gps. The 4 grey triangles are shown for 2 to 20 seconds and don’t move. As far as I remember, I never saw it in the “stable versions” of MF.

    2)  When I arrive to a roundabout the red maneuver arrow is still shown, but when I am inside the roundabout, the red arrow disappear and the map  zooms out. I feel this a little bit frustrating. I would really prefer that this 2 things were delayed until I reach the end of the red arrow. And I also would prefer the same for a normal turn.

  • I suggested it for something that affects GLES ONLY ;-)
  • @stavrich - it seems there is possibility to make renderer incompatible custom color scheme... see you PM please
  • BUG: GPX file display.
    When I open MNF and select to display a gpx track, it doesn't do that. It simply displays my last position. It does not move to the map location where the gpxtrack/route is to be displayed.
    I first need to move the map to the approximate location where the route/track is to be displayed and then I see it. 
    This is a bug of course.
    I don't know whether this is a gles bug or not, but I mentioned already before that there were GPX track errors in the GLES version.
  • The link http://download.mapfactor.com/mapfactor_navigator_gles_alpha.apk points to 0.38.103+
    - experimental limit for FPS (Settings > Advanced > Maximum FPS)
    - fixed option to change arrow/highlight color
    - fixed order in info dialog
    - fixed text orientation during switching navigation modes
    - revised scheme editor (patterns on links)

    known issues:
    - confirmed bug @tvo 2 with roundabout autozoom
    - missing texts/info for imports

  • Can you explain what FPS is and how it works please? Never heard of it, and I bet some others neither.
  • FPS=Frames Per Second. When you reduce FPS limit rendering is less smooth but it should reduce overheating of device.
  • In this 103 and the previous 100 version I see "pins" on the road. Especially in curves, probably these are the nodes that define the "way".
    Please remove, it is quite annoying.
    Samsung Galaxy S5 mini (res 1270x720), Android 4.4.2, MNF gles 0.38.103

    (Edit: Now the image gets so "blown up" I see that the icon in the top bar shows a pedestrian instead of a car which is my current profile. I checked to make sure)

    And another edit:  I now suddenly realise MNF is in software mode. why? Anyway, when switching backto hardware mode the pins are gone. Nevertheless, I prefer not to see those pins in any render mode
    See image
  • I have tried 103 and found that hardware mode was enabled by default (just as .100 version, maybe it remembered my old settings...). I don't see the pins on my phone, even in software mode. From the above screenshot, pins appear anywhere on the map, not just on the route and I agree they can be annoying. I guess they were not meant to appear on the map.
    More important, in my case, this time I had no GPS issues. I used to lose GPS signal very often with the previous GLES version. If the developers haven't changed anything regarding this, then it must have been my phone acting up..
  • I cannot see nodes either, but I think that these may be text labels and not nodes
    could it be that it is only because simulation is set to 10x speed?
  • @hvdwolf - those are not "pins" but "texts"/street names - did you experiment with scaling text?
    @IU0BMP - yes, it remembers your previous settings if you "upgrade" APK (i.e. after uninstall you lose your settings)
  • @mdx: Text size was almost to it's minimum setting in software mode and I didn't change that. At least not that I know. In hardware mode the text size setting was at its normal (default?) size.

    Also: the menu tells me that I can change the size of text, road and icon size. 
    I can do that in the software mode, but in hardware mode only text and icon size are available. Road has disappeared.

  • @hvdwolf - thanks, this is probably a bug. I was told that the settings should be separate now (i.e. 3 for SW rendering and 2 for HW rendering = 5 different parameters in total) because they have different scale. Older GLES/HW versions ignored this settings completely and there was maybe intermediate phase when it used SW params. We will investigate it, thanks.
  • Route not found: start Fridolfing Landkreis Traunstein start, destination Lübeck, lübeck.
  • Zooming is really good now, great job guys. I was wondering whether it'd make sense to make the roads just a bit narrower (since we can not adjust it anymore) cause roads close to each other still overlap.
  • I agree with Tantum but at the same time I would like to display the minor roads at a lower zoomlevel as well. You really have to zoom in deep before you see them. I don't care about all the other details, but roads are important.
  • A couple of bugs in 0.38.103:
    Last afternoon and night I had to drive 140 km back and forth. I had rebooted the phone just before leaving. 
    1. When going back home at 23:30 it was still at day mode with the setting at automatic mode.
    2. When I switched it manually to night mode, the sky still stayed blue instead of becoming black.
    3. MNF crashed 3! times on the way back.
    With regard to 2: Once I restarted the app, now of course in manual night mode, the sky was black.
    W.r.t. 3: I know it is an alpha, but MNF crashes more often, also previous builds. I mostly reboot my phone when going on a trip now. It is as if MNF doesn't "clean up" after first use and crashes on what it left behind (in memory?) when starting again.
  • I couldn't provide this earlier....but just to put my previous post into perspective. When you only have time to glance at the navigation...it's really hard to understand which road you are on...all of them are kind of just overlapped --- this is just before the turn...so zoomed in to max


    Edit - just a comparison to see how many roads there actually are...very unclear from the GLES rendering
  • Motorola Moto G with Lollipop 5.0.2 & Navigator GLES 0.38.103.

    In hardware render mode there is still the occasional random crash. I re-started my phone before a recent 45 mile (65km) journey & Navigator  worked fine. I re-started it again today before a 6 mile (10km) journey & Navigator crashed after about 1.5 miles (2km). I re-started Navigator (not the phone) & the journey completed with no further crashes, as did the return journey. I've also noticed that Navigator crashes at the end of a journey (after the "Destination reached" message) but stays running in memory. Re-starting the phone appears to be the only way to close Navigator when this happens.

    On a different theme I've not found any map updates yet for July.
  • OK, thanks for info. Regarding map updates I will write in different thread (http://forum.mapfactor.com/discussion/3999/mapfactor-osm-data-processing).

    OT if you would like to translate GLES version there is now crodin project also for Android:

  • Hello,
    the link http://download.mapfactor.com/mapfactor_navigator_gles_alpha.apk now points to version 2.0.0
    It is original GLES version merged with other features from DEVELOP like "i" in toolbar to switch between version with and without texts, some bugfixes, translation of list of maps taken from planet.osm, GPX changes ...
  • @mdx I think the problem with roundabout autozoom has been solved in version 2.0.0, only tested by simulation but it looks good. Thanks.
  • Well, GLES 2.0.0 works as expected. It is usable. In hardware mode, the only flaw for me is that it is a bit slow when I browse the map on my device. Maybe it would be more fluid on a quad core....
    In software rendering, it is more or less the same as 1.6.20, right?
  • During route simulation, displayed navigation and voice gets sometimes complete asynchronous. Especially, when  the simulation speed is increased
  • @rab That's normal and not a GLES issue, because the voice itself cannot speak quicker, although the progress on road is. The instructions are then queued and appear on wrong places.
    The alternative would be that while instruction 1 is not finished spoken yet, instruction 2 will be already started. Are you multitasking enough to handle that? ;-)

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion