Test of Android GLES Alpha Version
  • 246 Comments sorted by
  • you should be able to copy album.style from one device to another
    may be it is corrupted?
  • If you export a particular color scheme it is exported as <name>.mtheme. That one can also be imported.

    Do not share the album.style! That  file contains all color schemes. It is very annoying to overwrite your own album.style file which already contains your own modifications because someone else shares his/her complete album.style file.

    Again: only export your theme(s) and share that or copy it to another device.

    For example: See my GrayNightMode theme. It is a zipped file otherwise any browser would display it as the xml file it is.
    So unzip it, copy it to your phone/tablet. Double-tab it from within a file manager and import it.
    If you don't like it you can remove it again from your main album.style file with the delete option.

    I created my GrayNightMode theme as the current nightmode style is way too light and for my taste way too brown. My theme is much darker, it is "boringly" gray, but for me it is much better at night.

  • Moto G 1st gen. running Lollipop 5.0.2 & MFN 0.38.84

    When in hardware render mode the autozoom still does not work correctly. It remains at minimum zoom (ie zooms fully out) when in navigation mode. It occasionally zooms in for directional changes (when approaching a turn or roundabout etc.) but then zooms out fully again. This makes it difficult to look at the map.

    In software render mode MFN crashes when

    1) On loading navigator sometimes the menu doesn't appear, just a white screen. After a minute or so a system message appears saying navigator is not responding & offers options to wait or close. Choosing wait does nothing.

    2)If the menu does appear & I choose a destination, then navigate, when calculating or re-calculating the route navigator simply shuts down & returns to my phone start screen. It appears to work fine in simulation mode.


  • Today I installed the Gles-Alpha and switched to the hardware-renderer. That's really fast. (Nexus 7 2013, Lollipop 5.0.2).

    What I have to say, my own created mca-files (Tracks) with digger disapear, when zoom-level is coming to detail. The track-line is hiding under the streets from the official mca-files.

  • Two more graphical differences between software and hardware rendering.

    First again with digger created, a line with two colors in hardware-rendering (left) and in software-rendering (right). Same file!


    Second, I've changed in the album.style the appearance of the one-way-arrow. The hardware-rendering in gles seems to stretch the values.

    Left software-rendering and right hardware-rendering


  • I can confirm the same stretched arrows for HW/GLES redering
  • Today...for no apparent reason the line that shows your route disappeared after the recalculation and never appeared again...I think this is a second time it happened to me

  • There is update of alpha GLES version to: 0.38.89+
    - fixed order of layers (should be visible on streets and import layers for example)
    - fixed landscape zoom after rotation
    - fixes from DEVELOP 1.6.19
    - fixed "blue holes" during navigation
    - framerate limited by 20fps
    - NMEA replay and show in map
    - larger texts in navigation view (3D)
    - changed landscape 3D view
    - fixed patterns stretching (oneways)

  • oneway-strechting --> okay

    order of layers  --> no change
    still the same behaviour like in my posts http://forum.mapfactor.com/discussion/comment/10070#Comment_10070 and http://forum.mapfactor.com/discussion/comment/10070#Comment_10075 (except the oneway arrows)

  • Next, the calculated route disappears for some part of a (perhaps very long) way in hardware-rendering.

    left software                                                                                                   right hardware
  • thanks - I can confirm the bug with long routes and overflow of indices.
  • The link now points to 0.38.90+ GLES Alpha:
    - fixed long routing highlight (I am not sure if that helps also in Tantum's case)
    - optimization in click into map (set routing points)
    - fixed loading icons from imports
    - increased size of internal cache for current view data
    - added "Automatic" into renderer selection dialog (note that your current HW settings changes to SW now, so you have to re-select it again ... Settings/Advanced/Map renderer/Hardware
  • it's good to see such an intensive development for GLES version, thanks mdx and the mapfactor team

    - the bigger street names are giving you better overview of where you are however now it seems too big and rather distracting. In the certain view (I couldn't capture it) the street names now cover more than 1/3rd of my screen


    - the lanscape zoom out seems still a bit too far when the next turn is further away (imagine that you're looking at this on a 5 inch screen which is cca 70-80 cm away from you)


    - also when I edit the color scheme and try do get back to the map view the navigator crashes
  • So far I like the GLES version a lot. However, it is still much slower in screen rendering compared to the software renderer. If you simply take a favorite and do "show on map" or calculate a long route (700+ km) and display the route on the screen, the screen is instantaniously drawn in software render mode and takes "some time" to render in hardware mode. I know this is an alpha build, but do you think the rendering speed will (much) improve?

    I assume you use api version 2 for android 2.2 and up? Or version 3 for Android 4.3 and up? Based on the reports for also Android 4.2 users it must be version 2.
    Not that it really matters but I'm just curious.

  • And ... I just downloaded 0.38.90 which has an automatic switch between hardware/software renderer and it chooses software on my device (Samsung S5 mini, Android 4.4.2). (I found out as it was set to hardware and the map didn't look like hardware).
    On what basis is this automatic choice made?
  • 0.38.90 - long routing highlight fixed  --> okay!

  • @hvdwolf - I am not sure what do you mean? The map looked like SW rendering, but was selected HW rendering?? Or automatic?

    The choice for "automatic" in 0.38.90 is simple - return SW. It is placeholder for future changes and it should be default value for release on Google Play (one day). The decision may change from version to version, but I expect device resolution, computation power and maybe also version of maps.

  • Moto G 2nd gen Android 5.0.2 Ver 0.38.90. Rendering now very smooth. Screen does not stay awake even when on charge (hardware or software mode), although navigation continues.
  • @mdx:
    I should have been more clear.
    When I closed 0.38.89 I had set it to hardware renderer.
    Then I downloaded 0.38.90 and opened it and select the map. From the looks I knew it was the software renderer and not the hardware renderer, which I had selected earlier.
    So in preferences I did see it was set to Automatic which resulted in SW as that was obviously visible.
    That's the reason why I asked: On what basis is this choice made?
    I thought the app did some checks on startup and decided to chose for HW or SW, but the "Automatic" setting is not an "Automatic" sectting, but a "Default" setting where SW is the default.
    At least that is what I conclude from your answer.
  • On my Asus Fonepad 7 model K 0004, Jelly Bean

    Renderer on hardware

    on map no text

    Bilder-Upload.eu - share DEINE Bilder

    on simulation like flying in the air

    Bilder-Upload.eu - share DEINE Bilder

    When renderer on software or automatic everything looks like the playstore version.

    gles version is continuously crashing on the tablet and had to be restartet. I am back to the playstore version for the moment.
  • well.. I have been following this thread since it started but only today I decided to try this version. I have only looked at maps and tried a simulation with hardware rendering. No major bugs. The app works and looks smooth, but text size and icon size are too small for me even though I have set them to maximum size. My phone is an LG L9 (aka P760), I will try on my tablet, 7", Android 4.4.2. I will report if I notice something wrong.
    I have a question though: does hardware rendering affect battery consumption?
  • @hvdwol - thanks. The dialog indexing shifted and that's why old HW (2nd position) changed to new SW (2nd position) ... yes, it could be done better. (as side-effect several people tested old SW rendering in 0.38.90 and it was crashing in some cases, but fix probably on Monday)

    @Oldie - can you change projection? (Lubos says that it is probably the source of problem)

    @IU0BMP - we did not investigate the battery consumption yet. We would guess that it will be slightly higher than in SW rendering. There is already (internal) parameters to limit the framerate, if it will help later the battery consumption.
  • I just noticed that the house numbers are missing from the GLES version...will this feature be implemented?
  • Also noticed that street names are shown on inverted lines:

  • @IU0BMP - Battery consumption looks good to me (S4 mini). Appena fatto 60 km e consumato qualche punto percentuale. 
  • Hm, the place above was with Miller projection.

    This is, what I see, when I change to Mercator projection for the same place from my favourites:

    Bilder-Upload.eu - share DEINE Bilder
  • Map download of United Kingdom fails: twice in a row. Next to that: it needs to be restarted multiple times.
    Is this GLES, your servers, a corrupt torrent or a corrupt map?

  • I would say bad connection, please try again
  • The third attempt worked. I had rebooted my phone in between.
  • UK download worked fine for me first time this afternoon on GLES.
    Anyone got any suggestions for screen sleeping during navigation?
    It makes this version totally useless for me, as I have to keep pressing button to turn back on.
    EDIT: (screen sleep fixed see below)
  • my screen stays on, at least in simulation
  • Sorry just noticed in settings, display always on is turned off (guess this had reverted after alpha version installed).
  • Moto G 1st Gen. Lollipop 5.0.2. MFN 0.3.90

    App continues to crash in software render mode. Navigation view is still too "zoomed out" in hardware render but does autozoom much better when approaching roundabouts, direction changes etc. No problems downloading maps on GLES version.

    Is there any way to navigate to recent destinations? If not could this be added as a new feature?
  • go to Search and click on a history item (below search windows)
  • Yesterday I was driving and navigating.. The red arrow disappeared and reappeared again about every second. After a few minutes navigating, my phone froze and I had to remove the battery to turn it on again. Until next update, I will be using the stable version.
  • I agree with @Tantum: The text size is way too big.
    Normally I would adjust that via "Settings -> Map Scale -> Text size", but that currently has no influence at all.

    - Is this because it is an alpha build, and this map scale functionality is not yet implemented?
    - or should this work and is it therefore a bug?
  • Using an Archos Copper 70 tablet (android 4.4.2), I tested the app in pedestrian navigation. The walk was only 1 kilometer long by everything was ok..
  • When I enter the tunel the navigation arrow stops, every time in my case, and does not follow my route in the tunel. I know that in the stable version the arrow follows me in the tunel as well.
  • Hi folks - is it possible to ensure that the lower level roads are also rendered when zoomed out a little? If there is an issue with performance I'd rather disable the building rendering than the road rendering when zoomed out.

    It was very nice in the nonGLES version...pls see the comparison


  • Hello,
    the link http://download.mapfactor.com/mapfactor_navigator_gles_alpha.apk now points to version 0.38.95+. There are several fixes:
    - fixed hardcrash for software rendering
    - disabled textplacing during zooming (for faster drawing)
    - revised autozoom
    - fixed blinking of icons
    - fixed order of multiline texts
    - fixed loosing route numbers
    - fixed some broken Arabic characters
    - removed icons on 3D horizon

    known issues:
    - display of coordinates in info panel (fix is prepared to 0.38.96)

  • Thanks mdx, each version is better and better.

    Only one comment after a short drive...the red color of the supporting arrow that shows the turns is not ideal as it has the same color as the arrow that represents your car...and when these two render on top of each other it's not clear which is which. The green color was better in my opinion.
  • I have tried 0.38.95 navigating. MFN didn't freeze or crash anymore, but lost the satellites very soon. The get the fix again, I switched to GPS Test (it seems to speed up the fix) and the fix was there, only to be lost again after a few seconds. This happened several times and I went back to the stable version which worked as usual.
  • @IU0BMOP By "stable version" do you mean 1.6.19 or 1.5.22? thanks
  • Yes, I meant 1.6.19. If the GLES version really deals with satellites in a different way to 1.6.19, I can investigate further and let you know the results. This is the first time that I notice a different behaviour regarding satellites, between two different versions of MFN. Anyway, my test with 0.38.95 lasted only a few minutes...
  • I experienced similar behaviour than IU0BMP. Not sure whether it was related to gps fix or not but on a 10km route the gles version showed a status as of I wasn't moving 5 times. This did not happen with the previous test version.

    Just to confirm, my gps lock on the phone was steady and strong
  • GLES 0.38.95 on Motorola Moto G running Lollipo 5.0.2.

    Getting better with each fix. No more crashes in software render. Still a little zoomed out in hardware render compared to software render. As reported by IU0BMP & Tantum I too have seen loss of GPS (map appears frozen) for a few seconds before it recovers. Keep up the good work.

  • GLES 0.38.95 hardware rendering, only tried it in simulation mode, but nevertheless:
    *) after starting the app and calculating a route the initial map-display does not zoom to the route (shows whole Europe), from the second time on it does (see images)
    *) autozoom - the sizes look practical to me - a good mix of zooming in at maneuvers and giving overview the other time
    *) after some minutes of simulation the app crashes, especially, but not only when speeding up the simulation
    *) the speed limit symbol still is too small. It must have at least double the size to be useful while driving motorbike
    *) 2D-mode: the waypoint symbols in the standard app are too big for my taste, in GLES-version on a Moto G (4,5") they look alright (about 2 mm), while on a Nexus 7 they are way too small (about 1 mm)
  • Problems with GPS fix today 1 hour without a fix previous ver. Just installed 0.38.95 will test tomorrow.
  • GPS is controlled by Android,
    Navigator cannot make GPS reception better or worse. Try to reboot your
    device, it quite often helps. Help by email please.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion