How to import my POI (Points of Interest) to Navigator FREE
  • 107 Comments sorted by
  • ERR 2012/07/07 15:04:03 XPathNode: can not access source file: C:\Users\Peer\Downloads\digger_11\digger_11_0_47\import\test2\digger_config.xml
    ERR 2012/07/07 15:04:03 XPathNode: can not access source file: C:\Users\Peer\Downloads\digger_11\digger_11_0_47\import\test2.mca\digger_config.xml

    got this, by importing a .xls.
    Is there sombody who can help?

  • @Ferien:
    ... you found these messages in the "digger.log"-file ?
    This seems to be an normal behaviour of  diggerQt.exe creating these messages if you select "Create new import" ... Just ignore them ...
    The mentioned digger_config.xml file will be created later by executing diggerQT's "Save configuration and run import"-function ftom the "Run import" dialog
  • Digger download link is dead. Is there an actual one?
  • Hi Martin,

    Is there a way to import POI's/create a MCA file with a Linux PC?

  • @bodypilot:
    ... use diggerQt with wine on Linux ...
  • I am using Navigator free edition - version 0.9.122 on my Archos tablet with GPS built in.
    Maps etc are all working great.
    I am now trying to get some of my POIs to show.
    On my laptop I have downloaded digger 11 and have created a file xxx.mca.
    I have copied that to my tablet and put it in navigator/images - the same folder that poi.mca is in.
    I have rebooted my tablet and started Navigator but there is no sign of my personal POIs.
    I cannot find any way of 'importing' them - but I understand this should be automatic.
    I also can't see an option to show them or not - i.e. they do not appear in settings/POI types - should they ?
    I look forward to what appears to be a brilliant piece of software.
  • please place it to the navigator\data\ folder
  • Many thanks.
    That has got it onto my map.
    It was also difficult to see because the icon (xxx.png) was only 22 units square so I had to zoom well in before I could see it! I have increased that to 100 and it is good for me.
    I am now away.
    Will set to to convert my POIs and get them installed.
    Many Many thanks
  • Hello,

    I use Mapfactor Free for Android and I want install my POI File.

    The POI-file is a *.csv file, wich I converted with the digger_11_0_47 Program into a *.mca File.

    Here is a example for my *csv-file:


    10.907500,51.734700,"Hotel-Reiterhof Zur Talsperre|Altenbrak-Wendefurth| S. 117 Karte 7A4"

    11.778383,51.212000,"Berghotel Zum Edelacker|Freyburg (Unstrut)| S. 246 Karte 7C5"

    When I use Mapfactor, the icon is shown on the map and all is o.k.

    BUT: When I go to Search -> OVI -> Search Import there is nothing

    I can't see or search the Description of the file...

    What is wrong?????? What do I wrong????

    I try'd to replace the " and the |  , but nothing was better... It does'nt work... :(

    Can anybody help me with this problem???

    many thanks...


    When I try


    10.907500,51.734700,Hotel-Reiterhof Zur Talsperre,Altenbrak-Wendefurth, S. 117 Karte 7A4

    11.778383,51.212000,Berghotel Zum Edelacker,Freyburg (Unstrut), S. 246 Karte 7C5

    the digger is getting down and does'n work.

    What is here wrong???

    Sorry, I am a newbie....


  • ad acer123 - do you have any text selected to be visible in the map? If not try that.
    The crash (well it should not crash, but ...) ... is probably related to "too many commas", as you use separators from "Name"
    - I can confirm the crash in current version, but the reason is something else ... fix in progress, thanks.
  • Hello,

    I run with Navigator on an Android Smartphone.

    I tried to import waypoints on my phone using wwwindisch instructions on another thread here, I succeded in finding them on the phone by putting them in the data folder. The only problem is when I try to view them, when I select in Imports under POI I get "No results". What does it means ? Everything goes right at each step and them I got nothing... 

    What could have I done wrong ?

    Thank you for your help.

  • Hi Kolza,
    can you try digger ver 12 (, where you can separately select which columns should be visible in the map, which are available for search and which are extra description? Android and version 12.x will work with this output, and for us it is easier to fix, if there is a problem.
    thank you

  • Hi Martin,

    I've got the same problem as kolza. Unfortunately I can't use version 12 of digger because I run Navigator Free on Windows mobile, where version 11 is the latest. mca-files produced by digger 12 do not work at Navigator 11.


  • Hi Jan,
    you can use Navigator Free version 12 (soon we will switch default "download" to ver12).
  • Hi Martin,

    Hooray! It works.
    Thank you very much, Martin.


  • Hello,
    When I try to use digger,after choosing the source data columns, I always obtain this message


    Microsoft Visual C++ Runtime Library

    Program: c:\digger_12_0_4\diggerQT.exe

    This application has requested the Runtime to terminate it in an
    Please contact the application's support for more information


    What can I do ?
    Thanks for your help,
  • is this file UTF-8?
  • yes I have converted it into UTF-8 with" Simple Text Encoding"
  • if your file is not private, please email it to support, I will test it
  • should I send it to  "support (at)" ? or else where ?
  • Hello,
    Thank you for your help.
    I do not see what I can do wrong
    In my log-file,I have the same error as JOSHOM in July 2011

    ERR 2013/02/02 21:15:20 XPathNode: can not access source file: U:\BATEAUtechnique\navigation\Navi-gratuit\digger_12\digger_12_0_4\import\o\digger_config.xml
    ERR 2013/02/02 21:15:20 XPathNode: can not access source file: U:\BATEAUtechnique\navigation\Navi-gratuit\digger_12\digger_12_0_4\import\o.mca\digger_config.xml

    Do you know what was wrong for him ?
    Could it be possible to contact and ask him ?
    Best regards
  • Hello,
    I have changed the icon and now the conversion to mca and import to navigator is OK.
    Thanks again to tomas for his help,
  • Hello, when I use wether Digger 11 or 12 I get an Errormessage: ERR 2013/02/14 20:44:30 XPathNode: can not access source file: G:\N_A_V_I_G_A_T_I_O_N\M_A_P_F_A_C_T_O_R\digger_12\digger_12_0_4\import\Test_S_2\digger_config.xml
    ERR 2013/02/14 20:44:30 XPathNode: can not access source file: G:\N_A_V_I_G_A_T_I_O_N\M_A_P_F_A_C_T_O_R\digger_12\digger_12_0_4\import\Test_S_2.mca\digger_config.xml
    I don´t know how to provide a xml. configuration file, maybe someone can help me, please!
    Best greetings, Alfred
  • Hi Alfred,
    your configuration file probably refers to imports you removed.
    try to delete it (backup first)
  • Hello, first thanks for your prompt response. I looked after it, but there is no such file. Neither in my nor in admin account. There is just a file named "setup.log". By the way, I´m having trouble with the placement of the icon relating to then poi. What format must it have and where should it be saved? (I have a seven inch China- Navi with WINCE6) . I tried a simple OV2-File to convert, without icon. Maybe this has something to do with the failure?
    Kind regards! Mapfactor is IMO a gorgious program for free!
    Yours, Alfred
  • which windows do you run?
    files and folders in this location are hidden , you need to select 'show hidden files and folders' in folder options
  • Hi, WIN7 x64 Ultimate and have adjusted, that all files are shown (that is the normal setting for me).  By now I have made it so far that I can create a MCA- File from OV2. I saved it in the root directory where all the maps are, it showed me the names of the POIs in mapfactor, but the POIs are empty. I am also not sure, what format the pictures must have. BMP, ICO. PNG or something else and where I have to put them for a fine integration. There is no complete workaround with details, isn´t it?
    The Questions are: Where should the MCA- Files after converting be and what format must pictures have to be used as icons for OVIs?
    I put the pictures together with the OV2- Files in the "import" - Folder of digger12, left the settings in the following steps untouched and got a MCA- File. Something is wrong with that, but I don´t know what!
    Kind greetings, Alfred
  • Great post! Very helpful, thank you. What camping site POIs did you use? I want to do exactly the same thing.
  • Well, I don't know, which site gmmas uses, but I prefer this one:

    About 31003 campsites in Europe.

    And there I take the gpx-files, because Digger 12 supports them. But be aware, you have to convert the gpx-files into UTF-8. They are in ISO-8859-1.
  • I agree, archies looks very comprehensive. So, can I ask the obvious question. How do you convert gpx-files into UTF_8 ?
  • Well, there are serveral ways to do it.

    One is to use Notepad++ (freeware). Open the pgx-file with Notepad++, in the Menu go to Encoding --> Encode in UTF-8 without BOM. or Convert to UTF-8 without BOM .

    If you are using Linux, open a terminal and enter 
                     iconv –from-code=ISO-8859-1 –to-code=UTF-8 source.file > destination.file

    If you are fit in programming or scripting, many languages (php, java) can do it.

    In any case, you have to change the head of the gpx-file (first line) from
        <?xml version="1.0" encoding="ISO-8859-1"?>
        <?xml version="1.0" encoding="UTF-8"?>

    Good luck!

  • Xclnt post by gmmas.

    Can we access the PC Navigator icons for imported POIs? There are a heap of them defined but I haven't found them yet.
  • The answer is "well, yes, maybe". The dll files gfxQVGA.dll and gfxVGA.dll are basically compressed archives containing about 300 .png icon files. Without looking too deeply at this stage, one contains the icons at 50x50 resolution, the other the same icons at 100x100 resolution. I have extracted them and renamed a handful so win7 recognizes and previews them.

    So far diggerQT only seems to give the option to attach one icon file. Still to be determined is how the scaling works so the icons look right as the map is scaled in and out.
  • I am not shure where icons are, in one .mca file I think, but you can import multiple icons with digger, Object assignment appearance page.
  • Those are experts in converting poi or route formats

    But they still do not support mca files ...

    [Edit Sept. 8]

    The webmaster of that forum says, if more people ask for support of mca files there, it will worth for him to look at it.

    There is also a thread in English language for mca files:
  • I
     trying to user Digger 12.1.5 with wine under Debian/Wheezy and when selecting an csv file and type icon i get a crash very soon. Selectint mark works but i fail to create an mca file - The last step

    Import started, output path is 'C:\Program Files\digger_12_1_5\import\vcss.mca'
    [Step #1] : test 194 source objects...
    0 map objects loaded.
    Error: mapFactor exception: All data was banned, cannot finish import.

    I fail to find the Problem.

  • When you're using "icons" and reach this window
    did you change the test-image into another? You can use *.png or *.gif, other types also should work. A good size is between 32x32 and 64x64. But you can play with the sizes and try to get the best result.

    (I'm using Linuxmint with wine and that works fine)
  • I dont reach that screen. I retried with Debian/Jessie e.g. wine 1.6 and the very same behaviour. The Windows i still have (an XP) wont execute diggerQT 12.
  • Okay, that you don't reach my screenshot, I can confirm. While I was using Linuxmint 13 (now it ist 17), I also didn't reach that screen. But now with the nes Linuxmint, it works fine.

    But that it doesn't run under WinXP, that's strange. Do you have any MapFactor - Software running on WinXP? The Setup-Tool or FreeNavigator? While Installing one of these programs, there is also a Redistributible C++ Version (or something like that) installed. Perhaps that is needed for Digger on WinXP.

    A mca created on Window you can edit in Linux.
  • I'm trying to use digger 12.1.5 on Ubuntu 14 under wine. I extracted the zip file in the C drive directory of wine.
    The plan was to load the cma file onto my android smartphone to use with free Navigator.
    I have a csv file created with Google My Maps with lines like

    When I run digger I get the following in the log file

    ERR 2015/03/28 19:24:40 XPathNode: can not access source file: C:\Program Files\digger_12_1_5\import\Britian_U_Trip\digger_config.xml
    ERR 2015/03/28 19:24:40 XPathNode: can not access source file: C:\Program Files\digger_12_1_5\import\Britian_U_Trip.mca\digger_config.xml
    ERR 2015/03/28 19:25:23 Exception thrown: .\src\PoolFont.cpp(208)
    ERR 2015/03/28 19:25:23 Exception mpfc::exception& ex caught: .\src\PoolFont.cpp(254) message:'mapFactor exception: PoolFont::idFont - can't retrieve font ???, ???r???.'

    It doesn't create a cma file in the import directory.

    What have I missed?

  • Do you also have an installed Version of the Navigator Setup Utility or PC Navigator (look above)?

    I tried with your (one) data to generate a mca-file. (Linuxmint 17.1 & wine) I had no probem. So, I've no idea. Sorry.

  • PoolFont detects fonts from system and other directories, it seems wine provides you incorrect path, be sure you have installed ttf-mscorefonts-installer and use latest version of wine:
    sudo add-apt-repository ppa:ubuntu-wine/ppa
    sudo apt-get update
    sudo apt-get install wine1.7 ttf-mscorefonts-installer
  • Mine is a simple request, I have Navmii installed on my old Samsung galaxy mini 3 and have created favourites on it . I would now like to copy them on to my new Moto 4 G with lollipop OS as latest Navmii installed. Is this a simple task or do I need some sort of brain transplant to do it?
  • @Traveller_HA5_3DOM

    You aren't talking about MapFactor Navigator, are you? I think, Navmii is adifferent navigation-system. Perhaps you should ask a forum for Navmii?

  • Hi all!

    I switched to the MapFactor Navigator to use it, when renting cars in the USA. Worked fine and I would like to use it at home (Germany), too.

    I am running into a problem, which I could not solve up to now. I definitely need to use my own POI. I imported them as CSV using Digger12.

    The problem is:

    1. Small CSV - some 100 entries - work fine.
    2. Medium size CSV - some 1000 entries - are processed without any error by Digger12, but only a relatively small part shows up in the import-Table.
    3. Large CSV - some 6000 entries - are processed without any error by Digger 12. When selecting the import-table in the navigator, it crashes.

    Anybody any idea, what I might be doing wrong?

    The app is running under Android 4.1 on a Huawei Y300 Smartphone.

    Thanks for any idea and help.

  • Was a dublette - sorry.
  • email your source file if you want, I will try
  • Good Morning,

    I would like to transfer my waypoints from Garmin in Mapfactor Navigator. The .mca file has already been created and stored where the mca files are.

    It does not work .....

    Can someone tell me the exact path?
    Is there a file to replace (favorites?) ??

    Thanks in advance


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion