Importing GPS Tracks
  • Is it possible to import a track?
  • 28 Comments sorted by
  • Yes, but I haven't found a way to use them for navigation yet.

    So here's a rough explanation of my "tool-chain":

    1. Create Track (e.g. @ --> get .gpx-file
    2. Open file with RouteConverter (
    3. Change Type from "Track" to "Waypoints"
    4. Save file as "Haicom Logger (.csv)" (Don't ask why...I just figured out that it works...)
    5. Open the .csv-file with diggerQT (see this forum)
    6. Use the default coordinate system and select the right columns for latitude and longitude
    7. There's a little catch: The "Next"-button is grayed out on the screen where you can choose how the POIs are displayed on the map. Double-click on the word "test" and select an image (.png or .ico).
    8. Convert the file and copy the output to your Navigator FREE folder
    9. The points should now be marked with the selected image in the map.

    Sounds complicated, but works for me.

    Please let me know, if you need further help.
  • Thank you wwwindisch - I updated digger11
    to newer version, which should directly import GPX files (points). If there any problem please let me know.
    thank you

  • Thank you for the update, mdx.
    In the special case of me using bikeroutetoaster it doesn't help that much, since the saved gpx-files contain tracks, not points. So I still have to convert them. But that's not the fault of digger11..
  • Hello, Where wrong? I downloaded a route on I added DiggerQt and gives me this error
    [Step # 1 of 5]: objects a test for reading ...
    Error: mapFactor exception: Were all objects banned, no data to import ... Thank you
  • Could I ask wwwindisch: 

    In your step 8: "Convert the file and copy the output to your Navigator FREE folder"

    I've read elsewhere that it should be copied to

    "C:\\Documents and Settings\All Users\Application Data\MapFactor\Setup\Data\Images" where the file poi.mca resides. Is this the one you mean?

    In your step 9: "The points should now be marked with the selected image in the map."

    Do you not have to go to Import and click on the name of your file? Does Navigator find and load them without being told to?

    Your help would be much appreciated (see my thread about Navigator Free crashing).


  • Hi

    Ok I have tried all the above and moving source files into different folders and nothing works, getting the same error:

    [Step # 1 of 5]: objects a test for reading ...

    Error: mapFactor exception: Were all objects banned, no data to import ... Thank you

    Maybe it's me being a thicky but can anyone describe (in an upload GPX to navigator 11 for dummies kind of explanation) how I get routes uploaded in navigator 11 Free?
  • Hi Paul,

    big SORRY! I forgot to mention the main point: I'm talking about NavigatorFree for Windows CE5 (NOT the version for desktop PCs); I'm running it on my CarTrek 700 satnav.

    @ micpennett & ciprian:
    I suppose gives you a gps TRACK. Have you converted the track to waypoints (steps 3 & 4)? I got the same error when I tried to process a track with diggerQT.
    The detour via the .csv file (step 4) is a bit strange, but it works for me. And there is a big advantage about it: You can open the .csv file with MS Excel and take a look at the data. You should see a table, which contains (besides other data) the two columns "longitude" and "latitude".

    If you still have problems, please let me know...I can come up with a more detailed tutorial, if necessary.


  • more details please thanks
  • I've done a little tutorial with Screenr:

    Part 1:
    Part 2:

    Sorry for the "German-English" ;-)
    Please share your experiences with the conversion of tracks...
  • Hi Thanks for the tutorial but can not make him go.
    I use, NavigatorFree a Navon N260 with Windows CE 5, routes saves NMEA.
    I tried everything says ok but does not work.
  • Just to make sure I got you right: You converted the NMEA to CSV and then with digger to MCA-files and copied them to your device? And digger completed successfully but your device didn't recognize the way-points?
    Here is the sample route I'd used for the tutorial:

    You can try to copy the file to your NavigatorFree folder and zoom the map to the big park about 1km south-east of the center of Dresden/Germany. There the track should become visible...

    @mdx: The import of POIs should work the same way for all NavigatorFree installations on WinCE5, regardless of the actual device, right?
  • yes, the resulting MCA files can be used regardless of the actual device ... (with the same major version). Note, that diggerQt is currently only for windows PC.
  • @ wwwindisch :
    First of all : thank you for this idea of "importing" gpx-tracks as waypoints using routeconverter ( saving in  "Haicom Logger (.csv)" format" )
    But be aware :
    This solution seems to work only with N(orth) and E(ast)  latitude / longitude coordinates,
    because digger expects ( WGS84 ) coordinates as "signed" values :
    The latitude and longitude are represented in signed degrees. For the sign, "+" is assigned to the north latitude and east longitude,
    while "-" is assigned to the south latitude and west longitude. "+" may be omitted.
    So waypoints with coordinates within the southern / western hemisphere will be "missinterpreted" by digger
    due to the missing leading "-" sign in the saved "Haicom Logger (.csv)"file !
    This is not a "routeconverter" issue ( Haicom Logger seems to use the nnn.nn,S nnn.nn,W  notation of coordnates and not the "signed" notation ... )
  • @ retsmoor:
    Thanks a lot! I had not noticed that so far. Maybe other .csv formats come already with signed coordinates? Haicom was just the first that worked for me... It doesn't necessarily have to be .csv; .gpx-waypoints (not tracks!) should also work, right? So there are a few more options to try...
    I had chosen .csv because it makes it easy to take a look at the data (e.g. with MS Excel)...that's the whole reason. If all fails it would be no big deal to write a little Excel-Macro that changes the nnn.nn,S nnn.nn,W notation into a signed one.
  • Hello all,

    i've been trying to add a waypointlist as track to my NavigatorFree, mostly like wwwindisch explained.
    That means, I imported as waypoint-gpx into diggerQT, made a doubleclick onto "test" and added a 64x64 sized ico in blue to all records.
    But when I try to look at the track on my maps in NavigatorFree, I can't see it.
    Yes, the <track>.mca is located on my Navi and in the menupoint "settings" - "maps" - "select regions" it is activated in the section "all imports".

    What's going wrong? Which size has the icon to be? Is it to big or to small?
    Which data source type do I have to select in diggerQT? user data or speed cameras?
    Which source column do I have to select? Map or Table? name, comment, description, class_type, elevation, time or symbol_name? All or none?

    Please help.

  • Well, it's not totally correct, what I've written before. Yes, I found my waypoint-track in NavigatorFree.


    :(  It's amazing, I found it near the coast of somalia in the sea !?!?

    The original track-gpx shows me the track in Germany and Belgium - that's correct.
    But after converting it with diggerQT, I don't see the waypoints there but - how I explained - near Somalia.

    Doesn't diggerQT understand my gpx-files?

  • So, I think, I've found the problem.
    I supose, that diggerQT makes a reading-mistake, but I'm not sure.

    In my waypoint-gpx-files (created with RouteConverter) the coordinates are listed like this:

    <wpt lon="6.108203997" lat="50.744936988">
    This point (above) is near Somalia in the sea.

    When I now change the position of lon and lat in the file like this:

    <wpt lat="50.744936988" lon="6.108203997">
    lon and lat have still the same value but an other position in the file - this point in Navigator Free is exactly there, where is has to be - in Aachen, Germany.

    So, does diggerQT evalute the values of lat and lon or does it reads the first comming value as lat and the second as lon, without looking to the key/attribute lon or lat?

    With greatings from Germany

  • Hi crocodilefarm,
    I can confirm this bug - thank you for your report. Next release of digger should fix this ...
    thank you
  • Hi,
    I've tried Navigator FREE for 3 weeks and I am very pleased. Soon I downloaded digger application. Can anyone tell me how can I upload a shp. file correctly. I have tried all options and I get message:
    "Error: mapFactor exception: all objects were banned, no data to import..."
    Please Help.
  • Hi imoanteeli,
    are your shp-files perhaps routes or tracks?
    That has been an error, when I tried to import my gpx-datas. I had to convert them into waypoints. That xml-structur is different from the others.

    May be, that could be your way.
  • Just a note ... digger ver12 will be able to import also lines and areas, but at the moment you can see the result imports only in Android version. If you would like to try/test it, let me know.
    p.s. i.e. I can confirm what "crocodilefarm" is saying about points/lines
  • Hi Martin,
    I have tried to import a .shp file that contains my village. That means about 25 lines and 5 areas. The digger did not work. I've tried to import separately lines and after that areas... the same error.
    What can I do?

  • Sorry, I forgot: I use Navigator FREE on Android 2.3. 
  • Hi Martin,
    If it is possible I'l be pleased to try digger version 12. I will send to you all my results an observations. I'm impressed by Navigator FREE and I want to help to improve it. 

  • Hi Martin,

    because I have a WinCE-based Navi-System, I'm looking forward to the digger-version, that will come after version 12 and perhaps will work with Windows / WinCE.

    Until that, I convert my gpx-files (create with RouteConverter) with an own programmed simple-simple Java-Tool, so that lat and lon will stay in correct position.


  • Hi,
    for 2 days I've used Navigator 11 FREE for Android in Hungary and I am impressed. In the same time I've used  IGO on Noth Cross. Navigator (with OSM maps) was more accurate, more simple and more efficient. For 16 hours of using continuously Navigator FREE had not any mistakes, not any cracks. Simple and effective.  Congratulations to Mapfactor  Team.
  • Guys! What the hell? Something as basic importing a route shouldn't be such a hassle!
    I usually plan my routes on and want to import them to Navigator(WMo). I usually end up with reclicking the route in the PC Version... I just tried editing the routing_points.xml, but that fails as well.
    Using digger would be nice. If it worked. Via CSV, as described above, i get only useless points,because the data is recognized as icons. Importing a GPX route looks good (recognized as line) until I run it. Then I get the already mentioned "all objects were banned, no data to import...".
    Why don't you just put an import function for gpx on the device? Then we could download tracks directly from the net.
    Anyway, many thanks for navigating me through Crimea last week. Excellent map coverage.
  • With NavigatorFree12 and DiggerQt 12 it is very easy to import a track.

    I did it with an ordinary track-gpx-file, made some settings (changed the style for the line, [line width for detail zoom --> 8, minimal line width --> 4, shrinking ratio --> 33, fill colour -->0053D9 {blue}]) and exported the result to my data-folder.

    et voila..

    A perfect track-line...

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion