Test of Android version 5.5.x
  • 234 Comments sorted by
  • @stepan - disappointing to hear this. Try to keep it as simple as possible. Just have another optional box or panel area for the waypoint label to be displayed at the same time the waypoint alert appears or announced - nothing complicated. I am quite happy to loose some map area for the benefit of the label.

    For all of us who use the waypoints is very important that we have all the relevant information and also be able to quickly clear a waypoint on the move (back to the toolbar issue ;-)  ).

    Personally I cannot use the 3D version as there is no waypoint label displayed. The 2D version at least shows a label now and then depending where the waypoint appears on the screen - usually no label.

    @MacDony - I have requested a TTS announcement of the waypoint label a long time ago but that was a no-go.

    Its a shame as Mapfactor is really good on everything else. 
  • 5.5.93

    - prepared for France and later possibly some other OSM countries to be divided into more regions (we expect easier and faster map data computing and delivering to users)
    - @stavrich - waypoint name announcement in TTS is implemented now
    - @stavrich - problem with showing waypoint labels on the map all the time is much deeper than you think... all texts on the map are subject to text placing (i.e. many texts are not displayed so that they don't overlap each other). Of course there are preferences which label categories are more important and should stay visible but unfortunately waypoint labels are not among them and there is no easy way to know that a label is waypoint and should not be thrown away (or at least no fast enough way not decreasing the app performance). But we'll try to look at this more....
  • @Stepan,

    V5.5.93 arm64-v8a
    Waypoint name announcement in TTS, no change for me (tested in simulation)
    Is there an option to activate?
  • 5.5.94

    - possible crash when downloading list of maps available for download fix
    - @MacDony - there is no other option to activate but select a TTS language. You should hear "waypoint 'something' reached". But the pre waypoint announcements are still like "100 meters from waypoint" without its name.
  • @stepan -
    TTS announcement - worked on mine using google tts - i think it has to be TTS and not recorded. 

    Is there a chance to have the announcement much earlier ie at the first / second announcement. At "waypoint ????  reached " is already too late as I have just passed it. 

    As for having the waypoint text visible I was more thinking of having a specific box for the waypoint so that it wont interfere with the map and any other labels. Use the area reserved at the bottom of the screen that displays the "current location". My "layman's" solution is to suspend the "location display" and display the wp text for the 2 miles duration prior to reaching the wp. Possibly I am oversimplifying a difficult change again :-).

    My workaround for the TTS solution is to add extra waypoints prior to an important waypoint, such as a "Stop" waypoint, but is not a solution for all the waypoints ( I could end up with non-stop waypoint announcements :-) ) ; but I am still grateful - many thanks.

  • @stavrich

    so you would like to hear "500 meters from waypoint nameofwaypoint"? if it is so, we can do it...
  • @Stepan,
    Ok for TTS (google tts)
    500 and 100 meters from "Waypoint TTS" and at the "Waypoint TTS" would be nice
  • be careful, announcements could take too long
  • @stepan - that will be better but will be even much, much better if we could have it at the " one mile from waypoint nameofwaypoint" and repeat it at the ""500 meters from waypoint nameofwaypoint" announcements as well. 

    Not to go into great detail but it will give me ample time to safely overtake the motorbike in front to follow me.

    It will be fantastic if you could do it on both.. this is turning into a nice new year gift :-)  
  • @stavrich ok, but there is no time for it right now, sorry... probably in the beginning of February :-)
  • @stepan - this is fantastic and I am indeed very happy to wait  :)

  • V5.5.94

    MY PLACES > GPS RECORDING >  GPS Positions Recording - the option "Turn on/off manually" is not there anymore.

    I am not sure on what version this happened but on my old test phone v5.0.39 the option is still there.

  • Just tap on record as gpx or record as nmea, this will start recording manually. Tapping on the disc button will bring up the options for automatic start. All buttons are still present, v5.5.94 arm64-v8a
  • Not working for me. Tapping on record as gpx or nmea nothing happens.
    Tapping on the disk , GPS position recording, I get two options instead of three options.

  • Good Morning,

    I installed Navigator on an Android 9.0 Moniceiver.
    Version 5.5.94 arm64-v8a
    The VoiceCommands are not full presented, after a few seconds
    the voice stopped. I don't know the reason. Tested with different voices.

    Happy Day

  • Hi,
    Please modify the TTS.xml file for the next update.
    A modification is to be made for the French language.
    See image below.
  • Hello,
    Voices are completly when I use speech prozessor: Google Speech
    and Voice Language: synthesized german

  • Hi,
    Changes for the French part of the TTS.XML file
    For the next update Please :)

  • 5.5.96

    - waypoint name in all waypoint related TTS announcements @stavrich
    - preparation for new France OSM regions fix
    - french TTS updated @MacDony
  • Thank you so much for the update ;)

  • 5.5.97

    - preparation for dividing United Kingdom OSM into more regions
  • 5.5.98

    - UK OSM fix
  • @stepan - many thanks on the waypoint tts announcement. Excellent work! Well done to all involved.
    Next challenge to display waypoint label as well :-).
  • Hi, 
    if anyone wants to help us with translations, please do it here
    or there is one more our app
    Thank you very much :-)
  • Dutch done for both
  • French ok for Wake-me-there.
  • French ok for Navigator.
  • 5.5.99

    -minor bugfix
  • Hi,

    In the TTS.xml file

    <tts_data language="en" region="uk">
        <text>take exit</text>
        <text>New message received.</text>
    <tts_data language="fr">
        <text>Nouveau message reçu.</text>

    Please add the missing part of the TTS for France with:
        <text>prenez la sortie</text>

    Please adapt the Navigation.xml file
  • Have noticed that it takes much longer for the app to load. Anybody else ...?
  • 5.5.100

    -french tts update (@MacDony)
  • Hi Stepan,
    can you see if this addition of direction in the TTS is possible ?!
    Thank you so much.
  • @MacDony - it's more complicated than the previous adjustments... but not a bad idea though, we'll look at it
  • Awesome ! Thank you very much ! 
  • Hi Stepan,

    Version 5.5.100
    Changes in the Navigation.xml file were not made for "TTS-USE-EXIT" for French language

          <!-- Turn right to "street"-->
          <!-- [Take sharp right, Turn right, Bear right, Carry on straight ahead, Bear left, Turn left, Take sharp left] to "street" in [100, 200, 300, 400, 500, 1000, 2000] [meters, yards, kilometers, miles] -->
          <!-- Take slip road. -->
          <!-- Take slip road in [100, 200, 300, 400, 500, 1000, 2000] [meters, yards, kilometers, miles]. -->

  • @MacDony ok, wait please for first 6.0.x beta release, will be available soon
  • sorry for my stupidity... but 5.5.x is the version of what? :-)
    Where can we see it?
  • The Android Version of Mapfactor Navigator.
    Go from main menu to Settings, Extended, About Navigator
  • @Stepan,

    Please add the blue lines in the Navigation.xml file
    This allows to have the Destination Name with the TTS.

    Edit February 18, 2020

          <!-- Destination [NAME] reached (MacDony) -->

    Thank you so much
  • Thanks @Oldie,
    the title (Android version 5.5.x) confused me ;)
    And the manual: Navigator 12. EDIT: "12" is only on the french manual

    It's a pleasure to read this topic, a lot of goodwill
  • Hi Stepan, Tomas

    February 21, 2020
    update of the TTS.xml and Navigation.xml files for the French part.
    I can send you the 2 modified files if it's better.
    I specify that I modified only the French part.

    You can download them on my google drive here:

    Thank you so much
  • 5.5.102

    - bugfix release
  • 5.5.103

    - android 4.4 crash fix
    - french navigation by @MacDony
  • 5.5.103, Android 6.01

    If a category (e.g. Travel and accommodation) is clicked in Settings - Map Customization - POI types, it takes approx. 4 seconds until the selection list appears.

    If a continent/country is clicked in Map Manager - Download Maps (or Delete Maps), it takes approx. 3 seconds until the check mark appears.

    In the other menus, the response times are as usual.
  • v5.5.102 - Sony xperia zx2,  android 9. ( @stepan - I have posted this in the bugs section but I think it should be here...)

    The "Save as GPX automatically" is not working. It saves files in NMEA format  instead.

     I do not think is the app as the same version works ok on my BB Z30. I have de-installed Mapfactor, cleared cache, delete all data files and Andorid com.mapfactor folder.
    Re-installed Mapfactor but still get the same problem whether installed sdcard or internal storage.  This is driving me bonkers..!

    Choosing "Save as NMEA automatically"  enables the bar at bottom - "Record as GPX" & "Record as NMEA".  In effect "Save as NMEA automatically"  behaves as " Turn on/off manually" instead.

    If none of the manual record options is chosen then no files are saved. In effect the  "Save as NMEA automatically"  just switches off recording.

    There is no option to switch off Automatic position recording as per the screenshot from V4.x release. 

    To summarise:-
    Turn on/off manually = missing
    Save as GPX automatically = saves in NMEA format
    Save as NMEA automatically = Turn on/off manually

    ... screenshots below


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion