Test of Android version 5.5.x
  • 234 Comments sorted by
  • The Problrem with the disabled GPS while in Background or while The Device is locked after a Upgrade to Android 9 have to do with the Maintenance-Service. It is not necessary to keep the whole device alive @Roldorf. The Android 9 changed the settings in the maintenance-service. To fix the problem just going to Settings (Einstellungen)> Maintenance (Gerätewartung)> battery (Akku)> If navigator listed in the list> click on the listed App and disable the Standby mode. Otherwise change the global settings for this the under the three vertical dots top right. Maybe a change in the App Settings is also possible, but this have i not yet tested. Navigator should change such settings by itself.

    Off Topic: Never was making of a GPS-Track so economically. 2h GPS-Track need only 2% Power. Thats really very nice. I guess when i buy such a chinese outdoor device, this maybe need so much power for the GPS like a older Samsung device.
  • Hi,
    Version 5.5.35
    Backup on Google Drive is not possible!
    This version turns it without end....

  • I am getting more and more disappointed with Mapfactor's performance. I keep hoping that the next release will address the long going issues but alas nothing gets done instead other bugs get introduced. I had a quick look for an alternative app but couldn't see anything to offer all I need unless I go for a Garmin Zumo (last thing I want is to carry one more device). 
    Mapfactor excels in route planning with stops (waypoints) and you should keep improving on that - very few apps offer this function. Navigating from A-B there are hundreds of apps and quite a few extremely good. 

    So I have decided to carry on shouting and pestering until something gets done. Here I go again..
    1. Fix crashes - unless Mapfactor is only for short trips.
    2. Fix slow response of info panel - Screen responsiveness
      The screen responsiveness of bringing up the info panel is unacceptable. It works ok at the beginning of the navigation but the longer in navigation the response deteriorates and usually stops working.
      The zoom ( + / - ) buttons appear all the time, no matter how long navigation is running but the Info Panel that I really need is just a hit or miss - usually is a miss.
      I need the functionality especially to clear missed Waypoints or add quickly a place as a  Favourite.
    3. Waypoint labels - display waypoint label. Proposed solution - Having the waypoint name displayed at the bottom information panel - location line. 
    - Suspend the location (road/place) display when approaching the waypoint.  
    - Display the WP label until the WP is reached. 
    - Revert display to Road/Place 
     or display the WP label somewhere else on the screen. 
    Search facility - MUST have a search like Google. 

  • 1. and 2. is hopefully fixed, we will release it if it passes our own tests
    3. not yet
    Google search - we cannot pay what Google demands, it is simply too much
  • 5.5.42 available to download from http://download.mapfactor.com/mapfactor_navigator.apk

    - restore from Google drive fix
    - better app performance during long routes
  • image I still can't enable some road classes. However, Major Road is working again when a new vehicle profile is created.
  • most likely corrupted file vehicle_profiles.xml
    rename it and then start Navigator
  • I tried this before. But this time it worked. Then after some testing the "Secondary Road" option disappeared. But oddly I was able to activate "Other Road" after several tries. So I removed the file again. Afterwards, also after several tries, the "Small Local Road" and "Other Road" options came to life. I have experienced the same behaviour on two different Phones.
  • I tried version 5.5.42 yesterday. It crashed after 6 hours, that seemed better than before.

    One thing was different to my earlier crash-experiences: I always used to navigate with map renderer "SW low resolution", this time I started in hardware render mode. After about three and a half hours I switched back to SW render mode (HW mode is in every phase zoomed out way too much for me, I am unable to navigate in that setting) and two and a half hour later MFN crashed. Maybe it was coincidence, perhaps it has to do with render mode, I don't know.

    By the way: On my previous phone (Motorola Moto G) I always had problems with slow response of the app, on the device I am using now (Xiaomi Mi A1) I don't have any problems of that kind.
  • Version 5.5.42
    Android Pie

    Screen responsiveness -NO/slow response of info panel. Still Info Panel
    not responding.

    On every touch the +/- zoom buttons appear instantly but the info panel is too shy to make an appearance.

  • 5.5.46

    - 64 bit native code for 64 bit devices
  • Hi,
    "Still Info Panel not responding"
    and the button back to the menu too.
  • I have no such problem, please give more details
  • Hi Tomas,
    when I make a trip long enough and I want to leave Navigator, I click on the button back to the menu (arrow) and it does not work.
    I click several times, we see the button change mode to click, but it does not work.
    By insisting, the panel "quit navigator" appears, I do "no" and I have access to the menu.

    I did 25 trips from 1 hour to 2 hours last week and weekend and I had the problem each time.
  • @Tomas @MacDony - Tomas are you saying that the Info Panel responds on your device or are you referring to the "back to the menu" button.
  • I think is the same problem....
  • @stepan - I think mine is 64 architecture, Sony Xperia zx2.
    Can I have the download link
  • Mine is 64 bits version.
    V5.5.46 bug arrow button fixed, with 2 hours drive.
    But, partial blue screen on Map in navigation mode.
  • 5.5.49

    - crash navigating on 64 bit devices with low res software rendering fix

    available on Google Play Beta channel later today, also available for download at http://download.mapfactor.com/mapfactor_navigator.apk (@stavrich)
  • @stepan

    V5.5.49 - Info Panel screen response.

    On a two hour ride. Good improvement. Info Panel responded some of the times on the first screen touch but most times it required a 2nd or 3rd/4th screen touch. On a few occasions there was no response.

    This is the first time I had response compare to the previously No response. You are on the right track but still needs to be improved - it has to perform the same way the Zoom +/- buttons pop up instantly.

    I hope @MacDony can confirm my findings
  • I also can confirm. Navigation was in for about 5 hours today, response is much better, but still needs some tweaking! Best version ever so far!
  • 5.5.51

    - showing location on map from Booking fix
    - changing sound volume when device is in "do not disturb" mode possible crash fix
  • I'm still missing the function:
    -  the continuation of navigation after a re-start, if navigation was interrupted/MapFactor ended (eg as in Sygic).

    A very useful function for a complex route with many waypoints.

    Is it possible to implement this feature?
  • @user_mf - unless I misunderstood you - mine works the way you want it. All my rides / routes use a lot of waypoints and after any unexpected shut downs, controlled exit or even device re-starts I am able to restart navigation from where stopped - just click on "navigate" and I am off. Any waypoints cleared will remain cleared and this is very important to me.

    Even after completing a route and navigation stops with no problems the route will remain in the " Route Info" until a new route is loaded.

    Same thing was discussed some time ago (see https://forum.mapfactor.com/discussion/comment/16568#Comment_16568 )

  • @stepan @tomas

    Back to Info Panel screen response  . Today the response was worse than last time, v5.5.49. I noticed that when a lot of re-calculations are taking place ( which is expected after a missed waypoint ) the response time deteriorates dramatically.

    If stopped moving, calculations slow down or stop and the Info Panel screen response improves, might even say becomes perfect ( I think this is also true if the re-routing is a few miles away the number of re-calculations reduces and the Info Panel can slip through)

    Suggest the Info Panel response takes priority over the re-calculations otherwise we get into a catch-22 situation. That is the user tries to resolve the problem but the Navigator wont allow it.

     @2highlander @MacDony any chance you test my findings?

  • Hi,
    I can confirm that the response time of the info panel and the arrow back to the menu is worse than the previous version.
    The partial bluescreens of the map in navigation mode are still present, about 3 times for 10 kilometers.
    I can not do screenshot because it's too fast, less than a second each time.
    it's like a blue flash at the bottom of the screen and triangular in shape.
  • Hm, MFN is my bike navi, running on a S5 the whole day long when riding. Till now I couldn't notice any blue screens. But when switching from one menu option to another, sometimes the blue splashscreen comes up, it's only as long as a glimpse with your eyes. Maybe the splashscreen is running in the background and mixed up by the renderer. Did you try another renderer in the MFN settings?

    And yes, screen reaction somehow seems to react depending on how much the processor is busy with calculating and other jobs in the background. My S5 is rooted now and all bloatware, android system apps included, which is not necessary for navigating has been banned. I also activated the developer options, activated force GPU rendering and limited background processes to exactly 1. Didn't notice any difference so far, but must provoke some special situations with lots of recalculations and see how things have changed.
  • @stavrich - thank you, it actually works.

    @stepan @tomas

    BUT, for better usability (continuation of navigation after a re-start) you can pack 2x clicks in one:
    - navigation + select destination --> Continue navigating (dialog box yes/no).

    And then ...
    In version 5.5.51 I observe the "blinking" of the maps during navigation (chaotic zoom in and out..in and out..).  E.g.  start 48.782741, 8.182077; end 48.779442, 8.176762
  • I guess you should disable the alternative routes at all. This cause alot of calculation power. But i make not often big trips..... cant test it. On some big trips i have reproduced the non-responding-bug, but this was 2016....
  • Alternative routes is disabled. As my rides are pre-planned routes with a lot of waypoints the alternative routes function is more of a hindrance to me.

    Everytime a waypoint is missed or bypassed for whatever reason Mapfactor tries to re-route back to the missed waypoint, which is expected, but it won't allow any user interruptions ( I hate one track minded systems :-). )
    Very annoying if the waypoint is missed due to road closure and following a diversion and still cannot clear the waypoint unless you stop.

    It's not easy being on a motorcycle - we need quick responses.

    Just hope the Mapfactor team recognize this issue, put a high priority and looking for a resolution. [-O<
  • just set Skip next waypoint on toolbar, t has been there for a long time
  • @tomas - I think what you call "toolbar" is what I call "info panel" . I have four of the buttons set as Skip next waypoint. The problem we have is that the Toolbar / Info Panel won't activate when touching the screen. Especially if there is any re-calculation taking place it never appears.

    But if you are talking about a different thing please let me know straight away.


  • this is toolbar, info-panel is where you see speed, time....
    I suppose it is too busy while recalculating route, it is not that surprising
  • I had two trips this week, each about 4 to 5 hours, and did not have any MFN crash so it seems that this bug has been solved. Thank you for this!
    About response time of info panel tool bar: I tried this a few times and for me the response time seemed normal.
    Config: LOS 16.0, 64 bit,
    MFN 5.5.49, renderer "SW low resolution"
  • Ha! Would You please try the same when using the hardware renderer and give Your feedback?
  • @2highlander: I had a one hour trip today and did it with HW renderer. I had no delay, when touching the screen the tool bar appeared immediately. But maybe one hour is too less.
  • Navigating from A to B is usually OK as there are no increase in recalculations. Missing a waypoint causes a lot of recalculations and the longer mapfactor is running the screen response gets worse.
  • 5.5.65

    - vehicle profile road restrictions - changing speed and preference redesigned to enable easier and more precise value change
    - some possible crash fixes
  • 5.5.66

    - possible crash when closing app fix
  • Version 5.5.66
    Green arrow bug :
  • "5.5.66

    - possible crash when closing app fix"

    No, the main crash when closing the app is not fixed, today it crashed again. But it restart now automatically and after restart it can be closed without crash.
  • I still have problems enabling and disabling road classes. Always several tries are needed for turning off and on.  
  • 5.5.69

    - timeouts connecting to our data and license servers optimized (i.e. the App should work better when there are connection problems)
  • 5.5.69 green arrow bug.... no change.
  • @MacDony green arrow bug - can you please send routing_points.xml or describe how exactly to reproduce this bug?
  • @Stepan,
    In navigation mode, navigator makes me go to the left, I close the road to the left, navigator recalculates to go to the right, the arrow remains in its first position.
    Start : 47.2610067, -0.3464000
    End : 47.2602758, -0.3417939
    the road that I closed : 47.2620850, -0.3460408

  • 5.5.72

    - map mode does not change to 3D automatically but stays the same after route recalculation during navigation
    - navigation route color does not change after route recalculation when navigating on an alternative route
    - navigation arrow on map is refreshed after a road is recalculated (@MacDony)

  • Toolbar ongoing issue.

    A couple of hours motorcycle ride today and trying to get the Toolbar to appear was very frustrating and I feel that nobody is looking at it. I can appreciate that most users are not using Mapfactor the way I do ie navigating routes with a few waypoints and possibly never ever had to delete/clear a waypoint on the move via the toolbar.

    Out of despair, today I screen recorded the last few miles - just to show how unpredictable is the Toolbar response. I have enabled the "Show taps" to see the taps on the screen - a small white circle.

    Video can be downloaded from here -  https://app.box.com/s/483i84465zily2zubmaq7a6qakdb76t6

    I hope this will help in finding a solution.

  • Hi Stavrich,
    I do not have this problem, well, not lately.
    But I do not use the "out / in" zoom in navigation mode.
    Maybe a solution to test.
    How many Waypoints and Kilometers in your routes?

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion