Test of Android version 1.3.xx
  • 124 Comments sorted by
  • The bottom info was missing for me because GPS was turned off. Why is it not shown without GPS?
  • In navigation.xml:

     in 'any_other' languages,
     at the end of the file, should be A-OT-01-00
     (1167 line in chattiewoman dropbox).

     in languages 'pl' and 'any_other' there is difference in group 'roundabout_simple_now'.
     In 'pl' is 'CX-RO-00-01', so i copied all this group to 'pl', with -01 at the end. Without this there is no token "Rondo" (ang. roundabout). IMHO it is no needed too much. I checked it another time, and it looks good.
    In tts.xml:
    in 'pl' part, 'A-SL-00-00' should be "Wybierz zjazd.". Now it sound like 'Leave motorway' on each sliproad - quite funny.
    There is another problem with IVONA-MAJA.
    I added more spaces to token "skręć w    lewo.", because I can't hear letter 'w'. (ang. 'turn left).
    In token 'A-SM-08-00' additional letter is needed "Gdy będzie to możliwe, zawróć."
    Maybe groups from languages "any_other" should be copied to each language separately.
    There is still problem with letter 'w', but only in IVONA-tts, Google-tts works good,
     so it is not good  idea to add more spaces to token.
    'dropbox', line 1172: A-OT-02-00  (navigation.xml, any other languages, back on route).
    In tts.xml:
     tts_data language="pl": token 'By-SL-00-10', the same reason as above 'A-SL-00-00': "wybierz zjazd.".
  • After some journeys and further tests I am very content with my current tts.xml and navigation.xml in German 8-)
    If you now add the spoken references, as suggested earlier by hdvwolf, I will be in heaven ;-)
  • Hmm, I am not sure if you will be happy with new 1.3.25+ available on the same link:
    - tts.xml and navigation.xml are revised
    - compass if off completely (you can try it to switch it on in settings)
    - slow start-up was/is related to "IVONA" workaround (there are some issues that you could select language which is not downloaded ... try it now please.

  • Before I download: What Germany related modifcations did you NOT take over? Or why should I be unhappy about the update?
    The compass worked fine for me - what were the issues with it?
  • No more delay on opening app on Ver 1.3.25
  • OK, thanks for test :). Here is 1.3.26+ http://download.mapfactor.com/mapfactor_navigator.apk
    ... there were still some issues with compass (devices without compass), now there are Chattiewoman tts.xml modifications. Gray compass settings if is not available.
  • So far, so nice :-)
    The only issue I had: Since update to 1.3.26, whenever I opened the app (so that the menu was shown), an error message appeared: "Current Text to Speech engine does not support selected voice. You may want to choose another engine or language."

    1. My application language is German. The message should be: "Das aktuelle Modul für Text-in-Sprache-Ausgabe unterstützt die gewählte Stimme nicht. Bitte wählen Sie einen anderes Modul oder eine andere Sprache."
    2. The currently chosen language was ok (it was the German tts I tested all the time with), and it worked fine; thus the error message is misleading. I suppose it has something to do with the earlier change from IVONA to google tts.
      I could resolve it by setting Navilock Doris, then back to synthetized German.
  • Better and better. In polish (pl) tts, there are too many pauses in the sentences:
    1. from A-SM-03-00 to A-SM-07-00 i added "," comma, at the end (now there are "." dots).
    2. A-RO-00-00 also comma at the end: "Rondo,"
    3. from By-SM-01-10 to By-SM-07-10 also commas at the end (now are dots).
    4. By-SL-00-10 token "wybierz zjazd." (now is "zjedź z autostrady.", ok for motorways).
    5. from Cy-2ml-10 to Cy-100m-10 also commas at the end (now are dots).
    6. in file navigation, in 'pl' part, standard later tts, there is no line with TTS-DIRECTION and STREET_NAME, maybe intentionally, or not (I added it in this part and del in standard now).
    7. Sometimes i had no voices at all, for example at the end of route, so I added all 'needed' parts from all other languages. Now is ok. - every time i have all tokens.

    Of course it is only my suggestion, tested with IVONA-MAJA.

    btw, after changes, file has new time and data, so it may be not overwriten after update!
    I hope also other people from pl will add more.
  • Can somebody confirm chattiewoman 1.3.26 behavior (dialog "Current Text to Speech engine does not support selected voice. You may want to choose another engine or language.")?  We are not able to repeat it - I suppose German IVONA sounds.
  • when I set English Ivona, I get no message and Ivona works
  • Only after .xml edit and save files.
    (I connect phone as hdd to laptop, Ivona and Navigator are on this hdd - flash ext mem.. Maybe only when Navigator closed, and not closed pernamently - additional window still active)
  • My case is a "bit" more complicated.
    First, my phone had no tts at all because I previously had deactivated Google tts.
    I downloaded IVONA (German Marlene), set it as default tts.
    Then I wanted to choose it for Navigator, but I couldn't because it crashed in version 1.3.20.
    So I re-activated Google tts and chose it for Navigator. Until 1.3.24, I switched between both German voices, but finally stayed on tts.
    After update to the latest version, the message appeared.
  • I have a question concerning the new features mentioned on Google Play. You write: "Show next manouvre by clicking on streetname during navigation" - what do you mean?
    In navigation mode, the next manouvre is always shown; this is not new.
    Thanks :-)
  • In openstreetmap, roundabouts are often tagged as "highway=mini_roundabout on a node.
    Could you support this feature in the new version?
  • @chattiewoman
    during navigation next street is displayed at the bottom - click on it
  • W.r.t. chattiewoman's issue about the "Current text to speech" message.
    Today I cancelled a simulation and accidentally rotated my phone upside down and then back. Suddenly I got the message "Current Text to Speach engine does not support selected voice. You may want to choose another engine or language."

    I did this "cancel simulation and rotate, rotate back"  about 10-12(?) times again and it happened twice afterwards, so I think it has something to do with cancelling the simulation and rotating the phone. But I can't reproduce it every time.
    After every message which I "OK-ed" I didn't change anything and immediately did a route simulation again: the voice worked fine.
    Svox engine, voice Jan, Navigator 1.3.26 in Dutch language.

    (Note: Speach instead of Speech. I'm not sure whether it was a typo of chattiewoman "autocorrecting" it but I typed it literally, which means that the message is incorrect as it should be "speech" indeed.
    And in Dutch the message should actually be: "
    De Tekst-naar-spraak uitvoer ondersteunt de geselecteerde stem niet. Kies a.u.b. een andere stem of taal.").
  • Where did the UK postcodes mca go? It's no longer in 1.3.26 (and maybe neither in 1.2.50).
    Is it integrated now in the UK map?

    (Edit: And where do they come from and how old are they?
    The reason behind this question is that in my previous nav app I had to create my own database of postcodes. So I created a 1.6 million UK postcodes mysql database which can be updated every 3 months.)

    Edit 2: It seems to be integrated in the UK map?
  • 1.3.x has extra buttons for "composite countries" (Germany, France, UK) in map downloader - i.e. under United Kingdom you should see also UK postcodes
  • When you have all the maps for a region, and they are the newest ones, you don't see a button (which is not too clear, now that I think about it).
    For UK I have on entry without regions button, for Germany I have one entry without regions button. For France I have a button as I don't have all maps.

    For Germany I see all 4 mca files in the data folder, for France I see my 2 downloaded maps in the data folder.
    For UK I only see 1 mca file and I can't find the *sustenance* file for the postcodes (as how I seem to remember it).
  • thanks for another bug report - I agree that it is quite misleading & I can confirm, that the button disappeared after UK map update
  • Hi there,

    I'm using MapFactor with my Android mobile since almost one year - after my PDA retired ;) 

    Lately I updated to version 1.3.24 and today we had a trip of roundabout 200km city/country and autobahn.

    I welcome the compass display - BUT...

    This version is the first one that drives me crazy. Where ever I stop on my trip the map starts to rotate in the display! In the city you have no chance to have a view to the following route, because it's in most cases completely out of sight!

    The last versions kept the display with routing headed up.

    Is this a bug in the software? My settings are all the same since the last version except the compass option is on: Autozoom, 3D mode, detailed navigation and the rest is set to default.

  • @tomas,

    because it's not in google playstore! For security reasons I normally do not run any apps from other sources.

    But I'll try and come back...

  • @Joopy - if you do not want direct link, you can still use Google Play, but get access to Navigator "beta" via
    ... probably today I will upload on both places 1.3.32(?).

    and Google Play beta now contains 1.3.33

  • Today I had to drive about 100 km to a destination. Navigation went fine and voice assistance via tts functioned fine.
    On the way back I suddenly realized after about 30 km that I didn't have voice assistance. I stopped and started navigator: no difference. I rebooted the phone and started navigator again: still no voice assistance.
    At home I fiddled a little further: still nothing.
    I switched to recorded voice and did a simulation: I had voice assistance.
    Setting back to tts voice and another simulation: Now the voice works again.

    I could be "something" with the phone, but it could also be a bug.

    version 1.3.33

  • Unlucky :-(
    1.3.33 doesn't work on Samsung GT-9001 (known as S+) and Android 2.3.6.
    I had to reinstall 1.3.24
  • what makes you think that?
  • Same problem here.
    Motorola Defy with Android 2.3.7
  • @tomas:
    I got an unexpected error when starting and had to close. I tried to reinstall again, restarted smartphone but got the same result.
  • Thanks for report. Current version 1.3.35+ should fix the problem with Android 2.3:

    @hvdwolf - can you try to send logs and write there "forum, hvdwolf" - I am not sure if there will be anything, but I am afraid that it is not easy to repeat the bug :(
  • @mdx: I can do a logcat and possibly even clean up the logs a bit.
    Do I need to attach them to a post or do I send a mail?

    And I know this is a tricky one, if it is a bug and not my phone.
  • @hvdwolf - mail is better in this case, thanks (but note that it is for me, from forum)
  • Well, I do/did have a much bigger issue now. I downloaded 1.3.35 and in simulation mode I don't hear anything.
    When going into settings to language the app crashes always, also after reboot.

    So I removed the app, without removing the data, but still the entire data folder is removed. Why?
    Fortunately I regularly make backups of my favorites.xml, route_points.xml, tts.xml and vehicle_profiles.xml.
    Anyway: after downloading a few maps I went into settings and now I can select my tts again. Upon simulation it works again.

    Upon exit I am asked to rate the app again. I already did that before but having a free app I can imagine why you want this.
  • I installed 1.3.35 now and it works under Android 2.3.*
    Thanks a lot.
  • Additional sugestion in polish part of tts.xml:

    A-SM-03-00 "Zjedź do prawej," or "Trzymaj się prawej,"
    A-SM-05-00 "Zjedź do lewej," or "Trzymaj się lewej,"
    By-SM-03-10 "zjedź do prawej," or "trzymaj się prawej,"
    By-SM-05-10 "zjedź do lewej," or "trzymaj się lewej,"

    For my own, but why not, i added emotional words (sweetie, honey, darling) in 'stressful' situation, e.g.:

    A-SM-08-00 "turn arround when possible" 

  • @PrzemekSupak - I am not sure if the translation is correct. A-SM-03-00 should be for "bear right", i.e. cases where you have complex junction and your direction is almost straight, but straight is already used and left is also used. As far as I understand it is rather "keep right", which is Bx-KW-01-10

  • Yes, Yes, Yes... I checked it once again!
    My translation was good for case from another post - (A2 / B66):

    There is small issue with angle of the road and correct token.
    My translation was good ONLY for this case not for complex junction.

    Now polish translation A-SM-03-00 "Jedź w prawo", sounds almost the same as 'Turn right'.

    But where is the problem (issue) - The best translation is in language="en" (bear right) and language="cs" (mírně doprava).
    Sounds good in connection with complex junction and this case above (A2 / B66).

    So the best (suggestion) for both is:
    A-SM-03-00 "Jedź lekko w prawo,"
    A-SM-05-00 "Jedź lekko w lewo,"
    By-SM-03-10 "jedź lekko w prawo,"
    By-SM-05-10 "jedź lekko w lewo,"

    Also in the other languages it is possible to use words matching for case A2/B66 and complex junction (gehen leicht nach links???).

    (btw) This is not the last translation, I think.

    With positive emotions, in language=pl,
    "Gdy będzie to możliwe, złotko zawróć."
  • TTS problem in 1.3.35

    @hdwolf & @all

    I can confirm the behavior of version 1.3.35.
    At start of the simulation no TTS.

    Navigator menu languages​​: Crash.
    Restart Navigator, Simulation: No TTS.
    Navigator menu languages​​: Crash.

    Again 2-3 restarts of the Navigator, without going into languages ​​menu,
    and TTS works with the simulation.

    After closing the program and restarting it, again the same behavior.

    This behavior is independent of the selected TTS engine in Android, GoogleTTS or Vocalizer for example,
    and is also independent of the version of Android and the version of Sense on a HTC Desire X. At last Android 4.1.1 and Sense 4+
  • I downloaded 1.3.36 this morning but I have no idea what has been changed. Maybe this error.
    I used tts this evening and it worked. Don't know on repetitive uses.
  • 1.3.35 -> 1.3.36 ... there is a fix for cases when you have corrupted SD Card (older version failed to run even from internal memory). There is also a minor fix if you do not have compass on your phone that you will not see message about compass calibration.
  • Can somebody else confirm problem darkbert is describing? What is your voice setting before first simulation? Can you please try 1.3.36 "just in case"?
    thank you
  • 1.3.36 has an issue with favourites. Changes (or deletions) to favourites are not stored.
    Edit: The behavior is strange. I'm quite stubborn and every time I start Navigator I rearrange the favorites again and delete the same one.
    the 3rd time it worked.

    I can confirm the behavior darkbert is mentioning about the crashes and about the tts behavior. I also mentioned it in post 84

  • @ hdwofl
    @ mdx
    here are some Test results of version 1.3.36 on HTC Desire X with Android 4.1.1 and Sense 4+:

    First start with Vocalizer, no TTS in the simulation.
    Two more starts, no change.
    Fourth Start, TTS works.
    Next start, no TTS support.

    Selection of the Google TTS engine; Test in Android, ok!

    Only the fifth start of the simulation TTS was present. (poor quality)
    Next start, no TTS support.

    Repetition of the previous tests, with additional switching off HTC
    between the tests, without changing the behavior.

    Calling the Navigator "Languages" menu sometimes produces a program crash.

    Difficulties in favorites not tested.
    "live on the road" not tested.

  • In cases when tts does not work , you can stop Navigator , start the task manager and terminate the app , which provides the Android tts . In my case that's Vocalizer . The next start is definitely with tts . Other Starts not . Again until after the tts Android app was terminated with taskmmanager .
  • I have now Navigator 1.3.36 and it works with pico.tts coming with my xperia active. But this is not very nice. I installed (and uninstalled) ivona (Marlene German voice), but the memory of the phone seems to be to small for that, instructions came only separated by pauses of several seconds. I think its a memory issue.

    I am back now to the French lady (no tts).
  • In reaction to darkbert: I have done the same tests as you, but I didn't kill the tts app.
    However, every time the tts didn't function from Navigator I tested the app itself via the Android Text-to-speech settings ("listen to example"). That kept on working. I have the idea that somewhere in the interface "something" gets decoupled and does not get reconnected until you initialize it from Navigator (switch to recorded voice, switch back to tts), or "from the other side" by killing the tts app.
  • @hvdwolf
    exactly my opinion
    therefore nothing to do for the user at all...
    isn't it?
  • I know they are already looking into it. We just have to wait.
  • There is 1.3.39+ available on http://download.mapfactor.com/mapfactor_navigator.apk
    Please let us know if it finally solves TTS problems ... thanks

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion