Test of Android version 1.3.xx
  • 124 Comments sorted by
  • On my device, it's a mess as tts cannot be chosen anymore. My options are no sound and recorded sounds. Navi lock Doris now is activated, but does not make a sound :(
  • Same for me. I can only select recorded voices or silent mode.
    My recorded voice is working though.
  • OK, thank you both - I am reverting the link back to 1.3.36, which was probably better (in the case you do not have older APK any more).
  • Update: After the fifth attempt to open Navigator v39 and sending logs to Tomas, tts was available and working again.
  • I tried at least 10x times to stop/start Navigator 1.3.39 but still no tts.

    I reinstalled 1.3.36 but I still don't have tts. 1.3.39 definitely changed "something" in the /data/data/ configuration section of Navigator which is not downward compatible.
    So I had to uninstall Navigator and freshly reinstall it. When you do beta testing that's not a big deal: that's why you volunteer to test (even though you also have to re-download the maps). For an end user this is a bit awkward. I don't know whether it can be changed but it would improve user experience. Especially if 1.3.39 would have been a Google play release and MapFactor would have to set a previous version 1.3.36 back (probably renamed as 1.3.40 then :) ). It would cause serious issues.

  • I did not notice it ... good that my tts is working again @-)

    Send logs using the settings menu, maybe it will help you too. Who knows? ;-)
  • Sending logs wins over delay. Plausible.
    However, in v40 the delay still exists.
    Open the app, go immediately to language settings. The option values are somehow corrupted.
    If you now close the window, the app crashes. But if you just wait longer, the tts entries appear and work.

    By the way, I will update the German tts file soon again.
  • "I would just double check that hvdwolf meant it is not simple to
    reinstall 1.3.39 by 1.3.36 without uninstall, right? (that's
    unfortunately expected that downgrading is "problematic")."

    Yes, that was what I did and what didn't work. And that is what users would do when Google Play would  "update" your installed version.

    Just installed 1.3.40 (over 1.3.36). Started it up, waited for 1 minute, went into settings and yes: tts is there and it works. A few stop/starts and it still works.
    I will keep checking it the coming days.

  • What I meant: you can even leave the language settings window open and wait, until the entries finally appear
  • Again v40, but I suppose it also applies to v39:
    The tts voice speaks only, if I first go to language settings, set recorded voice (in my case German Navilock Doris) --> OK, then reset back to tts.

    When I then close Navigator, reopen and retry my simulation (setting is still tts), the voice is gone.

    Hence: whenever I open Navigator, I first have to manually reactivate tts ...

    Second, but not since v40, but also earlier: When I close Navigator (using the Exit button, of course), the car mode is not always closed.

    Third: why do I get speed warning sounds in simulation mode?
  • just about speedwarning - I think it is because simulation does not exceed speed limt
  • "Second, but not since v40, but also earlier: When I close Navigator (using the Exit button, of course), the car mode is not always closed."

    I can confirm this: what's more. In most of the times it is not closed. This is already going back to 1.3.24.
  • I can confirm that in 1.3.40 car mode does now close after exiting Navigator. Voices still problematic. As Chattiewoman describes I have to change to recorded voice then back to tts for tts to speak. When I close then open Navigator there's no tts.
  • For info I use a Motorola Moto G running Android 4.4.4
  • Up til now the tts functions without faults in 1.3.40
  • v42: The delay in languages settings still exists, but never mind this page:
    TTS is working again, without any workaround :-)

    What are other changes of v42 we could test?
  • @chattiewoman - the delay will always be there as it takes a while to TTS to present what languages are available (that's what I was told) ... or are you able to crash it again? TTS is the only change since 1.3.40.
  • Hum, but in the first tts versions the menu was ready immediately, with tts. And it worked. Strange.

    Concerning the crash: good point, I forgot to test it. Now tested: No crash :-)

    PS: I'd recommend to put a little info text when opening the languages page, something like "Loading ..." or so.
  • TTS problem appears to have been resolved in v.1.3.42+ on my Moto G. Thanks.
  • thanks - in the original version you could select sounds, which could be not available (as far as I remember) ... now they should be filtered
  • presently i am testing 1.3.42 on my moto g i will get back if there are any issues with the app
  • I tested the new version but I am facing a weird problem I tried simulation of the route with distance of 15km and hardly after 5 km the app closed by itself without any warning I tried resetting and also downloading the whole maps same problemagain .
    Just for info using moto g with android 4.4.4
  • please set debug level to high (settings/advanced), repeat crash and then email logs
    P.S. please type description
  • Tomas done I posted the logs through mail I could not find the GPS coordinates for departure and destination can u please help me how to find the coordinates
    attached link describes my problem
  • I used navigation instead of simulation and faced a weird issue:
    The map was North up. I checked settings, restarted navigation, but without any success.
    What finally helped: I closed navigation, ran simulation, ran navigation again. Tomorrow I will be on tour again, so we'll see whether it's reproducible.
  • It is expected. Compass sensor is not used during navigation even if you have checked "use compass". When you start navigation you see last direction until you get direction from GPS(first run is north, after simulation there is still last direction). We plan to fix it in 1.4.
  • You got me wrong:
    GPS was already available, the route was already calculated, and the instructions came correctly as I drove for a while. But the map was North up though.
  • On my way back the issue did not appear again.
    The only difference: yesterday it took very long to find the first GPS signal.
  • There is timeout for "Waiting for GPS" message(1minute I thing) after timeout you can be navigated by location provided by network.
  • Not had a problem with GPS signal Ver 1.3.42
  • By the way, since v42 closing the app always closed car mode, so far :-)
  • 1.3.43 - fixed (?) language dialog for devices without TTS (the rest should be the same as for 1.3.42)
  • Snap GPS for Android is needed!

    I tested both - WindowsCE and Android.
    Windows is much more better on mountain roads, especially with poor GPS signal or not perfect maps... or my phone has weak GPS.

    Road to Spindleruv Mlyn (Cz).

    I added a lot of POI files and now Android version doesn't remember my choose of speed warning Camera Sources.

    Bigger Speed Restriction Sign would be better (200 - 300 percent), because 50 and 90, on sunny day, looks the same.

    Maybe information about Countries law restrictions - can I use my Camera Warning files (e.g. in Czech Republic or France), or not.

    (edit2) For polish testers, tts.xml with 'darling', and changed A-SM-05/03 "Jedź lekko w prawo/lewo":
    (btw) Even my 'wrong' translation, from post above, is better than 'turn left/right'... or check it on WindowsCE without TTS - the first word is 'zjedź', not 'jedź'. Not perfect, but one letter make a difference.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion