Test of Android version 4.0.x
  • 280 Comments sorted by
  • Hi,

    Version 4.0.71
    September 29th:
    In navigation mode, click on the 3-position icon (bottom right)
    Navigator crash.
    Restart, click on the icon 3 positions, no crash to destination.
    Logs sent.

    Sorry, it's September 30, error for the mail logs.
  • I am sorry for delay but I am very busy last working days.

    @mes - I still did not find time to take a look of Navigator's slowing down - there is one another task with higher priority. About the problems you mentioned with Netherlands map - you wrote that it is an issue of OSM map and you are right. Feel free to fix it in the OSM, we are not going to do that.

    @Matthias - It needs quite a lot development to support it all. Our routing system currently cannot handle many features you mentioned.

    @MacDony - I took a look into logs you send but there is nothing what can help me to reproduce the issue. Can you maybe create GPX or NMEA and send it to us together with routing points?

    @MacDony - The version 4.0.x does not announced the name of the waypoints.

    @MacDony - About the SW renderer - the rendering takes sometimes up to 1 second per frame and thats the reason why the navigation arrow is behind. The most of time takes the text placing - in the map movement we are disabling text placing, also it is not 1FPS but it is still not fluid. You wrote "Can you move the position of the arrow 5 mm up, to be above the information panel in the lower left, it hides the route when turning to the left." I cannot imagine it, can you provide me a screenshot?

    @MacDony -  the finding position of GPS takes very long when you have no mobile data, when you have not enough big view on the sky or when you are going to fast. It works that way that it downloads the positions of the satellites for your position and then it search directly there (if the position changes in between it does the process once more time).
  • @Lubos,

    "You wrote "Can you move the position of the arrow 5 mm up, to be above the information panel in the lower left, it hides the route when turning to the left." I cannot imagine it, can you provide me a screenshot?"

  • @lubos

    "I took a look into logs you send but there is nothing what can help me to
    reproduce the issue. Can you maybe create GPX or NMEA and send it to us
    together with routing points?"

    Start : 47.26045, -0.3418386
    End : 45.784252, 4.896956
    with toll road and no waypoint.

  • new problem version 4.0.73
    While navigating a route the Map View changes to the Menu. Navigating continues but the map is not visible anymore. When I click on the Map Icon the map is sometimes show for a short period. Then the Menu appears again. Sometimes when I click the Map Icon the Exit menu is shown.

    My phone is connected to an external power. When it happened the first time the phone was on for two hours (guess) while mapfactor was running for half an hour.

    logs are sent!
  • I had a 2 hours ride today with v4.073 running for the first time and didn't have any problems. MF is running on an old S5 in a splashbox, powered by an external power pack.

    The only problems I have sometimes are raindrops falling on the display which makes it go crazy because it interpretes every drop as a finger tip. OK, that's the handy, not MF.
  • The Navigator 17.1.6 vehicle_profiles.xml are no longer compatible with the Android Version 4. When i copy the vehicle_profiles.xml to the cellphone, it will be ignored. The vehicle_profiles.xml are no longer used in Navigator 17. This file was renamed to truck_restrictions.xml. I guess this renaming was completely unnecessary. I copied my settings from my vehicle_profiles.xml to this new truck_restrictions.xml, but Navigator 17 don't use my user defined settings anyway. I am very happy about that the android version is using the old vehicle_profiles.xml and the PC Navigator should do the same again. I was scared why the PC Navigator calculated another route than the Android Navigator.
    Edited: 201810131115

    I made some testings and found out that the OSM Gates and Barriers are used for the routing-algorithm. Thats good, They are just invisible.

    @2highlander A Handy is in english not a cellphone, it mean just "nützlich; handlich; nahe; praktisch". But Autobahn and Rucksack are english words. :)
  • And Kindergarten ;-)
  • @ Matthias

    'Cellphone' is American, Mobile Phone is English. Rucksack is Back Pack and Autobahn is Motorway.

    Hope that Helps.
  • @Roldorf: i guess we need a new name for a mobile phone. My suggestion is "Taschenrechner". In all this years of using english forums, i never learned english. :)
  • Taschenrechner = pocket calculator
  • OK boyz,

    sorry, hope you all can excuse a native Bavarian's poor English and everybody knew what I really meant. :D
  • @2highlander
    It's OK I have never known a mobile phone as anything other than a 'handy' here in Germany and I have lived here since 2001.
  • @MacDony - I moved the GPS arrow in SW renderer (it will be in 4.0.76+)
    - I tested the route in the simulation and it worked it for me. It probably behaves differently when the position comes from GPS.

    @mes - your crash was solved by replacing navigation.xml, right?

    @2highlander - raindrops cannot be solved by software, anyway I recommend you to try screen protector. Some of them reduces effect of raindrops.

    @Matthias - I am not aware that Navigator 17 would not use vehicle_profile.xml, it sounds for me not correct but I am developing mobile versions of Navigator only. Maybe @tomas can say something to it.

    Today I optimalised navigation UI which was really incorrectly implemented. After it my test of decreasing Navigator performance measured much better numbers. That means that Navigator speed is still decreasing during time but it should be much better in the next update. I hope it will work without problems at least for 500km. The change will be in the version 4.0.76+.

    Über deutsche Wörter im Forum - mir ist das egal. Ich wohne in Deutschland und ich verstehe das.
    Grüße aus NRW
  • replacing only navigation.xml did not work. After I removed all files in that directory navigator worked again as before. Then I made my personal favorite settings again and removed the announcing of waypoint in naviagtion.xml and navigato still works great!!
  • Hi,
    - Thanks for arrow position.
    - the "parking" and other icons are very very small in navigation mode, even at 70%
    - in "My Route" -> "share as GPX" does not work. "file share failed"
    - in "My Route" -> it is not possible to share as NMEA? If yes, how ?
  • Hi,
    Version 4.0.77
    Favorite => my route => "share as GPX" does not work. "file share failed"
  • @MacDony my routes share as GPX fix is in 4.0.78, will be available today
  • No update for me today in 4.0.78
    Only 4.0.77 today !?
  • 15h55 update 4.0.78 in France,
    share as Gpx Ok ;)

  • Version 4.0.78 (Already found in the previous version)
    Bug "U-Turn" in the vehicle parameter.
    By default, I do not allow a U-turn.
    The U-turn setting is not taken into account when upgrading to another version.
    After the update, it is necessary to check the U-turn, calculate, uncheck the U-turn, recalculate, so that it is taken into account in the calculation of the route.
  • when I leave the application and launch the application, the U-Turn problem returns.
    I will put you my test file in Gpx.

    The link :
  • After use, the navigation arrow is still too low.

  • Version 4.0.79
    U-Turn problem
    navigation arrow
    Nothing changed 
  • Version 4.0.80
    U-Turn problem
    navigation arrow
    Nothing changed
  • my uturn setting remains the same after exiting and starting Navigator
  • Hello Tomas,
    The problem is that the U-Turn parameter is not used in the calculation of the route.
    With the file I shared here, when I ask Navigator to "show on the map", the "U-turn" setting in the vehicle profile is not used.
    If I select and deselect the "U-turn" parameter and ask Navigator "show on map" again, the "U-turn" parameter in the vehicle profile is used.
  • @MacDony try the U-turn now please (4.0.81)
  • @Stepan

    Version 4.0.81
    Bug u-turn fixed, Thx ;)

    Position navigation arrow !?
    Many thanks.

  • Hi all,
    What's new in version 4.0.82 ?
  • When I search Pois near GPS-Position or
    middle of the map, I found Pois,
    but when I click "show on map" the prog
    returns to Select-window!
  • thanks
    POIs are highlighted, but it does not take you to map view - we will fix that
  • 4.0.82 - preference screen language occasionally appeared in android chosen language not in application chosen language fix
    4.0.84 - showing nearest POIs on map fix (@Siggi)
    (4.0.84 will be available later today)
  • hi tomas,
    thanks for prompt reaction and information!
  • @MacDony - I moved the GPS arrow in SW renderer higher in 4.0.85+ (not sure when it will be published). It is not possible to do it exactly by your screenshot because the dimensions of manouvere panel are not every display different.
  • @Lubos,

    Version 4.0.85
    - Navigating from an address on Google-Contact, bug fix Ok.
    - GPS arrow in SW renderer, put the position of the navigation arrow a little bit higher the same value and it will be great.
    Many thanks
  • Hi all,

    Version 4.0.85
    - Load a Gpx file with several Waypoints.
    - Show on the map
    - Delete Waypoint
    - The calculation is not done.
    - Back to Trip Info
    - Show on the map
    - The calculation is done
    - Add Waypoint
    - The calculation is not done.
    - Back to Trip Info
    - Optimize
    - Show on the map
    - The calculation is not done.
    - Back to Trip Info
    - Show on the map
    - The calculation is done
  • The version 4.0.85 is currently releasing. There might be some bugfix version but the development of it ended.

    I am quitting the forum, I hope that someone from MF will continue where I ended.
  • @Lubos,

    If you leave MF, good road to you and I was happy to meet you on the forum.
  • @lubos - really very sorry to see you leaving the forum (I presume not leaving MF), you are one of the best. Always responding to our posts and doing your best to help. It will be our and MF's loss.

    Wish you all the best.
  • @lubos That's an era ending, a real pity. Thank you for all your commitment!
  • @lubos,. Sorry to hear you are leaving the forum. Thanks for all the help you have given us. It is greatly appreciated. Good luck for the future.
  • @lubos You may remain as a private guest? You are cordially welcome!
  • Wow!!!... What a blow to MFN - my favorite navigation app!!!... Good luck in the future!!!...

  • @lubos: Sorry to hear you are leaving. Thanks for being there for the users and all you've done to improve the app.
    Good luck in the future. 
    "take care of those you call your own and keep good company"
  • Normally  my Bluetooth helmet headset‎ is paired to my smartphone. MF audio comes through with no problem. 
    Phone calls take priority over MF announcements. When call ends MF's announcements resume.
    This is setup 1. Intercom A connected via Bluetooth to smartphone. 

    Setup 2. 
    Intercom A connected to smartphone via Bluetooth ‎and also connected to a second intercom B device.
    Intercom B is only connected to Intercom A.

    When a phone call comes through, the smartphone interrupts the intercom connection between A and B.
    B cannot hear the call.
    End of call - connection to B resumes.

    MF announcements do not come through to device A.
    ‎MF somehow does not interrupt the intercom connection as it should.‎

    Please note that connected to a Garmin nav system instead it work as it should be. Garmin interrupts the intercom connection and the device connected to Garmin ‎hears the announcement. The second intercom device does not hear the announcement. 
    End of announcement and intercom connection between the two intercom devices resume.

    Can someone have a look into this please.‎
  • If jumping back to MFN, using a Main Link, it go always to the main page with the 6 circles also when it already running. Only the link in the smartlauncher categories and the link in the last used apps go back to the last used page, for example the gps recording page. I guess in 4.0.83 it jumped with all links back to the last used page and in 4.0.85 again not. Maybe this is a feature and no bug, but i don't need this.
  • Sorry, this is a android problem. I restzarted the xcover4 and it go again back to the last used page. I know the development closed.
  • I am not quit sure what the announcement from Lubos means. 'Development ended' and maybe some bug fixes for 4,0,85
    Does that mean there will be a new version and development for version 4 has ended or has the development of navigator ended????
    I have noticed recently that a number of firms developing navigation software have ceased trading. I will keep my fingers crossed mapfactor is OK.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion