Test of Android version 4.0.x
  • 280 Comments sorted by

  • I tried SW renderer but point B,C,D are not that different than in HW renderer.
    E is I admit not an bug but may be easy to fix ;-)

    Well. Thank you for taking the time to read my feedback. Beta-users are ment to report feedbacks, right ? So I thought it was worth reporting things that I though would make it better/nicer and not only bugs.

    Concerning BT SCO : PLEAAAASE keep it !!! This is REALLY a important feature, especially if the app is not compatible with CapPlay, AndroidAuto or MirrorLink.

    I think a configurable delay would make the trick (and I can give you feedback on at least 5 car models from different brands).

    Once we can assess that the delay helps, you may wake up BT earlier (by the same amount of time as the delay set) to take care of your "traffic light" example.

    This way, the announcement itself will happen at the exact same moment with or without delay (and whaterver the value of the delay) but the BT will be initiated earlier enough for the end user to hear the full announcement.

    BT Wake Up Delay set = 0.5s
    Announcement estimated duration = 3.5s
    Announcement should finish 10s before traffic light

    Wake up BT 0.5+3.5+10 = 14s before the traffic light
    Play the announcement 13.5s before the traffic light

    Thank you.
  • @stavrich
    settings/advanced/backup and reset/backup and reset
  • How can I find this address:
    Poland, "Nowa Wieś", Włocławek commune, code 87-853
    Can you search for places by codes? show how to do it - classic search
    MF 4.0.53
  • @stavrich which keyboard are you using? (It seems that the app receives on every frame confirmation button - "enter")

    @Matthias @zorglups I will take a look on it on Monday how difficult is it to implement it (currently it is #define in the code), if it is easy to do than it can be on beta on the beginning of August.

    @przemekp I think that we do not have code in the data for Poland. Anyway I can confirm that Nowa Wieś ist problematic for our search engine because it returns more than 100 results and then we do not show all of them. I will take a look on it on Monday, maybe there is something I can do about it.
  • @lubos - I think you are right - it seems that it receives "Enter" after the first letter only. It will accept the rest of the letters with no delay and wait for the "Search" or "enter".

    This is on my BB Z30 with the default keyboard - I dont think it can be changed.

    Before we blame my old poor Z30 the same thing happens to my Samsung Galaxy S3- the only difference with the Samsung is the delay, after the first letter, is shorter and will accept the rest of the letters before a "Not Responding..." message.  I assume the Samsung is faster than the Z30 and does not time out for the "Not Responding.." message.

    Please videos 

  • @lubos : Thanks a lot. I'm yours for beta testing this ;-)
  • @przemekp - The codes are in UK only (other countries with none or extremelly low coverage). You can search Nowa Wies but the DB is searching in the city names, not in descriptions. Also if you write "Nowa Wies Wloclawek" then it finds nothing. I patched the search engine to show max.500 results (since 4.0.54+ which is not released yet). With this limit you can show all Nowa Wies in our data. Anyway I tried to search Wloclawek and it found a town. I am not sure if it is the town you search.

    @stavrich - The Prefer Google variant is on versions 4.0.53- working that if you have internet then it uses Google if not then Mapfactor fulltext search (internally LOOGLE - Lubos's Original Offline Google-Like Experience). I think that on your device the detection of internet connection does not work correctly. I remade it and call Google search independ on internet detection - offline search is then used only when Google search returns nothing. This modification will be in Navigator 4.0.54+.

    @zorglups - I have still no updates, I will keep you updated when something new happens.
  • @lubos - No problem. I hope I can test it before getting on the road for the holiday season
  • I suggest filtering
    separated by a semicolon

    for example

    Nowa Wieś; gmina Włoclawek
  • @zorglups - I have it just implemented, it will be in 4.0.55+ but I did not test it enough, I would need more devices for testing

    @przemekp - this filtering we are not able to implement, when you are search in cities then it is a merge of more area admins. What you see under the city name is not standardised and it can be in every country different.
  • Just updated to 4.0.56 and on initially opening with TomTom maps, they worked fine on hardware rendering. However every subsequent attempt to view them resulted in a blue screen with no mapping. It occasionally closes after selecting TomTom maps on hardware rendering as well. Can only view the maps on software rendering. OpenStreetMaps works fine on both hardware and software rendering.

    Sent previous version logs to Stepan but had no feedback.

    Moto G5s Plus Android 7.1.1
  • I just installed version 4.0.56 over 4.0.53

    I noticed that all vehicle profiles appeared multiple times in the menu.

    Also I noticed that the size of navigation.xml was large< about 400k. Ik should be around 71k.
    When I opened this file I got an error. This file contained all information was repeated several times The error was on the first line of  a repeating section.

    I removed all files in .../files/navigator/ and started navigator again.   Mapfactor recreated the files and worked great again.

  • at this time I see that after updating the app several files are saved with a date added to the name of the file. I know this is done on request of some users but I think that the directory .../files/navigator/ becomes a bit messy with this extra files.
    I have a suggestion for another method to update while keeping adjusted files. The following could be done in the update process:
    1. make a full local backup during the start of the updating process. Give the backup a name that shows the mapfactor version to distinguish it from normal backups.
    2. then  delete all files in the directory /files/navigator/.
    3. then start the normal updating process.

    1. mapfactor has a clean new set of files in /files/navigator/
    2. every user can easily restore the backuped files if they want to.

  • Hello @lubos,

    I installed the version 4.0.56 and see the option to setup a delay. Unfortunatelly the effect is not what I thought it would be.

    In my case, whatever the delay set (by default: 3s and tried with 6s), the announcement starts playing on my phone speaker for less than a second then continue on BT SCO.

    Best regards,

  • AM I the only person having problems with TomTom maps and hardware rendering? Is it possibly linked to my map version as it is quite old? Got to resolve this given that OpenStreetMaps works fine in all modes.
  • may be files are corrupted?
    ty to delete maps and redownload
  • Not that @tomas. Works fine first time after program updates then I have problems. I've also installed before with the same results.
  • I cannot see why it should not work with TomTom maps when it works with OSM

  • @lubos - v 4.0.56 - Search issues. Well done Lubos all 3 searches work as expected. "Prefer Mapfactor" seems to be the slowest but it works. "Prefer Google" & "Classic" quite fast. Sorted!!

    Something to improve upon. Can you add a way to cancel a search.

    I noticed if stopped for a break or for whatever reason for some time, 20-30 minutes, and leave MF running sometimes it looses GPS / satellites. My workaround is to stop navigation after stopping and restart navigation when ready to go.

    Is there a way to force a GPS/ satellite re-connection manually - it will make life easier and save some embarrassment from 10 guys behind me pointing at their Garmins and laughing while waiting for me to shut down and restart MF  :\">
  • I owned a garmin 2720 and had many problems with it.
    I am very happy with mapfactor
  • It would be very nice if there was a option to reconnect the gps.
  • @all - There are new texts to translate, we appreciate a work which is done by community and we hope we keep you motivated to continue in it. Here is the link to translation portal:

    @mes - I agree but it has currently for me no priority. Navigator has still major issues and that has higher priority.

    @zorglups - I think I improved it today (it will be n 4.0.57+)

    @amlumsden - HW renderer has completely different initialization pipeline and I am not surprised that the behaviour is different. I cannot reproduce on my test devices but I tried anyway to fix it. Please give us know if the next update (4.0.57+) provides any change (it will be hopefully this week on the beta).

    @stavrich - Canceling search is quite problematic because there are some "atomic" operations which cannot be interrupted. I will ask my colleges. About reconnecting GPS - there might be a way but this is something which should be solved by your device manufacturer.
  • @lubos - thanks lubos - if something can be done for "cancelling search" would be great. 

    As for the GPS i dont think is the device - I tested it with copilot and triplogger, both were happy to be stationery for 1+ hour but still remained connected to the satellites. If memory serves me correctly, once I checked the GPS info and i could see a few satellites active but zero in the info panel.

    Please note that only happens when on actual navigation following a route - not armchair testing

    There is no need to shut and restart the device only exit MF and start the app again and start navigation. The good thing is that it will restart from where it was left and navigate to the next waypoint.

    We need a quick way to kickstart the gps connection routine ie Tools > GPS info > Refresh .

  • Thanks, @lubos. I'll let you know the results when the next build is installed.
  • Hi @lubos,. Good news - 4.0.58 seems to have solved my problem with TomTom and hardware rendering. Working perfectly with maps and no crashes so far. Thanks for all your help in resolving this. Was driving me crazy.
  • @stavrich - I am sorry for longer time without updates. I've just added the restart button into GPS info. If it passes the internal testing then it will be in the update 4.0.63+.
  • 4.0.63 on Google Play Beta now
  • @lubos - Many thanks - I will download 4.0.63. and let you know - will test it in Spain next week on big routes with 50+ waypoints.and a lot of lengthy stops. Cheers
  • Hi, currently using 4.0.63. Persistent bug from earlier versions:
    I am not able to restore disabled_links.xml. Backup seems to work, disabled_links.xml is created (and not empty), but restoring has no effect. (Restoring of vehicle_profiles, routing_points, favourites works.)
  • mapfactor version 4.0.63, osm maps, premium options
    phone: samsung trend plus

    I made a motorcycle trip today of 350km. Mapfactor worked properly except for one (allready known) problem. After a while the response time of mapfactor is increasing.  Redrawing the screen takes more time and when I touch the screen it takes a long time to show the menu in which I choose to skip a waypoint. It also takes a lot of time to skip the waypoint.  This is very annoying.

    I know this problem is known but it is the only real problem that I have with mapfactor. So I thought I mention it again. I hope that you will find a solution soon for this problem.
  • Version 4.0.64
    Like the new destination arrow, much clearer. Search now also works properly no overwriting of display.
  • Navigator 4.0.64.

    I temporarily switched back to Classic Mapfactor Search to compare a few things.
    However, mapfactor crashes repeatedly and reproducibly on Classic search after having typed in the name of the city. So getting the country works, typing in the city works, and then crash.
  • Hello,
    I'm using Mapfactor Free for Android since Aug. 2014 and regularly update it as well as OSMs whenever I get notification for new version. Latest update to v.3.1.120 was about 3 weeks ago. And as this is the latest version available on Google play store, my question is where to find v.4.xxx to download?
  • You have to register yourself as beta tester on Google Play for Navigator. Then the "beta-channel" will be activated and you get the beta builds. Currently at 4.0.64 (or so).
    When you have enough off it , you simply deactivate being a beta-tester. You need to de-install the beta build, and then reinstall from Google Play.
  • Hi,

    The translation is not applied to the vehicle profiles.

  • Since profiles are exspected to be (extremely ;-) ) individual, it is left to you, to name the profile. You can rename any profile from the context menue.
  • Of course, I totally agree with you Oldie, but by default, it should be in the language used. ;)
  • @lubos - restart GPS worked. Used twice in Spain- many thanks

    Just back from a motorcycle tour in Spain. Being in an unfamiliar country I was depending on MF. I have prepared my routes in advance, avoiding motorways and aiming for scenic twisty roads. All were fine apart from navigating roundabouts and complex junctions with roads running parallel to each others.

    Roundabouts - Mapfactor considered every entrance to a house drive as an exit. For example the street sign showed a roundabout with three exit roads but MF displayed four exits. A few times the wrong exit was taken.

    I can understand that possibly this is not easy to correct but the most annoying thing is that the display is not clear. Most of the other apps or Garmin zoom-in to give a clear view of the roundabout or junction but not MF. We need to zoom-in (use half the screen and if a garage entrance or a path to nowhere must be shown  at least we can see that is goes nowhere) for clarity and detail - please do something as this was very frustrating, dangerous (and embarrassing for me :\"> ) for 6-7 motorcycles having to U-turn or go round the roundabouts a couple of times ...

    In addition - the calculation and display of route on exiting roundabouts is very slow - very disconcerting as to whether the right exit taken. Position of arrow is quick but the drawing of the route line is too slow. 

    Also, and mentioned before,  the slow response. When MF is running for a couple of hours it becomes very slow to respond (sometimes it does not respond at all)ie info panel or going to main menu or any other setting. 

    Main thing is the zoom-in - we need to have it. I was not happy having to guess the right exit and keeping fingers crossed till the navigation line catches up.

    Version 4.1.63 - hardware renderer

  • @jkubik - Thanks for the report of issue of disabled_links.xml, unfortunally it is currently not a priority for us

    @hvdwolf - In our new data are sometimes unsupported characters which causes the crashing. I fixed it in 4.0.70+ but it should be also fixed on the side of data generating. Note that publishing the next Navigator update on beta might take longer.

    @mes, @stavrich - The slowing of Navigator is currently my second main task, I will keep you updated if there is something new about it.

    @MacDony - Vehicle profile names are always generated in english on Android due to unitialized language in the moment of xml generating.

    @stavrich - About createdata I cannot give you any answer. This should be answered by @tomas. About zooming... can you maybe provide a video to show the problem? Thank you
  • @lubos: I hope you will succeed in preventing navigator from slowing down. Looks like a difficult task
  • @lubos: Classic search works again (although I hardly use it normally).
  • Hi,

    Version 4.0.70
    In "Low software resolution" mode:
    - The navigation arrow is about 20 meters behind the map position(navigation mode).
    - The movement of the card is not fluid, the display is done by jerks.
    - Can you move the position of the arrow 5 mm up, to be above the information panel in the lower left, it hides the route when turning to the left.
    Or have an adjustable parameter of position.
    - The location position is very long, 1 to 2 minutes, sometimes more (outside with 7 satellites)
    Thank you for the mode "Low software resolution", my smartphone no longer warms.
  • @mcdonie: I think that's why it's called
    "Low software resolution" mode...
  • @steiny180,

    I do not think the resolution is applicable to smartphone performance.
    By default, Navigator is in Hardware mode on my smartphone, I put it in Low resolution mode so that it does not heat up only.
  • Hi,
    crash about 1 km before the Waypoint on the route of September 22nd.
    crash during a recalculation of the route on the route of 23 September.
    Logs sent.
  • I thought that in version 4.0.xxx Navigator announced the name of the waypoints ?!

  • Yes and why dont you use all OSM data? House names are ignored, Lift Gates are ignored, barriers ignored, opening hours ignored, and why you created a alternative search method when you have no database which is important for such a search method? mapfactor is the only software for pc and android, but if you not using more osm data in version 5, i go to search another software (i know there is maybe no alternative). And the crash when exit bug is still present.
  • I made a trip today with version 4.0.17
    Apart from the slowness/responsiness problem (which is known and being worked on) Navigator worked fine.

    I had a few issues with the map (Netherlands, osm, last version):
    1: roundabout on the N375 nearby Koekange. navigator told me to turn left and the turn right but it should say roundabout, take second exit. (is osm problem)
    2. two places where navigator told me nothing but it should tell me to turn left (or right) because I had to leave the mainroad and follow the route on another road (is osm problem0
  • Hi,

    Version 4.0.70

    Wednesday, September 26, for 7 hours of driving:
    - start 2h00 crash
    - restart 1h00 crash
    - restart 0h30 crash
    - restart 0h15 crash
    - restart no crash to destination
    once a message "Navigator is stopped"

    Thursday, September 27, for 6 hours of driving:
    - start 2h00 crash
    - restart 1h00 crash
    - restart 0h30 crash
    - restart 0h15 crash
    - restart no crash to destination
    no closing message from Navigator.

    Low software resolution mode
    no waypoint.
    Cold phone.
    Android 5.0
    Logs sent.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion