Test of Android version 4.0.x
  • 280 Comments sorted by
  • Search for POI nearest to map center. You may ask why is this so important?

    I am English and to spell some of these places to search under address (which does work) is a pain in the BUM.
    It was much easier to search nearest from Map Center or GPS position and have a list displayed with the distance from your position to the POI.

    We even used to get phone numbers on some so that you could call to see if they had rooms available (with Hotels).

    Now all I get is 'No results found'.

    I live in Germany and tour Europe on a regular basis so some of the spellings are quite challenging.

    Please PLEASE can someone look at this and make it work again.

    Many thanks and I live in hope that we can find a solution to this broken feature.
  • I will take a look on it on next monday
  • @Roldorf
    well, I followed your three-point instructions from 15th May and have no problem finding hotels (or any other POI group) around destination
    Radisson, Ramada, Classico, Atlantic

  • Version 4.0.45
    I imported a GPX file with route points which worked fine. It calculates a route fine. Instead of the name I gave it, it gets automatically the name "Nieuwe tussenpuntenlijst 1" (Dutch). When I try to rename it, the route disappears and is no longer available. Neither after a restart. No matter which name I use (like simple aa), it disappears.
    When I simply exit, the route is auto-saved with the auto-generated name.

    If I simply save (save current route), I can give it name but it is added next to my existing just imported "Nieuwe tussenpuntenlijst 1", so now I have 2 identical routes. I can't rename either of them.

    Workaround: Import route with standard auto-generated name, use button "save current route" giving it the correct name, then delete (or rename :) ) auto-generated imported route.

    Workaround: Remove current loaded route from navigator, Import route with standard generated name, use button "save current route" giving it the correct name, then delete (or rename) the auto-generated imported route.

    Please fix.
  • @amlumsden - I am still waiting on feedback on two APKs I sent you, also there is nothing new on my side

    @Roldorf - I fixed the issue, it will be in 4.0.47+. Note that the issue was there only when SW renderer was active

    @hvdwolf - There was a bug with renaming routes which has no group. All your lost routes are in routing_points.xml but there not visible (their names are starting with "!#IN -1"). I fixed the issue in version 4.0.47+
  • @lubos, sorry for the delay in responding but I was away longer than expected.  I have emailed you directly.  Many thanks for your help and apologies again for the delay. 
  • @lubos

    Many thanks Update to 4.0.47 POI searches, nearest, map center etc now works with SW renderer on all my devices.
  • 4.0.47 also fixed the renaming of the routes (which are not in a group).
  • in 4.0.48  voice stutters
    Today I noticed that the commands are spoken by a stuttering voice. Not always. Sometimes the sound is ok.  But regularly the sound has hickups so fragments of the command are gone. And then I can not understand the spoken command.
    This happened with the dutch recorded voice. I changed to the english voice but the problem remains. It looks as if mapfactor is busy with someting else that has a higher priority then sound.
  • Since re-installing version 4.0.48 after testing a couple of builds, Navigator doesn't recognise my local backups nor my favourites although both files are there.  Am I missing the obvious? 
  • @amlumsden: Check whether your new data is on external memory or internal memory,
  • @hvdwolf,  data is on external memory.  Placed backup on internal memory but every time I try to restore, the app hangs.

    Also noted that I still have problems with hardware rendering which seems to be related more to TomTom maps rather than OpenStreetMaps.  Very strange.

    EDIT:   Noticed that my backup seems to be corrupt so that solves one problem. :(
  • On june, 20 I wrote that I had a stuttering voice. Voice was with bluetooth
    Now I have done a simulation without bluetooth with the same route and the voice was good.
    Probably the problem was with my bluetooth device.

  • BUG: On versions 4.0.48 to 4.0.50 (and possibly others):I create a route in Navigator. When I wanted to save it in the "Route Information" screen, Navigator hangs. After some time Android asks whether to  "close the app" or "wait". This happens on both my phone and Android car head unit.
    This happens with simple 3-point routes (start-intermeidate point-destionation) as well as with multi-point routes.
  • The same problem for me saving route using 2 different phones Samsung Galaxy  A5 2017 and S3. When I go to My places / My Routes and Save current route, I can save the route without any problem.
  • @mes - There is some problem with Navigator CPU usage after longer time, I was never able to reproduce it on debugger but we are aware of it.

    @amlumsden - Copying files into Navigator folder using another app or PC can on some device make the Navigator folder for our app readonly and then the app behaves very weird. I am not sure if this was your case.

    @hvdwolf, @tvo - I fixed this issue in the version 4.0.51+. I am not sure when it will be uploaded to the beta.
  • @lubos,  solved the problem with my backup as it didn't save correctly to my pc (my fault for not checking).  As to the other problem regarding hardware rendering, I continue to have problems if I select TomTom maps (it either immediately closes, hangs or the map is not displayed).  It displays OpenStreetMaps OK with hardware rendering.  The only way to ensure that I see my TomTom maps is to set as software rendering.
  • lubos mentioned a CPU usage problem. I am experiencing problems with audio instructions beeing asynchronuous to the map display during navigation. While the instructions appear at the right time the display is at least two or three seconds behind. This makes it hard to navigate in sections where there are many maneuvres in a short time. I don’t know when this behaviour began but I’m sure it hasn’t occured last year. The lagging begins no later than after fourty minutes of navigation.

    Configuration: Lineage OS 14.1, Navigator version  4.0.50, software rendering with low resolution, NMEA-recording active.

    Further comments: Except the described lagging problem I’m very happy with the program, for me the GUI is okay and I have all the functions I need for my purposes.
    I’m very glad with the new battery level display, while my own warning souds still get overwritten with every new software version.

  • @lubos Version 4.0.51. The saving route problem has been solved for both of my phones. Thanks
  • Why is the POI searching so extremely slow? Watch Kiwix how fast this software search the offline wikipedia. Please watch for better indexing and better search algorithm. I was in pressure and needed a fast searching for a OVI, and cancelled it. Cancelling caused a Crash. Better waiting some minutes until Mapfactor finished the search.
  • POI data are not using database. When you search for POI then the component findnearest is called. This component loads map data around point (for some POIs with radius 100km) and then it returns the POI from the map.
  • @lubos,  any other ideas as to why my TomTom maps won't render when using hardware setting?  Not only doesn't it render but the app can crash as well.   Can it be the version of TomTom maps I have?   Any help would be appreciated.
  • My colleague was doing something with that but due to his vacation I have no updates on it. I will give you update on next Monday if there is something new.
  • Sorry to bring my "Waypoints" issues back but so far I had no response from @stapan regarding voice announcement of the waypoint text label. ie to work with TTS. 

    On top of that the other really annoying thing for me is that Waypoint text labels sometimes are displayed on the map next to WP flag but a lot of the times the WP flag appears but not its text label. 

    I cannot work out the behaviour rules behind this. I dont think it has to do anything with the text length (happened on very short  and long label) or map zoom levels.

    As the voice announcement seems to be a challenge can I please have the WP text label shown at the same time the WP flag comes to view. If the text is too long then it can be truncated to 20-30 characters but I need to see the label.

    Or at least let me know if I am doing something wrong.
  • text isdynamic, it will appear when there is space for it
  • Next issue..?
    The POIs have a different size when just looking on the map and during navigation. When navigating, they appear much smaller.
  • The difference in size of poi icons between 2d and 3d view is an issue for me as well.
  • @tomas -  a dismissive reply but to me is still a problem. On simulation mode the labels are shown irrespective of space available. 

    Why cant we have the same behaviour in navigation mode - fixed instead of dynamic. This will help people who create routes with waypoints.  I create my routes, run a simulation, make my corrections and I expect navigation to match the simulation.

  • Have tried to copy favorites from my phone to my wife's phone. File is in the correct place, but when I look under 'My Places' on my wife's phone I get no places saved. I used to be able to do this between my tablet and phone but it now seems to no longer work.

    Am I doing something wrong or has this changed?
  • Jambafee wrote at june, 27:
    " I am experiencing problems with
    audio instructions beeing asynchronuous to the map display during
    navigation. While the instructions appear at the right time the display
    is at least two or three seconds behind. This makes it hard to navigate
    in sections where there are many maneuvres in a short time. I don’t know
    when this behaviour began but I’m sure it hasn’t occured last year. The
    lagging begins no later than after fourty minutes of navigation."

    Today I had exactly the same experience on my samsung trend (lineage 13.0, Navigator version  4.0.50, software rendering with low resolution) The audio instructions are on time but the display stays behind.
  • @amlumsden - still nothing new, can you send logs in the navigator settings/advanced and write down into text "please forward to stepan" ? Thank you

    @stavrich - I am sorry but stepan is not activelly using the forum... I found a ticket in our feature request system which requests the waypoint names in TTS. In the description is a link to this topic: 
    http://forum.mapfactor.com/discussion/7742 . I send it to my colleages to bring it to their attention but I do not promise anything.
    The texts are behaving the same way in simulation and navigation but your speed is not the same, that means that autozoom is choosing different zoom and thats make a big changes in text placing. There is almost no chance to change the textplacing system as you requests, the waypoint names in TTS I see more realistic.

    @2highlander, @john_percy - this is issue with HW renderer only, I still did not find time to review it, there are too many requests on me but I am an externalist only who is working about 4hours/week, I am sorry

    @Roldolf, @mes - I am not sure if it is yours case but manual copying files into Navigator folder can on some devices break the accessibility to files from Navigator. (Note that favourites are using java implementation, also it can behave differently than e.g. routing_points.xml)
  • @lubos -Many thanks for your reply. I have examined the file I was copying and have found that there are some parts of the file missing (was a straight drag and drop from phone to desktop). I have now used the phones 'copy file' to send to desktop and all the file seems to be there. Will try tomorrow to send to wife's phone and let you know if that has worked.
  • @lubos - The new favorites.xml workes fine on my wife's phone, it seems that using windows to drag and drop the file to the desktop and then to the other phone loses the end of the file (the last four lines were missing). I used 'asus file manager' from the playstore to copy the file.
  • I have also seen with some file managers on Android, when copying/drag & drop .xml files, (any .xml file), the file manager changes the extension to .xml.txt.
    Don't ask me why.
  • Search problems

    V 4.0.51 
    Search Engine : Prefer Google 

    Searching by postcode. 
    After first letter it will not accept the next letter. It will freeze for a few seconds and either will accept the rest of the postcode or "Navigator isn't responding message"

    If the rest of the postcode is accepted still i get the "Navigator isn't responding message" . 

    "Wait" will go back to the search screen and after some time back to "Navigator isn't responding message"

    Never had this problem before - always had very quick search results 
  • it does not happen to me, but I have v4.0.53, so please wait for that release
  • I not hanging up, the time the "prefer"red methods need, is mostly unacceptable.
  • Strange! My last comment " Update to Search Problems" has disappeared - posted before Oldie's comment .

    Was just giving some additional information that the only search engine that works on mine is the "Mapfactor classic searching" - quick results while typing the search but is not as sleek as the other 2.

    "Prefer Google" and "Prefer Mapfactor" hang up after the first letter almost all the time. I guess it times out and hence the "Not responding..." message.
  • MapFactor... YOU ROCK !!!!

    I've been trying so many navigation apps both on IOS and Android but no one succeeded in fitting my needs until I tried your Android Navigator.

    My needs may be somewhat special but at least you fit them:
    • Caravan towing so I needed an app that would not send me through small impossible routes to avoid a congestion. You allow this with your Tomtom maps for trucks.
    • Use vehicle sound system over bluetooth (Bluetooth SCO).
    • Lane assist being not the "animation joke" used for years by Sygic.
    I installed the app yesterday and keep testing it a bit then will buy the options (mainly to support you) and pay for the Tomtom Truck maps.

    My next comment will give you my preliminary feedback.
  • Here is a first feedback that I hope will help you make your product even better.

    Phone: Samsung Galaxy S8
    Android : 8.0.0
    MFN: 4.0.51
    Rendering Engine : Automatic

    Those are sorted from the most important to the less important (to my perspective):

    A) You are the only app I found on Android that implemented the Bluetooth SCO communication "use vehicle sound system over bluetooth". This is FANTASTIC !!!
    Unfortunately, it does not really work in my case (Citroën C3 Picasso (and I'll test tomorrow on a VW Touran)).
    I'm sure that you could simply "prefix" a blank wav to the announcement wav when "use vehicle sound system over bluetooth" is selected. The blank wav length should be configurable in second tenths as it highly depends on the vehicle brand. My Touran bluetooth system wakes up much faster than the Citroën one.

    What happens is the following: When an announcement is played out:
    1. my car audio (eg: radio) mutes => OK
    2. I hear no annoncement => :-(
    3. my car display displays : "Call ended : 00:00:02"
    B) The road highlighting (purple in the default colors):
    1. Is disappearing behind the arrow (current position) as we go along the road.
      This is not nice as this is a bit jumpy and also, if I zoom out, it is sometimes interesting to know what road we drove so far (maybe in another color).
    2. Is too large/wide. I think a narrow line is enough to show the way (like Tomtom GO does) and in complex crossing, it is showing more clearly which road to take.
    C) In 3D mode, the POI icon is way too small, even on my rather big screen.

    D) In 2D mode (yeah... I still like it)
    1. The animation is not fluid (it saccades).
    2. There is no autozoom.
    E) Sliders are not practical to set the speeds in the road restrictions (vehicle profiles).
    Indeed it is quite challenging to set a specific value (eg: 90) with a big thumb on a small slider ;-). I would suggest one of the following:
    1. Allow only increments by 5 (eg: 85 ... 90 ... 95).
    2. Replace the slider by a numerical text input.

  • I tried the "use vehicle sound system over bluetooth" in my Touran this morning and it works much better than in the Citroën. 
    I still miss the beginning of the announcement.
    If you allow the user to configure a "bluetooth wake-up delay (in second)", I would set it to 2s in my Citroën and 0.5s in my VW. I'm sure that would do the trick.

    This is a major differentiator with other navigation software.
    I found none using SCO on Android and know Waze on iOS.

    I can beta test any change you make to address this issue.
  • Hi @zorglups,

    to points B,C,D I say only that HW renderer needs a revision but there is not enough time for it (other things have higher priority). Point E I skip (that's for me a minor issue). In the app are other major issues which needs to be solved.

    With BT SCO - there is a good reason to that no other app has it. In Android documention stays that opening SCO channel takes max. 5 seconds., in praxis it can be even more. There is in our navigation engine an estimation how long it will take to the voice message. This is unprecious especially when there is a traffic light.

    After I found out that it works so bad I requested to remove this function from the app but noone was with me in this.

    Theoretically we can make the estimation time for SCO configurable, it depends on @tomas. I think it will never work for everyone correctly.
  • I have the same problem (mapfactor sound via Bluetooth-cropping the first part). Yes, please make a configurable delay.

  • Back to Search problems

    Installed the latest version 4.0.53 as suggested

    Same problem with Prefer Google and Mapfactor. It freezes on the first letter. Then the  "Not responding..." message appears, hit "wait" ( sometimes the Not Responding message will come a couple of more times)  and after a little while it will accept the rest of letters and perform the search.

    Only "Mapfactor classic searching" works as expected- quick results while typing the search but is not as sleek as the other 2.

    I know my device is very slow but this should not happen - it was working fine before ( dont know on what version)

    Quick update - it works ok via voice  - using the microphone ! !
  • try to reset to default in settings/advanced
    please select Backup and delete

  • @tomas - I haven't any backup and delete options. Only Backup, Restore and Reset.
    Please expand :-)

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion