Test of version 7.2.x for Android
  • 165 Comments sorted by
  • In routing points xml?
  • 7.2.60:
    @2highlander: Your routing points contain 2 routes with invalid folder ID by a mistake causing the crash. We have made a fix to force all routes with unknown folder ID to be listed in the root folder. Thank you for your patience in testing
  • Oh Boyz, thx a lot for Your efforts!

    Tomas' index hint helped me to find 2 passages #IN -1 in routing_points.xml. Unfortunately this file is not formatted similar to favorites.xml but at first glimpse a confusing 2-liner. At least I managed to delete the appropriate passages within the SET tags belonging to with a xml tree viewer. Seems to run all fine now on my S9+, even reordering seems to work correctly now. Bugs seem to be simply blast to Nirwana now :))

    On my S5, I will install 7.2.60 now and try the unmodified routing_points.xml with those invalid indexed routes included and will report.

    What will stay is the question what caused the invalid #IN -1 indexes and why appropriate routing_points.xml still do their job prior to 7.2.54?
  • Installed 7.2.60 on my S5 with routing_points.xml still containing the 2 invalid indexes. As You wrote, the appropriate routes appear in the root folder and as on my S9+, it seems all bugs seem have been blown away.

    Will now try to load an invalid indexed route residing in the root folder, save it with another name, push it into a folder and look if it will be indexed correctly.

    Boyz, You saved my day so far, thumbs up!
  • Experiment finished. Saved both invalid indexed routes with another name, pushed them into another folder and kicked the wrong ones. Restarted MFN and the renamed routes stayed in their folder where they were pushed in. I'm assuming their index is ok now, otherwise I would have discovered them in root again. Right?

    On both phones I tested today, reordering is also working now as intended. Root items and groups aren't messed up any more.

    BTW, the invalid indexed entries are veeeery old, I'm quite astonished about the fact that related errors are becoming apparent just now.
  • Copied the now correct indexed routing points file to the S4 today and additionally updated it with 7.2.60. All bugs killed and all works as intended so far.

    Good and finally quick job Boyz, thx so much!
  • V7.2.60

    Back to moving routes into Groups.

    Moving a route into group it was ok in the old days. 
    Got very challenging in v7 ( see posts earlier) but now it has become impossible. 

    Is either my phone wants to make it difficult for me or maybe I have no idea what I am doing or Mapfactor wants this to be a challenge :-) 

    Instead of trying to describe the problem please watch the video and me let me know if its a bug or only happening to me. 

  • Hi Stavrich,
    Select on the left and right click on the folder
  • Hooray!! ????
    This is great! A good solution in moving routes but could not see how to do it.
    As mapfactor gets more complex we need to have help boxes popping up - I tried different combinations but never thought of that.
    Thanks @MacDony
  • Stavrich, Your video made my day. If You want users to go nuts then provide Your clip as much as possible =))
  • Version 7.3.7
    - new POI categories
    - new map mode - gestures in map while navigating/simulating allowed (movement in one perspective only)
    - bug fixes and improvements related to Android Auto and My Routes
  • Version 7.3.7 - It works very good. Also the Backup and Restore problem is solved. It works now very fast and good. But now is a new problem. It crash while importing new maps (mca-files), but the import was nevertheless successful.
  • Version 7.3.7: I deleted all maps and imported the maps again and MFN crashed not. The Crash while map import seems to be not so important.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion