Test of version 7.2.x for Android
  • 117 Comments sorted by
  • "7.2.37
    - searching in My Routes fixed,
    - drag and drop in Favourites and My Routes fixed,
    - info dialog for GPS record in GPS recordings bug fixed"

    cant install it, because the restore works not. Please tell me when the restore problem will be fixed.
  • Hi,
    Favorites A-Z / Z-A = ok
    Routes A-Z / Z-A = bug

    Moving favorites isn't really functional as it also selects folders
    This function is not very easy to use, I proposed a much simpler one which would be functional.
     Why absolutely want Drag and drop?!
  • Because Your suggestion too simple ... :D
  • I guess my restore problem is because of my very long names for favorites and routing points and routes. So please tell me the maximal length. Do you use now a my sql database? Am i the only one with to long names?
  • Hi Maze,
    Your favorites are stored in the file favorites.xml which You can open and edit with for example notepad. The file can be found in the root of the mapfactor directory besides other XMLs for example vehicle and preferences XML

    Backuped files created by the internal backup option can be found in the backup directory of mapfactor. With the internal restoring option these files are simply copied back in MFs root directory. You can also do this manually by hand.

    So, as a workaround to backup or restore, take Your appropriate XMLs and copy them to the backup directory or any other one.and do the restore by copying the backupped files manually back to the mf root directory. Pay attention MF to be closed completely and maybe delete cache before restoring....
  • @2highlander Hello, i have Android 11, and all root directories are in Android 11 protected and encrypted. So i have no access to the root directories and the restore is the only way.
    In Mapfactor 7.1 works the restore and in 7.2 will MFN crashing. I do no update anymore until a dev say, that the restore will work again or tell me how long the routing point names can be. I guess they have since 7.2 a maximal length, because i use names with the whole address and phone numbers..... Maybe i will change my Routing point names sometime.......
  • Is MF running in internal memory or on optional SD card?
  • A as external formatted SD-Card was to slow for me and it is FAT32. FAT 32 is for me not possible because i use the kiwix offline wikipedia. And the card works faster when it formatted as internal memory.
    But i made a test with a external formatted sd-card, and after android take over the data it will be also encrypted. It was only working for 1 single import. And removing the sd-card for every import of data is no option for me. The access is not allowed anyway.
  • Hi all. I'm using MFN v.7.2.37 on a Samsung Galaxy 21FE & Android 12. I have HD traffic enabled & it works fine on the phone screen. Traffic information is displayed on the phone & routing avoids traffic problems. When I connect my phone to my car & use Andoid Auto on the car screen I no longer get HD traffic. There is no traffic information displayed on the car screen & routing appears to ignore any closed roads etc.
  • Maze,

    You may connect Your phone to a PC and then import Your data to MF residing on the card. Then You may copy it back to internal memory if necessary. On my phone MF is running on a SD card, no problems concerning speed...
  • @2highlander I was testing this all while the installation of my CUBOT KingKong 5 Pro. But now i have my config finished. I cant remove this SD-Card. A Backup and Restore of such a SD-Card is impossible and if the SD-Card removed from the Smartphone and it restarted, all data are lost because the SD-Card is encrypted and Android change the encryption key when the card removed. Some users save the Key and are able to restore data. But this is not easy. The next step for me is first learning how to use TWRP.

    My Places and Config Files are my files and should be stored in a free location for sync with the PC. But the most important thing is: Please tell me why the restore operation not works with long names.
  • Hi,
    can you put an example of a long name of a favorite
  • I created the names with Excel from my address list. They are really extremely stupid to long. I will trying to change all my favorites wit short names.

    Here is a Example:
    <item name="Deutschland  ,Limbach-Oberfrohna ,09212 ,Zum Lindenhof ,12 ,Wirtschaftshof Sachsenland    ,info@wirtschaftshof.com ,(03722) 50 48 24 , , ," lon="46015720" lat="183053200" />

    I can use short names and a external list with the full addresses in future. But so extremely stupid is this way not, because i need then no list with the addresses and can read the addresses and phone numbers from the navigator app.
  • I can backup and restore favourites with this long name
    tried both local and drive
  • @tomasThank you. Then is it an other unknown reason. I guess it have nothing to do with internal or external memory. I removed MFN several times and reinstalled it.
    When come 7.3? I guess i wait so long with the update. I have to start every single google play update with hand, otherwise will MFN also updated....
  • v 7.2.40 - management of "My Places"

    What is going on?

    The latest changes have made the management, that is, moving moving routes or favourites to different groups almost impossible. I spent half an hour to move a route to a different a group and still haven't manage to do it. 

    Was not fantastic before but it was useable. Please just put it back the way it was - there was no need to change anything.

  • 7.2.40, managing my places

    As soon as You grab an item and dragging it to a group beyond the top border of the screen dragging stops and a requester pops up to put it in the last group seen on the top of the screen. Impossible to drag an item to the very first group of the list if it is not shown on screen.

    Do You really test the app before publishing it? This is not a hidden, but a fundamental bug.

    Managing my routes seems to work well though.
  • it works fine for me and it has not been published - here you get pre-release versions
  • Nevertheless, even in prerelease fundamental bugs like this should not appear.

    In my places, please create a list with about 10 groups and one place in root. Then turn Your phone to landscape mode and try to drag the root item to the very top group of Your list. Works in my route but not in my places on both of my phones Galaxy S9+ running with Android and Galaxy S5 running with Lineage OS.

    Also, the selection of one or more items should automatically be canceled after drag and drop, nevertheless the operation was successful or not, much more comfortable.
  • as I wrote, I do not have this problem, neither in portrait, nor in landscape

  • @tomas What use you for a Smartphone for testing? Always you cant reproducing a issue. The Software should work on all Smartphones and Tablets. Use please also a Smartphone with a native Android System like the chinese for testing.
  • may be, but I cannot test on all smartphones, that is why ew pot pre-releases here
    may be you can tell us about your hardware, Android version...?

  • Galaxy s9+ Android 10
    Galaxy S5 latest Lineage OS 17
  • Sony xperia XZ2 - Android 10

    In previous MN versions, in Favourites a long tab on a favourite will give the option to change it's Group (this option was not available for the Routes and we discussed it in MF v 7.1- I have posted a video as well).

    In this latest 7.2 version the whole thing is screwed up completely and I am surprised that has not been picked up at all by your team. 

    Tomas -I would like to see some screenshots or a video from your smartphone to understand how is supposed to work. 

    I have 24+ groups in my Routes and is almost impossible to move a route to the top groups in the version.
  • if you don't believe me, here it is

    I do think it would be more productive if you produced video
  • Where to find 7.2.40?
    Download from #1 in this Thread gives me 7.2.39 ...



    Regards ...
  • 4.2.40, My routes:

    Normal and reverse sorting is buggy, groups and items in root are messed up, new order is not stored after having gone back to main screen or the app being closed

    Sorting in my favs is ok.
  • @2highlander, what meah 4.2.0?

    7.2.40 is on Google Play. But i dont test it.

    My System: Cubot KingKong 5 Pro with Android 11, Systemupdate from 20220705.
    If 7.3 Released i make a test again and if it not works, ill send my full backup with private addresses to your support email address which listed here: https://www.mapfactor.com/de/uber-uns/kontakte/
  • Sry, auto correction, 7.2.40 is the right one *grzgrmbl. Edited this in my last post ....
  • if you don't believe me, here it is
    https://drive.google.com/file/d/1bRiTT3KTu6pSU7DHs6VZYrDKSbR8CJeT/view?usp=share_link


    Tomas,

    Unfortunately, the list in Your video does not contain any group. As mentioned, create some groups so that they must be scrolled during drag and drop and then try to move one item sitting in the root of Your list to the very first or last group. As soon as You want to drag the item beyond the top or bottom border of the screen the operation stops with the requester popping up.
  • @Tomas - here is my recording.

    The objective is to move the last route to the first Group, about 20+ routes and 24 groups

    Started moving the route and suddenly it stops.
    Tried again and this time managed to move it up 5 groups and the request pops up.
    Tried a few more times with similar results.

    Now, whether my finger is moving too fast or too slow is besides the point; I should not have this problem. I do not experience this issue with other apps - I am able to slide items up and down easily.

    At the end I edited the routing_points files - should not have to do this. 

    I think it will be better to highlight the routes or favourites  and choose the Group to move it into. 



  • Video and alternative approach: Hits the point ....

    Stavrich, would You please also test sorting A-Z and vice versa in my routes?
  • I have more than 20 groups

  • As far as I can see in Your video You only have several single items marked by a GPS icon sitting in the root, but no groups. Groups are marked with a directory icon. The problem described only appears in combination with groups.

    BTW, You also may test sorting A-Z and vice versa in my routes....
  • video does not show everything and I have no intentions of supplying further evidence
    I can only tell you that I have 25 groups

  • I simply can't see You dragging items over or to a group. Stavrichs video clearly shows the problem which You can't ignore because it's not a minor bug.
  • The stavrich video exactly represents the issue but will try, give me one moment....
  • https://drive.google.com/file/d/1iuJ7FNAUyV_jarclpvIs1AqKtvVuP2xP/view?usp=drivesdk

    Hope the link works....

    The List of groups is much longer, but I cannot reach any group beyond the screen. As soon as I'm dragging the selected item out of the bottom border of the screen the operation stops with the requester popping up.
  • Hi 2highlander,
    The video is not public so we don't have access ;)
    Fixed :D
  • I watched very carefully Tomas' videos and I noticed the speed. 

    I tried it again this way. Moved the route all the way to the top edge of the screen, out of sight as Tomas did, and kept it there till the first group appeared - all very fast. 

    Good? No!

    If I wanted to move to a  group that was, say, in the "2nd page" trying to go down to that page was not easy - kept overshooting the target or the requester popping up.

    @Tomas - is obviously that there is a problem here. This action should be smooth and easy to perform and not be a dexterity challenge.

    @2highlander - A-Z, Z-A sorting works on mine.
  • https://drive.google.com/file/d/14VJGx8jzYsSEvBVhxWvY5B_fhj_XuzKz/view?usp=drivesdk

    Video showing the sorting bug in my routes.

    Groups are messed up with root items and last order is not stored when going back to main screen and entering my routes again ... ok, in this special case this makes sense *harhar

    Sorting in My places is ok
  • Sent content of cache to silicium nirwana, sorting bug stays....
  • Restored a veeery old backup of routing_points.xml, sorting bug stays....
  • Latest playstore version 7.2.42:

    Sorting in My Routes: bug
    Drag/drop item portrait mode: seems ok
    Drag/drop item landsape mode: bug


  • 7.2.42
    - Picture-in-picture mode activated. Press Home button while navigating.
    Due to inconsistent behaviour and UX we have decided to refactor reordering items in My Routes and Favorites. Stay tuned and be patient
  • That's a good idea, I have a slight idea concerning how You will manage reordering in future :D

    Pip mode works fine...
  • At least a hint, I got the latest two buggy versions from the official Google playstore, not from the well known mf apk download link. Maybe You want to correct this before embarrassing people.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion