Test of version 7.2.x for Android
  • 165 Comments sorted by
  • 7.2.43
    -possible PIP crash fix
  • 7.2.43
    Search in Favs and My Routes does not work at all. The earlier magnifier icon in the entry field is missing, using the appropriate button of the keyboard shows no result. Don't know if that also was the case in earlier versions.

    Boyz, You really have a lot of work!
  • I have no problem searching favourites
    there is no questionmark, just search box
  • Did not mean a questionmark, but a little magnifier glass at the end of the entry field, like adress or POI search on the main screen. I thought there was something like that in an earlier version but I'm not sure.

    But now, something weird has happened. First, search began to react on entering numbers only. I played around a little and now it's fully functional again. It now finds terms again which were not found before. And no, there are no gremlins on my S9+/Android 10, because my S5/Lineage OS17 is showing exactly the same symptoms. Actually, search function is also dysfunctional there, must continuing testing. I won't bugger You with things that I'm not sure of before having tested them on my second phone.

    The only common thing on both phones is that MF sometimes is not closed for several days but only sent to background. Especially on my s5 You then will notice that the reaction of the whole system is remarkably slowing down. May this be a reason, a kind of stack overflow ..?
  • HaHa, think I found some MFN gremlins, the same on both of my phones.

    First notice that I'm always using both phones in landscape mode, espacially for typing.

    Let's begin with searching a route. When tapping in the search field to start the keyboard pops up. So far, so good, but this is where the fun begins: the entry field of search routes jumps to search FAVORITES and search will end with no match.

    Now, what always disturbed me is the fact that my keyboard is so big with standard settings that it is overlapping the area where the icons for favorites, routes and gps recording are sitting.

    As a consequence I shrinked the keyboard to prevent it from overlapping with the icon area and voila, search is working as usual. This behaviour is 100% reproduceable, I could take it on video.
  • On my device searching in favourites and routes works fine (MFN 7.2.43, Xiaomi Mi A1, LineageOS 19.1).
  • Next thing about searching routes and favorites.

    In Germany, the first letter of a substantive is written in capital. Thus, a search with a term typed in the searchfield with german orthography will end in no result.

    Search for a route named Tomas. If You type it as "Tomas" no result will be found, wheras "tomas" will present You a match.

    Ok, in practice, typing only small letters is a very convenient and comfortable way to enter something, but You have to know it ...
  • Hi JambaFee,

    Use landscape mode and enhance the size of Your keyboard so that its top border overlaps with the area where the icons for favs, routes and gps recording are sitting. You will have fun .... I will try to make a video meanwhile.
  • I can confirm the behaviour when entering search text with capital letter: It doesn't work. The same happens when searching for entries with special characters like äöüÄÖÜ (but "ß" works).

    Example - existing tour with the words "Große Mühl":
    entering "mühl" ==> no match
    entering "muhl" ==> ok
    entering "Muhl" == no match
    entering "große" ==> ok

    Regarding the problem with enhanced keyboard size: I can't get my keyboards big enough to verify it.
  • 7.2.52
    - new Organise mode. Activation in My Places toolbar menu. Tell us your experience
    - searching bug fixed
  • Searching with capital letters and special characters works for me now.
  • S9+ / Android 10 / MFN 7.2.52

    Organize mode / Favorites:
    Works ok

    Organize mode / My Routes:
    Organizing works in principle, but the new order is not stored. A-Z and vice versa order still the old bug - root items and groups are screwed up as seen on my linked videos above. Choosing all items in root or in a group using the little box does not work at all and will mark nothing. My guess is that those bugs are related.

    Organize mode in general:
    In the top line there is a little box on the very right side to mark all items or none. If no item is chosen the box must stay empty in my opinion, actually it will stay marked even if nothing is chosen.

    Will also test on my s5, I would expect exactly the same bugs there. Testing on 2 phones with completely different OSes is quite illuminating because it shows that a certain bug is not an issue of one specific phone. S9+ is running with Android 10, S5 with latest Lineage OS 17. So, if both phones will show the same bug the assumption is close to suspect a bug in the app's code and not on specific settings of the phone.
  • Did the above tests on my S5 now. As I expected, exactly the same behaviour. On both phones, all bugs diagnosed appear in the My Routes section. My Favorites section is working perfect excepted the little organizing bug choosing all items with the checkbox. But this is one I can live with.
  • Found one more bug in my places search with the character letters ö, ü etc.. For example type only an 'ö' in the search line. It will also find items with an 'o'. Search with all the other character letters behave the same.
  • JambaFee,

    On my S5 I'm using Gboard for typing, think in landscape mode You may expand it's size far enough for reproducing the error with the upper keyboard border touching the icon area. Remember, search in My Routes will then jump to search in Favorites. I'm actually testing other keyboards to exclude this bug being a special issue of Gboard
  • Tested the keyboard bug in search of my Places with Microsoft SwiftKey now. Same bug as with Gboard. Conclusion: bug seems not to be a specific issue of several keyboards but a bug in the code of MFN.
  • Keyboard bug in My Routes search, see linked video:

    I tested with Microsoft SwiftKey which can in opposite to Gboard be expanded stepless and has the feature of showing and hiding a toolbox menu. In the video, I first switched to My Routes, starting typing lets the keyboard pop up with the toolbox menu hidden so that it does not touch the icon area of MFN. Watch what happens when the toolboxmenu is popping out by tapping the little up/down arrows on the keyboard's upper left side thus touching the icon area...
  • 7.2.54
    - Entering to Organise mode by a long click
    - bug fixing related to Favorites and My routes screens
  • 7.2.54

    Not useable, potential crash when simply switching from favorites to My routes, potential crash when simply scrolling the list of favorites, potential crash after some time when in organize mode ... :(( :(( :((
  • what does it mean 'potential' crash
    please define 'some' time
    I have no crash when switching between routes and favourites

  • Potential = in 100% of all retries and reproduceable

    Some time = after a while when scrolling, I didn't succeed in scrolling up and down more than 5 times before the screen freezes.

    When tapping on mainscreen/my places You'll find Yourself in favorites, tapping on My Routes then inevitably leads to a crash, the favorites screen gets frozen, no reaction of the app any more and after a few seconds the OS 'close app or wait' dialogue pops up.
  • I cannot reproduce any of what you describe
    scrplling up/down 20-30 times, both in organise and normal mode, switching between favourites and routes, both by clicking on tabs and dragging screen left/right

    may be someone else can comment?
  • Scrolling with favourites and routes works fine for me.
  • Ok, I will clear data and cache before testing on the Lineage phone
  • Deleted data and cache, downloaded Germany only, Navigator and maps are running in internal memory to exclude faulty SD card, restored favs and routes. Restoring was accompanied by some crashes, but was at least successful.

    Bugs stay, I'm so tired! :((
  • Last try, will uninstall the whole thing, delete all hints pointing to MFN on my system and do a complete new install.

    JambaFee, did You really use 7.2.54 for testing scrolling?
  • Ok, fresh install with v 7.2.54, but I can't restore my data backupped before. MFN crashes when I tap the ok button in the hint box 'data restored'. Trying to import the backup with one item after the other had the same result. MFN crashes and will start with the whole fresh install dialogue next time.

    So, my personal solution now is to give up for some time and sadly ban MFN temporarily from my phone. Even as a beta tester, I don't see it as my job to deal with severe bugs of common functions. They should roughly do the job to guarantee a basic usability of the app and not fool the users.

    Sorry for my maybe harsh words, but the latest 2 versions were the worsest ever. Something seems to go completely wrong with quality control, just my 2 cents.
  • it is true that Navigator freezes when clicking OK after successful restore and we will fix it
    but files are restored, freezing has no effect on this
  • Hi,

    Just a (peace) word, I'm also using a S5 as my main GPS device, but I maintain it with stock Marshmallow to avoid any complications.

    My phone is a S7 under stock Oreo, my spare GPS with same configuration than the S5.

    Sometime I meet a crah with wifi on (no Sim on the S5). MFN on tthe S7, same conditions, never crash. So I consider it's hard for the developper to simulate all configurations.

    I remain satisfied as MFN runs anyway with the last versions.

    Comparing to Osmand, I had to downgrade two generations to get normal use, four versions for my 2013 Tab 3 KitKat...

    On my Tab 3 MFN runs well with the v 6 still provided on the site.

    I'm aware that it's not a solution for you with the last version, but you could consider a downgrade to get normal behaaviour ?

  • @tomas "it is true that Navigator freezes when clicking OK after successful restore and we will fix itbut files are restored, freezing has no effect on this"

    It seems you never will fix some issues on Android 11. I guess i wait a year or 2 for an update and i will remove the forum from my daily watching list.....
  • @Maththias
    this freezing is a recent issue and I do not think it relates to Android 11
  • The recent home of bugs is a stock S9+ with Android 10, it's a typical every day phone where what app ever should roughly work.

    More likely I would expect bugs on my S5 with Lineage 17, but in this stage of MFN I don't dare testing on this one because I use it on my motorbike for navigating only without a SIM.

    I'm not a programmer but I would extremely like to dig in the code to find out what's going wrong in the app...
  • Did one more fresh install of 7.2.54, but now pushed app and maps to SD card to get full accss to the MFN directory. At least took my last S5 backup files and maps and copied them to the S9+ to ensure exactly the same configuration on both phones.

    Be it on SD or pushed back to internal memory, the bugs on the S9+ described above stay... :((
  • Hi,

    how many items do you have in favorites and routes? May be too many?
    Today I was reminded to your problem by a customers mail client - reliably crashed when trying to reorder in inbox. Too many mails - more than 33.000 directly in inbox and a lot more in subfolders ...
    Ok, you will not have that much favs or routes - but a much smaller device ;-)

    Regards ...
  • There are surely not too much items, favs and routes did their job on formerly versions on both S9+ and S5 without any problem, they were not changed since then. S9+, home of bugs, has 64Gb internal memory and a 64 Gb SD card, each of them has about 30 GB of free memory. RAM is 6 Gb of which 3 Gb are used. Size of Favorites.xml is 31,3 k, routing_points.xml is 198,4 k. These files also run on the smaller S5 with an older version of MFN.

    The issues definitely began with changing the organize mode and made the app completely unuseable with Version 7.2.54. I'm pretty sure installing this version on my S5 will make it run into the same problems.
  • S9+/Android 10:

    Kicked 7.2.54 and reinstalled 7.2.52. Same fav and routing files, scrolling and switching between favs and routes runs fine again.

    It's definitely not my phone but MFN 7.2.54!
  • 7.2.59
    - bug fixing related to My Places, refactoring 
  • 7.2.59

    Switch from My Places to My Routes or GPS Recording:
    Immediate Crash - Screen freezes

    Scrolling in My Places:
    Better now, You can scroll up and down longer but it will freeze definitely after some time

    At least I had a glimpse into the logfile and found the following error:
    ERR 22/12/09 21:54:57 (JAVA) Failed to get key: java.lang.String cannot be cast to org.json.JSONObject

    As a consequence I looked to the appropriate settings in MFN. When tapping settings/About Navigator You will notice that the check for a new key is failing with the hint "Error checking for a new key".

    So, how do I get a new key and may the described issues be related to the missing key?
  • Ok, MFN 7.2.59 clean install from scratch, result: bugs reside on my stock S9+/Android 10.

    To be 100% sure of what I'm reporting a 2nd test on my S5/Lineage17. I had Version 7.2.52 running on this phone, scrolling and switching was fine. I now installed 7.2.59 just over it.

    What I expected, exactly the same issues as on my S9+: switching from favs to routes or gps recording immediately freezes the screen, the same after scrolling a while in favs, public key check fails.

    Btw., I don't think the problems are not related to a missing key. 7.2.52 is also failing in key search and has no issues with scrolling and switching in My Places.

    Boys, You're really testing my patience ...
  • Stock Galaxy S4, install 7.2.59 over 7.2.40, exactly the same bugs as on S9+ and S5.

    I'm going nuts...eventually these issues are a very specific problem of Samsung devices?
  • do you have the same favourites and routing points on all three devices?
    if so, one or both may be corrupted?
  • No, favs, routes and gps rcordings are slightly different and concerning switching and scrolling they all run well on 7.2.52 and earlier. When examining those files with an editor I can find nothing noticeable. I can send You the mentioned files of all devices for looking at them, but I would assume that corrupted files will create an error hint in the logfiles.

    The very strange thing is that all 3 Samsungs exactly are showing the same strange and 100% reproduceable behaviour with MFN, be it 7.2.54 or 7.2.59, be it a clean install or an update. This is a big nut to crack me thinks ...
  • it is a mystery, none of can make it freeze and no other user has reported problem yet
    if you want to email there two files, I will try
  • Email adress?

    Short idea:
    May the discribed issues be related to the change in fav and route search concerning character letters ä,ü etc.?
  • support (at) mapfactor.com

    can you please make video to show what you do prior to crash ?
  • I do nothing special. After tapping on My Places on the main screen you'll usually see Your favorites. If then tapping the My Routes icon the screen immediately freezes.

    Will make a video but have to install 7.2.59 before
  • I tried your files and it froze in a few seconds after screlling up and down favourites
    I did not even switch to routes, or click on anything

    I will keep testing and let you know
  • Did You have a glimpse to the files with an editor? I found nothing special there and, as said, favs and routes on my three Samsungs are different. And on all three devices they run without problems under version 7.2.52 concerning switching and scrolling and stuck with 7.2.54 and above.

    But anyway, thx for testing and verifying Tomas!
  • there are two routes with index -1. that means they do not belong anywhere

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion