Test of version 7.2.x for Android
  • -searching favorites across folders in both app and Android Auto
    -searching countries in map download manager
    -downloading maps enabled in Android Auto
    bug fixes

    Available via download link 
  • 165 Comments sorted by
  • Please remove the seconds from the current time in the dashboard, they are unnecessary and would allow for a larger display of the time.
  • No change :
    The phone in Portrait mode -> launch Navigation -> turn the phone in Landscape mode -> ... bug ... -> turn the phone in Portrait mode -> ... bug ...
  • -searching favorites across folders in both app => Ok, Thx
  • please,
    is it possible to change the tilt angle of the map in landscape 3D navigation mode?
    same 3D vue portrait mode in landscape mode
  • Where did you move the map files?
  • why do you want to remove seconds when 'secondless' time is already in notification bar
  • @Tomas
    The "no seconds" time in the notification bar is not visible on a motorcycle, we are about 70 cm from the screen when we are driving.
    Having the time without the seconds on the dashboard allows us to know the time and with the seconds, the format is too small.
    Without the seconds, the format is larger.
  • Meanwhile I found the new location of the map files (*.mca) and almost ALL THE OTHER FILES that were stored up until now in "Android/data/com.mapfactor.navigator/files". This includes among others the folders backup, data, log, nmea, odometer etc. The new location is "System/data/data/com.mapfactor.navigator/files/navigator/data".

    This seems a very bad idea to me because without root you have no manual access at all to these folders and even with a rooted device you have no more chance to synchronise data from Android to PC.
  • I agree, bad idea, but not ours, please email Google
  • @tomas:
    *) Since version Android 11 Google has restricted the acces to "Android/data" and below, that's where until now the navigator files were located (Android/data/com.mapfactor.navigator/).

    *) Access to Android's system folders, e.g "System/data/data/com.mapfactor.navigator/files/navigator/data", has always been restricted, so that's nothing new.

    Moving navigator's user files like map files, routes, logs, nmea etc. to another location makes sense, but moving them to a location that always has been restricted is no good idea and neither Google nor anyone else forces an application to use this location (or do you know any camera app that stores photos where noone can access them?).

    To synchronize my navigator files with PC I am using MyPhoneExplorer, which has acces to "Android/data", so I have no problem in my workflow with the status quo.

    For those who want to access these files directly without root or via USB connection on PC it would make sense to place them in a normal folder in the file structure (like camera apps do e.g. in DCIM) or, if you don't want to show them on first level, use a folder below "Android/media/" as WhatsApp does, for navigator this would mean "Android/media/com.mapfactor.navigator/".
    Edit: ...or make SD cards usable.
  • For those who still see the mentioned files in "Android/data/com.mapfactor.navigator/": Go to "settings - Map manager" and you will immediately see a dialog showing that files are beeing moved without beeing asked if you want that or not.

    Warning: Only do this if you never want to access these files manually because it will only work with rooted devices!
  • I have always used my SD card for map storage and that had worked until I made the mistake of updating to the newest version. 7.1.46. Now nothing works at all because the old location is now unaccessible. (unexpected error at start)
    As I don't have enough free space in memory I'm forced to use the SD card.
    So as I understand there is currently no way to install or move the maps to an SD card.
    Navigator unfortunately is now useless for me.
    Waiting for a reasonable solution. And not these crazy Google restrictions.

    In 7.1.37 on 220211 still ok
    DMP 22/02/11 14:28:25 (JAVA) Base data extractor: extracting file '/storage/D03C-BE89/Android/data/com.mapfactor.navigator/files/navigator/atlas.idc' started

    In 7.1.46 on 220429
    ERR 22/04/29 20:59:39 (JAVA) Base data extractor: destination not writable!!!

    BTW I also had to move my ORUXMAPS data to Android/media on the SD card. But there the location is configurable.

    Config: Samsung S4 Android 11 Lineage version of 220428 Storage 16 GB SDcard 32 GB

    FYI on my XIAOMI Redmi Note 4 Android 12 (lineage) the old SD card location works without problems with 7.1.46

  • Hi Uli, nothing has changed, SD card can be used.
    your SD may be faulty, or need mounting, difficult to say from your description
    please send logs to support
  • Hi Tomas, the card is certainly not faulty. I have 4 SD cards, 2 in my 2 Samsung S4 and 2 in my 2 XIAOMI Redmi note 4. All SD Cards have the same content and all work in the XIAOMI's. None work in my Samsung S4's any more. The S4 SD reader is also not faulty, at least Navigator was able to write the logfile in SD /Android/data..... In both S4's navigator stopped working with "unexpected error" at the same time. So it's either an Android (Lineage) feature, the S4 has Android 11, Xiaomi Andoid 12, both have navigator 7.1.46. Or the S4 lineage version has introduced a bug. Or navigator has a problem with Samsung S4.
    I will do some experiments with an older lineage version.
    I will certainly send you logs from February and April. Unfortunately navigator crashes with above error, so can't "send logs". Please provide me an email address.

    Thanks for your help
  • support (at) mapfactor.com
  • I have an old Galaxy S5 running with Lineage OS 17 without simcard and a S9+, think it's Android 10. On both devices You can move MF 7.2 from SD Card to internal memory and vice versa, in both locations MF is working fine.

    Also on both devices You only have access to MF directories and files when being installed on SD Card.
  • I think I have found the problem.
    I took my oldest backup from 20220325 and did a restore.
    Everything was running again, Navigator version 7.1.44.
    Updated to 7.1.46, still ok.
    Updated Lineageos to lineage-18.1-20220407-nightly-jfltexx-signed.zip, all still ok
    Updated Lineageos to lineage-18.1-20220414-nightly-jfltexx-signed.zip, then KABOOM, it seems to make navigator believe that the SD card is not writeable, although it can write at least the logfiles.
    The following lineageos updates 20220421 and 20220428 same problem.
    This is reproducible.

  • @Uli Are your SD-Cards FAT32? It seems your problem is caused by your SD-Cards and your OS.
  • Yes, all 4 SD cards I have tested are FAT32 on 2 S4 phones.
    And yes, like I have mentioned above it's a problem of lineageos, starting from the 20220414 update. Previous versions work correctly.
    So it's no navigator fault.
  • 7.2.16

    -importing and showing GPX on map containing non-ASCII characters in file name or path fix
    -device time and GPS time panels without seconds added
  • "importing and showing GPX on map containing non-ASCII characters in file name or path fix"
    I have watched the new version now, and didnt find how to import a gpx file. Can you showing only gpx files which self made by Navigator? Are Speed-Colors for Pedestrian or bicycle implemented?
  • to import gpx click a gpx file and select Navigator
  • "to import gpx click a gpx file and select Navigator" - this works not, OSMAnd starting and Navigator is not available.
  • My file manager is total commander. Choosing 'open with' will give You a list with all apps installed with MFN amongst them. Does MFN appear there?

    Second Option could be changing the standards in MFN app info
  • I have Andrpid 11 and Total Commander and in the Settings is no standard adjusted, but under "open with" and "send to" is MFN not listed. But not matter, without speed colors is it anyway useless for me.

    Maybe it is relevant, that the MFN was installed by a google drive backup and after the google drive restore i used a adb backup restore. Both backups worked only for some irrelevant apps..... this mean this backups are useless. adb backup - useless google drive backup - useless. [s]Maybe if the 64 bit android is mainstream are no backup restore from 32 bit to 64 bit possible?[/s] My device have already a 64bit OS.... Used the 64 bit checker.
  • V 7.2.16:
    *) OSM-tags "maxspeed:forward" und "maxspeed:backward" are still ignored, no speed limit is displayed at all in these cases.
    *) Still no warning when a waypoint lies on a blocked road, while PC version does warn. Details here: https://forum.mapfactor.com/discussion/comment/19986#Comment_19986
  • I create MCA-files with Digger, place them in the data folder and include them in speed and camera warnings. If the name of such a file contains letters like äöüß (e.g. zzSchärding) navigator crashes on start. The log file contains the message "can't open file '/mnt/sdcard/Android/data/com.mapfactor.navigator/files/navigator/data/zzSch'".

    It's not a big deal if you know that but maybe this behaviour could be changed.
  • Hi,
    When you delete all the waypoints, the tab indicates the directions does not empty.

  • V
    MFN v.7.2.16. Android 12. HD traffic symbols showing on phone screen when not connected to car. When connected to car HD traffic symbols are not showing on car screen.
  • Long journey today. MFN routed me to a closed road. Not shown in Android Auto but when I eventually arrived at my destination & checked the app on the phone the closed road is clearly shown. Why does this not work in Android Auto.
  • 7.2.21
    -remote commands via COM port
  • Another problem today with MFN trying to route me via a closed road. Which is the stable version for use with Android Auto? Due to problems with the HD Traffic pack when using MFN v.7.2.16 with Android Auto I can no longer rely on the beta version to avoid closed roads.
  • 7.2.23
    -screen turning off while navigating fix
  • Hi,
    Backup Vehicle Profiles.xml does not work every time.
    I noticed that the Vehicle_Profiles.xml file was not backed up in my latest backup.
    I went to the Profiles menu to see that my personal profiles were still there.
    Then I made a backup and the file was backed up again.

  • Hi,

    I've some problem with Navigator 7.2.x at start up with wifi on : it fails during checking purchases, I sent 2 rapports.

    If I quit the wifi, it launchs, then if I set the wifi on to check new maps it's ok.

    I cleaned the Navigator cache, it fails again with wifi on.

    My main GPS device is a Galaxy S5 Marshmallow stock, maps on external microSD.

    For information, same configuration on my spare GPS device, and main phone with Sim, Galaxy S7 Oreo, it runs.

    Thanks for your help.

  • Hi Tomas,
    Import Gpx does not work correctly.
    Files sent

  • Oopsss!!!
    Sorry, rookie mistake :D
    I forgot to download some maps.... :-$
  • Navigator Android crashes while import of routing_points.xml from PC-Navigator Free.
  • what exactly do you mean by import from PC
    do you use Restore?
  • I synchronized the files from PC with the backup-Folder, yes and then i restored it. This is the only way in Andrpid 11 because google want it so and mapfactor dont want finding a solution......
  • email your file, I will check
  • It happens also with backups which made with the Android Smartphone and also with the Favorites.xml. I guess my files are ok. This mean it have nothing to do with the files from PC. It crash anyway after restoring settings and routes and the restore works not.
  • I installed v. 7.1.45 and the restore works again. import of maps need to long time.
    Maybe the problemhave to do with my long routingpoint-names. I can email you my files, but i dont know the email address.
  • 7.2.33
    Improved item management in My Places - Favorites and Routes. Animated transitions with new select feature - multi-item drag&drop enabled, support for multi-level management - experimental
  • Favorites A-Z / Z-A = ok
    Routes A-Z / Z-A = bug

    Select a favorite and press the icon 3 pts = crash
    Swipe favorites list = selected favorites
  • I'll take a look at it
  • The Space between the My Places are to big.
    I want also sort by date.
    The restore of a backup works not. Navigator crash then without import of settings and my places. (Maybe is the reason because i have long names for my places with name and tel number and all address informations.?? But this was until 7.2 no problem.)
    Why works the import (restore) by somebody yet? I dont understand. Please tell me the enail-address for sending files.
    This is so strange, the backup works and the restore not.... Please look at this.I going back to 7.1 again.....
    Why is the restore not provided after a clean installation? Always i have to download useless a map. :(
  • Favs/My Routes:
    Selection behaves strange, in Favs a requester jumps up offering any group but not the one intended. The requested way selecting and moving via drag and drop should work obviously is in favs with reverse alphabetical order me thinks ...

    And btw, the veeeery old issue concerning switching from day to night mode and vice versa is still not solved! It's hard to understand why new buggy features are implemented before the app is working nearly perfect.
  • 7.2.37
    - searching in My Routes fixed,
    - drag and drop in Favourites and My Routes fixed,
    - info dialog for GPS record in GPS recordings bug fixed

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion