navigator stops navigating when screen is off and power plug is disconnected
  • Hi,

    I have a problem with the navigator.

    When I start to navigate und turn off the phone screen the app stops navigation when no power plug is connected.

    In the case a power plug is connected the app gives voice commands even with a switched off screen. When I switch the screen on again the app navigates with voice and visiual commands. Everything works perfect.

    When I disconnect the power plug everything works as long as I don't switch off the screen. If I do so there are no voice commands any more, the app stops recording gpx tracks and when I turn on the screen again the app shows the current position but doesn't navigate any more.

    The maps are stored on an external sd card. I use Map Factor Navigator 1.4.24 on a sony xperia z1 compact with android 4.4.4.
    I already tried to reinstall. But the problem still exists.

    I hope some one can help.
    Thanks in advance!
  • 21 Comments sorted by
  • may be Display always on is switched off?
  • Stay awake is only valid when charging. When I simulate a route and turn off the screen and then back on I have an error message 'Unfortunately navigator has stopped working'. I shall check it out tomorrow to see if I can repeat it while navigating. MF 1.4.24 android 4.4.4 Moto G 2nd gen. Maps (OSM) on external SD card
  • Update. Using Samsung Tab 2.7, android 4.2.2, MF 1.4.24, this doesn't happen. If i turn off the display and back on the simulation is still running. Maps (OSM) on external SD card.
  • Navigator stops when screen turned off during navigation. Tested this morning during navigation. This does not happen with other navigation software on my phone, (Oruxmaps) keeps tracking with screen turned off. This is essential for saving battery power. As I have said previously, this doesn't happen with my tablet, I have used it while cycling with the screen off and only the voice commands.
  • it does not happen to me on my Note 2
  • It does also not happen with my Xperia Active. Last weekend we used as pedestrians an unknown footpath in our neighbourhood. After we found the entry, I switched my screen off and put the phone into a pocket. From there we still got our voice commands until I finally closed Navigator.
  • Hi Oldie, what version of Android are you on? I can do that with my tablet on 4.2.2, but not my phone on 4.4.4. Everything else works with the screen off, including music.
  • Hi,

    I have some new information. This error only occurs when I switch the application language to german. As soon as I go back to english everything works correct. I have not tested any other languages.

    I will monitor this issue and give updates if I discover new information.

  • The latest, Sony offers for the Active ICS 4.0.4 :o
  • I tried it last night on an LG G3 with KitKat 4.4.2 and navigation (voice instructions) worked with the screen off. So no problem here.
  • After testing a while with english as system setting I found out that this was just a temporary fix. I had the same problems after a while.

    In my first post I descriped that the problem doesn't occurs while the power plug is connected. I discovered that navigation stops working even when the power plug is connected as soon as the battery is fully loaded.
  • After update to Android 5.0.1 and Navigator 1.5.20 this doesn't happen any more. I don't know which was the cure, lollipop or navigator. I suppose I should go back to previous version of Navigator to test, will in the next few days.
  • Hi Roldorf,

    where can I get the Navigator 1.5 version? I can only find version 1.4 on google play store.

    thx vizete
  • thanks, I will try this version
  • I tried version 1.5.22 today. But the problem still exists.
    I will try it with cyanogenMod these days and give feedback.
  • Its a problem with Android 4.4.4 all versions work fine now I am on Android 5.0.2
  • I'm using CyanogenMod 11 now. But the problem still exists.
  • Do you have the energy-saving-mode activated?

    I had that too, when it was activated. After inactivating, it worked (at least for me).
  • Hi Vizete

    You describe the symptoms I'm having.
    Vodafone 985N, Android 4.4.2; MFN 1.5.22.

    I prefer screen off for cycling (battery saver). Incidentially, my old Samsung S1 with older MFN works perfectly.

    Have you found a solution yet?


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion