MapFactor Navigator WinCE 4.2
  • Hello,

    I have a ViaMichelin X930 (WinCE 4.2), I am replacing it with MapFactor Navigator.

    I installed the software and maps of MapFactor on SD.
    When starting the GPS, white screen with ViaMichelin logo.

    Thank you in advance for your help to make it work on my ViaMichelin MapFactor.
  • 13 Comments sorted by
  • Hello,

    You probably need DLLs that are missing because the manufacters of PNAs are using not a full WinCE OS.
    This: "There are some missing Dlls on the Viamichelin that you need to install too. Here is the list:
    coredll.dll, ole32.dll, oleaut32.dll, shlwapi.dll, wininet.dll, ws2.dll, zlib.dl" was written by a other member here.
    You could also use "MioPocket" to unlock Your GPS or simply use the missing DLLs that come with it.

  • if you get Via Michelin logo, then you are not starting Navigator - you need to change path
  • Connect Your 'tablet' with PC (via USB) and tell me sth more about all *.exe files from main directories (internal and external memory of this navigation).
  • Try to rename navigator.exe to the *.exe-name of the old program (ViaMichelin.exe or something like that).
    I managed it with a Targa-Device and original installed Sygic-program.

    It is possible, that you device is hardcoded to that specific navigation-program, so renaming MapFactors exe could help.
  • Hello, 

    Thank you for your answers.

    I found two different tutorials for MapFactor, one says to copy the software and maps in InstallSD folder and copy each other where we want, which is telling the truth? 

    When I only InstallSD a folder (containing MapFactor), I get this: 

    I downloaded MioPocket followed a tutorial which indicated that he had put in a InstallSD MioPocket folder. (I renamed the InstallSD folder (containing MapFactor) in MapFactor I always get this:. 

    I downloaded the DLL, I have put in the InstallSD folder (containing MioPocket). 

    I renamed Navigator.exe in ViaMichelin.exe, I always get 

    Should we put everything in the same InstallSD file?
  • Rename folder 'Navigator' to InstallSD and file in this folder navigator.exe to InstallSD.exe.


    Copy all files and folders from external memory (SD card)\Navigator to internal memory, without any folder. The same with *.dll (all needed dll to main folder).
    Rename 'Navigator.exe' to 'ViaMichelin.exe' (???)

    or try find 'How to unlock ViaMichelin X930'.

  • Hello,

    Thank you for your answers.

    I emptied SD (before doing backup) and put for now only MioPocket.

    MioPocket did not work the first time, now it works.

    It offers me the GPS software.

    Clicking some, it tells me that he is not "\ Storage Card \ name of GPS software (not installed as standard)

    In the folder \ Storage Card \ ago:

    Application Data (empty folder)
    InstallSD (contains 3 files MioPocket)
    Media (4 contains empty folders: Books, Music, Pictures, Video)
    MioAutoRun (MioPocket file)
    My Documents (empty folder)

    In MioAutoRun folder, there is a Programs folder.

    I tried to MapFactor in the Programs folder, software not detected, then replace the files in the folder InstallSD by those MapFactor software detected.

    In MioPocket, there is an Explorer, I look exe MapFactor when I clicked, an error message indicating that the exe is not a valid Windows CE application.

    Where do I put MapFactor in the Programs folder or in the folder InstallSD or elsewhere?

    "not a valid Windows CE application" is that the version of Navigator that is not compatible with the Windows CE GPS? I use the latest version of Navigator, Version 15. The GPS WINCE 4.2

    Thank you in advance for your help.
  • 'Navigator15 - Setup Utility' --->>> Install... --->>> Install Pocket Navigator --->>> WindowsCE ????
  • Hello,

    'Navigator15 - Setup Utility' --- --- >>> >>> Install Install Pocket ... Navigator --- >>> WindowsCE

    That's what I'm doing.

    One idea on the error message is not a valid Windows CE application?
  • As far as I remember miopocket works much more better on internal memory.
    Is it possible install and run miopocket without sdcard?

    The same is with Navigator.
  • Hello,

    After several searches, it seems impossible to install anything on a ViaMichelin internally, one can only SD.
    Someone who has a ViaMichelin X950, attempted with an older version of MapFactor without success.

    Too bad, thank you anyway for your help.
  • Access to internal memory on ViaMichelin is possible with special driver (not only standard ActiveSync) - that is all what I know about it.
    Look at Youtube.
  • Hi all,
    With inazuma69 we managed to run 'Navigator Free' on ViaMichelin X-970T (Windows CE 5.0 Core).
    Missing dlls where extracted from a MioPocket archive. Perhaps it can help, see Use Navigator Free on a Viamichelin X-970T GPS

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion