Test of Android version 3.1.x
  • 185 Comments sorted by
  • Some filemanagers opens file with file intent then navigator knows name of gpx file. If filemanager uses context intent then Navigator has inputstream of file but it does not know whats the name of gpx file. Normally it shows something in 1234 format but false is quite unexpected.
  • I had correct name after import
  • For me, the name is "false"
  • Today observation. Kraków was totally jammed this morning. I've observed that not every traffic jam was displayed on the map. There was couple of jams which were indicated in hd-traffic list with proper description (avg speed, delay) but there was no indication on the map. Show on the map option pointed to proper place but traffic indication was not displayed. Observation was made with software rendering. Reloading to hardware rendering showed properly these jams - but of course that was after reloading MFN.
    Second observation - with software rendering zooming out cause road numbers to be displayed on the roads (that's nice) but with hardware rendering there is no road numbers displayed in any zoom.
    LG K10, Android 6
  • One more observation. It is not a bug but rather some feature request. With previous and current beta version, when there is plenty of traffic jams (which is lately normal in Kraków) I know exactly when new HD Traffic info is coming, because (probably due to huge amount of data) navigation freezes for couple of seconds during refreshing HD Traffic data (I've got rather low end phone - LG K10). Route is not always recalculated after that (recalculation "by hand" gives different trip which avoids new jams). I have observed, that this behaviour exists when new delay caused by new jam is no longer than couple of minutes. For enough long new delays, route is properly recalculated. I don't know exactly how big should be this new delay to force MFN to recalculate the trip and probably for longer trips it is OK. But during traveling in town, when whole trip lasts normally no longer than 20 min, couple minutes longer can be 20-30 % of whole trip. So it would be nice to have an option "Avoid any new traffic jams if possible" which force MFN to recalculate the trip after any new HD Traffic info concerning current trip is downloaded.
  • @MacDony which file manager are you using for gpx import
  • @lubos,

    Gmail and import with navigator

    file name : HOTELS-2018.gpx
            <name>Nouvelle liste de waypoints 1</name>
        <wpt lat="46.5386933" lon="2.427126">
            <name>Dimanche 5 - VESDUN</name>

    import file name in navigator "false"


    file name : Trajet_samedi_18_Aout_K.gpx
    <rtept lat="47.573047" lon="1.302883"><desc>continuez sur Rue de la Taille aux Moines</desc></rtept>
    import file name in navigator "Kurviger"
  • The download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 3.1.72+ available for testing. If you need older 3.0.125 it is available at http://download.mapfactor.com/mapfactor_navigator_stable.apk.

    Or you can simply use Google Play beta system for automatic updates of beta versions at https://play.google.com/apps/testing/com.mapfactor.navigator.
  • Hi,
    Suspend problem when downloading map updates
    Problème de mise en veille au téléchargement des mises à jours de cartes
  • "Edit colour scheme" hangs for me in Navigator 3.1.72 beta

  • Edit colour scheme does not work for me in 3.1.72
  • Galaxy S8+ same problem with edit color scheme
  • BlackBerry Z30 - 3.1.72 edit colour scheme not working either.
    In addition I lost my own colour scheme.
  • ok, scheme editor will be fixed in 3.1.73+ (hopefully coming this week).

    @stavrich - our team decided that when format of album.style changes then custom color schemes will be removed (because it is easier to implement it - I was against it)

    @MacDony - I have no news about issue of map updates (noone mention it on last meeting, sorry)

  • @lubos - Not very nice  :(  . It took me ages to get the right scheme that suited me ie right colours, sizes etc...

    I think it should be a warning to advise us of any impact to our own changes and instructions how to save them if possible.

    I saved the album.style before designing my scheme but unfortunately I saved the default file in case I messed it up - did not save the one with my changes :( 

    Please take this to the next team meeting.

    Many Thanks
  • @stavrich there is backup of your album.style in navigator folder
  • @MacDony - I updated GPX import, when gpx name is not accesible and there is name in metadata then then name from metadata will be used. Will be in 3.1.80+
  • My version of mapfactor navigator is now 3.1. 72 downloaded from the link in this topic.

    Google Play shows that I am a beta tester. I have automatic updates enabled. But I do not get any updates from google play.
    In Blackmart I can download version 3.1.75

    What is the best way to update to the latest beta version?
  • @mes for the latest beta is always the best way to use Google Play Beta testing program:
  • I think that my version of mapfactor was not linked to playstore.
    I leave the tester program to reïnstall mapfactor from playstore.
    Then I join the tester program again with the link supplied above (thanks, Lubos).
    I hope that it then will be ok again (perhaps I have to wait a day or so)

  • yes, there is some waiting time...
  • Just downloaded 3.1.80.

    It has been said before but here it goes again.

    It would be of benefit to all, developers and testers, a change log to be issued with every update.

    The change log must be specific to the update and issued with the update.

    It's no good to second guessing the reason of the update - it should be transparent to all beta testers.

    We are all trying to improve Mapfactor Navigator so let's work together.

  • After one day no updates for beta version in google play store.
    Yesterday I created a new virtual android 6 machine In Genymotion. I installed only Mapfactor and fakegps.  Then I joined the tester program.
    Now when I open  google play store and look for Mapfactor I see the following message: "You're now a beta tester for this app. Awesome!".  But I can only open Mapfactor, there are no update's present.

    Is there something else that I should do?? Should I wait longer?? Should I use a new fresh google account?? Does my virtual system block the tester facilities???
  • I agree with @stavrich.  Why have we stopped seeing change logs?   Very frustrating trying to determine if previous problems have been addressed or if new functionality has been added.
  • I also agree with @stavrich.
    A seperate webpage for the beta versions is preferrable in my opinion. Then you have all the beta versions in one place and you can keep the changelogs there.

    By the way: google play store still does not shows  updates. I  think that this has to do with my virtual environment an the gaps's version.
  • build 3.1.81
    beta warning removed
    passing exception description from C++ to Java

    build 3.1.80
    name of gpx fixed for gmail intent
    possibility to force eink configuration
    unnused strings commented to decrease the number of strings to translate in Crowdin
    untranslatable strings marked as such to decrease number of strings in Crowdin

    build 3.1.75
    configuration file version checking added
    gles - optimize for eink displays
    composer - always using default album fixed
    scheme editor revision

    build 3.1.72
    version code fixed
    textplacing possible int overflow followed by crash (sqrt from negative number) fix
    google drive sync added
    distance indicator more ugly (MP's request)
    selected files to backup/restore loosing check status fixed
    Google Drive authorization json file added
    sign in to google drive fix
    fixed release crash caused by textual data unknown by configuration
    ui fixes
    move to sdcard fixed
    HUD scoutview redrawing fixed
    using default new version map file when there exists non default map file with lower version
    album style merging disabled
    checking configuration file version added. If default configuration file is newer than user's, backup is created and new configuration is copied to user's folder
    hud dialog in night mode fixed
    reset to default google drive flow better
    google places search localised by app language
    buttonbar all icons same width
    navigate icon fixed
    buttonbar fix onclick reaction
    new main menu buttons icons
    new what's new
    routing point in restricted area warning

    build 3.1.65
    crash from GA fix
    catching strange NumberFormatException from GA
    Traffic situations batch data size decreased to avoid map freezing

  • build 3.1.64
    reset to default revert
    google places search language set to english
    reset to default safer
    reset to default fix logging
    google search - do not freeze on timeout
    google places search fixed (?)
    Revert "android:google search fix attempt"
    increased main menu padding for large screens
    google search fix attempt
    google place search encoding and reset fix
    menu layout revision
    database search czech translation of 'street' fix attempt no 2
    search string 'Street' check translation fix
    options menu crash patch
    padding around menu buttons commit revert
    no gradient color buttons
    map manager download page not centered in normal layout fix
    removing unnecessary defines
    rtgnav revision in progress
    TT data version 62
    google place search revision
    alternative route selection label fixed
    menu layout fixed

    build 3.1.47
    new stop icon
    double deleting in navigatorAPI fixed
    dim menu icons on click
    menu layout fixed(?)
    ugly icons revision
    mapping ottis situations on roads revision
    ugly icons used
    gpx import destination info added
    SW renderer pixel density fixed (?)
    show gpx info fixed
    gpx rte import support fixed
    gles highlighted icons scale fixed
    vehicle parameters names fixed
    BETA version warning
    Ukrainian TTS added

    build 3.1.42
    enable/disable poi types on map fix
    search - multiple callback fixed
    gles zoom hack better
    more hd traffic incidents list improvements
    gles icon scaling better
    delay added to list of traffic incidents
    map in menu issue fixed
    SW rendering scaling fixed
    gles font bold fix
    SW renderer - emulate 160dpi on all screens

    build 3.1.39
    GPS new API implementation revert

    build 3.1.38
    use old logic to detect if it is signal or not

    build 3.1.37
    gps signal tolerancy added

  • With changelogs it is internal problem - our internal changelog we cannot publish and it always take some work to write some official changelog. We agreed that anyone who publishes new beta will post changelog on forum (not everyone is doing it).

    @stavrich - About color schemes we agreed that there will be possibility to import .style file into navigator (it will be in the next beta)... there are backups in navigator folder so you will be able to put your scheme back (maybe icons will have default size, transparency - because of icons we changed the album.style format)

    @mes - I am sorry but we cannot help you with Google Play problem and we do not want to let users to use older versions. What you can do:
    1) use the device where is not a problem to download the actual version
    3) using this app export apk into another phone
    4) on another phone install the apk
    Note: this does not need rooted device
  • @lubos - many thanks, appreciated.
    I found the file and I used my text compare utility. I merged my changes to the new default album.style, quite a few lines. Whether it will work with no problems time will show :) .
  • @lubos - thank you for thinking about my problem. I use helium backup for transferring apps from phone to phone.
    Unfortunately, I do not have another phone to carry out your solution. I have only one phone on which I run a stable version of mapfactor and I run the test version is in a virtual environment on my pc.
  • Disabled roads are no longer coloured in on the map. I blocked a road and it used to be coloured in pink but that no longer happens.
  • for me it is pink, same as before
  • I've had another go and it is fine BUT it seems to take longer to show up so it could be impatience on my part.

  • @mes: Transfer the file via your wifi network using ES File Explorer or equivalent.
  • build 3.1.84
    buttons with same drawable should not share state (eg Record as GPX & Recoed as NMEA)
    do not use mapview with dummy screen size
    show on map from itinerary fix
    proper drawing of disabled buttons background and text
    icon on disabled buttons gray
    calling show manoeuvre for the first time after a route has been computed fix
    zoom on whole route with enlarged bounding rectangle
    build 3.1.83
    using newle added Favourite place as navigation destination does not work fixed
    build 3.1.82
    intent for importing album.style
    possible null pointer exeption while waiting for google search result fix

  • For me:
    Simulate navigation > Long press > Mute sounds
    locks up Navigator
  • build 3.1.83:

    backup to google drive works
    restoring from google drive:
    1. when I select the first item for restoring (map colour schemes) it seemes to work OK.
    2. when I select all items and select OK to restore mapfactor freezes.

    request for backup/restore:
    1 add a button to select or deselect all items
    2. perhaps remembering the choosen google account is an option.
    3. remove existing backup on google drive

    something must be wrong:
    I can not find a backup of mapfactor on google drive. Mapfactor shows a backup but google drive does not.

  • @john_percy - problem will be fixed in 3.1.85+

    @mes - Which version of Android do you have? Can you send us logs?

    GoogleDrive backup in Navigator is using Google Drive private space (just like GMail, Google+ and other), you cannot access it using Google Drive app.
  • @lubios: logs are send
    How can I access google drive private space??
    How can I delete older backups of mapfactor?
  • settings > manage apps

    it does not freeze for me, but it takes about 20s
  • In Google - settings - manage apps I can remove all hidden data (all backups). I would like to be able to remove all backups except the all one. It would be nice when I can do this in mapfactor.

    When I tried to restore the backup I waited more the 5 minutes. My phone warned me that it took a long time and asked me if i would end the program or wait longer. Perhaps the logs give an answer.
  • I narrowed the restoring problem down to the file: preferences.dmp
    When I try to restore all files except preferences.dmp it works fine.
    When I try to restore only preferences.dmp mapfactor freezes.
    This happens with a google backup/restore and with a local backup/ restore.

    I deleted the file preferences.dmp and started mapfactor again. Now  mapfactor creates a new preferences.dmp. But backup and restoring gives the same problem.

    So there must be a problem with the handling of the file preferences.dmp during the backup/restoring-proces
  • Version 3.1.85

    import Gpx ok, file in favorites/my trips
    favorite selection and no step in trip info
    with this file :
    but is ok with this file :

  • Test itn file with Route Importer, same problem. 
  • Solved, I was missing a Suisse card Map, sorry.  :-\"
  • @mes is happening the same when you use local backup? if yes can you provide us backup which causes crashing? (local backups are stored in navigator/backups)
  • yes, it happens with google backup and local backup.
    When I exclude preferences.dmp  from restoring it works. So I think the problem is related to the file preferences.smp
    backupfile is send by email from withing mapfactor
  • build 3.1.87 - release candidate
    reset to default - crash on restore fixed
    build 3.1.86
    enable Back in Rate&Exit dialog to cancel app exit
    crashing promo code dialog fix
    build 3.1.85
    do not crash soundplayer on shutdown
    muting sound fixed

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion