Test of Android version 3.1.x
  • 185 Comments sorted by
  • I can confirm GPS problem still there in v. 3.1.37.
  • @lubos - I am using a Moto G4+ and not custom ROM.  This is one of the cleanest out there so can't understand why this is happening.  It certainly doesn't happen on any other app just this one.  Shared a screenshot with @stepan but heard nothing from him.  Somewhat disappointed.
  • Version 3.1.37, GPS linking impossible
  • I can confirm that versions 1.36 and 1.37 are not suitable for navigation. 36 losses GPS, 37 all the time has a star symbol as after losing GPS signal, fortunately tracing current position, but still losing GPS.
    Android 6
    LG K10
  • OK, I tried to fix it (update 3.1.38+ is already rolling on the beta and download link is updated)

    @amlumsden I talked with @stepan and he did some attempt to fix it in the past but he did not fix it. Solution would be replace strings translated by system by string translated by us. It is strings like "yes", "no", "ok", "cancel"... I suggested it to him but we did not yet agree if we do it.
  • I've installed and checked v. 1.38. Situation is better, but still similar to v. 1.36. MFN looses GPS for the moment at every 18 sec.
    Android 6
    LG K10
  • and in previous versions it worked ok on your device?
  • I did revert of all GPS changes in 3.1.x and put build 3.1.39 on the beta.
  • Yes, there was no problem with versions prior to 1.36. I'll install stable and check
  • I've mist Your comment about v1.39. Then I'll try this one
  • V. 1.39 seems to work ok. At least around the house ;). I'll post confirmation after longer trip afternoon
  • @lubos - v3.1.39 seems to be ok. It worked on a short trip with no problem.
  • @lubos not sure why there is an issue with the labels and why you can't agree to fix it.  Surely I'm not the only one suffering from this as every other app on my phone works as expected without these hyroglyphics.  Any idea what is causing this?
  • I confirm that in v. 1.39 GPS works fine
  • @amlumsden We have in company about 20 devices and we cannot reproduce it on any of them. To fix it we need device where the problem is. Solution of replacing problematic strings source is quite bad because it would add untranslated texts in all languages.

    I found this issue here: https://stackoverflow.com/questions/42574641 and they are suggesting the bad solution only
  • I have 3.1.36 navigate all over Denmark and not had the problem with GPS signal. Device Motorola Moto G2 Android 6.0
  • I guess it is not on all devices. I'm on 3.1.37 and before that on 3.1.36 (obvious isn't it :) ).
    I had no problem on my joying head unit in my car, and not on my Moto 5G+ phone either.
    Just used that one this morning to track a short cycling trip.

    I did however have a weird mixture of a transparent menu over my map screen on my phone when I took it out of my back-pocket approximately half-ways. The menu was still overlayed over the map after I finished, but then it was simply stopping the track and closing Navigator. so everything still worked, but a "screwed up" screen.
  • Issue with map showing in menu should be fixed in next version
  • @lubos thanks for the link.  This is very strange as no other app causes the corrupt labels.  I would understand if it happened on all but it doesn't. I can live with it but still not convinced that the link actually explains what is happening and why only your app.  Just have to keep my fingers crossed that it will somehow be fixed in future.  Anyone else with a Moto G4+ out there experiencing the same?

    UPDATE:  Did a bit more research and it appears that others are having the same problem but with different apps and only on Android 7.0 update.  Strangely enough, it only appears to affect 1 app on each phone and this appears to be random.  Lenovo have not responded with a fix or reason for this.  Just unfortunate that it affects Navigator on my phone.  Ah well, I'll just have to live with it unless Lenovo fix it.  Sorry for bugging you about this, @lubos.
  • POI - v 3.1.39  BB Z30

    I noticed that choosing specific POIs instead of ALL are not saved but revert back to the default state of None.

    From default state of None choose only the Petrol Station  (1/22), leave the rest types to None. 
    Go back to maps and you will notice that no Petrol Stations are shown. 
    Go back to POI types and you'll see your choice has been reverted to None.
    If you choose ALL it works as expected.
  • @lubos - can you please let me have the link to v3.1.39.    Installed latest v 3.1.42 but did not save the previous apk and would like to compare a couple of things such as size of location pointer, screen resolution on software renderer and display of road names at different magnifications.

    BTW - seems the POI I reported previously has been fixed 
  • Navigation arrows remains in static after some time, different locations, programs works, have to exit program.

    MapFactor Navigator 3.1.42
    device: Galaxy Tab S3, SM-T820 9.7'', (gts3wifixx)
    Map renderer: Hardware (experimental)
    Navigation map mode:
    - 3D while simulating (speed x )
    Dover > Holyhead: Simulation hangs, have to exit program.

    2 files, 3.14 MB in total ・ Will be deleted on 1 September, 2017
    - Dover-Holyhead02.zip
    - Dover-Holyhead01.zip

    Download link: https://we.tl/ejJLbl3CzE
  • Like @Jan_Gruuthuse mentions: Navigation arrow and screen update suddenly stop, program hangs and need to be closed from task manager.
    I had this twice with 3.1.37 or 3.1.39.  
    First time on a 1½ hour drive with(!) navigation on my Motorola G5+ in a rental car last Friday 18 August. On the way back I had no issues.
    Second time on a 15-20 minute drive without (!) navigation, only the map display, last Saturday 19 August. This was on my Joying android radio head unit in my car.
    Since then no other crashes. That's why I didn't mention it. I simply assumed there was one  "faulty" beta version.
    Logs didn't mention anything. (And then I removed  "all those" logs from both my phone and head unit as I had collected quite a few and decided to clean up. sorry.)
    I'm not yet on the .42 version. 
  • I could normally switch between map views and could exit program normal. Just simulation did hang at a random point.

    I had another issue too. Auto Night modus switching, at this point program halts. I stopped using auto switch night modus. I can't reproduce this at will and have as such no logs of this event.

  • V3.1.42
    Software / Automatic renderer.
    TomTom maps

    Compared to previous version v3.1.37.  :-
    Screen resolution not as good.
    Using same magnification road names are not displayed 
    Navigation and location pointers are a bit too big

    Please see screenshots - V3.1.42  v  V3.1.37  ( @lubos - any chance for the v3.1.39 download link)

    image image


  • Version 3.1.42
    import GPX file (rte) not possible.

    <?xml version="1.0" encoding="UTF-8"?>
    version="1.0" creator="Kurviger.de version 0.10"
      <rtept lat="47.26048" lon="-0.34170">
        <name>01 Repère 1</name>
      <rtept lat="47.23057" lon="-0.42123">
        <name>02 Repère 2</name>
      <rtept lat="47.26079" lon="-0.48234">
        <name>03 Repère 3</name>
      <rtept lat="47.24312" lon="-0.56451">
        <name>04 Repère 4</name>
      <rtept lat="47.23843" lon="-0.64663">
        <name>05 Repère 5</name>
      <rtept lat="47.21059" lon="-0.98373">
        <name>06 Repère 6</name>
  • Navigator 3.1.42, Moto G 1st Gen, Android 7.1.2, system default language german, application language english.

    The earlier mentioned poi-Type error doesn't crash but is erreanous: Settings > Map customization > POI types ==> Only "Culture and Entertainment" and "Sport and Health" can be customized, tap on the rest returns to the main menu.

    A serious crash happens by choosing Search > POI > Nearest from <whatever> ==> Only "Culture and Entertainment" and "Sport and Health" work, the rest crashes the application. So for example I'm not able to search for a petrol station while navigating.

    After restart in both cases the main menu is in english but the settings menu is in german.

    It has been mentioned before that the zooming in is too less for some situations. I must agree to this, espacially in areas with lots of roads near to each other and complicated crossings it is very hard to navigate.
  • I finally found some time to write here some answers:

    @amlumsden - I have that Lenovo will fix it soon (I have also Lenovo and I can say they have really no support at all for my device)

    @Jan_Gruuthuse - There was big revision of vehicle profile code and I asked our internal testers to test it (they evidently ignored me because I found bug - "Width: 130km/h" :D ).

    Anyway in your log I found:

    That caused the problem, I did not find out what to do to save this value there. Can you delete your vehicle_profiles.xml and try find out how to set the invalid number? Thank you

    @MacDony - I hope I fixed the issue in the next version, wait for update 3.1.45+

    @JambaFee - It seems that your album.style did not update. Can you upload somewhere default_album.style and your album.style and put link here? Thank you

    @stavrich - I sent you private msg
  • Complete new install MapFactor Navigator 3.1.42
    With selected application language English (UK)
    - Settings menu stays in Dutch
    Shouldn't that be in English too?

    Road parameters: Imperial: slider is hard to select the wanted miles, steps to big, selecting 30.0 mph nearly impossible: 30.4 mph, 31.1 mph, 31.7 mph (still locked to metric??)

  • new vehicle_profiles.xml has car, truck, bus:  <speed_limit>4294967295</speed_limit>
  • ok, I checked code and it seems that this value is unused that value is stored using "speed_extra_urban" tag (in km/h).... so yes, it is locked to metric.

    Does the problem with simulation still occur?
  • Just started test run, took some time configuring everything.
  • MapFactor Navigator 3.1.42
    device: Galaxy Tab S3, SM-T820 9.7'', (gts3wifixx)
    Map renderer: Hardware (experimental)
    Navigation map mode:
    - 3D while simulating (speed x )
    device in portrait mode
    Dover > Holyhead: Run Completed
    Holyhead > Dover: Run Completed
  • seems OK now, with new vehicle_profiles.xm
  • "- Settings menu stays in Dutch
    Shouldn't that be in English too?"

    Something odd going on: Map language and Application language?
    Setting Map language to App language: makes the settings menu appear in English

    I can't put my finger on it? switching to English (UK) from English (US) in Application language and the settings menu is back in Dutch after exit / start program.

  • Starting mapmanagement closes MNF under 3.1.42 on Galaxy S7. Doesn't matter chosing early maps or not.
  • Settings: Map Management:
    - Data Source: OSM
    - Data Download: Direct download

    You do gave internet connection: Wifi or Modem
    android: 7.0 on SM-T820 wifi
  • Don't know why, now it works since I moved installation to mnt/*
  • @lubos: You are right, I use an old album.style which I changed for my needs years ago. After every update I copy the old version over the new one. I now integrated my modifications into the newest file-version and well, my POIs are working again. Thank you for the hint.
  • 3.1.42: There is an incorrect string used in the vehicle profiles.
    In the vehicle properties for average max speed, it uses the string width.
  • this has been already fixed in the next version
  • 3.1.44 : App stalls when trying to set vehicle settings for Bus or Truck.
    Priority slider for Road types has no effect on route calculation. (all MFN versions?)
  • I can't find whether it has been mentioned before.

    The navigation color that is displayed as overlay on the road, is often displayed as underlay. It is very clearly from node to node in the road.
    This is in hardware mode.
  • MapFactor Navigator ß 3.1.47
    device: Galaxy Tab S3, SM-T820 9.7'', (gts3wifixx)
    Map renderer: Hardware (experimental)
    Navigation map mode:
    - 3D while simulating (speed x )
    device in portrait mode
    Dover > Holyhead: Run Completed
    Holyhead > Dover: Run Completed

    Sometimes while simulations run, the itinerary gets l
    ost. Only occurring with the above two runs.
    You know it happened when the upcoming maneuver panel no longer shows distances.

    Could not test night mode autoswitch, manual switching between the day/night seems ok.

    New menu design: rather good ;)
  • hi,

    the export of gpx is always in wpt format not in rte format

    version 3.1.47

    Favorite => My Trips => select => share as GPX => choice GPX type => waypoint or route => Ok, file save

  • can you please share this gpx file?
  • routing points are probably too far from any road
    please check that relevant maps are downloaded
  • Ok, solved, but the name "false" ?

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion