Bugreport for Mapfactor Navigator Beta on Android
  • 88 Comments sorted by
  • may be I should have said that in Navigator/Search/Coordinates you can use decimal degrees
  • I tried to navigate from Sofia (Bulgaria) to Cork in Ireland. The app cannot find any route. The same, if I try to navigate from Sofia to London. It seems, that the problem is connected with the ferry transfer. Is that right?


    Otherwise a very very great app. I sold my Garmin because of this app

  • at this moment ferries have not been implemented, so you need to navigate to calais and then start again when you reach Dover
  • Ok, thanks for the fast answer
  • ad cybersonic, regarding sounds on Jelly Bean. AudioTrack on Android 4.1 no longer properly supports 8bit sounds (at least it looks/sounds like). There is update of all sounds to 16bit with better resolution, so please update/download new sounds and let me know if it helped.
    thank you
  • hi Martin

    it's works!!!

    many many thanks!

    =D PS:i mean only german sounds works.
  • "only German sounds works" ... do you mean you tested only German sounds, or other do not work? (I hope for the first ;)
  • yes i'm tested german.

    and recently:

    english  -ok

    french   -ok

    polish - dont work!
  • thanks! (fixed typo, now it should be OK)
  • I have installed Mapfactor Navigator on my HTC One S running ICS 4.0.3. At first, during the initial set up everything seemed to work fine. The user menu screen came up and I downloaded the map in my region. However after playing around with it for a while. I don't know what happened to the user menu screen. I tried many options to reach the user menu screen by pressing various on screen buttons and could not get to the user menu screen. I was able to get to the user menu screen only once when I restarted the application. Is the user menu mapped to the capacitive button for "recent app" key? If so I just have to wait for the next HCT One S update. I have read that the next HTC One S update will provide the user the ability to map menu functions to the 'recent app' key.
  • menu is accessible by hardware button Menu, or by a Menu icon which looks like four horizontal lines
  • When we talk about the problem for searching and suburbs maybe the best way is to allow search across any city  in the country. If you have more than one street with same name in different cities or suburbs than there should be options to chose which street you want. Now CITY is mandatory filed and this make biggest problem, you always must know in which city is your street 
     ( if you have suburbs this is almost impossible to know  because suburb is virtual city) .
  • Hi there!

    I cannot download any map using my smartphone with Android 4.0.3,
    neither using the app Navigator, nor Navigator Center... a message
    stating that it is impossible to download the list of all maps available

    could someone help me!? how can i fix this problem?

    Is it possible to install maps manually?!?! if yes, where can I download maps?!

    many thanks

  • you can uninstall Navigator, delete navigator folder and then start from scratch
    you can install PC version, download maps to your PC and then copy maps and other .mca files to the navigator/data/ folder on your device

  • Hi I am using latest Mapfactor version0.9.124. I found one and that is that Estimated time of arrival is not correct. It is always to fast. Is this a setting?
  • problem is that many streets in OSM have no speed information, and that is why ETA is not accurate
    you can go to www.openstreetmaps.org and start adding this attribute
  • Hi
    where can I put the street name to start my navigation. I have android Samsung mobile.
  • in search, first select country, then town and then street
  • Hi,
    How can I change the icon of the current gps-position in a smaler one? It takes a lot off screen on my huawei y200.

  • I don't know if it's a bug or not... but I don´t like it:
    If you are driving and MapFactor need to recalculate the route, but MapFactor can´t do it (I have to do some test to know why it can't), then the navigation is stopped. Why MapFactor doesn´t try to recalculate the route few seconds later?

    Sorry for my English and thanks for all the work.
  • Hi Malkavi,
    do you mean that button "recalculate route" is disabled or something else? Navigator will recalculate after some distance (maybe there is time limit too), and if the ID of the street changed [or some parameters changed, like vehicle type, new waypoints, enabled/disabled some roads, etc.]
    p.s. if you send me your log files, I may see more ...
  • Hi Martin,

    I will look for the logs tonight. 
    The issue happened while driving to an usual place. MapFactor said to go straight but I turned right. There was a bad road in OSM (now fixed) and when MapFactor tried to recalculate the route it can´t and then it didn´t talk anymore.

    Anyway, I think that there was another way to go to that place even avoiding the fixed road.

    Thanks for all Martin

    Ivan G.
  • please give example
  • You can try searching for "Bemposta" in Portugal. Just appears one and in OSM there are 7 I think.

    We cannot choose the city you want.

    The only way is selecting the city centre and then selecting display on map. We have then the location of al the places with the same name and we can by touching the map select routing to there,




  • I can see what you mean, but this is the same in openstreetmaps.org where the map data is from
    you can correct it at the above site and it will be in the next update
    for your information, we have 9 different places call Bemposta in the commercial version
  • Thanks for the reply, but as I said before the places already exist in OSM.

    If you use other navigation systems that also use the same maps from OSM if appears (in the case of Bemposta), 8 different places ( and 3 more containing Bemposta in the name) in the search and we can then choose what we want.

    Best regards



  • yes, they exist, but they have no administration area attribute - if you look in osm you get the same result as in Navigator, you cannot say which is which until you see them on the map
    Bemposta, Portugal
    Bemposta, Portugal
    Bemposta, Portugal
    Bemposta, Portugal
    Pinheiro da Bemposta, Portugal
    Bemposta, Portugal
    Bemposta, Portugal
    Pinheiro da Bemposta, Portugal
    Peredo da Bemposta, Portugal
    Bemposta, Portugal
    Bemposta, Colombia
    Cerro da Bemposta, Portugal
    Bemposta, Portugal
    Bemposta, Portugal
    Bemposta, Portugal
    Bemposta, Portugal
    Bemposta, Portugal

  • OK. Everething is fine. Te problem is with OSM data.




  • Hello tomas,
    I use Mapfactor on a Nexus 7 tablet (OS 4.1.1). After the update from 0.9.124 to 0.10.60 some elements look better (greater) but not all.

    Bugs (?):
    - the switch "autozoom=on" has no influence of the mapscale while driving (also in v0.9.124)
    - is there a map scale or zoom level available for display on map ?
    - OVI Icons are too small
    - speed icons are also too small

    - display the OVI name under the icon (name of shop or name of restaurant)

    best regards

  • Hi,
    I use MapFactor on Samsung Galxy S3 since few months. First time it worked well, but since I updated the Android to 4.1.1. it started to make trouble. When it change from portrait to landscape it hangs on and I see only a dark desktop. I have uninstall and install for new, all the same. The only way to stop the navigator is to restart the phone. Now on my phone it works Android 4.1.2 but MapFactor dont work how it must do. Today I have buy and install the Germany map from TomTom, but MapFactor still dont work. Please help me or pay my money back.
    best regards,
  • please close Navigator, go to Android settings/Application manager, select navigator and the click Clear Data
    see if it helps
  • thanks for your help, I have try. Without effct. Stil the navigation, after 20-30 min I see a black display but the bar uppermost and I here the voice anymore. Sometimes I start tosee the black display after 2-3 min. When the navigation is ready, I try to stop the App, but is not possible. I have to reboot the phone.
  • you can always stop application in the Application manager
    anyway, please email logs (navigator/log folder) to support
  • If I found some bugs on the paid truck map for UK, something like low bridges on map but much higher in fact and it doesn't route me through does street which is very annoying can be reported somewere to be fixed?. One big issue is the Dartford tunnel in Kent where are basically 2 tunnels one on the right side with a high of 16.6 ft and the left side one with a high of 15.9 ft.
  • maps are from TomTom, please report on their web site
  • Hi,
    I am testing the free Navigator on an Android 4.0.4 Dual sim device (Alcatel OT 997D) in Northern Germany.
    It works in principle, but there are some issues.
    1.) When I set up routes and have to use the BACK soft key, I often get a white screen (I will send logs, if I find the email address)
    2.) While navigating a reminder of the Android calendar or a telefone call leads to a crash (Sorry, no logs)
    3.) Sometimes the advices are very late. For instance if I cross an autobahn bridge to use the on-ramp on the other side I am told to drive straightforward unless I nearly missed the on-ramp.
    4.) The speed-limit warning is nice but does not cover all areas. But this may be an osm issue.

  • Hi Binner,
    do you use MapFactor Navigator 1.0.0 or some older version?
  • Hi Developers,

    First of all I would like to thank you for the very good navigator app.
    I have been using this app (openstreetmap) in Germany for 3 weeks,

    Here are some compliment aspects:
    - Clear audio guidance
    - Fast route re-calculation (!)
    - Search by google works
    - Search POI works
    - Speed warnings and camera warnings work

    And here are some improvement factors:
    - On Installation, the route preference was "shortest" this could give a bad impression on the first time use.
    - What does the car mode do? How to configure it?
    - I had only one time experienced the lane guidance, need more of that
    - Freeway direction (e.g. take the A5 to Frankfurt)
    - Show the current road name, not the next road.
    - Too many instructions inbetween (500 meter to roundabout, 200 meter to roundabout, roundabout)

    And here are some bugs that I experienced:
    - If you start the app and turn the phone upside down, most of the time the screen rotation breaks the start of the app (it hangs)
    - Arrival time is not so accurate (in general the journey takes about 5-10 percent longer)
    - I set the camera warning for 500 meters distance only, but the warning sounds at all possible distance (1000, 500 and 100 meters).
    If you turn left/right approx. 100 meters from your destination, the navy says destination reached.

    Thank you and best regards,

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion