Bugreport for Mapfactor Navigator Beta on Android
  • There are a couple of bugs in Mapfactor Navigator Beta on my Galaxy Nexus (ICS 4.0.3 - CM9 - aktual franco.Kernel)
    1. Map Downloader don't work (there are no maps for selection in the window). The download of maps just works with the Navigator 11 Setup Utility in Windows on the PC (this will be a problem for Users with Linux)

    2. The Program crash's a lot. Often it will be, when I will change from Portrait to Landscape.

    3. View in Landscape: You can't see enough. The map-Window is too small and the infos at the bottom are to big/high.

    4. View Portrait: here also: the infos at the bottom should be further below.

    5. Just in Landscape View: the Menubar at the Top (the bar with the Zoom-Icon, Destination-Icon, etc...) is often not correctly visible (sometimes its o.k., sometimes its like this picture)
  • 88 Comments sorted by
  • Hi.

    When there are more than one place with the same mame only one appears in the search.





  • Hi, I am using version 0.9.124 on Android 2.3. It works fine only I have found that Estimated time for arrival is not correct according to the streetlimits. Auto mode works OK, but you can not see the setting is on Auto, Off or On. Keep up the good work. Thanks for this great tool.
  • No response to my comment posted more than a month ago!



    When there are more than one place with the same mame only one appears in the search.



  • Additional Bug:
    6. After using the mapfactor navigator sometimes (perhaps 10 times), it is no more possible to start this app. I must deinstall this app and reinstall it. So I can use it again.
  • Additional Bug:
    7. The degree-sign is not correct (its with a questionmark - see screenshots above): Instead of p.e. 46°51'07.3" its like 46?51'07.3"
  • Hi Efred,
    this was not meant to be public, but ... well ...
    It looks like you have not correctly set DPI on your device. You can change it for example with https://market.android.com/details?id=lv.n3o.lcddensity
    There are also some issues with Android 4.0, which could be related to crashes on your device. The next beta version should be during this week.
  • oups.. I'm sorry. I thougt, if I post it here, it would be interessting for other people to see the progress. If you want, you can delete this thread.
    I'm sorry for this trouble.

    the DPI of my device is correctly set (320 DPI is default on the Galaxy Nexus), so everyone with a Galaxy Nexus will have this issue.
  • Hi Efred,
    sorry, I was wrong. There were not prepared layouts for version 4, and parameters were used for a tablet instead for a phone.

  • Bug in map downloader - if you are already downloading and screen
    rotates, downloading restarts from begining and is downloading already
    downloaded files
  • Hi AndyS,
    thanks - I can confirm that. This is related to test on CDN, where we currently have problem restoring the partial download. We are working on that.

  • First: Thanks for porting this to Android!

    Two remarks:
    It seems it uses also unfinished streets (as for example B31 West between Umkirch  and Gottenheim - near Freiburg). This is marked as not finished but is used for navigation.
    Also it uses streets which are not usable with bicycles (also at Autobahnzubringer Mitte between  Freiburg and Umkirch).
    Second: Touchin the screen let appear the upper bar with a magnifying glass. But this is not for searching a location as with the same symbol in menu (when pressing menu button). This is somewhat inconsistent.

    It would be great if the address book can be used as targets for navigation.

  • Hello Star,
    thanks for report. Regarding B31, do you mean part at coordinates (48.047516, 7.759791)? I see it gray as under construction and if I do not force it (by adding waypoint), car does not navigate there. Did you navigate for car or bicycle? (I see now, that bicycle is guided there).
  • Two things I miss compared with WM-version:
    There is no acoustic signal if my speed is higher than my defined one under speed-limits. Just the speed-limit-sign twinkles and I dont look to the smartphone every time while I'm driving.
    Trying to point a POI with my fingers on display it's hard to get the exact position and pointing to "i" then or trying to create my target that way, nothing happens or I just see something like "State xy" etc. but seldom the name of POI.
  • - the acoustic signal should be fixed with the next patch (0.9.93+)
    - for "info" is prepared new function which will no longer take only "exact pixel" and related info, but whole area of several pixels ... the integration of this function should be soon [i.e. not in this build but probably the next one]
    thanks for comments
  • Hi, I'm having some issues with my Milestone2, android 2.3, navigator 0.9.96. It seems the app uses only the coarse positioning data (mobile network antennas) instead of the GPS data. If I switch off the network (plane mode) then everything works very fine. I have an option activated so that the phone can use mobile & wireless networks to locate itself, but this is meant to happen only when GPS data is missing: Navigator should override this, just like all other GPS-based apps do. Tried on a Galaxy S and works perfectly. Is this a bug? Many thanks for this Android version, btw: it's the best app in its class!
  • Hi Wilhem,
    thanks for report and comments :). Can you please try to switch into high debug level (the last item in settings), test it and send me corresponding log file (/sdcard/navigator/log folder)? I am experiencing similar problems with Asus device, when GPS positions "comes from future". Because we are using the newer data then GPS wins. It could be some problem with location API, that when GPS date is not available it uses current date (?!). Maybe please also check your timezone, the system is maybe using it (?).
  • Hi,
    I try to run navigator free on my android 4.0.3 Archos 80 G9 tablet. My problem: I can`t find the menu on the screen. There is just the small pull down menu in the upper part of the screen. But there are only waypoints, favourites ...
    In the lower right corner I see a small three bar icon which looks like a kind of menu-button. But noting happens when I touch it.Where is normaly the main menu?
  • Did I use the wrong thread? No comments or answers after 3 days?
  • public holiday in the Czech Republic - please be patient
  • Used 0.9.100 for two weeks in the USA. I added my hotels and other destinations to my places after searching on google but found that every so often adding a new place would cause the app to create a new favourite file and wipe all the saved destinations. Is there a limit on the number of favourites in the .xml file? After the second time of having to input all my destinations again I saved a copy of favourites.xml to my external sd card. Is this a bug, or a deliberate restriction on the public beta version?
    Apart from this one aggravation Navigator performed very well with only a few false immediate turn right turn left directions where the road was straight with no turns. Is this caused by the joining of map tiles?
  • USA, Memphis, TN - driving the 'loop' (I240) coming from I40 and going towards I55, trying to pass junction TN385, the routing at this junction is running via a side-exit-road and not the main road, causing confusion about taking this exit or not. i have checked OSM data but i am not sure if this is a problem of the map-data or a problem of the routing algorithm.

    update: i just installed navigator 11 on my pc, did run a simulation over just this junction, and it went fine. So it must be an error in the android-app algorithm
  • @Roldorf - there is no limit for number of my places (there is limit in recent search, but that's not your case, right?). You probably do not have any log file from time when the file disappeared?

    For bad navigation maneuvers it is the best if you can give us exact coordinates of departure and destination (or routing_points.xml file). Ideal is if you can narrow it to the only one problematic maneuver.

    @winderlicht - I do not know, where is TN385 junction - can you give me coordinates and what instruction you get in PCnavigator and Android? Do you have the same maps (the same update)? Navigation engine should be the same.

    thank you
  • @mdx...
    exit 16 (node 282142355, Coordinates 35.0859758, -89.8748832)
    exit 17 (node 282142394, Coordinates 35.0850065, -89.8766255)  
    exit 16 is the exit for going TN385 south, exit 17 is for going Mount Moriah Rd. And here is where the routing of the android app is going wrong. instead of staying on I240 the routing is taking the exit 17, running on this side road beside of I240 to re-enter I240 after Mount Moriah Rd. The pc navigator is getting it right, so there seem to be a difference in the algorithm.
    Here the version i am using:
    Android App: 0.9.100 (latest download from google play)
    Pc Navigator free: 11.0.56
  • @mdx... Martin, i think i have found a solution. i started playing around with the 'Fahrzeugprofilen' and noticed that by default 'Auto' is having the German speeds and preferences settings (because i have installed the app in Germany few weeks ago), and that most of the major roads, like Autobahn, are NOT enabled ! To find this was tricky because the switch-symbol in front of each road in the list view was green BUT the green checkmark in the edit-mode of each road was missing!
    As soon as i have enabled those roads and as soon as i have created a new profile 'Car' with the proper settings for the USA, the test-simulation went fine.

    please make sure that after installation of the android app ALL needed roads are ENABLED (green checkmark in the edit mode for each road) by default in the 'Fahrzeugprofil'

    after some more playing around with the routes and profiles i have found that the android app is NOT KEEPING the profile settings. you can change them and it will use it one time, but as soon as you re-open the profile to check on it, the checkmarks are gone !!!
    this is making the android-app in the present version 0.9.100 useless !
  • wunderlicht
    I tried this on both my PC and fresh instalation of android version and found no problem. I am not sure how motorways in your vehicle profile became inactive

  • @tomas...you are right, the pc version has not this problem. but the android version is screwed.
    here my test results:
    the profile settings are stored in vehicle_profiles.xml.
    the paramter to set is called <speed_restrictions>yes</speed_restrictions>.
    in my case the value was 'no' for several road classes.
    with an external editor i have edited this file and changed the settings to 'yes'.
    before i copied over the original file i have made a backup, just to be sure.
    now, restart of the app with new vehicle_profile.
    voila...all roads are enabled!
    but...as soon as i am opening this road for edit, close it, re-open it, the checkmark is gone!!
    i close the app, re-open the app, the checkmarks are gone, means the app has overwritten the information i wanted with a default setting it must have stored somewhere else....bummer.
    i re-edit the file vehicle_profiles.xml, but this time i am removing the write-permission for the file-owner.
    voila...this time the app has no chance to mess with the settings, everything stays enabled like i wanted.

    the android app is defaulting the road classes as soon as you try to edit those

    quick and dirty solution:
    removing of write access to the file vehicle_profiles.xml after final edit of parameters
  • Hi wunderlicht,
    I am trying to repeat your bug (I am using slightly newer version), but the program saves the status of checkbox correctly. I tried it both in Route info/Route setup as well as in Settings/Vehicle Profile. Can you send me your vehicle_profiles.xml file? Are you sure that it was not write protected before?

    On the other hand there was a major bug in default Car profile. Instead of Train Ferry were allowed Other Roads (!), which are absolutely not suitable for cars (!!) ... sigh. So maybe this is somehow related??

    Maybe one more question - do you have only one vehicle or more?
    thank you for your help

    the problem was with names - if you enabled Train Ferry you actually enabled Other Roads ... so the default car routing should be the same as on windows (if I ignore number of expanded links for routing)

  • I don't know if I can report bugs there, but in the last build of googlePlay (0.9.112) are new bugs:

    I have only open the Navigator and the map downloader and in both programs Car mode is enabled and it is not disabled after closing the programs.

    And in the map downloader the list of countries does not load.

    Sorry for my English.

    (Is there any estimated time for the new update of the map of spain?)

    edit: Uninstalling and reinstalling the app fixed both problems. Incompatible old data from previous version?
    Ok... Now I see the problem. If you star the Navigator Downloader and you have activated the Car Mode Auto, the downloader enable the car mode and use the dark theme, but the downloader cannot list the maps. If you disable the car mode and open the Downloader, It works.
    The Downloader doesnt disable the car mode on exit.
  • Hi Martin,

    thanks for taking the time to look into this. so far  i can tell that the app definitely is changing the value for the use of the speed limit setting on my phone, maybe it is OS and/or phone related. i am using a Huawei Ascent Y200 with Android 2.3.6. beside of the default vehicle profiles i have added my own one - Car - which is holding the proper settings for the USA.
    I have done some tests with Train Ferry, but regardless of how i am setting it, the speed_limit settings are getting deleted after re-open of the road classes.
    i have send you a PM asking how i can send the requested files to you, and maybe we should continue talking via PM because i feel kinda guilty of jamming the bug-report thread with just one problem.


    i just did the upgrade to 0.9.112, i like the changes, good job...but... this version too is altering the settings for the use of speed limit in the vehicle profile
  • I dont know if this issue will be fixed or if it is reported:

    If you star the Navigator Downloader, the downloader enable the car mode, and the app cant list the maps. If you disable the car mode and open the Downloader again, It works.
    The Downloader doesnt disable the car mode on exit.

    Edit: Using Last version from market. 0.9.112
  • thanks malkavi, this was not known issue ... I can confirm the error.
  • thank you for your work and great app.

    Another thing that I cant get working are speed camera alerts and speed limit alert. I am using CM9 in a SGS I9000.
    I have done simulations in roads with speed cameras and nothing. I have alerts activated.
  • Do you see the speedcam icons in the map? (if not you have to download them first - in downloader select Imports).
  • yes, I see the icons, and I have done simulations in roads with speed cameras (and the icons), but nothing.
  • Any news about why speed camera alert doesnt work? Anyone having this issue?
  • It works for me with version112, both i navigation and simulation
    I use ICS
  • Thanks. Can I see some log or something to see what happend? I have CM9 / ICS and I am using spanish language/voice.
  • and are speed cameras switched on in settings?
    do you have sounds_xx_signal.mca in navigator\data folder?
  • I have find the problem. It is a translation bug. 
    Into the menu "Speed and camera warnings -> Speed", the first option is "off", but in spanish is "activado" that means enabled. The string has to be "desactivado" or "apagado" (disabled or off). 

    Then that is the reason, I had think that is was enabled, but no. Now I have a question, If i select "0% over speed limit" it will sound always or only if I am driving at the max velocity? I prefer to listen always, even if I do not drive at max allowed speed.

    Now I have changed the selected option and it works. Thanks for the great app.
  • 0% means that it will sound always when speed is exceeded, for example on 60km limit it will warn you when you drive 61km/h. If set to 5%, you will need to exceed 63km/h.
    however, not all streets have speed attribute in OSM map data, so it will not be always accurate
  • In the last version of the Google Play I have found 2 bugs:
    Version: 0.9.119

    - Opening Navigator Downloader start the Car Mode, even if I disable the Car Mode in options of Mapfactor Navigator. And the Navigator Downloader does not list any map, it says that the maps are updated and I cant do any more.

    - And the other bug is the string off in the speed menu in spanish. 
    off = apagado // on = encendido
    disabled=desactivado // enabled = activado
  • bug in latest version on Galaxy Nexus v4.1.1:
    no human voice in navigation mode.

  • On my HTC Desire S with MapFactor Navigator 0.9.122 I have 2 bugs:

    1. if I don't exit from application (working in background with/without navigation) when I start to charge my battery screen doesn't turn off. Changing "Display always on" doesn't fix the problem. When the phone is on battery everything work fine.

    2. If I have  way-point point between departure and destination when I pass this place I  must manually to switch off or to delete this  way-point because after some route recalculation this way-point remain active and navigation is trying to send me back from current position to  this point and then from there to destination.
    After passing some way-point navigator must switch off  this  point  automatically and to navigate to the rest of the route without trying to send you back on the previous places.

  • I have one another issue with searching addresses in suburbs of the city. All suburbs are represented like some "virtual"city's in the search. On this way if you try to find some address in the city, and if you don't know in which suburb is this address, you can't find nothing.

    tag:place=suburb by OSM identify a sub-division of a tag:place=city or tag:place=town and on this way all streets from 
     tag:place=suburb belong to the parent tag city or town and it must be possible to find address searching the city with out knowing in which suburb is this street.

    If you search Country=Macedonia, City=Skopje, Street="Anton Popov" you can't find nothing.
    Because this street "Anton Popov" is in small suburb of Skopje with name Avtokomanda you must search on this way:
    Country=Macedonia, City=Avtokomanda, Street="Anton Popov"
  • Hi, Borces,
    I've seen a similar issue regarding searching addresses. I can not find a street in spite of the fact that street is drown on the map. Country=Austria, City=Vienna(Wien), Street=Meisengasse. There are many of these situations: in Paris (France) or London (UK). 
    Is it a bug of OSM Maps or Navigator?

  • ad cybersonic - thanks, this is probably more common problem not related only to Navigator, see

  • Hi, Mapfactor Team
    Please, ignore place=suburb in Poland OSM map, because we can't search a lot of streets.

  • I do not know if it is a bug, but I want to know what is GPS coordinate format used in Search>Coordinates?
     As I've realized is not gg.gggggg format. It is a little unusual because Google Maps (www.maps.google.com), bing maps (www.maps.bing.com) and another maps on web are using this format (gg.gggggg).
    I hope that Mapfactor Team will improve Navigator with possibility to use gps coordinates in gg.gggggg format or to change type of gps coordinates used format. 
  • Hi imoanteeli,

    our format is in miliseconds, to convert miliseconds to decimal degrees simply devide by 3600000



Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion