Test of Android version 5.0.x
  • 120 Comments sorted by
  • My complaint from March 1 about not beeing able to set night mode colours is obsolete. It happened because I am using a modified (default_)album.style file which obviously changed it’s syntax somewhen in the last time without my knowledge.
  • Motorbike preset:


    I will go on my knees and shout out loud a big halleluja. Perfect, thx in advance for Your efforts, this really is good news.
  • 5.0.35

    - @2highlander motorcycle vehicle type added (adding new vehicle dialog was slightly redone because of this)
    - app color themes divided into light and dark
    - add search history item to favorites crash fix
    - @MacDony we take your suggestion into consideration (but probably not in this version)

    and @MacDony if you will be so kind, can you please have a look at new translations? especially "What's new" would be great to have in French... Thank you
  • Hi Stepan,

    Translation finished.
    But I do not understand "- second set of POI icons (............. - default vs outlined POI)"
    When I select the theme, nothing happens ... bug?
  • default icons are on round ackground
    otlined are not
  • Translation finished.
  • Hi,
    Thx for Motorcycles icon !
    but Motorhome icon ?! caravan with car or camping car or just caravan?!
  • Dto., awesome, thumbs up!
  • Hi all,
    Setting the profile speeds is more difficult on version 5.
    Is it possible to put +/- buttons to adjust easily?
    Thank you.

  • You may use the sliders in landscape format for less fiddling around.
  • 5.0.36

    - minor design change of vehicle profiles list view
    - translations updated
    - crash fixes
  • Hi,
    Navigator does not recalculate the route when I delete one or more waypoints on the map.
  • in navigation mode?
  • 5.0.39

    Navigator does not recalculate route after waypoint is deleted from map fixed
    - beta version warning removed from About dialog which probably makes it a release candidate :-)

  • Hi,
    My Routes -> "Share as Gpx" the file name = "!#IN 1 "+ filename or "!#IN 0 "+ filename
  • I am not shure what are you describing
    file name remanes the same when I share and select email client
  • the file name problem is only if the file is in a folder
  • 5.0.40

    - crash caused by rotating device while maps are being downloaded fix
    - canceled buy maps from free maps followed by app restart bug fixed @Siggi, @Durko
    - share as GPX from sub folder file name fix @MacDony
  • Hi stepan,
    many thanks, I'am happy
  • 5.0.41

    - download map data screen optimized for low resolution devices
  • Do You consider to make favorites searchable in future versions?
  • @2highlander

    we will discuss this feature, thank you for the idea

  • 5.0.46

    first install app settings shown in phone language not in language selected by user fix
    - selecting TomTom maps when the maps are not purchased shows eshop not download maps page
  • Just upgraded from blackberry to android Sony Xperia zx2 running Android 9.

    Problem : the Route- Importer I have been using to import my gpx files to MF is not working on this phone. Although it can find the files it won't read them. Error " the mapfactor-file does not exit or is not writeable"

    I tried to import the file via the file explorer by "open in" but the Mapfactor is not shown as one of the default apps. I tried but I cannot find a way to make it a default app.

    Too bad for me as I import gpx files all the time.

    MF installed on the sdcard as it was on BB
    MF licence transferred to new device
    TomTom update purchased.

    Desperately needing a fix
  • Most probably the routeimporter has not write access on the sd-card.

    You should copy the routing_points.xml from external memory to internal memeory and then try the import.
    And then see to copy it back.

    With regard to default apps: You can't set the default app as such. 
    Is there another app that wants to open the gpx if you open it in the file manager?
    If so go to the settings of that app and remove its "Default open" settings.
    In that case Android should ask again which app to choose (once or always use this app).
  • @hvdwolf - tried your suggestions and many thanks. It worked when moved the routing_points.xml to internal memory. Route importer imports the gpx but it wont import when routing_points.xml is moved back to the sd-card. Unfortunately if routing_points.xml is kept on the internal memory then MF cannot see it. Definitely Route-Importer although shows that has access to the sd-card somehow hasn't. Possibly the app is too old for Android 9 and I dont think the developer is maintaining the app or can get in touch with.

    Trying to import directly still no success. I cannot remove the default settings on the apps listed to open gpx files as there no defaults settings to remove ?!?

    See images - 



    This is really bad and annoying - I wonder if someone else with Android 9 can test the route_importer and file import and let us know
  • S9+ with Android 9 and MFN running from sd card, no problem here. I'm importing from Total Commander. Select open with ...., choose MFN and on it goes. No external importer needed.
  • Typical mistake, never look at the obvious and try a different file explorer!! Total Commander is great. The default Files explorer was the problem after all.

    Route-Importer, unless is updated, is now dead.
  • 5.0.48

    - minor bugs fixed
  • 5.0.50

    - possible mega pack inapp purchase loss after app update from version 4 fix
  • Hi,
    In My Trips, I sort Gpx into folders.
    - folder "2017"
    - folder "2018", etc.
    - subfolder "January, February, etc ..."
    - Gpx files
    If I move a folder in a folder, to make a subfolder, it does not work.
  • thanks for fixing the mega pack purchase loss.

  • Android 9
    MF 5.0.50

    While navigating a planned route (My Route with waypoints) touching the screen to bring up the information panel to cancel a waypoint the response to the touch is a "hit and miss" and today was a continuous miss. Usually is a long delay, the longer navigation is on the longer the delay or never appears but today was very shy, never appeared - at the end I had to stop and clear waypoints via Route Points which defeats having the info panel.

    On touching the screen the zoom +/ - buttons appear instantaneously but the information panel does not appear.

    This happens during an actual navigation not on simulation or just in map mode.

    The info panel should appear immediately especially to cancel a waypoint. Please fix.
  • I also hope for a solution for this problem!!
  • @mes - are we being ignored? :-?
  • no, please be patient
  • Hi,
    In Navigation mode or Map mode,
    Edit link, disable link = ok
    Edit link, enable link = no result
  • thanks, we will fix it soon
  • it works fine, you just need to click the broken barrier icon first
  • Today I used Mapfactor on my motorbike. The unresponsiveness of the screen during (longer) navigation still exists. I was hoping that it was improved in version 5 but the problem is still there. This is very annoying when I want to skip a waypoint. I know this is an older problem and a difficult problem.
    I hoped this problem can be fixed soon.
  • And I have a suggestion for extra settings for:
    1. turn the announcement of waypoints on/off
    At this moment I have edited the file navigation.xml to get rid of the announcement of waypoint but after an update I have to edit the file again.

    2 turn the blue traffic signs on/off (including the lanes) (left upper corner during navigation)
    I like this signs while I am driving in my car. On my motorbike I find this sign distractif so I would like to turn this off.
  • 5.0.55

    - UK postcode search fix
    - other minor bug fixes

    @mes longer navigation issues under investigation, no results yet, sorry

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion