Test of Android MFN beta 2.0.x version
  • Hi,

    This is a follow up of the "Test of Android GLES Apha Version". As that version is no longer alpha and not a separate download anymore since the 2.0.22 version I created a new topic here.

  • 81 Comments sorted by
  • Again:
    Please compare my "Dutch city"navigation screen (bottom one) with the  "Swansea, Wales" screen:
    Swansea: image
    Zwolle, Netherlands:

    Please tell me what gives you the cleanest driving experience and the best overview as to where to go?
    All those buildings simply give too much distracting non-information when driving, whereas the top image gives you a nice, clean, "one look is enough" overview.
  • Small improvement with translation on GooglePlay
    Now is 'DARMOWE nawigacji GPS...'
    'DARMOWA nawigacja GPS - mapy OSM albo TomTom w trybie offline. Podróżuj stąd wszędzie.'
    ('Podróżuj' or Wojażuj or Mknij or Pomykaj)
  • MFN, hvdwolf ;-P

    When I am already here: With hardware renderer, the blue horizon is still too big.

    Another issue I have over and over again, but don't know how to reproduce it to 100%: I go to My Places --> choose a Favourite, and select it as starting or destination point. The map will open. Very often, but not always, the marker as starter point is NOT set, and also missing in Route Info --> Routing points. I have to go back to my Favourites, and again select my point as starting/destination point to make it work.
  • Low priority issue:
    Android 4.4.2, MNF 2.0.24.
    I started again to modify map schemes in the "Settings -> Map Colors". In about 50% of the cases when I exit the editor, MNF crashes. (I already tried with restarting the phone as well)
    Until now I really can't pinpoint when it crashes and when not. I can't find a difference either between software renderer and hardware renderer either.
  • "MFN, hvdwolf"

    Really? :)

    I always thought Mapfactor Navigator Free. I changed it anyway as you might be right. If someone else corrects you again I change it back ;)

  • Ooooops :-)
    I always interpreted it as MapFactor Navigator  :P
  • Lets hope the employees know and see what the final verdict is :)
  • you both are 'unpaid' employees :-)
  • Thanks, but in that case lets hope the paid employees know. 

  • Feature request:
    In the early GLES builds we had the option to enable/disable 3D-buildings.
    Please bring back that option!!
    In the Netherlands a small projectteam, including myself, imported each and every address AND building into OSM using the BAG database via a josm plugin which really include the outer measures of every house and shed. This also means that earlier imported AND 3D-shaped rectangles for 6 houses are now 6 separate house outlines, with possible extensions, and each and every shed. 
    Seeing this in 3D in a map is really impressive but after a while this gives in cities an extremely cluttered and chaotic view where I like it to be as clean and simplistic as possible.

    So again: Please bring back the option to enable/disable 3D-buildings.
    Addition: It would also be nice to be able to switch it on/of separately in map view and in navigation view as in normal map view I do like it.

    See images:
    portrait: image
    Landscape: image

  • I think it looks quite nice

  • It does look nice. I don't deny that. That's exactly why I ask for the additional option to be able to enable/disable it for mapview and navigation separately, and that's also why I say "it is really impressive to see it in a map". 
    However, it's not nice when you are navigating in a Dutch city as it gets even tiresome on the eyes (if your screen constantly rotates in driving direction). 
    This summer in England and Wales it was no problem at all as only up to 10-30% of the buildings is mapped (see here) and only as simple imported AND 3D rectangles mostly.

    The Dutch and English have the same saying: "you can't see the forest for the trees". In Dutch cities that is now also true for the houses in MNF (or MFN).

    Note also that I use a modified color and road theme, otherwise it really becomes a "candy festival" of hard, saturated colors to the eyes. The only bright color should be the navigation arrow.
  • And another thing and this gets close to pettifoggery: The application icon in the Android notification bar in the topline of the screen is a "running" pedestrian. This is of course not a bug at all, but as 95% of the users (my estimated guess) is only using MNF (or MFN) as navigation app for driving, it is not really appropriate. (Did he steal anything and is he now trying to escape :) )

  • Yes, our time, hvdwolf :))
  • it is not pedestrian, it is a runner, meaning Navigator is running :-)
  • In German:"Man sieht den Wald vor lauten Bäumen nicht."
  • Bug: Transparency doesn't work for 3D buildings.

    I just thought by myself to change/set the opacity to 0 for buildings, to not display them at all. That works in "flat" mapview (no building outlines anymore).
    It does not work in 3D navigation mode.
  • @hvdwolf transparency for buildings in GLES in 3D is hardcoded to 75%. If you want to disable buildings just uncheck enable checkbox on same screen in color scheme editor. Crashing of scheme editor is weird, I checked google analytics and there is nothing about it

    @chattiewoman: I agree with horizont size but it is too near to release for changing it, maybe in 2.1.x
  • @lubos: Thanks, that works. I thought the option "enable" meant whether opacity/transparency was applied, not whether is was visible or not.
    The option should be named differently. Something like "Visible" or "Display on map", which means that all translations need to be changed as well.

    I still have my feature request though as I now completely miss the buildings both in map view and in navigation view, where I only prefer not to see buildings in 3D view when navigating. Simply the flat outline is no problem at all and can be helpful.
  • @hvdwolf can you please send us log of color scheme editor crash?
  • I feel a little bit embarrassed. 
    I can't make it crash anymore when using/exiting the map editor. It simply works. This is of course a good thing but "something" made it crash and that "something" is obviously not there anymore.
  • @hvdwolf If you remember when the last crash happened, you can still send the according logs from that day.
  • I made saving of color schemes more safe and faster, wait for next version
  • W.r.t. to those logs: I had a folder full of logs and I removed them all before doing the "crash test" as I wanted a clean set of easy distinguishable logs: "this log belongs to this crash when I exactly did this".
  • FYI there was a problem in software rendering regarding display house numbers. This bug should be fixed in 2.0.25+:
    There are also fixed some other bugfixes.
  • bug 2.0.25?  : Color map editor only supports internal schemes. My personal day/night scheme are no longer in the list and can't be imported either as there is no import option at all. 

    My schemes are still functional and active but when I want to change day or night scheme, my schemes are not in the list but there is no standard scheme selected/checked as well (as my schemes are still active): all radiobuttons are unselected.

    Edit: After a reboot my schemes are no longer being used and can't be loaded/imported anymore

    Edit 2: Of course by simply tapping the theme file I could (re)import it into Navigator. I had forgotten that option. Navigator works again with my themes.
    However, it is weird that my themes were no longer in the list, but still being used by Navigator until reboot.
  • Just added another panel ( 4th) and set it up as "Current Journey Distance". I expected to see miles covered but the counter remains to 0.00. Same behaviour with "Current Journey Time".

    Never used this function before therefore not sure what to expect or whether is working or not.

    Can somebody check it out and let us know

    Many thanks
  • @hvdwolf This could happend when album.style become corrupted. Themes are reloaded from standart set but in settings is stored ID of previously selected theme. In this case navigator uses default theme.

    @stavrich Current journey in infopanel is odometer function(so odometer must be enabled and it does work only in navigation)
  • bug: An old one but still not solved: When you modify a profile and change Extraurban or Urban speed, but NOT the preference setting, the preference setting is still increased by 1 (like from 50 to 51).
  • @hvdwolf will be fixed in 2.0.26+
  • 2.0.27
    - crash fixes
    - favourites fix (moving items into folder)
    - vehicle preference setting increased by 1 fixed
    - support for transparent roads in HW renderer
    - fixed armeabi-v7a configuration
    both links updated:
  • links are updated now to 2.0.29:
    - fixed crashes on 2.3 with ARMv7
    - fixed signpost size and click in map for high resolution displays

  • and here I am again with my own digger-created maps for my routes (http://forum.mapfactor.com/discussion/comment/10792#Comment_10792)

    It still doesn't work as expected. Is this still to come one day?

  • @crocodilefarm - we will not fix imports in HW rendering 2.0.x, maybe in the next release. Please let me know if there is any problem in SW rendering

    OT there is now 2.0.30 with fix of display house numbers related to town/village (in previous 2.0x version sometimes disappeared when center of the town was not visible).

  • @mdx in SW rendering it works as designed. No problem in SW.
    Okay, if I know that, I can live with it.

    If you ever should fix it in a future version, please let me know, so I'll test it.
  • I have a Xperia Z1Compact (Android 5.1.1, maps on internal SD card) as a new phone since a couple of days. It is running with the latest 2.x version from the play store and latest OSM maps.

    Route calculation crashes for longer distances.

    For example it calculates from Chemnitz along Autobahn A4 via Bundestraße B 49 and Autobahn A3 direction north from Limburg to just before Montabaur. If I set the target on the Autobahn A3 a couple of km before Montabaur, calculation is ok. Only about 5 to 10 km later on the same Autobahn, MFN starts calculating and then crashes without any reason. Berlin to Chemnitz is as well.

    Since I would like to go Portsmouth in October, I need long distances.
  • please provide departure and destination in coordinates, I will test it
  • Thank you, but I am sure, that will not help. If I calculate routes with my tablet, that is successful there (This is Jellybean, an Intel device; same MFN version and maps). So I hope somebody may have an idea, why it crashes under the circumstances of my new phone.
  • I use v 2.0.30 and can calculate routes from UK to Znojmo
    it is 1629km
  • That is, what I exspect. And that is, why I wonder, that I can calculate from Germany East a bit over 400 km but not some km more within (the same map, e.g. Germany West) in Germany.

    And I am now going crazy, because I went back from beta to stable version in Google play and downloading the maps of Germany is constantly breaking down because MFN map manager does not keep alive the phone and I am starting map manager now the fifth or sixth time today for the next map ...
  • I downloaded quite a few maps today, no problem
  • I have set my phone to 30 minutes to go to sleep and that makes it easier to download larger maps.

    I am now back to 1.6.20 and route calculation within Germany seems to be ok (whereas it was not after uninstalling and reinstalling version 2.x this morning even not with fresh maps).

    It is just downloading UK maps and I'll see then ... and it is working now.
  • You can download maps on PC using Navigator Free installer. Then copy them to phone.
  • hi folks,

    I've just installed android 6.0 on Nexus 5 and the google play version of Navigator (2.0.30) crashes after I change the map rendering to HW...does anyone else have a similar issue?
  • Ver 2.029 Partial blue screen during navigation in software render mode. Moto G XT1068  android 5.0.2.
    Logs sent.
  • > @Tantum: I've just installed android 6.0 on Nexus 5 and the google play version
    of Navigator (2.0.30) crashes after I change the map rendering to
    HW...does anyone else have a similar issue?

    Try to get stacktrace of the crash.
  • 2.0.31+:
    - fixed display of blue signposts
    - fixed reverse order for Arabic/Hebrew texts in HW rendering
  • v 2.0.30
    Speed limit indicator does not change. 

    It happened a few times - 

    Location - parked in a car park
    Route starting point is on main road with a 60mph speed limit
    After loading the route and starting the navigation, the speed shown on the display is 30mph
    Starting moving as per navigation instructions
    Getting on the main road - speed limit shown still 30mph
    Moving on to 70mph road -  speed limit shown still 30mph
    Getting on a 40mph road - speed limit shown still 30mph

    Please note that when exceeding the actual speed limit (30, 40, 60, 70)  the audio warning works as expected

    To recover from this shutting down and restarting MNF usually works but sometimes a device reset is needed.

    Any ideas ?

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion