TCP/IP communication in Free Android client
  • Hello,

    I'm trying to explore the new feature in the free Android client, but I'm unable to get any info.

    I can sucessfully telnet to the 4242 port of the android where MapFactor is installed, but after inputting some commands I don't get any response. Tried with windows built-in telnet client and also tried with putty.

    The commands I've tried were:


    But none worked. Any info or advice?
    Thanks in advance,
  • 3 Comments sorted by
  • Hi HSousa,
    did you try the extra utility first? After release I made comment to Android FAQ ... it is here
    Does that work?
  • Thank you very much for your fast reply.

    Ok so I tried the app and indeed it is working. But I found a "feature" related:

    1) if I fresh start NavigatorFree and then the tcpiptest.apk test application, it works fine.
    2) if I fresh start NavigatorFree and then use putty to remotely control the appl, it alsoworks fine.
    3) BUT if I fresh start NavigatorFree and use windows telnet to send commands, everything else will stop working, ie the tcpiptest.apk test application and the putty client will stop working.

    Seems telnet aquire some lock to the port and never releases it cleanly (or only maybe after large minutes)..

    Thanks again.
    Best regards,

  • ... it's been a while, but if anybody is still interested there are couple of fixes in 1.2.34+ related to remote commands on Android. Here is the standard "pre-release" link:

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion