Navigator Free bugs
  • I think I have found a bug. Where is the right place to report it?

    The (possible) bug is that Navigator Free will not route through "highway=service" roads. If the route starts or ends at this kind of road, Navigator Free will not be able to find a route.
  • 58 Comments sorted by
  • Can you send me coordinates of start & end? (or routing_points.xml file)
  • Sure.

    Here you are a simple route in gpx and xml generated with This router work well but NF says it is not posible to find the route. You can try any other point in the nearby highway with the same results.

    I have checked the configuration but I see no problems.


  • The problem was with roundabout Way id=59367905. Recently (Timestamp: 2011-02-19T16:07:46Z) User: [id:395941 name:Jorge Juan] ... I guess its you ;)
    modify that so it should be fixed in data we are computing now (from planet-110302.osm)
  • Navigator Free has also a setting for Pedestrians.
    This setting changes the routing algorithm to ignore the "oneway" setting, which is OK.
    It also ignores turn restrictions, which is also OK, when there are pedestrian crossings and no physical barriers in the middle of the road.

    On the other hand - it ignores also the settings of allowed roads.
    It sends pedestrians also over highways, when they are correctly disabled, and this is not OK.
    Please, verify - and correct in the next update.
  • I found a routing bug with this way:
    Routing in car-mode anywhere from West to the Georg-Kappus-Straße this way is used, but its allowed only as footway an d bicycles.
    Please check your algorithm.
  • Hello hurdy,

    I have run across the same problem however using the teleatlas maps the problem does not occur. At least in the version 11.

  • Hi, I tried the route suggested by hurdygurdyman and had no problem - I use default car, fastest route
  • Mysterious, simulating this route it's ok. But yesterday outside routing online there I got that wrong result. I'll try it again and report...
  • Just came back (and my dog wondered about my stupid walking around). Routing in mode "standard-car, fastest route" it happened again. Then I tried mode "bus" and it was the same. Then I started the maschine again and tried in simulation-mode.
    System is:
    Windows Mobile 6.5 on MDA Compact V (HTC Touch Diamond)
    Navigator free 11.0.11 with latest map-update

    Anywhere in navigator there must be a rule, that doesn't exclude "highway=footway" combined with bicycle=designated for car-routing. And I don't know any reason to add a tag like motor_vehicle=no to that way.

    I'll install a screenshot-programm on my MDA and will make some live-pictures, or is there any other way to document, what happend.
  • I found out the reason. Look at this:
    You see two ways westside of the bridge parallel to the stream “Scheidgraben”. The northern one is for official car use, the southern one is only for agricultural use and not permitted for cars.
    Routing from the northern one to any point at the Georg-Kappus-Straße eastside, you get a regular route over the bridge southwards and then over the unnamed service road and Friedrich Heitz-Straße (the service road is private and not permissive in reality and I corrected now).
    If you start routing on the southern one, the route follows the little footway directly eastwards to the Georg-Kappus-Straße, which is totally wrong and physically impossible because there's a cycle barrier.
    The same happened interchanging start and goal simulated with my PC.
    This failure should be corrected. If I imagine, that something like this happens to me as a foreigner in a small old town packed with driving tourists, it would make me more than a little bit nervous even if some police-guys looking around.
    What should a good routing do? It should recognize: “Ok, I start in the mud. So I search the shortest possible way through the mud out to the next official usable way and route regularly from there on.” And if the Goal is in the mud, it should route to the next possible point, which can be reached officially.
  • I am not sure that I understand - my route goes from the roundabout through Georg Kappus Strasse, Eichholzstrasse, Am Schiebgraben and Pfugstrasse. Which one of these is closed?
  • To clear the questions, I made some screenshots:
    This one shows the wrong routing started on the way, which is forbidden for cars. The orange line is the footway, where also only bicycle is allowed. The red dot is the position of a cycle barrier.
    This one shows the possible routing started on the way, which is allowed for cars. With the actually used OpenStreetMap-material it is ok, because the yellow lined part is a service-road, which was incompletely mapped. It’s private and not permissive and I corrected in OpenStreetMap. So after next map update routing should follow the green marked line.
  • I do not have any road or path where the orange line is, so it would not route through there - which data set do you have?
  • I am sorry, I was looking at TA maps :-)
    I now understand what you say - it did ask me if I wanted to start in the closed road
  • I use navigator free 11.0.11 with OpenStreetMap-data
    Reason for starting in the closed road could be a failure by driving. See my theoretic example five posts ahead. I'll try to find a practical example anywhere.
  • I made some experiments using the simulation with regular car mode and fastest routing mode with OpenStreetMap-material. I guess, I found out something like a rule:
    Normally the gray coloured ways in Navigator free are not permitted for motor vehicles. Everytime the start or the goal of routing is on a part of these ways, routing ignores, that one or more wayparts between start and goal might be forbidden for a car. Even steps are not ignored.
    As I said some posts before, routing should try to find the shortest way out of the forbidden zone and should only use allowed ways as far as possible to the goal, even if there ar some last forbidden meters.

    And sorry:
    in posts before I wrote "permitted" and forgot "not". That might have irritate you and I corrected. Give a little sympathy to a native german.
  • I can confirm "The Rule" - if routing starts in prohibited area (even stairs) it tries to leave that area ASAP. If departure and destination is in permitted area routing should not use prohibited types of roads. There are problems with "level of prohibited roads", i.e. stairs are probably worse than user prohibited Local roads etc.
  • ad riccie and pedestrians on highways ... can you give me example? I tried simple one in 11.0.11 and it worked fine. Note that if the start is already on highway it will route on highway.
  • Hi
    I think there is some problem with the navigator that it does not find route to certain poi. e.g. in UAE map if you set "Emarat Fuel Station, Muhaisnah" as the destination, you wont be able to find a route. (Using the existing map available at mapfactor).
  • Hi kush, the problem is with Way id=50371965, which should be split in Node id=1313122996. At the moment I do not know, why the conversion process did not do it.
    thanks for your report
  • well Node id=1313122996 was not part of the way = 118783060 (to Fuel Station) and you edit that on Tue, 26 Jul 2011 17:41:17 +0000, In changeset: 8837968, so next month you could see your corrections.

    Note, that "United Arab Emirates OSM
    July 20, 2011" could not contain that correction even if we would do it immediately (in reality we are using the first released planet.osm every month).
    I hope it is clear, thanks
  • Hi Martin
    Thanks for your reply.
    Regarding finding route
    1) Yes you are right that I have later corrected the node, but you may consider adding the feature of finding the closest possible route to a node where the user wants to reach (even if it cannot take you to the exact place). Otherwise for many navigator wont find a route for POI which are not very close to road, isnt it?
    2) Giving you a practical example : I was at Etisalat Academy in Dubai and wanted to go to Abu Dhabi Muroor Road 21st street, the navigator could not find the route. Even when I was on the road (which was on the map), it did not refresh and find the way for like long time.
    Searching for places/city
    3) While trying to search for a place using the "Address" menu if I select Country:United Arab Emirates, select City:Dubai, Now if I want to search a street which lies in Bur Dubai or Dubai Marina (both are a part of Dubai) I wont be able to find it. Now either I should be sure about the exact area where it lies (i.e. Bur Dubai or Dubai Marina) or I wont be able Therefore, any road/street which lies in sub-urbs or regions inside a city should also be available when one selects the main city.
    4) When using "Find Address" all the fields should not be mandatory, this will make search easier.

  • Hi Martin

    Yet another thing. There are lot of POI on osm which do not have any name, address details etc but are correctly classified eg. Fuel Station, Place of worship etc. If any POI does not have certain minimum information tagged in, navigator does not show them. By any chance if it was possible to make them available under POI search under relevant groups as per tags (e.g. if tags available are
    Name: --
    Amenity: Fuel Station
    show it as
    "Fuel Station, Unknown, Unknown 3 kms" or "name, Fuel Station, name, name, 3 kms"
    It will be really gr8, as re-editing so many POIs is really a big task and impractical.

  • I want to report a bug - since the last version 11.0.15 or maybe even since the version 11.x - when I select a CENTER of a village or a town, the center is now somewhere else than before and also NOT in the center.

    Examples are here for village "Jivova" and town "Sternberk":

  • Hi, Martin!
    Yes, the bug with Pedestrians from version 10
    is corrected in the new version (I'm using the WM6.5 version 11.0.15).

    As far as I see the setting "Bicycle" is like "Car", but with disabled Motorways.
    I suggest that Primary Road + Major Road should be disabled too.
    It uses also paths/footways (Other Road) with the same priority and basic speed limits as normal roads, which probably is not the best idea.

    And "Pedestrian" is like Bicycle, with the only one exception: it ignores the oneway=yes setting. Correct!
    But - Primary Road + Major Road should be disabled too - as far as I know, Pedestrians are not allowed to use these roads.

    I know - everything can be changed by creating a new, corrected profile - but this is not something that anybody will (and should have to) do.

  • @harvester_cz
    The problem with "Sternberk" is caused a village (?or maybe the castle, I will have to check the source) with the same name (if you select show on map you will see two centers of settlement). They have the same administrative details so the Navigator does not distinguish between them.

    Jivova looks at first sight ok (49.707876, 17.390827)?

    yes, Bicycle is handled as a Car with disabled Motorways. As far as I know you can cycle on Primary Road even it is not wise.
    The same is for pedestrians - I agree with you that at least the preference should be much lower.
  • First i got the software running on Transonic 4000 C with WinCE 4.2 as descipted here:

    But there are graphical errors:

    The progressbar on startup:

    Adress Menu:

    POI Menu:

    Coordinates Menu:

    (Note that only the selected tab is wrong)


    Navigation (Simulation):

    Maybe you use a special font in this areas or scale an image?

    Display size is 320x240 pixels.

    Thanks for help
  • Updated to 11.0.16 yesterday on MDA Compact V (HTC Touch Diamind) with WM 6.5.
    I imported my further settings incl. favorites and routes.
    Now, if I try to "show rout on map", I only see the routing points and no route, which was shown as a light green line in elder versions.
    Any ideas?

    On PC it works.
  • @Shadow - at the moment I am not able to reproduce it (I do not have functional 4.2 device here). It is probably related to ::GradientFill() which should be on 4.2 also supported

    @hurdygurdyman I do not understand - I tried PND version, and there is "show on map" gray unless you first compute route. If the route is computed then there is already highlight (green line). Was the route found?

  • @mdx:
    I played arround a little and compared.
    Maybe the main reason for my problems is the button "Route" I'm missing in main menu and I can't get it to be shown over the settings. But in "Settings/Applications/Organize..." there is a second choice for "Search and Navigate".
    Because of that I took the following way to show the route:
    -Menu/Find and Navigate/Favourites/Routes
    -pointing on any prepared route
    -"Show on Map"
    And so it's logical, what happened. Something went wrong with my update. The update did't transfer my personal settings automatically and so I took my last backup of settings, got a failure-screen like "Couldn't restore completely". I got back everything exept the applikation settings and thought, that could be ok.
    I will follow your tip in Discussion "Version 11.0.16" and will remove the settings.xml.

  • @Shadow - if you want to experiment with WinCE 4.2 device and version 11, you can try to replace exe by
    The problem is really with ::GradientFill(), Ordinal  1763, which is necessary to replace by some kind of "::FillRect". Hopefully there will be some official release soon.
  • Great work. I've tested your file and it worked out of the box.

  • I am using Navigator 11 Free on a Windows Mobile 6.5 phone.

    The program works fine, until .. I record a Journey.
    When I finish it, all is ok, but after switching off the GPS reciever, the program "hangs" and wants to send an Error report to Microsoft. Also about 40 MB of memory remains "occupied".

    There is no problem with switching on and of the GPS receiever if no Journeys were recorded.

    Hint: there is absolutely no problem with Navigator 11, release 11.0.15, but only with release 11.0.25 and 11.0.28.
    I tried with reinstalation, it came out that something between release 11.0.15 and 11.0.25 was changed.
    There are also a different settings files, maybe there is the clue.
    I tried with "upgraded" settings (from 15 to a higher version), also a "clean" settings install, no luck.

  • For me it's important to find a car park in foreign cities. And so I wonder that in Navigator free all car parks, which are tagged in OpenStreetMap just as "amenity=parking", are not shown. But car parks tagged additionally with access=private are located with a blue "P".

    That can't be a feature :-(

  • Hello hurdygurdyman,
    can you give me an example? (coordinate or nodeID) Are you sure that one is not named and the other is? At the moment still only _named_ POI are converted. I check the conversion and tag "access" is used only to block highway if it has value "no". Amenity 'parking':36 is converted as  'Parking Area'.

  • Hello mdx,

    you see several parking areas close to the station and along the Vogesenstraße. They are not marked on your map. But the two westside of Saarstraße/Stettiner Straße are private and marked on your map. Parking area normally has no names and the rule in OSM is, that we shouldn't missuse the name-tag for something like name=Parkplatz.



  • Hello Michael,
    the parking "highways" have an attribute service=parking_aisle, which is not processed yet, and they have no name. I see your edit in way id 49687739:
        "name"="Getränke Junker"
    and the filled name is the reason why it is converted. The first thing to do (for MapFactor) is handling POI without names and solve related issues (search, grouping in find nearest, somehow distinguish them, etc.)
    p.s. you are right about Way id=51675474:
    ... I will check this, thanks ...
  • well, have a look at history ... so the reason is that it HAD name:
    name = Privatparkplatz ... which was correctly removed on Fri, 07 Oct 2011 07:48:10 +0000
  • Hello martin,
    thanks for information. Correctiing the "Getränke Junker"-parking area I oversaw the wrong name-tag. I'll correct that. I hope, that nobody will give a name to any parking space making shure to recognize them on your map :-)

    I agree, that POI's normaly have names except parking areas, toilets, public telephones etc. But these are also important to be shown on maps or routers in case of need or emergency.
  • Hello again,

    I downloaded the latest Windows Mobile release 11.0.35, but the problem with switching off the GPS receiever after recording a Journey still remains, as reported above on 20.10.2011.

  • Riccie, do you use external Blue Tooth GPS?
  • Hallo Riccie,
    I have also noticed that when the gps is removed while MF is running it tends to crash.
    This is for all versions pc and win mobile.
    If I rember correctly my old navi software ( Tom T. ) running on win mobile also had the same Feature. Just no crash report to MS.
    Just my 2 cents
  • Hi Martin,

    i found a bug/problem with the maxspeed.

    Some highway are tagged with "maxspeed:forward" and "maxspeed:backward" when there are different maxspeeds for the directions (e.g. see here:   - when you are driving from east to west on the "Rietberger Straße", you are going to enter the "city". The maxspeed ist slowed down (from 100 to 70km/h) about ~ 300 meter before the city limit (50 km/h). But when you leave the city, the maxspeed changed from 50 to 100km/h). Maybe you can add the feature to your routing software. If it is not so easy to add it, it would be good to take the lower maxspeed as maxspeed tag when you "compile" your mapdata - at the moment the software did not see a maxspeed for this track.

    By the way, what happend to the Germany (and netherland)-maps? All other maps were updated during November ? Will there be an update before X-mas ?

    Thanks a lot.
  • Hi Bernd,
    at the moment routing link keeps only one speed limit for both directions (if it is bi-directional link). Lower speed from both raised many complains about false speed warning, so it is difficult to choose ;). The plan is to extend routing data so this attribute could be there too.
    p.s. Germany is computed on dedicated machine (handling all parts + TMC) and there were computed TT data - update should be from planet 111207. netherlands_osm failed with probably disk space problem, we will check details tomorrow.
    Edit: Netherlands from November data is on update now ...
  • HI Martin!
    The program Navigator 11 free is really great! Thank you!
    But I found a little bug in Israel. The Hebrew fonts should be written from right to left like the Arabic fonts.
    Maybe if you have some time you can change this. On the PC-Version the Hebrew writing is wrong on the map and in the information window. On the Android Version it is only wrong on the map. In the information window it is written the Hebrew way! Thank you!

  • Hi Martin,
    I found a route calculation bug, the same thing happens both on Navigator Free 11 (Win XP) and on the Android version.

    This route:,45.3648657&end=11.853699,45.372061&pref=Fastest&lang=en&noMotorways=false&noTollways=false

    cannot be calculated by Navigator, I get a "No route available" error. The vehicle profiles I'm using allow any kind of road to be used.

    Anything between Corso Primo Maggio and Corso Boston (exits 8 and 9) seems to be unreachable going north. It seems like that segment of road is unlinked from the others. The southbound direction works correctly.

    I'm only a beginner with OSM editing but their data seem fine to me, and as you can see the ORS site can route on that stretch of road; so I think the issue is about Navigator Free routing system.
    Am I doing anything wrong?

  • Hi Wilhem275

    Ive checked the route you highlight in your post on OSM and this looks fine as you stated. There were some minor changes made on the 27th May 2012 which should have been included in the latest update of the Navigator maps.

    If you look at this,11.849760&loc=45.374187,11.853261&z=14&center=45.360348,11.834979&alt=0&df=0

    you can see that the route should be navigable.

     I have checked my copy of Navigator 11 free on Windows 7 and I get the same problem. I don't think you are doing anything wrong, and Martin probably needs to look at it.

    Most of the problems I've spotted are mapping errors in OSM and its usually easy to correct them.

    Despite the minor problems with Navigator , I agree with Kay, its great software.




  • Hi Wilhem275,
    I can confirm that route for standard Car failed. I tried connectivity (pedestrian with enabled Motorway) and it worked fine. So the problem is probably in turn restrictions or oneways?? The problem is near departure as well as near destination. I checked and it is deleted with comment "Checking Junction" on Sat, 21 Jul 2012 ... i.e. two days ago ... Italy is currently computed so we will see (but probably in the August update).
    p.s. maybe it was related to "corretto direzione oneway" and bit older data in Navigator?
  • Hello

    I am using version for Android with TOMTOM maps. In portugal, using "car" on vehicles parameter and allowing Motorways and charge road on road restriciotns (100% on highway preferences) while 0% preference for primary road and Major roads, the proposing rooting never includes highways! does someone do have similar problem? I wallways use "fastet" as optimation mode.


  • I already answered that by email
    you can email back file vehicle_profile.xml

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion