Verison 11.0.54
  • I just updated to the new version 11.0.54 for windows CE and the map render during navigation is very slow comparing with the older version 
  • 27 Comments sorted by
  • Similar problem with a Windows Mobile 6.5 Prof. device. Application freezes after route (re-)calculation. Any suggestions?
  • Same problem here: WM6.1, Free Maps:
    Animation stops somtimes after route calculation. But navigation runs in background, have speech output and GPS is accessed. Touchscreen works "blind" (if you know, where the buttons are ) and I can access menu and target selection again, they are working. But when returning to map, you see the first map-picture, than the animation stops again. Do you need any further information, could I debug anything, is there a workaroud?
    Thanks for this cool software.

  • Hello yacine, picpp and rockford,
    do you still have original 11.0.37? Did you replace old version or do you have new folder with 11.0.54? It could be mix of configurations or as the newer version should show more details, it may something to do with memory, but should not ... can you send me your navigator.log.txt files?
    thank you & sorry for the trouble

  • Hi All,

    I found the problem.

    Problem is not at Navigator version, but at map of the Czech Republic.

    I tried to load back previous Czech Republic map nad suddendly the navigation works and show calculated route and not just sign "Waiting for GPS signal".

    So roll back previous maps of Czech rep. and it should be OK.

    I am not sure if this problem is also for other maps ?



  • Hello Otto,
    what version did you have and which one are using now? Maybe some particular routing is failing now and was working before, but other than that I can't see any reason? I am using version 201204120, size 66 316 338bytes, md5: 831575572f51aeaef138d98274e6d90e *czech_republic_osm.mca
  • Hi Martin,

    Map of CZ that works has 65 438 693 bytes. I belive it is the one before last update.c02c5e20ecfdba6f8dd03d9beb744d93 czech_republic_osm.mca

    I used some Microsoft app for generate hash. Do not know if generating hash has some standards.



  • Ok, got some hash knowledge.

    MD5 is: c02c5e20ecfdba6f8dd03d9beb744d93 czech_republic_osm.mca
    used this app


  • Martin,

    The version you mentioned 66 316 338bytes czech_republic_osm.mca , come from last Navigator map update. And this version does not work neither at version .37 or .57. It makes that "Waiting for GPS signal" but the navigation is running behind the frozen screen. With previos map, it works as it should.


  • It is still not working. Could someone share the older map data. The update site is password protected and I can not download the older map... if it is present there after all. The Navigator 11 is crashing for me very often too e.g. at route recalculation.
  • I am not sure what is the problem - here is the older (March 2012) data of Czech Republic
    let me know if it helped
    p.s. delete newer mca file (if there are more versions Navigator takes the latest one)
  • I am not sure, if the problem is only with Czech Covex, what is your current country you are located in ? There was more maps with the same update that came with map of Czech rep.

    regards Otto

  • Supprisingly I am in Czech Republic.:) And yes with those older osm data, the Navigator 11 works and is not crashing on router recalculation or wait for gps data. If I may help to trace that let me know how (I know there is a log file, but there is just a "hard crash" at the end).
  • the problem is for 95% related to _lanes_. As somebody reported: normal route calculation looks ok, but if you look at the crashing log files they end with routing. The problem is in navigation only. It tries to look for lane info which is in some countries bad. This is not problem on Android as there are lanes not drawn yet. We will revise the data now ... sorry for the trouble
    p.s. it looks like it will be simpler to publish new version 11.0.56 than to patch all data ...
  • No problem, thanks for attention.
  • Hi Martin,

    i have a problem with the new 11.0.54 version.
    I am using: Transconic PNA-4000; Windows CE 4.2, installed on SD-card, primary german maps

    The programm starts normal and the map-modus has no problems. The search for a destination seems to have an error. First i choose the country, in which the adress should be (no problem here). But after clicking the country name i get the windows hourglass turning and turning and turning and turning ...
    Nothing happend (tested it for minimum 15 minutes)
    I deleted the program folder and made a new installation - no effect.
    I deactiveted all maps except one - the germany west (newest version) - no effect.

    Any suggestions?

    regards Bernd
  • @Barnd - anything in navigator.log.txt?
  • Downloaded older Czech Maps, trying it next days.
    Thanks for exploring the problem.
    (nb. I'am in Germany, 50 km from Czech borderline, but never navigated in Czech areas with this version, just downloaded Czech map because we're there sometimes in holidays or at weekends.

    I'll report next time
  • Sorry for that, but problem persists. Replaced newer Czech maps with older ones. Tried to navigate to Praha->Ok, changed the target to somewhere in Germany-> screen hangs.
    If you know, where the menu button is, you can switch to the menu. The menu and the target selection works. So I could close and restart navigatorfree. Normal position display works, then selected a target (the same  again)->Navigate->screen hangs again. The last thing i saw is the bar "calculating route", then this dialog disapears and there is a white area where the dialog has been and the rest of the target selection.
    Next thing I will try: delete all maps, leave only one for my position there.
    Do you need some other information?
  • Can you test it with 11.0.56? The problems were not only in Czech Republic but at least in Austria and probably other countries too :(. If you do not see it on update now (CR), you should see it tomorrow.
  • hi,

    the log file (before starting the search) ends with:
    CONNECTING TO com device - port: COM2; speed: 4800
    Routing: opened germany_osm_west as 0.

    after starting the search it ends with:
    CONNECTING TO com device - port: COM2; speed: 4800
    Routing: opened germany_osm_west as 0.
    PROFILER: <2> Search::setContext - 0.020 secs
    PROFILER: <1> Search::Search - mode - 0.031 secs
    PROFILER: <1> Search::setContext - 0.041 secs
    PROFILER: <1> narrow-row - 0.157 secs
    Exception thrown: .\src\CompressCanHuff.cpp(41)
  • Ok, last results about 11.0.54: deleting maps except germany east, rebooting device, starting with defaults: no change of strange behavior. Switching now back to an older Version from Oktober '11. Will download 11.0.56 tomorrow. No interesting logging so far as I can say.
    Bye from rockford, and thank you for that really cool tool.
    BTW.: the Setup utility runs fine in Wine windows environment on linux. (except device support, but thats not a problem)

  • Tested a little bit more:
    version 11.0.19 with actual maps: same behavior
    version 11.0.19 with maps from that time seems to run (5 targets entered, hangs for 5-10 secs, then picture is running.
    Another thing what I at first didn't care about is: when I try to find a target for instance in my hometown then the database shows me streets that are definitely not here. As they sound they must be somewhere in south or west germany but not here in Saxonia (east germany)
  • Last for today
    version 11.0.19 with maps from that time one time hang with same symtoms (at 20 target tests)
    version 11.0.54 with 11.0.19 maps seems to work nice. (no hangs within 10 targets)
    The problem with wrong steetnames persists in both versions with old an new maps.
    The name of my hometown exists 5 times.
  • Hello,
    Got 11.0.56. with only east german map and earth map seems to work (treied 10 targets, no hangs)
    Now putting other maps to the device...
    BTW.: yesterday I wrote: I deleted maps except of one, this wasn't true, I found in  logfile, that navigator found the maps at my SD-Card ( I didn't deleted them really, only moved them) so I don't now, if 11.0.54 without czech map  runs or not, sorry for wrong post.
  • new version - new maps - no problems

    thanks alot
  • Hello, agree with ahr,
    11.0.56 runs fine with actual maps. Great work.
    Problem with to much streetnames persists, saw it in two towns but its not a big problem, as long as the streets, what are really there, are not missing.

    Thanks, Rockford
  • I can confirm that with 11.0.56 update all seems to work OK. Thank you.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion