Test of Android version 1.6.x
  • Hello,
    the download link http://download.mapfactor.com/mapfactor_navigator.apk is now redirected to version 1.6.4+ available for testing. If you need older 1.5.22 it is available at http://download.mapfactor.com/mapfactor_navigator_stable.apk

    -updated translations (el, es, fr, hu, lv, nl, ru)
    -TTS british/american english
    -TTS exit names
    -current journey time in infopanel
    -reset to default updated
    -bug fixes
  • 86 Comments sorted by
  • FYI http://download.mapfactor.com/mapfactor_navigator.apk now points to 1.6.20+ with couple bugfixes and potential buffer overflow bug.
  • 1.6.4 crashes with tts voice on my phone, both with Google tts as well as SVOX tts.
    Samsung S5 mini, Android 4.4.2.
    For some reason MNF was "suddenly" on recorded voice, so I switched to tts. MNF crashed immediately and now crashes on startup.
    Reverting back to 1.6.2 as it simply doesn't work now.
  • I do not have this problem (Google TTS)
  • @hvdwolf
    yes, our programmer was modificating TTS, it is possible that it doesn't work on some devices, thank you for report... we try to fix it soon
  • Ditto: 1.6.4 Crashes on Moto G and on Nexus 7 (4.4.4)
  • Same for me on 4.1.2.
    I couldn't open it once in order to change settings.

    Log stops at

    DMP 15/04/01 08:18:55 (JAVA) Settings::setProperty(/APP/navigation_voice,sound-de-tts(DE))
  • Crashes, after delete tts.xml it works.
    It works with old 'tts.xml'.

    ...but without TTS (Ivona, Google).
    Crashes with TTS.

    After renaming tts.xml, navigator starts without TTS.
  • Thanks, Przemek. Worked also for me.
  • 1.6.5+ is here: http://download.mapfactor.com/mapfactor_navigator.apk

    -updated nl translation
    -TTS crash fixed
    -attempt to reduce GPS delay
    -trigger playback pause(settings/advanced/notify other apps about voice command)
  • tts works fine again. It was a very short 2,5 km trip.
  • Seems to be working alright...however I've done only 20 km with it during rush hour in the city
  • @Lubos: You mentioned in the "release notes" for 1.6.4: "-TTS exit names"

    What do you mean with that? I tested with a few motorway exits (in simulation mode) and I expected something like "Take exit 18" or "Take exit Zwolle-Zuid" as I know it has that name and number.
    However, MNF just mentions "Take the exit".
    For me that is in Dutch. Is something not correct or is the tts.xml not adapted for Dutch yet?

    Edit: Which name and number do you use in MNF? The motorway_junction name and number tag, or the motorway_link name and number tag?
  • Works in simulation on Moto G2nd gen (XT1068) android 5.0.2, and on Galaxy Tab 2.7 (GT P3110) android 4.2.2
  • With version 1.6.5 the TTS voice doesn't say the street names anymore. It just says "turn left, turn right". Reinstalling 1.5.2 everything is ok. My phone is LG L9, android 4.1.2. I have set Android and Navigator in English but I use Italian TTS voice..
    By the way 1.6.3 and 1.6.4 crashed on start.
  • Check your settings. Mine were set back to recorded voice.

    If it's really your tts still not saying street names, you'd have to fix the tts.xml and probably the navigation.xml yourself.

    I didn't test it yet, with German language.
  • Try copy tts.xml and navigation.xml from 1.5.2 to 1.6.5, both or only one.
  • Works fine with German and English TTS in simulation mode.
  • I believe it really depends on my tts. I opened those xml's but don't know how to fix them.
    In the meantime, I can downgrade to 1.5.2 or live without street names, no big problem :).
    I may experiment a bit and see if my tablet has the same problem..
  • PrzemekSupak. I installed 1.6.5  on top of 1.5.2 so I believe that tts.xml and navigation.xml come from 1.5.2. Maybe if I rename one of them or both, they are created again as default..

  • After installation 1.5.2 copy both files from navigator to 'documents'.
    New installation 1.6.5 and copy both files from documents should work.

    I use old 'tts.xml' and it works fine.
  • @hvdwolf exit names are avaible in Tomtom maps for now
  • if you delete tts.xml, default one will be recreated
  • @tomas maybe normally, but the application crashes before the file is created.

    This is really strange. After update to 1.6.5,the app ran fine.
    I saved the tts.xml and navigation.xml, then I modified them. I don't know what went wrong with the new files, but the app crashed again. Ok, let's restore the saved files for 1.6.5.... Still crashing!!
    That's when I deleted the files, but still without any success.
  • PrzemekSupak, thank you for helping me.. I tried it but nothing has changed. The funny thing is that the English UK synthesised voice says the street names. The Italian one does not :)
  • 1.6.6+ is here: http://download.mapfactor.com/mapfactor_navigator.apk

    -LV language added into selection
    -TTS fixes (US voice, IT streetnames)
  • It works with1.6.6.. well done!!!
  • Btw issue with polish translation still exist - I use "my own" tts.xml file and everythink seems to be fine:


    I just added my own translation (Synthetized Polish):
    A-SM-03-00 Lekko w prawo,
    A-SM-05-00 Lekko w lewo,
    By-SM-03-10 lekko w prawo,
    By-SM-05-10 lekko w lewo,
  • Download more voices.... goes to download list of available maps. Ver 1.6.6.
  • @lubos

    One comment on the "smoothness" of the rendering - I assume that's what you meant by "attempt to reduce GPS delay" ... I do not see it to be honest. You said (in a different thread) that for some phones it's really smooth but on Nexus 5 I do not see this. Is this gonna be further improved? I think it would greatly improve the experience.

    Thank you
  • There are voices too in list but we know that this is bad. Thank you for report anyway :)

    "attempt to reduce GPS delay" means something different. Some users have problem that voice commands are told too late. This "attempt" can give you voice command 500ms-1000ms faster.

    About smooth renderer - I created known issues list of smooth renderer and it was too long... We must reduce it first and then we will see
  • MNF 1.6.6

    The blue "exit signs" on motorways are no longer correct. They are displayed when driving on the exit itself, not on the road where you need to take that exit.

    I drive the motorway and the exit signs shows me the direction of the on-going road itself, not the exit. Then I take the exit and while driving on the exit the exit sign for the exit I'm driving on is displayed. At the bottom of the exit at a cross-roads I have to go left, straigt on or right. When I take the right, and driving on the that road then the exit for that "right exit " road is displayed.
  • please give example

  • As I can't find out how to get the coordinates from a point I select/point on the map, I can only give a general direction. 
    Start: A28, Netherlands, Zwolle coming from the south just before the river.
    destination: Netherlands, Zwolle (Zwolle region), Ijsselallee, (No preference), crossing with Hanze Allee
    Edit (thanks to @chattiewoman): start: 52.49768 6.04846   ; destination: 52.50126 6.08414

    The overview image 01 displays the Exit of the motorway (bottom left) and the exit of the round-about at the end of the exit.
    Image "02": This image SHOULD display "Zwolle-Zuid, Hasselt, Almelo". Instead it displays the direction of the further away town and the next exit (Groningen, Zwolle) following the motorway. This is definitely all wrong as that is the direction to continue on the motorway.
    Image "03": This image SHOULD display "Ring zuid, Hasselt, Almelo". It displays the sign I SHOULD have when driving on the motorway telling me which exit to take of the motorway (image 02).
    Image "04- No directions": This image SHOULD display nothing as I'm already on the (lower grade) road without directions. Instead it displays "Ring Zuid, Hasselt, Almelo" which should have been displayed when driving on the roundabout itself towards the roundabout exit (image 03)
  • @hvdwolf About the coordinates:
    In map, drag the point to the exact middle of the screen. Then go to search - - > coordinates and simply find the coordinates there.
  • Thanks a lot. I have updated my post.

  • @hvdwolf "The blue "exit signs" on motorways are no longer correct." ... do you mean that in 1.5.x it worked and now it stop to work? There were no changes in data until now reading the exits and integration of 'ref' tag with 'motorway_junction' but this will be visible in April data ... so I would like to double check that this is caused by application and not data.
  • @mdx: The blue road/exit signs worked fine in 1.5.x and I do think it worked correctly as well in 1.6.2, but that was indeed before the added functionality of the motorway_junction tag.
    They still work in 1.6.x, but the "timing" is not correct: They are too late.
    In 1.5.x they were displayed in advanced, like they should. If you need to take the exit, the exit directions were displayed.
    Now in 1.6.6 the road/exit signs for the exit are displayed on the exit itself, not before the exit.

    I will try to test tomorrow with 1.5, and we will see what the April version of the map brings. I will switch on early maps.

    Edit: Before 1.6.6 the road/exit sign was displayed before the motor junction, as it is supposed to be. In 1.6.6 the road/exit sign is displayed after the motorway junction on the road segment is it added as tag.
  • I tested with 1.5.2 with the latest (standard) Netherlands 44-201503110 map and that one works as supposed. The road/exit signs are displayed at the correct moment before the actual motorway_junction.
  • 1.6.5 worked fine with the exit signs.  Germany north 6,3,2015
  • @hvdwolf - thanks for extra tests. There is now available 1.6.7+ which should fix the problem with signposts:
    Please let us know if the problem persists

  • Hi Martin,

    To start with: I will use the English definition of lanes for a motorway which are different from Dutch, German, French (and who knows more). Therefore, a 2-lane motorway has 2 lanes going forward and 2 lanes going backward. A 3-lane motorway has 3 lanes going forward and 3 lanes going backward.

    It does not work entirely correct yet. It works in 90% of the cases (or so). 
    I did not completely pinpointed the issue yet, but it seems that with a one lane or two lane road (motorway)  the directions are displayed correctly.
    It seems that with 3 or more ongoing lanes with 1 or 2 exit lanes the directions currently get combined. It shows me the correct exit to take with the right "exit arrow" and also the lane-assistant at the bottom is OK, but on the signpost it mentions all directions, both the ongoing as well as the directions for the exit.
    This means that mostly on motorways, trunks and lower grade roads having a two-lane road (2 forward, 2 backward) with one exit it works correctly (see also bottom image). 

    It also makes a difference if you have 3 ongoing lanes with one or two exits, where the most right ongoing lane also functions as an exit lane.
    Edit: In the below images the lane assistant is correct, but the signpost based on the lane assistant is not always correct.
    Mixed lanes going wrong:

    Separate lanes working correct:

    But as said: It needs some more detailed analysis
  • FYI there is 1.6.11+ now which enables passing though barriers with a penalty

    @hvdwolf - I am not quite sure what do you mean :(. If you give me coordinates of better wayID where do you think it is correctly mapped but incorrectly displayed I can check it
  • There is also fixed visibility of road numbers in 1.6.11+
  • @mdx: See comment 9551 above where I specify the coordinates.

    Or going from way-id 6505882 to way-id 6505867 and then taking the exit to  way-id 6505874.

    The sign and the lane-assistant (bottom) show the right exit, but the sign displays the wrong text. It displays the text for the ongoing destination, not for the exit.

    I can see that someone added a destination after I added my destination:lanes, but that destination is also correct.
  • Happy to see all this activity re 1.6.xx.

    Unfortunately I got stack on 1.4.24 as the newer versions have the "assertion failed" incorrect state and when that happens app crashes - see discussion http://forum.mapfactor.com/discussion/comment/9578#Comment_9578 .

    Are we getting closer to a solution? I would love to start using some of the enhancements!
  • still no solution :(
  • 1.6.12+ is here: http://download.mapfactor.com/mapfactor_navigator.apk

    -updated IT, RO translations
    -line to destination
  • 1.6.13+ is here: http://download.mapfactor.com/mapfactor_navigator.apk

    -updated IE, LV translations
    -bug fixes
  • I like the product. But why a route to navigate and a route to simulate? Strange.
    Also it could do with opengl hardware acceleration. On the roadmap already?

    Edit: GL already in alpha. Didn't notice. Exciting.
  • One for navigating while actual moving. Simulate (static, not moving) for planning trip @ home, ...

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion