External SD & Kitkat
  • Are you planning on updating the app to allow saving maps to the external SD card with Kitkat (Android 4.4)?

    I updated the app to the latest with no success.

    Please advise.

    Thanks for your time.

  • 18 Comments sorted by
  • it works for most users, try to close Navigator and delete data in Android settings/application
    manager/Navigator - then reboot your phone. If this does not help,
    please email logs (navigator/log folder).
  • Thanks for the quick reply, Tomas.

    Your suggestion worked great.

    Thanks again for your time.

    - Dave
  • I have a Sony Z tablet with android 4.4.4.  Until now it has worked well updating maps.  Now on starting Navigator I get a message: "The Navigator folder is set as read-only.  This could be because the device has been updated to Android 4.4 or higher."  After clickng the only option, "OK", I get another message "Unfortunately, Navigator has stopped." inviting me to report the error or not.

    How can I get Navigator working again and updated maps downloaded?
  • Did you already try tomas' suggestion only two posts before yours?
  • Thanks, but going to Settings|Apps|Navigator shows 2.53GB of data on device that comprises downloaded maps that I don't want to have to re-download.  The folder storage/sdcard1/navigator/log is empty.
  • why not take backup?
  • Because the backup application asks where to store (answer: SD card, 6.9GB available), yet reports "not enough space" when selecting the Navigator app and starting the backup.
  • can you backup to your PC?
  • No, because the backup application still only offers the SD card as the location although the Xperia is recognised by the PC (using Debian 7.7) but not shown in the file browser nautilus.
  • why do you need to use backup application? just copy files with a file explorer
  • On GNOME desktop you need mtpfs package(your case), on KDE you need kio-mtp package to see your device on PC
  • I thought you suggested a backup ...
    Copying doesn't work between sdcards:  I think this was a restriction introduced with Android 4.
    Anyway, I tried a few moments ago to update maps and the message appeared about Navigator having stopped + Report or OK.  It then started to download a list of available updates and to download them fully. What was the original error?
  • Coming back to the subject "External SD & Kitkat"

    My OS is kitkat an I have a 32GB external SD card. Data on that card are accessible through several applications, 

    But the Mapfactor app tells me that I can't move map data because I have only one SD card. The external card is not recognized. Closing the Navigator, deleting the data in Android settings and rebooting didn't work. De-installing all and reinstalling the app and maps didn't' work either. 

    What's the email address for sending the log?

  • go to Settings and click Send logs
    please type description, otherwise we will not look at it
  • @kmap - you can try 1.4.18+ available at http://download.mapfactor.com/mapfactor_navigator.apk ... that should fix some issues with SD Cards.

  • Great job guys on the 1.4.18+ !!!...
  • 1.4.18+ doesn't show up (yet?) on Google Play.
  • No, because it is a beta. You can try it at your own risk.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion