[SOLVED] Mapfactor stops with shared location (URI Intent) in Android
  • UPDATE: Version 1.4+ has fixed this bug. If someone would like to know adequately how to share and open a location with Mapfactor in Android. Please check the official Mapfactor Intent guide for the right URI syntax: Intent Guide

    I use an app to stored locations in android (Easy Navigation) which allows to share and open a location with MapFactor. When I do that, Mapfactor shows a "navigation menu" with several options (navigate, set as destination,.., save to favorites, show in map, etc)

    BUG description: If I choose any option from the "navigation menu" (exception "show in map") immediately Mapfactor freezes and I can't do anything. Actually I have to kill the process to stop the application process which makes this bug kind of frustrating.
  • 19 Comments sorted by
  • What version of Navigator do you have? (latest is 1.1.5+ available here)
  • Hi,

    Yes I'm trying already with that version (the same as in the playstore) and still freezing.
  • The developer of Clicknav send me the error code in MapFactor for this bug. Maybe this can help:

    02-12 16:17:37.213: E/MPFC(447): (JAVA) java.lang.NullPointerException
    02-12 16:17:37.213: E/MPFC(447):           at com.mapfactor.navigator.map.MapActivity.onMapPostActivityResult(MapActivity.java:874)
    02-12 16:17:37.213: E/MPFC(447):           at com.mapfactor.navigator.map.MapActivity.access$200(MapActivity.java:76)
    02-12 16:17:37.213: E/MPFC(447):           at com.mapfactor.navigator.map.MapActivity$1.onClick(MapActivity.java:259)
    02-12 16:17:37.213: E/MPFC(447):           at com.android.internal.app.AlertController$AlertParams$3.onItemClick(AlertController.java:934)
    02-12 16:17:37.213: E/MPFC(447):           at android.widget.AdapterView.performItemClick(AdapterView.java:301)
    02-12 16:17:37.213: E/MPFC(447):           at android.widget.AbsListView.performItemClick(AbsListView.java:1280)
    02-12 16:17:37.213: E/MPFC(447):           at android.widget.AbsListView$PerformClick.run(AbsListView.java:3071)
    02-12 16:17:37.213: E/MPFC(447):           at android.widget.AbsListView$1.run(AbsListView.java:3973)
    02-12 16:17:37.213: E/MPFC(447):           at android.os.Handler.handleCallback(Handler.java:615)
    02-12 16:17:37.213: E/MPFC(447):           at android.os.Handler.dispatchMessage(Handler.java:92)
    02-12 16:17:37.213: E/MPFC(447):           at android.os.Looper.loop(Looper.java:137)
    02-12 16:17:37.213: E/MPFC(447):           at android.app.ActivityThread.main(ActivityThread.java:4921)
    02-12 16:17:37.213: E/MPFC(447):           at java.lang.reflect.Method.invokeNative(Native Method)
    02-12 16:17:37.213: E/MPFC(447):           at java.lang.reflect.Method.invoke(Method.java:511)
    02-12 16:17:37.213: E/MPFC(447):           at com.android.internal.os.ZygoteInit$MethodA
  • google play did update mapfactor to 1.1.5 today on android 4.2.2 (asus memopad hd 7)
  • I was already using the v1.1.5 when I posted the bug. No solution yet
  • Thanks. I will let you know when the bug is fixed (hopefully next week).
  • After 5 months and several updates this bug still persist in v1.2.50. I understand that you're busy with other features but I would like to insist asking for a solution.

    This time I attach two screenshots to illustrate the bug:

    -As described above, I use the app Easy Navigation to storage my frequently used or new destinations and of course I have set Mapfactor as my default navigator for the car. Then after tapping a desired destination from the Easy Navigation's item list, Mapfactor launches and shows this option menu:

    -The bug happens when choosing any of the three options inside the red area above (set as departure, waypoint, destination) as Mapfactor immediately stops and closes with a notification error (next image). Which means that I can not set as destination the shared location from Easy Navigation and therefor it is impossible to navegate.

    I hope there will be an update soon with a real fix. No doubt it would make the navigation much easier and allow a wider interaction from 3th apps (promoting even more the Mapfactor usage).
  • Can you try 1.3.20+ (http://download.mapfactor.com/mapfactor_navigator.apk) ... as far as I know at least coordinates should be fixed and there were also other related bug fixes.
    p.s. do you have Google Analytic enabled?
  • @mdx

    Hi Martin

    Sorry to reply this late.

    I tried with v1.3.24 to open a location from Easy Navigation (sharing coordinates through geo URI) and still in some cases Mapfactor freezes and quits after error.

    I posted my conclusions almost two moths ago
  • My colleague suggested to add here following link:
    ... but I am not sure if he has enough info to repeat the bug. The link is now pointing to 1.3.36+.
    p.s. he says that intent from clicknav works in his case ...
  • @mdx Thanks for the reply, Martin. 

    Actually I tested again with last app version 1.3.40 and the bug above exists only if no address is given within the Intent's URI. In particular this includes the very frequently used schemes:
    geo:lat,lon and http://maps.google.com/?q=lat,lon
    (except for http://maps.google.com/?daddr=lat,lon which works ok). 
    Otherwise with both address and coordinates, everything seems running great.

    Also, I would like to point out that any location url starting with (secure-protocol)
    https is not supported by Mapfactor, so far only the standard http is recognized.

    Anyway I'm happy to see that there's an official wiki guide for the Intents and I will update the other thread to add that useful information.


  • URI Intents seems fixed now.

    Starting from beta v1.4.7

    Thanks to the dev team!
  • Starting from 1.4.7?
    Which version are we talking about? Android is still at 1.3.43.

    I created an app for myself which uses this as well and already works for some time.
  • Well, yes - there was already _unofficial_ 1.4.7 build, to fix some particular problem. But in that build there are some incomplete dialogs etc. 1.3.43 is in stage release on Google Play, so I would wait till complete release and then I would move 1.3.43 to "stable" link and maybe publish 1.4.x here on the forum. At the moment it is "work in progress".
  • Ok.

    What I meant with "I created an app for myself which uses this as well...". The app is a "add POIs" app that checks whether the navigation app already has a POI in it's maps at that location or not. so I don't need an online connection. But it is far from finished.

    I use for address:
    action:  android.intent.action.VIEW
    activity: com.mapfactor.navigator.map.MapActivity
    address: geo:0,0?q=<address>

    And for coordinates:
    action:  android.intent.action.VIEW
    activity: com.mapfactor.navigator.map.MapActivity
    address: geo:<latitude>,<longitude>?z=<zoomlevel>

    This is how it is described in your knowledge base and it works fine.

  • @hvdwolf
    Sorry, v1.4.7 is indeed a quick fix beta version (google+ beta community), so I should've said v1.4+
  • UPDATE: Version 1.4+ has fixed this bug. If someone would like to know how to effectively share a location through URI Intents in Android. Please check the official Mapfactor Intent guide for the right syntax: Intent Guide
  • That official Intent wiki guide are the intents MapFactor Navigator listens to.
    The official Android Maps (and other) intents are here.
  • @hvdwolf
    Yep you're right, I referred to sharing the location with Mapfactor. It's not a general guide.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion