cannot download map of Austria
  • I have a problem to download the map of Austria to my Xperia Z. After I start download it shows no progress at all. With other maps there is no problem. If I choose to download couple of maps at once including the one of Austria, download proceed normally until it starts to download Austria. It just shows 0 of 97 MB and thats it. I have already reinstalled software and rebooted phone but it did not help. Please advise? 
  • 9 Comments sorted by
  • our servers seemed to be fine, please try again.
    you can also download maps using our PC version:
    once maps are downloaded, copy them to your device, navigator/data folder.

  • I have recently encountered a similar problem trying to update maps and downloading a new one to my Samsung nexus S  phone (OS Android 4.1.1), but have not had any problems doing the same with my Asus nexus 7 tablet (Android OS 4.4.2).

  • Hi LukerZet and deganid,
    is it solved? (there were some issues regarding conversion to multiple servers on our side) ... if the problem still persist (from today on), please download the latest 1.2.35+
    and send us log files via (Settings > Send Logs)
    thanks for report
  • Hi Martin,

    I've just tried, and the problem is still there. 

    The version I have on my phone is 1.2.25. I'm not sure I understand how to upgrade to 1.2.35 with the link you gave me.


  • With the link, you will download an apk file on your device. Then you must open (run) this file in order to upgrade.
  • I couldn't do it directly.  I had to download the *.apk to my pc and copied it to the phone.

    Anyway, it helped.   I can download now map files form MapFactor site.   It seems very slow, though.

  • Hi,

    It happens again.   It gives a list of updates for existing maps but does not download them when requested to do it.

  • try it from another hotspot?
  • Did you try to switch download from torrent to direct? See enhanced settings.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion