Jerusalem is missing
  • I want to use the map of Israel but Mapfactor can't find the city Jerusalem. 
  • 29 Comments sorted by
  • how old map of Israel do you have? I tested in 20130216 (available on early maps) and it finds that correctly (in PC navigator). It is possible that the polygon for the city was not valid in some older version.

  • I downloaded the map of Israel from MapFactor and transferred it to my mobile phone (Windows Mobile 6.1). When I want to search for Jerusalem its just not there. The streets are there but I can't get there because I can't select a city to go there.
  • is the map version 20130216?
  • Where can I check this?
  • setup utilities/install map data/manage map downloads/free regions - hold pointer on the Israel line
  • It is map 201302160.
  • and can you find Jerusalem in PC Navigator?
  • No. The area where Jerusalem is located says "Lifta". But Lifta gives me just a couple of streets. So it definitely doesn't represent Jerusalem
  • Wait. With PC Navigator you mean the application installed on my PC. I haven't done this but could try this. Wait for a second.
  • Oke. It's getting more wird. I see Jerusalem but in Hebrew. Then when I zoom in Jerusalem is gone and again I see "Lifta" and other area's but not Jerusalem. My guess is that it is some kind of political tric from OSM.
  • but yu can search for Jerusalem? If yes,then copy the new Israel map file to your device.
  • As a matter of fact I can search for Jerusalem in PC Navigator. Where has PC Navigator installed this map? I can't find the map file? 
  • Yes it is working. I installed the map again on my mobile phone and it is working now fine. Like the app anyway and I am planning to use it a lot. Thanks a lot Tomas :-)
  • I have the new ver. of the Israel map and I kann't find Jerusalem, also install PC Navigator and could not find there too.
  • There used to be (and probably still is) problem of map division into not-overlapping but fully-covering areas. At the moment we use

  • I did vor 2 days a map update and since then I have the problem. can I get the older version somehow? I tried looking for it on the net but found nothing.
  • If you are using "Early maps updates" (Advanced settings), you can temporarily disable this check box and download "stable" maps. This works only the first week after the maps were available for download.

    Do you know how old were the maps? I tried 2013.12 and it does not work there too ...
  • I don't know the version of the map. I was in November in Israel and it worked. I think I downloaded the map in september but I have no idea the nummber version.
  • Well, I tried September data and it failed there too. I would rather focus on current/new maps to fix/improve it there ...
    There is no "name" ... I believe that it is because it is not clear what language it should be ... and there is "int_name" instead (?). Because it was edited more than 1 year ago, I suppose you could not find it before (???).

    We are using some alternative names like "name:en", but only when "name" exists. Maybe some OSM mapper could comment on this?
  • thank you for your explaination. well i'll have to live with it, or use other App where I can have TomTom map.
    I don't understand enough, I'm just a user.
    Thanks again

  • OK - it should be fixed in March 2014 data, i.e. if 'int_name' is available and 'name' is missing, 'int_name' will be used instead.
  • oh...thank you. I hope it will work
  • I have the new version of the map and I can actually write jerusalem and it give me result. but...I kann look for just a few streets in the region of the old city. if I want to look for other streets, it does not find. I have to use Google search (and I need internet fot it.)
    I appreciate the effort you made.
  • Do you type the name of the street (even if it is not listed)? There should be filter and search in nearby area ... can you give me an example?
  • I tried for example the street Agron (really near the region), Herzl Blvd (tried to write it : Herzel, Hertzel. Hertsel....), Derech Ruppin (Ruppin Road), and many more. did not work.
  • It is strange - if I switch to English I am able to find "Agron" (I originally tested that on PC Navigator and it worked there). Then I tested it on Android with Czech language selected and it did not work. What language do you use? I will investigate it more next week.
    p.s. do you have maps palestine_osm.mca also downloaded?
  • I have German language on the mobile and default on the navigator, also german. But the map is in Hebrew, I don't know why it is so. On my husband mobile it is the same and he complain as he cann't read the map. 
    I can not write the streets in hebrew, it does not recognize whats written.
    I write in german.
    should i download Palestine also?
  • try to switch application language to English
  • wow.. it works, in English I have much more streets, actually all I tried worked. And the map is in English not hebrew. Now I'm ready for vacation.
    Thanks a lot 

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion