Navigator Free on Wince PNA : File timestamps usage ?
  • Hello,

    Still trying to understand why Navigator Free (12.3.0) often freezes at startup on my Wince 5.0 PNA, I wonder if it could be a timestamp issue.
    I explain myself :
    My device (Viamichelin X-960) does not provide "natively" a possibility to adjust its internal date; the bundled software only provided a manual setting for time, not date, and there is no normal access to wince control panel. And no adjustment was made according to the GPS date / time.
    So, by default, the internal date is January 1st, 2007 ...
    When starting Navigator Free, I check the appropriate box to have the internal clock adjusted from GPS time, so, after a fix, everything is fine.
    During my tests, I have often tried to "hard reset" the device, thus setting its internal clock back to January, 1st 2007. Now, suppose I start Navigator Free and lead the app to write data onto the SD card before new date/time readjustment : It may try to update / overwrite a file the timestamp of which is far later than the false current date / time ! ** IF ** the app implements any control with these timestamps, things may become difficult ...

    It's just an idea from a confused user !

  • 4 Comments sorted by
  • We are not aware of any timestamps usage on Navigator files.
  • Hi Mdx

    And thanks for your comment ...
    During the meanwhile, I've managed to get a "cleaner" system : uninstalled the original satnav app from my device, got correct date/time, load only stritcly necessary extra DLL's , found out how to properly (I think ...) close the program.

    Yes, I'm still not absolutely sure its shuts down properly, although the log file ends with "Application has finished", because the map remains displayed on the PND screen, and the clock display is continuously updated. It remains this way until I tap once more onto the screen, after what the startup loop (from the device rom) restarts.

    Anyway, it **seems** to restart now; there were issues with the way my script controlled the PND's startup sequence (these devices are known to be particularely tricky to "unlock").

    I go on testing the program and I hope it will work for me now, I'll come back with the results.
  • The splashscreen at the end is "an advertisement", i.e. expected, sorry ...
  • Oh yes, I saw it with the PC version, but I speak of the map itself ... Sorry for the "advertisement", in fact it only flashes very, very quickly (1/10 th of a second or so), and then we're back to the map ... Maybe something to do with my PND's "internal" software, it has an exe ("PndScreen.exe") to manage the background display. Not annoying anyway since everything works!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion