How to get latest version?
  • I have version v.11.0.19 installed. According to the Changelog? thread the latest version is v.11.0.28. When I click Product Update it doesn't find anything. I have tried to uninstall and re-install and I still get v.11.0.19. Is there something I am missing? How do I update to the latest version?
  • 7 Comments sorted by
  • The 11.0.28 is the version of Navigator (PC/Pocket/PND). Isn't it v.11.0.19 in your case version of Setup Utility? (if you start it you should see it in the right bottom corner).
  • The bottom right corner of the Setup Utility displays 11.0.15 FREE. When I click Menu -> Settings -> About in Navigtor Free it shows v.11.0.19.
  • Hello,

    could you send me log file from Setup Utility? On WinXP it is stored at

    "c:\Documents and Settings\USER\Application Data\MapFactor\Pocket
    Navigator Installer 6.0\setup.log"


  • DMP 2011/09/30 08:18:04 MapFactor Navigator installer application start
    DMP 2011/09/30 08:18:04 cmd line parameters: "C:\Program Files\Navigator11\Setup Utility\setup.bin"  "C:\Program Files\Navigator11\Setup Utility\setup.exe"
    DMP 2011/09/30 08:18:04 RcfReader: C:\ProgramData\MapFactor\SetupUtility\regions.dcf opened successfully
    DMP 2011/09/30 08:18:04 executable: C:\Program Files\Navigator11\Setup Utility\setup.bin
    DMP 2011/09/30 08:18:04 version: 11.0.15
    DMP 2011/09/30 08:18:07 Remote device connected:Desktop v1243340.1728932086 build 31753552
    DMP 2011/09/30 08:18:10 Clicker agent installed succesfully.
    DMP 2011/09/30 08:18:12 Remote device connected:WindowsCE v5.0 build 1400
    DMP 2011/09/30 08:18:13 HttpDownloader::downloading
    DMP 2011/09/30 08:18:15 HttpDownloader::downloading
    DMP 2011/09/30 08:18:17 RcfReader: C:\ProgramData\MapFactor\SetupUtility\regions.dcf opened successfully
    DMP 2011/09/30 08:18:17 HttpDownloader::downloading

  • Same problem as ghackaray. The PC-version is 11.0.15 FREE while the Windows Mobile version shows 11.0.16. I download the whole software just today. Nevertheless software is running well. I first just installed the maps and after a few starts also the speedcam-files. Now all maps are displayed what did not happen in the past.

    Thanks a lot.
  • @ghackaray - thanks for the log, it looks ok. Can you have a look at your automatically downloaded file
    and check the version there? There is section PocketNavigatorCab, PocketNavigatorRar and PcNavigator, each starting with version info available on the web.
  • I couldn't find a version number. But I did delete the C:\ProgramData\MapFactor folder and ran the setup utility again. It downloaded the files and when I check the version number on my CE device it is now v.11.0.28. So that seemed to do it. Not sure if I'll have to do this everytime to get the latest version.


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion