not enough space
  • Hello,

    I installed mapFactor Navigator Freeon Samsung tab 2 7 P3110 Android 4.0.4 16 GB with external SD-Card 32 GB.

    Maps are installed on the external SD-Card: /mnt/extSdCrad/navigator

    Downloading osm maps stops with the message "not enough space".

    There are more then 15 GB free space on ext. SD-Crad.

    Can anybode help me solving this problem?


  • 10 Comments sorted by
  • start Navigator, go to Settings/Advanced and click Change installation - see what happens
  • German version

    Einstellungen/Other:Fortgeschrittene/SD-Karte ändern:

    -> Externe SD-Karte is selected

    Pfad: /mnt/extSdCard
    Platz: 19.8 GB/29.7 GB

  • Several attempts have failed.
    After removing the external sd-card and restart the download works fine.
    Thank you!
  • OK, good - one possibility is wrong message of downloader version 0.12.18 ... slightly better report has 0.12.20 (and higher) available here (and later will be on Google Play too).

  • Hello,

    I have still the same problem. I removed the SD and changed the app-istallation from SD to internal storage. I'm useing the Samsung Ace 5830i with Anroide 2.3.6 and about 27 GB free space on the SD. I already download these OSM-Maps:

    Beldium (40 MB, Version:201212180);  Germany East (83 MB; Version 201212140);  Germany West (0,2 GB, Version 201301010); United Kindom (0,2 GB, Version 201212190)

    But I cannot download Germany North or Netherland. The downbloads stop under Version 0.12.18 with "not enough space". After Update to version 0.12.20 the downloads stop with the remark "fehlgeschlagen" (failed).

    So what can I do the get the OSM-Maps I would like to have.

    Thanks for your help



  • I had the problem after a change to CyanogenMod 10.2, the App didn't recognise anymore my external sd-card path, which is now:


    before it was:


    But in the terminal I could do just:

    ln -s /storage/sdcard1 /storage/extSdCard

    This worked for me on my SGS2, with previous 4.1.2 on it and now CM10.2

  • I am not sure if this will work, by try to edit file navigator.log.txt
  • "navigator.log.txt" is only output file, where are listed all paths to detected "SD cards"
  • After I updated from 10.2 to 10.2.1 ( I think that was the probem) the symbolic links didnt work anymore. but a dev. of navigator gave me a fixed version of navigator:
    this works now.

  • Thing is, that the path from external sd card is difficult to get reliable for all systems.
    So they have to check each system if they can read out the path.
    Clear that they cannot install on each phone each possible rom to test.
    They need user input for it, so best to send question to support than they can fix.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion