Saint-Gingolph - strange routing
  • Interesting behaviour with a route from 46.393005 / 6.804990  to 46.393532 / 6.803965 (lat / long). It’s in Saint-Gingolph, first one on swiss side, second one on french side of the city, about 100 m away from each other. Navigator plans a route which is almost 174 KM long (car with motorway and toll-road).

    Same route on looks better (320 m) while Google Maps goes directly (99 m). I don’t know which one is actually correct but I don’t think the Navigator-route is.

    P.S.: Same from 46.249342 / 6.846952 to 46.25038678 / 6.845621161. Seems like Navigator doesn't like the border between Switzerland and France.

  • 4 Comments sorted by
  • I tried both routes and have no problem
    see if your maps are from the same month
  • Tomas, you are right, the map of France was from August, Switzerland from December. The setup-utility never offered me an update of the map of France, but searching the forum I found out that there is a new version, consisting of 4 parts. I suppose this is what causes the weird behaviour.

    It took me a while to find out how to get these parts downloaded. After copying them to my android-device the former incorrect routing worked fine there. Now I'm trying for hours to find out how to get the french maps to work in the PC-version of Navigator, without success until now. Even after a complete cleaning of the PC, activating the early map access, downloading and reinstalling the setup-utility and the application I find every map I download in PC-Navigator, but not the french one.

    At a few places I read about a PC Navigator version 12.3.0, but mine still is 12.1.0, only the setup-utility is 12.3.0. Any hints what I am doing wrong?
  • JambaFee, yes, you have to install new PC Navigator. The recognition of updates fails sometimes - one way is to delete existing installation (the path is something like
    and it will force setup utility to download new installation.
    thanks for report
  • That was an the important hint - to delete the setup_pc_navigator.exe-file. The trick is: If you change the path for "downloadable content" e.g. to X:\PATH this setup-file is stored in the directory "X:\PATH\Install" and has to be deleted from there. I never did this before and obviously therefore always got the old version installed.

    Now finally I also have version 12.3.0 installed. Which leads to the next error (see thread "PC Navigator - Settings - About").

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion