Installing Navigator Free on WinCE 5.0 device
  • Greetings. I have a Mio C320 running WinCE 5.0 that I have unlocked using MioPocket 4.0 rel 68 (latest). I have been attempting to install Navigator Free on the device, but I am not finding any documentation that explains exactly how to do it. I have downloaded the latest installer from Mapfactor, but it does not appear to support my device even though most of the discussions I've read would indicate otherwise. When attempting to execute it (using Explorer in WinCE), I get the message "'NavigatorFree_install" is not a valid Windows CE application".

    Is there an archive of older versions that might work?
  • 18 Comments sorted by
  • "'NavigatorFree_install" is Setup Utility for PC, where you can download maps and also your WinCE application.
  • I think you need to install Pocket Navigator, not CE version
  • Thank you, tomas. The thread you linked appears to discuss when the application will not launch after installation due to missing DLLs. I did see that previously, but dismissed it as I cannot get to the point where the installer will run. 

    Or am I missing something? I interpreted the downloaded file as something to install in WinCE, not to run as a binary from within WinCE.
  • you need to change path to navigator.exe on your device
    if this cannot be done, then you need to change path and rename navigator.exe to fit what your device expects - I have no idea what it is, you need to look at SD which was in your Mio
  • I have the same issue on a win CE 5.0 device and NavigatorFree 14. Also tried version 12.
    Tried installing. Tried copying.

    EDIT: I have a problem with the installed CE version navigator.exe not "NavigatorFree_install"

    Using Pocket Loox N100, which has a Samsung SC32442 CPU and 64MB RAM.
  • I tried the Pocket Navigator. It installed the cab and everything went smoothly. Clicking the program shortcut it created it said it is missing some files. I copied all the possible dlls I know and now it says the same error: "'navigator" is not a valid Windows CE application" :(

    What else to check?
    BTW, thanks for your help tomas!
  • you probably need one or more of the following
    you just need to try all combinations :-(
  • Got it working!
    Some of the missing dlls that I got were not ARM but x86. One was even 16bit.
    I got all the missing dlls from the MioPocket PNA front-end package. Awesome!

    EDIT: It asked for serial, I said no. It asked if I wanted to change to free version->yes. Loads then I get a Fatal Application Error with exception 0xC0000005, address 0005641C :(
  • did you install maps?
  • Yes, maps are installed in the same folder. I found the log file but it doesn't give me useful info:

  • I wonder whether this error could be attributed to an incompatible DLL? What to you think? Any suggestions?
  • may be this is the problem?
    can not access source file: \Storage Card\navifree\default_editor.xml
  • Hi frisian and thanks. Unfortunately they did not help. I tried changing what I had one by one and also copying other DLLs.

    The fatal error occurs when at the startup when the loading bar is at the very end.

    One thing I don't understand is that PEinfo shows:
    Necessary library file(s):

    commctrl.dll Is loadable
    AYGSHELL.dll Is loadable
    WININET.dll Is loadable
    cellcore.dll Is loadable
    BtProxy.dll Is loadable
    COREDLL.dll Is loadable
    IMGDECMP.DLL Is loadable
    WS2.dll Is loadable
    gpstmc.dll Is loadable

    zlib.dll is also needed and present but no dependency checker shows it. Maybe I am missing something else? How would I know?
  • have a look in the log
  • Hello,

    could be also a problem with RAM-size. If all programs installed directly on PNA itself maybe change memory settings in system. I' running MF on WinCE 4.2 NET with 64 MB RAM and installed all my programs on SD.

  • I do not think so

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion