GPS receiver not detected
  • Hello.
    In an effort to make use of an "old"/out-of-date Packard Bell Compasseo 600 unit I installed Navigator 11 Free. The GPS receiver itself is not detected by Navigator and I'm not really sure how to make it so. The questions are these, then: Is the SiRF Star III chipset supported? And if so, how do I force Navigator Free to recognize it? Specs are listed below. Thanks in advance.

    Operating System
    Windows CE 5.00 (Build 1400)
    Processor: Samsung S3C2410X02/A26 with internal clock speed 266MHz 
    On Board Memory 
    FLASH: 32MB for OS image and applications 
    DRAM: 64MB  
    LCD: 3.5” TFT-LCD 
    Backlight: six levels of intensity (0, 20, 40, 60, 80 and 100% of the maximum level) 
    Touch Panel: 300 DPI touch screen; Finger-tapping type 
    CODEC:16-bits stereo; 44.1KHz max sample rate. 
    Earphone Jack: 3.5 mm stereo earphone jack 
    Battery Pack: 3.7 volt Lithium-Ion cell (non-removable), 1 100 mAh.  
    Capacity Detection: six levels of battery capacity (0, 20, 40, 60, 80 and 100%).   
    I/O connectors 
    USB: USB (v1.1).Mini USB connector.  
    SD/MMC Slot: supports SD/MMC memory cards (up to 1G bytes) 
    External GPS Antenna Connector (MMCX type) 
    Operating Temperature: 0 to 40 C° 
    Storage temperature: -20 to 60 C° 
    Humidity 20-95% non-condensing 
    ESD: +/-8kv air discharge, +/-4kv direct discharge. 
    Vibration: 2.60 Grms, 5 ~ 500 Hz 
    Complies with CE standards.  
    In Emission: Radio R&TTE directive 99/5/EC 301-440 
    In Immunity: EN-55024 
    Safety: EN60950 
    GPS Receiver  
      Chipset: SiRF Star III solution.  
    Frequency: 1575.42 MHz  
    C/A code: 1.023 MHz chip rate.  
    Channel:  20 channels.  
    Sensitivity: -159 dBm.  
    Position Accuracy: 10 meters, 2D RMS  
    Altitude: max. altitude 18000 m.  
    Velocity: max. velocity 515 m/s.  
    Baud rate: 4800 ~ 57600 bps adjustable  
    Output Message: SiRF binary or NMEA-0183 GGA, GSA, GSV, RMC, VTG 
  • 10 Comments sorted by
  • Hello,
    make sure you have GPS output set as NMEA and it should work. If the COM port is not properly detected, select any and change it manually in settings.xml file.
    good luck
  • Hi.

    I appreciate your reply.
    I have been looking through the settings but cannot seem to find any place where I can set GPS output to NMEA or at all.

    Here is the relevant part of the settings.xml:

        <com_autodetection_speeds>57600, 38400, 19200, 14400, 9600, 4800</com_autodetection_speeds>
  • I think you misunderstood - you can edit com port and baud rate, but your gps must be outputing NMEA


    baud rate is usually 4800, sometimes 9600 or 38400
  • Guess I did, then. Setting


    seems to do it. Should I be using the same settings for TMC?
  • if you you have a tmc receiver, then yes
    if you have Navigator FREE, then TMC is available in Germany only, in commercial maps it is in many more countries
  • I'm running Navigator 11 Free and not living in Germany so that settles it. I appreciate your help.
  • hi i had problem to connect my garmin gps60csx via usb navigator wont detect it so found garmin made a little prog for usb connections to 3rd party software it just adds a virtual comport enableing nav 9 to see the gps works for me here is a link to the program called garmin spanner


  • hello
    I come across Navigator Free by mapfactor and I am interested in using this navigation software.
    however, I am having some obstacle in using it.
    1. I am using the PC version for Navigator Free and it automatically detects COM 7 (GPS Data Interface in Device Manager). However, the "GPS Device Summary" shows the COM 7 as connected device and "Fix: No". all other details (satellites, time, latitude, longitude, altitude, speed) were shown as N/A
    2. What is a TMC device?
    3. after clicking OK, I tried to use the navigation features and the screen shows the map and other details. A message "waiting for valid GPS position" shows in the place where the street names should appear in the navigation mode.

    is there anything that i overlooked? if so, you can let me know. I can also provide specs of the GPS receiver that i am using. I apologize if this is a basic knowledge, I am new in this.

    thank you in advance
  • Hi 
    I have Win CE6 dvd .
    When I enable gps and it ask change setting . I get this message and get stuck, 

    and have to switch off and restart because it get stuck.

    I did COM1 editing and Baud rate editing on system file too. nothing helps.
    Can u help me.?

  • Tanks any1 who tried to solve this, But after a day i managed to Solve it on my own, it was a simple thing,  
    I removed internet dongle and started map.   
    It was conflicting with Net port And GPS port thats y.
    If your wince freeze, please remember to remove 3g dongle and start for the first time map use.
    Doesnt freeze



Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion