Navigator free for WinCE 5
  • Hi,

    I have tried to install the Navigator Free software on my
    WinCE 5 car head unit, unfortunately that the Unit has not recognized the Navigator.exe
    file. And displaying “Not find the Navigation Software”

    But I have tried another Navi -Software called City Guide
    that was worked fine.

    Please Advice.

  • 28 Comments sorted by
  • Hi, 

    This is just a thought... have you loaded the Navigator Free updater tool onto the head unit, by mistake?

    You need to install the update tool onto your main PC, then you launch and use this tool to download the maps you need, along with the core navigation software. Once downloaded and on your PC, you then use the tool to install them onto your WinCE device.

  • Hi,damith74,
    you may be missing some DLLs, see this thread:
  • HI Jkwatson,

    No, did not load the updater tool on to the Head unit. Only download the navigator files via Map Factor Installer 12.0 to SD card.



  • HI tomas,

    I have
    download and save the missing dll files which is describe in that link but
    result is same.
    Unit is
    displaying  same message " not find navigation software".
    As I told
    you earlier that another software running very well.<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />


    Thank s

  • and did you change path to navigator.exe?
  • Hi damith74,

    I'm using two devices, one with WinCE 6 and one with WinCE 5.

    What I did, was to copy the Navigator.exe and renamed it to the name of the old Navigation-System. exe-File.

    Maybe, your device is looking for a (e.g.) Route.exe (or whatever xyz.exe), than rename the copied Navigator.exe to that name and start again.

    At least, this helped me.

  • on some devices you can change path to exe file, if you cannot you need to rename navigator.exe as per crocodilefarm's instructions
  • path can change..
    Can direct the path to the exe file on SD card

    As i told you earlier that Unit support another Navi software with out any hassel..

    Unfortunately navigator free is not supporting


  • Please Advice,,,
  • please provide list of DLLs in navigator folder
  • HI tomas,

    Do you want to know the Navigator free dll? or other SW dll?


  • all DLLs in that folder - I hope it is in a folder and not in root.
  • Please find the DLL list in my SD card root.


    BTProxy.dll, CoreDll.dll, gfxQVGA.dll, gfxVGA.dll, gpstmc.dll, imgdecmp.dll, localisation.dll, localisation_ar.dll, localisation_bg.dll,  localisation_cs.dll, localisation_da.dll, localisation_de.dll, localisation_el.dll, localisation_es.dll, localisation_fa.dll, localisation_fi.dll, localisation_fr.dll, localisation_he.dll, localisation_hr.dll, localisation_hu.dll, localisation_it.dll, localisation_lt.dll, localisation_lv.dll, localisation_nl.dll, localisation_no.dll, localisation_pl.dll, localisation_pt.dll, localisation_ro.dll, localisation_ru.dll, localisation_sk.dll, localisation_sr.dll, localisation_sv.dll, localisation_vi.dll, mpfctoday.dll, ole32.dll, OLEAUT32.dll, shlwapi.dll, wininet.dll, WS32.DLL, zlib.DLL.


    Please Advice.

  • I think I would start again and install Navigator to a folder on your SD, there are a lot of files which should not be there
  • HI tomas,

    As your statement I did the same. But no luck.

    And I run the same SW in another Unit it was worked fine.
    But not on my Unit.

    Please find the Unit ID and version below.



    VER – 201A0108-2009030220-09030400S7B0A (WINCE@5.0)

    Expecting your Advice.


    Thank you 


  • these numbers mean nothing to me, I have no further advice
  • Hi,

    I have installed Navigator 12.1.10 on a Medion P4445, which is a WINCE5 unit. Just checked the provided DLL list against what I have in my Navigator folder.

    Additional to what damith74 showed I have the following dlls there:

    coredl2.dll, commctrl.dll, conversion.dll, doclist.dll, editor.dll, mfcce300.dll, olece300.dll and ws2.dll

    I don't have ws32.dll here.

    I'm not 100% sure all of these are really necessary, but that's what I seemed to find out when I installed it long ago.

    And Navigator works perfectly here, including TMC



  • Thanks Uli for the comment.

    some dll are came with Navigator 12 and some are added by myself.

    any way I will try with what you have mentioned dll s, and give you a feedback.

    Thanks a lot.



  • Hi,

    I also still not understand why this only happened to Navigator free Software.

    All other software I had tried and all are working fine with out any problem on my car navi unit.

    Seeking for your kind assistance and Advice.


    Thank you

  • The way I understand it, is that  WINCE5 comes in different variations. There are some units which come with a full blown WINCE installation. Most however come with a stripped down Windows version adapted  just to run the original navigation software.

    Now to install a "foreign" software it depends whether that foreign software brings with it all Dlls it needs or relies on the underlying Windows to contain everything else needed.

    Obviously Mapsoft Navigator is of the second kind and doesn't install everything it needs with the installation procedure but rather is tailored towards a full WINCE5 or at least some special version.

    So it is quite possible other software you installed runs without complaints but Navigator doesn't.



  • Thanks Uli

    That s mean no luck for me....!

    Thank you

  • here are the files we were including with some CEs

    problem is that you cannot simply add all four, sometimes it does not work because one or more of them are included, but should not be there
    you just need to be patient and systematically try all combinations
    good luck
  • HI tomas,

    Where can I find that dll s?

    Thank you

  • Hi damith74,

    mostly you'll find them with Google.

    E.g. look for "" or similar.




  • Maybe another helpful hint for people who have missing dll dependencies under WINCE.

    There is a free tool by Microsoft called Dependency Walker, latest version 2.2, see

    Though this tool doesn't run under WINCE, only under "normal" Windows versions on a PC, it is able to analyse WINCE exe files. You only have to tell the program where to find the WINCE libraries, otherwise it searches your PC's library path. Look at the provided help and the FAQ. Easiest way is to copy your WINCE files to a folder on your PC and point the Depends program to that folder.

    Hope somebody van use this, Makes finding missing dlls quite easy.




  • Hi!
    You can try this:
    1/ Install MIOPOCKET, as new as possible ( ), and run it. It works not only on MIO navigations.
    2/ Run any GPS program, and (first use) localise your Navigator12free. exe file.
    It works fine on Medion GoPal P4440.

  • Also I have moved the all files to the folder.. but no luck.


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion