Streets not found
  • There are many, many Streets that are not found.
    For example Oertelplatz in 80999 Munich is shown on Map, but not found in Adress-Search.
    Not in "München", not in "Landkreis München (LAND)", not in "80999".
  • 46 Comments sorted by
  • Is there any solution?
  • For some reason it can be found in Bezirkstail Allach-Untermenzing. I will verify why postcode did not work. I will let you know
    p.s. at the moment I can only confirm, that Oertelplatz (way id=10508707 and way id=19785010) visually belongs to postcode 80999 (relation id=1100794)
  • Ok, Thanks.
    Here is another example:
    Vesaliusstrasse belongs to 80997 and 80999 and is not found in 80999.
    In 80997, Vesaliusstrasse is found.
  • The postcode binding, as it is computed now, assigns street to at most one postcode area. If your two examples should belong to both areas then it is a problem. Based on geometry it looks that both streets should belong to postcode area 80999 only - so that's work for us to review that. On the other hand comment on way id=28708226: "FIXME"="Bitte Verlauf korrigieren. Nur in etwa abgeschätzt." could explain not precisely mapped postcode area.
  • Ok, thanks for Info.
    Perhaps there could be implemented a "area search" e. g. whole area of Munich over all "Bezirksteile" and so on. I think this problem occurs in all big Cities and so adress-search is unusable in big Cities.
    Or a "Radius Search" would minimize this problem. Radius Search schould be configurable e.g. 1km, 2km, 5km, ... around starting point or target point.
  • In Germany there are postcode areas, where the border between them is the middle of the street, which doesn' make it easier :-(
  • Hi
    I am trying to search roads like Saada street, Al Hosn area etc etc in Abu Dhabi and cannot find them although on the map these are visible. The roads are not available in the list when using find and navigate. Same with any area...Probably there is no area search and the list of roads is incomplete. What to do????
  • Although it shows all streets in map, most of them cannot be found.
    They can only be located if you know the postcode (what is usually not the case).
    Is there any workaround for that.
    In an other case I just go for a street nearby, and then I could see the street as junction. So they are all in the system, but not directly available. This seems to be one of the biggest bugs here.
  • Well, it is not necessarily bug in Navigator. The problem is the binding of streets to city/administrative area/center of settlement. Navigator is primarily using administrative area, which is unfortunately not always available in OSM data. For that reason it is also using nearest place and postcode area. What we plan to do is to dig out some info from is_in tag, if available. If you use 'i' (info icon) on named street in detail you should see to which region/city was given street assigned.
  • Thanks for explaining the issue. But if you don't know, where this street is, you are in trouble. Although NAVIT is slow and has some deficits - in this way it is working fine. After typing the first 3, 4 characters you get a selection of cities, and than you can find all streets in the city.
    So, maybe Mapfactor can have a look how NAVIT works with the deficits of OSM data.
    I checked this "i" but am not sure whether this helps. As for example in Freiburg/Germany I get sometime not just City but some other administrative data like "oldtown-center // government area Freiburg; Region"
    Nevertheless I am looking forward to a new version that might handle this isse better.
    Thanks for this nice application.
    Best regards
  • When you give a heavy look though I do not find it there on the map. for example (street or street Casin Caiuti) from Constanta Romania
  • @star: If I understand your problem correctly then I think following may help:

    Although I figured out that when you use the "Find and Navigate" option and then "Find Address" there when you get the option of "Enter City/Region/Postcode" you can directly type the roads or areas (not necessarily the City).

    But still there is a key problem I dont know how to work around it?

    If I try to search for a "Carrefour" nearest to the current position, it gives me a list but it does not show me the address along with it. This means if i want to go to a place which is near "Carrefour" , I cannot readily identify which Carrefour I need to select as address is not shown there.

    @ciprian: Have a look on and also try alternative spellings. If you dont find it still, just create it there (its very simple) and it will be available to everyone..... :-)
  • sorry - double post
  • @kush:
    I can't enter streets without entering a city or a postalcode before.
  • @star In the option to enter try typing areas or streets most of the areas are listed there....Earlier I also thought that we cant enter streets/areas. Try some key roads or key areas in the same field.
  • @Wolfi2000
    If you download Germany map for version 11, the postcode areas should be a little bit better (new process handling properly polygon geometry). It still assigns street to one postcode only based on the first coordinate of the street - note, that there are usually several crossings so the street is actually split. The Vesaliusstrasse you can found only it in 80999 postcode, but that is now problem in the source data and border given by Way id=28708226. Please let me know if you find more problems with postcode areas in this data.
  • @Kush
    Updated to newest version and maps. Not much change in this topic. Usually, If I want to navigate to a some other city I don't even know the area.
    Another issue: Once you type a not existing city (in this case I tried a street) into the city field, app crashed. I can't step back.
  • Ops, can you be more specific? Country, text? (or even better navigator.log.txt if there is some error or warning).
    I do not understand crashed & can't step back ... so the application was not terminated?
  • Example: Start Navigator (w/o GPS), do address find, Germany, type in a street instead of a city (which doesn't exist) - street gets red, than press return, and I see just the "wait" sign. Nothing will happen ...
    Maybe it is not as reproducable. I just tried it again and no problem. Sorry. Next time I will save the log for you.
    Once it happens, that the keyboard doesn't pop up and I couldn't change the city. After reinstall it was ok again.
    But one minor thing which is still happen: After close the application at my Touch2 the NavigatorFree Start screen pops up and keeps open until I push the screen again.
  • @star as far as finding a non existent city/area. You may try alternative street and then when it asks you junction, you may type the road originally looking for.

    But there are high chances that the road is not there on the map itself. For that you may try finding it on
  • "After close the application at my Touch2 the NavigatorFree Start screen pops up and keeps open until I push the screen again." ... that's "advertisement feature", so it is expected.
  • there is a problem in finding streets for example if I want to look Casin, Caiuti I do not find in Constanta where normal Mamaia I found where this region is 5 km away Why?
  • There is no administrative area for Casin ( so it is snapped to closer center of settlement (place), in this case it is Mamaia. I am looking forward to the revision of this process as in this case we could use "is_in:city = Constanța".
  • Martin

    When I try to find route from following node I am unable to find a route. This is because of some error in linking of roads. But my question why it does not find the nearest route? Same happens in other places also. Another issue is, if once navigator says route not found, it does not refresh after a few seconds to check if I am on a road from where it is possible for it to find a route. Please help.

    Node: Emarine (1373984765)

    Edited at: Wed, 21 Sep 2011 06:52:48 +0000 Edited by: Kush Version: 6 In changeset: 9357645 Comment: Emarine Tags: addr:city = Dubai addr:country = AE addr:housename = Jebel Ali amenity = public_building building = yes name = Emarine


  • Hello Kush,
    the problem is that Way id=25875343 is not connected to Way id=123119806. I would recommend to split Way id=25875343 and insert Node id=1373990494. The network graph has to be connected. Does it help?
  • Martin
    I have connected the two roads. I hope it will help. But I am still waiting for the second part of the question.
    If once navigator says route not found, it does not refresh after a few
    seconds to check if I am on a road from where it is possible for it to
    find a route. Please help.
    As it will help a lot.

    Also, I think navigator is unable to show a nearest route if the closest road somehow have errors in connections etc. Had it been possible then in the above case it would have shown a route from the Way id=25875343 and ignored the Way id=123119806 (now changed this way by way id=130756078).

  • Hello Kush,
    it was not necessary to remove the points and ways and add them again - it would be enough to make the end point of the new way part of the existing way ... but now it should work anyway.

    About route recalculation - there is a time and distance limit (imagine to drive on non-mapped motorway). If you need immediate recalculation just turn navigation off & on. Or for experiments use only compute route
  • Hello ! The problem of searching streets still persist?
    I changed and OSM but nothing .... I'm wrong somewhere? Thanks
  • The Problem is, OSM is a Projekt, that is made by some very engaged people.
    They where not on every place of the world.
    The European maps are good at this time an they are free.
    If Navigator can't find your destination on the OSM Maps, the Destination is not defined(nameless streets on the map or wrong Name) or not signed in the Map.
    You could try Internetsearch.
    Then Navigator will search an Adress by using Google Maps and shows you the Way to your destination.
    Works Perfect for me.

  • @caprian - can you be more specific? Which way/relation number you changed? (or changeset number)

  • I downloaded the map of Romania for Garmin website and I found that address, ie street Casin, Constanta, Romania
  • we are not velomap and we do not supply maps for Garmin
  • Ok I understand but I mean that he can not because OSM maps
  • @caprian - I could find your street, but I had to use the experimental search version. It is 4.1km from city center. There is "county" Constanta (, but no administrative area for the city. I noticed on several streets (including "Casin") that there is is_in:city tag, which we are not using yet.
    Thank you
  • ok i understand ....thank you
  • Hi, since Version Navigator Free 12 many streets in "Hamburg" located in town district "Eimsbüttel" can only be found under Town "Eimsbüttel", but not in "Hamburg"! Why that?? In version Navigator Free 11 is was ok!!
  • Hi, I'm searching in Gemany the street "Sundheimer Strasse" in "Kehl" "77694". I see the street name on the map but when I search it for navigation, mapfactor dont find it. Do you know wath can I do ?



  • It is really strange. If you search for "Kehl", there is only one city listed. If you tap that, you get "Stadtzentrum" and a list of streets belonging to a suburb "Kehl" of the city Weißenburg in Bavaria. If you tap on "Stadtzentrum" and then "show on map", you get to see the center of the city Kehl on the river Rhine, not of that Kehl, whose streets were listed before ...

    There is no index for the postal code 77694.

    I checked this on the Android and the PC versions.
  • Hi Phil,
    the problem is that there are two center of settlements with the same name and in the same admin area:
    The nearest search is using only one reference points and that fails (probably the wrong one).

    There is another problem that you should be able to find postcode "77694" but that fails too. At the moment germany_osm_south is recomputed due to boundary problems. I will let you know if the fix will also correct this issue.
    thank you
  • What do you mean with the same admin area? The only same area, they have common, is the Federal Republic of Germany. The distance between the two Kehls is approx. 300 km.,49.0292551&end=7.8111039,48.5731509&pref=Fastest&lang=de&noMotorways=false&noTollways=false  MF on the other hand has no problems to list dozens of "Neustadt" to select from and they are also located in Germany sometimes even in the same Bundesland.
  • By administrative area I meant a valid polygon (or multipolygon) with tags boundary=administrative and set "admin_level". There was (?) problem with boundary of germany_osm_south due to touching point at
    Because of this several postcode areas and administrative areas were failing or wrongly "did not belong to Germany" because older backup polygon was used. I am not 100% sure, that "Kehl" is the same case (I am still waiting for the data completion).

    Kehl 310485372 has valid admin area Weißenburg i. Bay. 1015141, but Kehl 240129751 does not have after processing any. I should know more by Monday ...

    P.S. good news - kehl 240129751 is now in admin area 452979 :)
  • Hallo mdx,
    same with Burghausen (an der Salzach), next to the Austrian border in the southeast of Bavaria
    If you search for Burghausen there are several choices. Since none of the others matched I chose that on without any second name. But then the streets of Burghausen, Münnerstadt are shown, which is in the north of Bavaria and appr. 400 km away. If you choose Stadtzentrum then the correct city appears on the map.
    But anyway you cannot choose any street in the city.
    Android-Phone: Acer Liquid E2 Duo, Android 4.2.2, MF Navigator Version 1.0.35
    BR, Jack
  • Hi Jack,
    try please recently updated germany_osm_south (20131201) - I see there Burghausen, Altoetting, which could be the one you are looking for (?). [you will need to have "Early maps access" checked (in Advanced settings)]
  • Hello Martin,
    works just fine, thanks a lot. Burghusen, altoetting is the one i was looking for and now it works properly!
    BR, Jack

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion