stil long delay when I click the screen
  • android version 5.0.61
    Today I made a trip on my motorbike. There was a roadblock so I had to skip a waypoint.
    I took almost half a minute before the screen responded on my tap on the screen to show the menu with the 'Skip waypoints' option. It also took almost 30 seconds again for mapfactor to respond on the tap on the 'Skip waypoint' button. Unfortunately I had to stop a few more times to skip waypoints.

    Stopping the app also takes a long time. Strangely I noticed that restarting the app was slow too.

    This is a very annoying problem with mapfactor. And it is there for a long time (at least two years) too.  Is there progress on the solution for this problem?????????
  • 14 Comments sorted by
  • I can confirm. Even after short trips my device gets unresponsive and very hot. I believe it is even worse than a few years ago, but I cannot prove it.
  • I also believe that the problem got worse.
  • Although I like Mapfactor very much the  unresponsiveness of the screen with the delay is a showstopper for me.

    I have seen that Mapfactor developed very much and made a huge step ahead.
    It is a very nice app with a lot of possibilities.

    But this unresponsiveness problem is now ongoing for more then two years.
    It seems that the problem even got worse!! Will there be a fix in the near future???????

  • I have the same problem and although it wont stop me from using the App it would be the icing on the cake if it was fixed.
  • I have just completed a 180km ride on my motorcycle. I was using Mapfactor only to monitor my position and was not using the navigate route function. When I stopped, Mapfactor took a minute to respond to input. Tomas, it would be good to know if you are aware there is a problem.
  • Hi Ckajca,
    Have you tried the "Low Sofware renderer" mode to see if Navigator responds better?
    With my old phone, in "Hardware renderer" mode, Navigator was blocking every hour or so and my phone was heating up a lot.
    In "Low software" mode I had no problems.
    The display is less powerful but it works.
    This is only an idea of ​​a temporary solution.
  • MacDony. I will try that, thanks
  • Changing der Renderer to the "Low-Software" render-enging is only a workaround, but no solution.

    I now have tried OSMAnd for long tours. There's no problem with getting slow. The only problem is the big size of needed space for the maps.

    I really like the NavigatorFree, but the problem with caching-management is a shortcoming.

    I would be very happy if this deficiency could be remedied.
  • may we know which version are you using?
  • Just downloaded 5.5.46 arm64-v8a
    I will try it the next days.
  • I am using the latest Beta version on Google Play store which appears to be 5.5.52 armeabi-v7a I did a ride yesterday with this version and the same slowness to respond occurs.
  • I'm using latest 5.5.52 arm64-v8a

    Going to test it this weekend.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion