Absurd Routing Mistake between Bolivia and Chile
  • We are using Navigator since 2014. In most cases we are quite happy with the routing results...

    But what happened to us last week, when we crossed the border between Bolivia and Chile, was ridiculous. To travel some 60 kilometers our Mapfactor Navigator (with paid upgrade to 3 routing options!) wanted to send us on 'world trip', south through Argentina - the shortest route being 5473 kilometers long! To get to Chile it ignored three (or more) convenient mountain passes and picked instead an unpaved road leading to Talca in Chile, far south of Santiago!! The nearest paved pass would be Paso de Jama, from the north of Argentina to Calama in Chile (then onwards to either Antofagasta or Iquique); still a looong detour compared with just 60 kilometers direct route.

    We also run Navigator on a tablet on our dashboard. This doesn't have the paid upgrade for 3 routing options, but in the same location it got the route almost right... But it picked the wrong 'Cancosa' in Chile (one I cannot find on any paper map!):


    I guess that's why I prefer to use Skobbler Scout. It refuses to update maps (since mid 2015) but still gets most routes right. Unless there's a completely new road since last map update:


    But how can this happen? Such outrageous routing errors!! I wouldn't mind a mistake by a couple of hundred kilometers - but over 5,000 kilometers detour is just plain stupid! And not a single route going north was even taken into account - that would have been our next alternative.

    ps: I have posted on our blog several off-line GPS reviews, which include your software: http://dare2go.com/new-review-off-line-android-gps-navigation-apps/
  • 17 Comments sorted by
  • Tomas' route is indeed the same route I get.

    For me it doesn't matter whether I use small local roads or not. With or without: I do get the same route.
    mapfactor: 2.2.63
    bolivia map: 44-201610110
    chile map: 44-201610280

    If others get a correct route and can't even reproduce your 5000+ km route, and one of your devices calculates it correct, then there must be a difference in settings even though you say not. Do you really use the same car profile (caravan  truck / bus / car) with same road settings. Next to road parameters, did you change anything in vehicle settings like weight, height, axle pressure/weight?

    And which Cancosa do you actually mean: Cancosa - Colchane (approx. 60 km as the bird flies) or Cancosa-Pisiga Bolivar (approx 27 km). I assumethe first one.

    I also tried OsmAnd. It doesn't give me a route.
    Then I tried Magic Earth. It gives me 2 routes: One of 50.6 km and the other 58,7 km

    I understand you are frustrated but if people try to help you it doesn't make it better when you get angry and use not really useful arguments.

    With regard to images: I'm on a lot of forums (fora) and there are more not allowing/supporting images.
    However, Vanilla has options and addons to allow that. So I made that a  forum request
  • Your images are not visible. 
    Please specify a departure and destination. Preferably as addresses but otherwise as coordinates.

    Also: If you edit the above post you can also change the category to bugs. 
  • Departure was Llica in Bolivia (west of the Salar de Uyuni), destination Cancosa in Chile.
    Sorry, but I have no idea how I could get coordinates of these places after I have left them.
    Here's the link to the most important (first) image:
    http://dare2go.com/hotlink/Navigator-2x-wrong.jpg It's on my webserver.
    Images show perfectly well on my screen, and I'm on slow mobile data (tethered from mobile phone) in Chile.

  • With alternative routes switched off I get one route of 66 km.
    With alternative routes switched on I get 2 routes: one of 66 km and one of 72 km.

    Do you have "strange" things in your car profile?

    And which navigator version(s) do you have?

  • If you got 66 km is that route roughly identical to the one shown on my tablet? It's still wrong, the Cancosa it aims for cannot be found on any paper map. The route on Skobbler is correct, although it turned out that the more southerly one was too narrow for our vehicle - we took the longer one and it worked out okay.

    Most road types are set to 50%, except Primary Road to 82% and Motorway to 65% (we find them boring).
    Version Number is 2.2.61 (I haven't received a notification to update, neither the app nor the maps).
    The version number on my tablet is exactly the same (but took a different route)!
  • ps: from experience with other apps (see my link in the first post) it doesn't have to be an outdated map version. If the data transfer or rendering is wrong (like a few missing pixels in an intersection) you get wrong routing results. Magic Earth seems to be a good example for this. I have caught Navigator with similar problems: one road simply not connecting with the next (due to a minute gap in the map).
  • pixels are completely irrelevant to routing
    also your links shows no screenshots

    you need to switch small local roads on to get 50km route
    settings/vehiccle profiles/car/road restrictions
  • Nope, Tomas - that's not it! Both, my tablet and the Android phone, don't have this switched on.
    Main reason: our overland camper is built on a 4x4 truck [Mercedes 1019 AF], which is 2.5 m wide and 'small local roads' are almost always too narrow for us. I got into too many difficult situations with it turned on.

    Yet my tablet almost found the route, the Android phone wanted to take a 5,000 km detour!
    BTW: we left it running during the drive - it never caught up.
  • that is the problem, you need to switch it on

    If the images don't show (they show on my slow connection in any browser I open them in) I can't help it.

    If MapFactor wouldn't be so cheap there would be an option to UPLOAD the images. Instead I have to hotlink them from my own webserver...
  • Tomas - did you actually read and understand my reply???

    It doesn't make any difference: on one device it worked, on the other not! Same setting!
  • alternative routes make no difference, you either have different settings, or different map version

    please do not call us cheap, others have no problem including links which work, for example
  • What are your map versions (date)?

    Note, that Skobbler may use OSM maps, but they are probably not the "same" as you mention in your other post. Mapfactors has its own proprietary format for its maps.

    As @tomas, I can not find any images with your links from above. If I would use your wording, may I call your blog now cheap, because your links are not working?
  • Map version on the Android phone (with the inexplicable detour)
    Bolivia: 44-201609130
    Chile: 44-201412230

    Map version on the tablet (where it [almost] worked)
    Bolivia: 44-201610110
    Chile: 44-201609290
  • Chile: 44-201412230 is from year 2014!?

    What happens, if you copy the Chile map from the tablet to the phone?
  • I would recommend to update all maps
  • Somewhere in this forum I thought that Lubos once mentioned that for "the new version" (version 2.x.y or so??), you needed to upgrade all maps (but I can't find it any more). You obviously did not do that. That might indeed very well be the error, or simply that the map is completely outdated and does not contain the updated info.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion