Strange routing
  • Hi there
    i noticed a strange routing trying navigator free on Android

    I've tried to find the issue on openstreetmaps but there are no broken connections or parts of the road marked as one way.
    If it is an openstreetmap issue, can you give me a hint where the problem comes from so that i can fix it?
  • 20 Comments sorted by
  • Sorry, i wanted post it in "bugs" not "feature request". Pls move.
  • it seems to be broken just above your destination, not sure what the poblem is
  • On my Asus K004 routing is straight ahead, even if the target is on the other side of the river. MFN 2.0.30. Map Germany West should be the latest. Download last week as far as I remember.
  • @Shadow: And as you started this thread, you can also edit your first post and change the assignment from "feature request" to whatever.
  • So even after a map update the routing is broken at this particular point. I searched again on Open Street Map but couldn't find the root cause of the issue.
  • The only possible reason I found was a very short section with oneway=no. It's tagged correctly (though it's not common to tag it that way), but it seems Navigator does not IGNORE oneway=no like it should.
  • Yeah, sry i didn't say that. Oneway = no was my try to fix it because the next part is oneway = yes but obviously the error is somewhere else. The bridge with its layer attribute seems to be right too. One thought was that this very small section is deleted when the raw data is parsed to create the map. But its shown in the picture so this can't be true.
  • It is really an error in the Navigator maps. I think the error is due to the country border running through the river. When maps are created they need to be cut at the border but roads should still be connected over that same border. In this case that went wrong. I really think the Navigator Luxembourg map is missing a very small part just inside the Luxembourg border. Maybe someone adapted the country border a little and now the Mapfactor map ceeation is not using that minimal part.

    OsmAnd and Here Maps work fine.

    And another note: The river is drawn as a line instead of a (multi)polygon. It should be a blue "area" between the two purple (border) lines. That is how it is mapped in OpenStreetMap. I think it is the same error with broken (multi-)polygons as I reported in "Creation of Maps: Rendering of lakes versus coast lines"
  • Osmand may have older maps, Here does not use OSM at all
    with TomTom maps route is correct
  • Luxembourg boundary is converted from relation
    which was recently edited:
    LU-DE condominium
    Edited 19 days ago by Stereo
    Version #70 ยท Changeset #36393777
    ... which is close to "planet.osm" cut-off day.

    The neighbor country germany_osm_west is old (201512260) and newer one is currently converted.

    If you check that particular link in PCnav you will see that it is in both countries. I would wait a bit after complete Germany update.

  • Start and finish on latest @shadow 's screenshot are both on Luxemburg territory exclusively. So the problem may not be related to borders.

    What I did not know until now: the river Sure/Sauer is common German and Luxemburg territory (called condominium as mentioned in the map).

    So you have two borders there. On one side of the river the border between German territory and the condominium and on the other side the border between Luxemburg territory and the condominium.
  • @Tomas: OsmAnd's maps are updated every 14 days. I was once quite involved with that.
    Your reference to TomTom maps is the same as mine about Here. That you want to promote Tomtom maps is understandable but saying that Here is not OSM based is also valid for Tomtom. Either your remark is just as valid as my remark, or both remarks are not valid.

    @Oldie: I mentioned that both points are in Luxembourg but only a few meters (literally) from the border and  that a minor change in the border (multi-)polygon could result in cutoff areas. Of course I can be completely wrong in my assumption but just because both points are in Luxembourg, but only meters from the border, can still mean they fall "outside" the map generation process. What is a few meters on so many square kilometers, coordinate wise? So I would prefer "evidence" instead of assumptions (from both of us :) )
  • I do not know how often Osmand releases maps, but did you test on January maps?
    I was merely stating my observations, nothing else
  • Luxembourg map of 5 January 2016. New one is almost there.
    OK, I understand.
  • I can confirm the problem of "shared boundary area" (condominium). Road
    network is split based on the border, where outer border is used for both
    Germany as well as Luxembourg. This means that "boundary crossing
    points" do not have connection in the opposite region. So yes, it is
    MapFactor problem.

    Is this the only place in the world?

    Potential solutions would be
    A) cut the common part from one of the region
    B) set all points within condominium area as boundary points (is there special tag for that in OSM?)
    C) use some artificial split polyline

    Probably B is the best solution if there are similar places in the world and there is some tag for it (?).

  • Today i recieved the new West-Germany map and from what i can see mdx is right. As you can see from the picture, the broken point is now on a slightly different position. Thx for your work!
    Wikipedia lists a few places on Earth where countries shares a region: Interstingly hvdwolf talked about issues with the Bodensee whitch is (according to the german wikipedia) also a condominium between germany, austria and switzerland.

    Someone created/is creating a special map for this:

    By now i think there is no special tag, but the region we're talking about has a note tag "LU-DE condominium"
  • Any News on this? Last time i tried it is still broken.
  • Even worse? Something wrong just north of the roundabout. Look's like there is some wrong data in both directions. I do not find a route over "Route de Wasserbillig". But I do not find, what could be wrong there ...

  • I am not expert on OSM, but I have seen similar problem when link was duplicated
    can someone check?
  • This issue seems to be gone. (latest Navigator version from Playstore, latest maps downloaded yesterday.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion