Test of Android version 3.0.x
  • 341 Comments sorted by
  • After I have updated to MFN 3.0.75 I have seen a problem regarding voice instruction for turning and roundabouts. The instructions are coming very early, sometime the last instruction for the coming roundabout is coming up to 800 meters before the roundabout, and therefore the last instruction sometimes comes before reaching an earlier roundabout, and that is very bad. The problem is also seen by simple turn instructions. I have seen this problem by normal navigation and by simulation.

    Please try to simulate this route, with normal simulation speed. I hope you can see what the problem is.

    Departure:         57.02129  10.01275
    Destination :     57.01732   9,96553

    HW rendering and default Car settings

  • @tvo
    I've observed this also with line assistant - in current version hints are displayed too far from crossroad. Today I've observed, that line assistant hints are displayed more than 3 km before exit from highway, which was practically on the previous exit. Similarly on other roads, line information can be displayed even 1 km before. Almost the same is with direction hints - they are displayed little bit later than line hints but, in my opinion, also to early.
  • I've encountered this in the 3.0.75 build. The turn "now" warning comes 500yds before it's needed then repeats itself 3 times.
  • I used 3.0.77 today for a bike trip. I had lots of left and right turns with distances of about 200 to 500 meters in between. The voice navigation was quite confusing.
    E.g. the next turn is left and I was about a few 100m before it, the voice said please turn left. The next thing she said was: please turn right in 200m. Then I was directly at the point were I had to turn and the voice said again please turn right instead of telling me to turn left.
    For me it looks like that the message should be something like ...and then turn right.
    Perhaps the distances for the points when a voice message is given are not calculated correctly depending on the speed or the vehicle that is used. I think both should be taken in account.

    For me it still looks like turning is not taken into account for any route calculation. Each turn needs a small penalty so a route with more turns is more expensive than a route with less turns. The reason for this is that you need to reduce your speed. Also the time for a travel is mostly top fast because mapfactor navigator is turning with maximum road speed and no traffic lights.

    When you want to download more voice language from the language menu and you want to go back the main window opens instead of the sub menu.
  • Repeated announcement


    Today on 60 mile route Mapfactor repeated continuously the 2 mile away instruction. It continually repeated the instruction eg "roundabout in two miles take the third exit" until reaching the roundabout and the next instruction or stopping and restarting navigation.
    This happened about 4 times and always for the "2 mile" announcement.

    NB. Don't know for how long the file will be accessible - Dropbox will be removing this functionality soon..

  • I used 3.0.77 today.
    The instructions were partially on the completely wrong moment.

    When one instruction was done (like "Turn right"), the next instruction followed immediately even though the next turn was 500 m to 2 km away.

  • Today I bought the TomTom card Europe.
    In the description, that there would be a lane assistant. But I can not recognize this. When changing a highway I get the same pictures as the free version, except that I see other signs ..
  • The latest version (3.0.79) seems to have it fixed the repeating speech messages. But now it seems like lots of turning advices are completely missing.
    Try this route with bike profile: http://www.openstreetmap.org/directions?engine=osrm_car&route=53.7092,9.7170;53.7244,9.7110#map=15/53.7191/9.7084
  • MapFactor Navigator ßeta version 3.0.79 Beta
    Dover > Holyhead

    Run Completed

    device: SM-T810 9.7''
    OS: Marshmallow (6.0.1)
    Renderer: Mali-T760
    OpenGL ES 3.1

    Map renderer: Hardware (experimental)
    Earth osm 44-201608040
    Map UK 44-201703040

    Speed cameras:
    cameralight 1001-201604050
    cameraspeed 1001-201604050

    Hardware 2D while simulating (speed x )
    device in portrait mode

    Departure Dover, CT16 1JA        lat:184061632 lon:4799552
    Waypoint: M42 from Dover        lat:188453530 lon:-6506942
    Waypoint: M56 from Dover        lat:192061750 lon:-9034454
    Destination: Holyhead, Llanfawr road    lat:191905868 lon:-16669312

    Vehicule Parameters:
    Maximum speed 55.9 mph

    Unit system: Imperial (British)

    Optimisation Mode: Fastest

    Road Restrictions:
    * 60 Motorway                      
    * 50 Primary Road                  
    * 50 Major Road                    
    * 40 Secondary Road                
    * 30 Local Connecting Road         
    * 20 Local road Of high Importance
    * 15 Local Road
    * 50 Small Local Road                                        
    only these are selected, all others are off

    Files (527 KB total)
    Will be deleted on 15 March, 2017
    Download link https://we.tl/hufSa1mepb
  • MapFactor Navigator ßeta version 3.0.79
    Holyhead > Dover (different waypoints)

    1st Run Failed
    2nd Run Completed

    device: SM-T810 9.7''
    OS: Marshmallow (6.0.1)
    Renderer: Mali-T760
    OpenGL ES 3.1

    Map renderer: Hardware (experimental)
    Earth osm 44-201608040
    Map UK 44-201703040

    Speed cameras:
    cameralight 1001-201604050
    cameraspeed 1001-201604050

    Hardware 2D while simulating (speed x 9)
    device in portrait mode

    Departure:   Holyhead, Llanfawr road       lat:191905868 lon:-16669312
    Waypoint:    M56 to Dover                        lat:192061190 lon:-8997924
    Waypoint:    M42 to Dover                        lat:188457708 lon:-6508073
    Destination: Dover, CT16 1JA                    lat:184061632 lon:4799552

    Vehicule Parameters:
    Maximum speed 55.9 mph

    Unit system: Imperial (British)

    Optimisation Mode: Fastest

    Road Restrictions:
    * 60 Motorway                      
    * 50 Primary Road                  
    * 50 Major Road                    
    * 40 Secondary Road                
    * 30 Local Connecting Road         
    * 20 Local road Of high Importance
    * 15 Local Road
    * 50 Small Local Road                                        
    only these are selected, all others are off

    Files (958 KB total) 2Runs-Holyhead-Dover.zip
    Will be deleted on 15 March, 2017
    Download link https://we.tl/1xCgBcLeTF
  • I have tested (only by route simulations) the voice instructions for 3.0.79, and I think it is as before 3.0.75 and therefore it is OK again.
  • Edit: version 3.0.79

    I can confirm that the instructions come in time again, maybe still a few seconds too early. This happens in cities where you have to do multiple left-right-left actions close after another like 10-20 meter apart (real traffic, no simulation). The message for the next turn came when I wanted to start the first turn.

    On the other hand: the warnings for cameras and traffic light cameras come too late. The 100 meter warning comes when you almost pass the traffic light/camera. At speeds of 50+ it is really too late. Are these messages pronounced at <exactly> 100 meter from the traffic light camera, thereby not taking the speed into account?

    If you drive at 70 km/hr, you are 20 meters further in 1 second. If the exact distance is 100 meter and the warning sounds need to be loaded from "disk", you are maybe 2-3 seconds further. I have no option to test this but I really like to know this.

    That might be another reason to be able to select either the warning sounds ór a (much faster) TTS warning: "Camera in 500 meters", "Camera in 100 meters" (instead of those heart-shocking warning sounds, especially when the unit radio is set a bit louder).
  • ....and increase flashing rate of speed icon when over the speed limit. It would be very beneficial to motorcyclist as we dont look at the display all the time.
  • @tvo: have you tested the route I have posted? There are some very obvious turns but for mapfactor it's must "straight on"

    In this picture there are two turns that are not recognized by MNF (this way):

    And here is another turn, that is not recognized:
  • @Garfield I have now tested your route, and can see the problems, but problems with green turn arrow, sound instruction and on screen instruction. The problems in 3.0.75 and 3.0.77 I described were only sound instruction problems, the green turn arrow and screen instructions were ok.
  • @tvo: your right, the sound instructions I had in 3.0.77 were wrong, which is now fixed.
    3.0.81 still has the same problem with missing turn instructions. Is there a place were one can see the change log?
  • The change logs are published only in this thread, if ever
  • copy&paste of our internal changelog(there is not everything due to missing android tag in some commits):
    09.03.17 13:36 : build 3.0.81 (buildbot-lightning)
    09.03.17 13:02 : otis test route start fix (stepan)
    09.03.17 11:15 : build 3.0.80 (buildbot-lightning)
    09.03.17 10:52 : otis licenses expiry list added (stepan)
    07.03.17 12:18 : build 3.0.79 (buildbot-lightning)
    07.03.17 12:01 : no notification logs when notifications are turned off (stepan)
    07.03.17 11:17 : checking for new key even in free version (stepan)
    06.03.17 17:15 : build 3.0.78 (buildbot-lightning)
    06.03.17 16:10 : let otis thread sleep when there is no active license (stepan)
    06.03.17 15:33 : OTIS - failed to connect to server warning only when the app is licensed for sure (stepan)
    06.03.17 10:17 : gles area pattern like in SW renderer (lubos)
    03.03.17 10:43 : build 3.0.77 (buildbot-lightning)
    03.03.17 10:19 : gles - glsl area pattern revert (lubos)
    03.03.17 09:48 : gles tmc and truck icons shrinking according to dpi (lubos)
    03.03.17 09:29 : glsl perspective precision rounded (lubos)
    03.03.17 08:43 : gles truck icon shrinking changed (lubos)
    01.03.17 17:40 : build 3.0.76 (buildbot-lightning)
    01.03.17 15:13 : gles - glsl matrix multiply in upper/lower float (lubos)
    01.03.17 14:28 : gles math in double instead of float (lubos)
    01.03.17 14:14 : gles cleanup (lubos)
    27.02.17 11:29 : build 3.0.75 (buildbot-lightning)
    27.02.17 11:13 : gles floating projection cleaning (lubos)
    27.02.17 09:24 : gles lerp for azimuth rewritten (lubos)
    27.02.17 07:54 : gles positions in double instead of float (lubos)
    24.02.17 14:11 : gles float projector for converting coordinates (lubos)
    22.02.17 14:59 : gles GPS processing in floats in progress (lubos)
    20.02.17 17:25 : computing future positions on current route in x miliseconds ahead instead of x seconds (stepan)
  • Ok thank you. It's interesting that there is so obvious commit related to the voice messages.

    Btw there is another strange turn message "please turn left" when you should drive straight on: http://www.openstreetmap.org/directions?engine=osrm_car&amp;route=53.74443,9.70714;53.74422,9.71137#map=16/53.7443/9.7093
  • I admit that some instructions sometimes sound "strange", but this can also be due to the "connections" of the road.
    In this case where the road merges together you have actually 3 roads (road segments). More navigation apps give strange warnings like in these or comparable situations.

    Same for the "Liether Moor" example a few posts above (I can't find the exact location even though there only seems one "Liether Moor"). Even though it is one road, if it is build up of multiple segments having so obvious turns, they sometimes get incorrectly interpreted. Again: I have seen that in other nav apps as well (I drive a lot of rental cars with all kind of Nav apps in there).

    I do not say you are wrong. The navi app is wrong but it is sometimes inevitable. You can't expect MNF employees to correct each and every street that has these characteristics.
  • V 3.0.81:
    Route not found when destination (in Northern Germany) more than 100km without Motorway (TT-Maps) - OSM always o.k.
  • please provide departure and destination in coordinates, we will check
  • Departure: 54°1726000, 9°152228 (Husum)
    destination: 53°580074, 9°980037 (Hamburg)
  • 3.0.81
    I do get a route. What kind of profile do you use?

  • I have no problem calculating this route with or without motorways, both with OSM and TomTom
  • @hvdwolf: you're right that this is a complex situation, but mnf tells me to turn left. Looks like the node giving this strange instruction is the one you marked red in your image and not the one where there are 4 ways are connected with.
    This is one road that is not straight on - ok. But there is no other road connected with this node so why it tells me to turn?
    The other situation (Liether Moor: http://www.openstreetmap.org/directions?engine=graphhopper_bicycle&amp;route=53.7217,9.7084;53.7252,9.7116#map=15/53.7235/9.7100 ) is the other way round: there is an obvious turn but no instruction!
  • The turn left is caused by the "knee bend" in the road I assume.

    The Liether Moor is wrong indeed. It consists of all different road segments. MNF must give turn commands in that situation.
    I guess the problem there is that you mix (unclassified) asphalt road (segments) with a track.
    Nevertheless: MNF is clearly doing this wrong.

    It might require some testing to combine tracks with "normal" (unclassified) roads and see if MNF does it always wrong.
  • Another bug (?) i found is that the route simulation uses wrong speeds. Mapfactor is told to consider speed limits but the simulation drives with 80 km/h (maximum speed I defined in the settings) instead of 70km/h as the speed limit is. I think that calculation for the jurney time is also based on wrong speeds.

  • Hello,

    when I wish select POI By address and name, I cannot select
    All oher Selects: Search imports - Nearest from map centre -
    nearest from GPS position - Nearest from destination
    I can select Imports.

  • @Garfield

    its not only in the beta version. Funny is you can get speedwarnings while simulating :-)
  • @Garfield: Come on. Simulation is just what it says. You try to simulate the route. You have to have an extremely  clever algorithm to simulate exact real world speed. It's all an estimation.
    Try for example iGO, Magic Earth and others. There is not one single app that "simulates" 100% accurately real world speed. I have been driving at 400 km/hr on an 80 km road at simulation speed 1 in other apps. What's more: I don't care at all. I simply want to see what my route is, the faster the better.
    I do not consider this a bug and if MNF considers it's a bug I hope they prioritize it as low. There are more important things to fix.

    And with regard to "I think that calculation for the journey time is also based on wrong speeds":
    That is also based on max speed tags connected to roads.In Openstreetmap that is not always the case. But most importantly: the ETA is not always correct due to the fact that MNF knows no "speed penalties" at all.
    If you use average speeds for a road, it makes a big difference if this road is just a straight on going road, or a road with multiple cross-roads, speed bumps,traffic lights and the like. Both can be average 50 km/hr but in practice they differ a lot.
    That is why ETA's over longer trajectories on motorways are fairly accurate, and ETA's through cities are way off. If you are driving in a big city with MNF you can easily duplicate the ETA with a factor 2. If you compare this for example with OsmAnd, which uses speed penalties extensively, you get a way more precise ETA in cities.
    Finally: The way MNF separates/groups road types in categories is sometimes "questionable". We had already many threads/topics about that subject. 
  • we do not consider this as a bug and unlikely to do something about it in the near future

    there are some minor adjustments in road categories and will be released soon
  • MFN 3.0.81/83
    LG K10
    HW render
    I've observed serious bug in these versions (most likely in 81). MFN crashes after forced (by leaving calculated route) route recalculation during navigation. I've observed this behaviour for ver. 81 couple of times. Ver. 83 i've tested only in simulation mode yet, and after issuing comunicate about route recalculation (probably due to HD-Traffic info), MFN has crashed as well.
  • @hvdwolf: I do not expect to simulate real world speed based on the current traffic and all situations that could occur. I did not know that ETA is based on speed limits while simulation is not using it, instead I thought they were equal. So what you said is good to know and ok for me.
    @J_Koppenhöfer: that's funny :D
  • @MKZ; I can confirm crashes in v3.0.83 when re-calculating route after leaving previously calculated route. This has happened twice on two journey's.
  • My navigator crashed 1 km before reaching the target as it tried to recalculate the route (for no apparent reason). Last error logged: assertion failed.

    Quite interesting: according to the log, the voice announced to recalculate, but the message was in fact not played.
  • 3.0.88 bugfix beta release (crash after route recompute fix, etc)
  • MNF 3.0.83 & 3.0.88
    Map layers not correct.
    See (reduced size) image below.
    The Industrial area layer is overlayed over the roads and POIs and even over the route pointer, both in map view as well as in route view. This is wrong. please correct.

  • 3.0.90 did not solve above.
    There is a very strange relation between the opacity of the industry layer (belonging to the "Builtup" category I assume) and the opacity of the "Buildings".
    If I set the opacity of the Buildings to the default 60, I get the image as displayed in my previous post. If I set the opacity of the "Buildings" (which I assume are the houses and the like) to 255, I don't see any roads at all.

    So 2 bugs:
    1. The Industry area layer is overlayed over "higher order" map elements like roads, railways, POIs.
    2. The industry layer should belong to the "Builtup" category and not to the "Buildings" category. (If I see this wrong, then someone please explain to me the difference between "Builtup" and "Buildings" as I consider "Builtup" as the underlayer for industrial, urban, military etc. as described in the landuse key.)

    Other bug: I changed the application language to English (to see correct word for buildings and builtup). The main menus are translated immediately. However, when I went into colour scheme editor all commands were still in Dutch (system standard). I had to exit navigator and restart it to get the correct english translation. No big deal but something that has to be corrected some time.
  • And please post (even a minor) changelog of the changes between 3.0.81, 3.0.83, 3.0.88 and 3.0.90, which I  saw pass by.
  • @hvdwolf - I believe that problem with industrial zones is not connected to Navigator update but to map update

        parking system library updated
        clean install download OSM data fix
        jni do not ignore constructors for jobjects
        gles - lines drawing using stenced triangles, 3d building fixed
        HD Traffic item layout revision
        fix on fix
        better socket timeout handling when communicating with HD Traffic server
        deleting multiple interest areas from HD Traffic server at once implemented
        safer route positions handling and crash while recomputing route fix
        some class data made private for safety
        minor fixes and several asserts added
        send rectangle to HD Traffic server only once fix plus HD Traffic server problems itself because of sending rectangle multiple times FIX ON FIX
        send rectangle to HD Traffic server only once fix plus HD Traffic server problems itself because of sending rectangle multiple times fix
        attempt to download only licensed countries traffic data
        better handling HTTP errors from TT server
  • Used properly yesterday and today and found the following issues using version 3.0.90 and TomTom maps:-

    Next manoeuvre icon shown incorrectly at the junction of the A229 and A262. I was heading north, the map showed that I should take the third exit (i.e. go right) but the icon showed that I should go straight ahead. the voice instruction was correct. This happened there on the way back when the map showed I should take the first exit but the icon showed that I should go straight across. All other roundabouts on the trips were fine so is it something about that one?

    Repetitive telling of 'continue straight on' even when there are no side roads etc. At one point it was it ignored the fact I was to turn right until I was past the junction. Up to that point, it had been telling me to carry straight on. 

    I was in Whitstable, Kent and wanted to use the OSM map to get back to Burwash, East Sussex. The choice of routes were all over the place turning a 45 mile journey into 80 miles plus. One of the routes included going to Folkestone and getting the tunnel to France and then returning to the UK. 

    The icons for my own POIs are extremely small even when I am using maximum icon size in the settings. Is this correct? The icons are 120 x 120 pixels.

  • @Allan_Whoops - The "carry straight on" instruction happens when Detailed navigation is checked in Settings-Navigation. Uncheck it should stop this.
  • I don´t know since when, but with 3.0.90 I can´t move under "MY PLACES" "MY FAVOURITES" by holding und moving. I can only hold and tip "Move up" or "Move down". In "MY ROUTES" I can hold and move the route up and down. In "GPS RECORDING" I can´t move them anyway!? I know that FAVOURITES have worked before the way ROUTES work now.
    New favourites are put always to the end of the list. Therefore it is much better to hold and move instead of hold an tip "Move up" many times to get the favourite to the top.
    I know I can sort them with A-Z or Z-A, but that is not the same. I want the favourites sorted the way I use them often!!
  • This crashed twice yesterday, once about 15 miles before destination on journey of 75 miles and then about 25 miles from destination on return. Are there logs and, if so, do you want me to send them to you.

    I use a Samsung TAB A as a glorified dedicated satnav.
  • settings/advanced/send logs
  • Mine did crash as well. 2 times on 2 approx. back and forth 12 km runs. Settings as usual with the only difference that I had set the renderer from automatic to hardware.
    No logs of the crash.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion